<!DOCTYPE html>
<html lang="en-GB">
<head>
<meta charset="UTF-8"><link rel='stylesheet' id='wp-block-library-css' href='https://c0.wp.com/c/5.2.4/wp-includes/css/dist/block-library/style.min.css' type='text/css' media='all' /><link rel='stylesheet' id='wp-block-library-theme-css' href='https://c0.wp.com/c/5.2.4/wp-includes/css/dist/block-library/theme.min.css' type='text/css' media='all' /><link rel='stylesheet' id='penci-fonts-css' href='//fonts.googleapis.com/css?family=Playfair+Display+SC%3A300%2C300italic%2C400%2C400italic%2C500%2C500italic%2C700%2C700italic%2C800%2C800italic%7CMontserrat%3A300%2C300italic%2C400%2C400italic%2C500%2C500italic%2C700%2C700italic%2C800%2C800italic%7CRoboto%3A300%2C300italic%2C400%2C400italic%2C500%2C500italic%2C700%2C700italic%2C800%2C800italic%7CArial%3A300%2C300italic%2C400%2C400italic%2C500%2C500italic%2C700%2C700italic%2C800%2C800italic%26subset%3Dlatin%2Ccyrillic%2Ccyrillic-ext%2Cgreek%2Cgreek-ext%2Clatin-ext&#038;ver=1.0' type='text/css' media='all' /><link rel='stylesheet' id='jetpack_css-css' href='https://c0.wp.com/p/jetpack/7.8/css/jetpack.css' type='text/css' media='all' /><link data-optimized='2' rel='stylesheet' href='https://www.thecheckeredflag.co.uk/min/0e4b5.css' /><script type='text/javascript' src='https://c0.wp.com/c/5.2.4/wp-includes/js/jquery/jquery.js'></script><script type='text/javascript' src='https://c0.wp.com/c/5.2.4/wp-includes/js/jquery/jquery-migrate.min.js'></script><script data-optimized='1' src='https://www.thecheckeredflag.co.uk/min/e0802.js'></script>
<meta http-equiv="X-UA-Compatible" content="IE=edge">
<meta name="viewport" content="width=device-width, initial-scale=1">
<link rel="profile" href="https://gmpg.org/xfn/11" />
<link rel="shortcut icon" href="https://www.thecheckeredflag.co.uk/wp-content/uploads/2018/11/TCF-black.jpg" type="image/x-icon" />
<link rel="apple-touch-icon" sizes="180x180" href="https://www.thecheckeredflag.co.uk/wp-content/uploads/2018/11/TCF-black.jpg">
<link rel="alternate" type="application/rss+xml" title="The Checkered Flag RSS Feed" href="https://www.thecheckeredflag.co.uk/feed/" />
<link rel="alternate" type="application/atom+xml" title="The Checkered Flag Atom Feed" href="https://www.thecheckeredflag.co.uk/feed/atom/" />
<link rel="pingback" href="https://www.thecheckeredflag.co.uk/xmlrpc.php" />
<!--[if lt IE 9]>
	<script src="https://www.thecheckeredflag.co.uk/wp-content/themes/soledad/js/html5.js"></script>
	<![endif]-->
<title>Kyle Busch joins Lexus for 2020 Rolex 24 - The Checkered Flag</title>

<script data-cfasync="false" data-pagespeed-no-defer type="text/javascript">//<![CDATA[
	var gtm4wp_datalayer_name = "dataLayer";
	var dataLayer = dataLayer || [];
//]]>
</script>


<meta name="description" content="Kyle Busch has joined AIM Vasser Sullivan for the 2020 Rolex 24 at Daytona, where he will drive the Lexus RC F GT3 in his maiden IMSA start." />
<meta name="robots" content="max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
<link rel="canonical" href="https://www.thecheckeredflag.co.uk/2019/11/kyle-busch-joins-lexus-for-2020-rolex-24/" />
<meta property="og:locale" content="en_GB" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Kyle Busch joins Lexus for 2020 Rolex 24 - The Checkered Flag" />
<meta property="og:description" content="Kyle Busch has joined AIM Vasser Sullivan for the 2020 Rolex 24 at Daytona, where he will drive the Lexus RC F GT3 in his maiden IMSA start." />
<meta property="og:url" content="https://www.thecheckeredflag.co.uk/2019/11/kyle-busch-joins-lexus-for-2020-rolex-24/" />
<meta property="og:site_name" content="The Checkered Flag" />
<meta property="article:publisher" content="http://www.facebook.com/TheCheckeredFlag" />
<meta property="article:tag" content="2020 Rolex 24 Hours at Daytona" />
<meta property="article:tag" content="AIM Vasser Sullivan" />
<meta property="article:tag" content="Kyle Busch" />
<meta property="article:tag" content="Lexus RC-F GT3" />
<meta property="article:section" content="IMSA" />
<meta property="article:published_time" content="2019-11-04T18:48:41+00:00" />
<meta property="article:modified_time" content="2019-11-04T18:50:31+00:00" />
<meta property="og:updated_time" content="2019-11-04T18:50:31+00:00" />
<meta property="fb:app_id" content="135274436510698" />
<meta property="og:image" content="https://i2.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2019/11/MENCS-Sonoma-Kyle-Busch-2019.jpg?fit=800%2C533&#038;ssl=1" />
<meta property="og:image:secure_url" content="https://i2.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2019/11/MENCS-Sonoma-Kyle-Busch-2019.jpg?fit=800%2C533&#038;ssl=1" />
<meta property="og:image:width" content="800" />
<meta property="og:image:height" content="533" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:description" content="Kyle Busch has joined AIM Vasser Sullivan for the 2020 Rolex 24 at Daytona, where he will drive the Lexus RC F GT3 in his maiden IMSA start." />
<meta name="twitter:title" content="Kyle Busch joins Lexus for 2020 Rolex 24 - The Checkered Flag" />
<meta name="twitter:site" content="@thecheckerflag" />
<meta name="twitter:image" content="https://i2.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2019/11/MENCS-Sonoma-Kyle-Busch-2019.jpg?fit=800%2C533&#038;ssl=1" />
<meta name="twitter:creator" content="@ZappaOMatic" />
<script type='application/ld+json' class='yoast-schema-graph yoast-schema-graph--main'>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</script>

<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="The Checkered Flag &raquo; Feed" href="https://www.thecheckeredflag.co.uk/feed/" />
<link rel="alternate" type="application/rss+xml" title="The Checkered Flag &raquo; Comments Feed" href="https://www.thecheckeredflag.co.uk/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="The Checkered Flag &raquo; Kyle Busch joins Lexus for 2020 Rolex 24 Comments Feed" href="https://www.thecheckeredflag.co.uk/2019/11/kyle-busch-joins-lexus-for-2020-rolex-24/feed/" />
<!--[if !IE]><!-->
<!--<![endif]-->
<link rel='https://api.w.org/' href='https://www.thecheckeredflag.co.uk/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.thecheckeredflag.co.uk/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.thecheckeredflag.co.uk/wp-includes/wlwmanifest.xml" />
<link rel='shortlink' href='https://www.thecheckeredflag.co.uk/?p=325145' />
<link rel="alternate" type="application/json+oembed" href="https://www.thecheckeredflag.co.uk/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.thecheckeredflag.co.uk%2F2019%2F11%2Fkyle-busch-joins-lexus-for-2020-rolex-24%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.thecheckeredflag.co.uk/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.thecheckeredflag.co.uk%2F2019%2F11%2Fkyle-busch-joins-lexus-for-2020-rolex-24%2F&#038;format=xml" />

<script data-cfasync="false" data-pagespeed-no-defer type="text/javascript">//<![CDATA[
	var dataLayer_content = {"pageTitle":"Kyle Busch joins Lexus for 2020 Rolex 24 - The Checkered Flag","pageCategory":["united-sportscar","sprint-cup"],"pageAttributes":["2020-rolex-24-hours-at-daytona","aim-vasser-sullivan","kyle-busch","lexus-rc-f-gt3"],"pagePostAuthor":"Justin Nguyen"};
	dataLayer.push( dataLayer_content );//]]>
</script>
<script data-cfasync="false">//<![CDATA[
(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'//www.googletagmanager.com/gtm.'+'js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-MG875N');//]]>
</script>


<link rel='dns-prefetch' href='//c0.wp.com' />
<link rel='dns-prefetch' href='//i0.wp.com' />
<link rel='dns-prefetch' href='//i1.wp.com' />
<link rel='dns-prefetch' href='//i2.wp.com' />
<style type='text/css'>img#wpstats{display:none}</style> <style type="text/css">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</style>
<script>
var penciBlocksArray=[];
var portfolioDataJs = portfolioDataJs || [];var PENCILOCALCACHE = {};
		(function () {
				"use strict";
		
				PENCILOCALCACHE = {
					data: {},
					remove: function ( ajaxFilterItem ) {
						delete PENCILOCALCACHE.data[ajaxFilterItem];
					},
					exist: function ( ajaxFilterItem ) {
						return PENCILOCALCACHE.data.hasOwnProperty( ajaxFilterItem ) && PENCILOCALCACHE.data[ajaxFilterItem] !== null;
					},
					get: function ( ajaxFilterItem ) {
						return PENCILOCALCACHE.data[ajaxFilterItem];
					},
					set: function ( ajaxFilterItem, cachedData ) {
						PENCILOCALCACHE.remove( ajaxFilterItem );
						PENCILOCALCACHE.data[ajaxFilterItem] = cachedData;
					}
				};
			}
		)();function penciBlock() {
		    this.atts_json = '';
		    this.content = '';
		}</script>
<script type="application/ld+json">{
    "@context": "https:\/\/schema.org\/",
    "@type": "organization",
    "@id": "#organization",
    "logo": {
        "@type": "ImageObject",
        "url": "https:\/\/www.thecheckeredflag.co.uk\/wp-content\/uploads\/2019\/08\/TCF-Square.jpg"
    },
    "url": "https:\/\/www.thecheckeredflag.co.uk\/",
    "name": "The Checkered Flag",
    "description": "Independent motor sport news since 2009"
}</script><script type="application/ld+json">{
    "@context": "https:\/\/schema.org\/",
    "@type": "WebSite",
    "name": "The Checkered Flag",
    "alternateName": "Independent motor sport news since 2009",
    "url": "https:\/\/www.thecheckeredflag.co.uk\/"
}</script><script type="application/ld+json">{
    "@context": "https:\/\/schema.org\/",
    "@type": "BlogPosting",
    "headline": "Kyle Busch joins Lexus for 2020 Rolex 24",
    "description": "Kyle Busch has joined AIM Vasser Sullivan for the 2020 Rolex 24 at Daytona, where he will drive the Lexus RC F GT3 in his maiden IMSA start.",
    "datePublished": "2019-11-04",
    "datemodified": "2019-11-04",
    "mainEntityOfPage": "https:\/\/www.thecheckeredflag.co.uk\/2019\/11\/kyle-busch-joins-lexus-for-2020-rolex-24\/",
    "image": {
        "@type": "ImageObject",
        "url": "https:\/\/i2.wp.com\/www.thecheckeredflag.co.uk\/wp-content\/uploads\/2019\/11\/MENCS-Sonoma-Kyle-Busch-2019.jpg?fit=800%2C533&ssl=1",
        "width": 800,
        "height": 533
    },
    "publisher": {
        "@type": "Organization",
        "name": "The Checkered Flag",
        "logo": {
            "@type": "ImageObject",
            "url": "https:\/\/www.thecheckeredflag.co.uk\/wp-content\/uploads\/2019\/08\/TCF-Square.jpg"
        }
    },
    "author": {
        "@type": "Person",
        "@id": "#person-JustinNguyen",
        "name": "Justin Nguyen"
    }
}</script><script type="application/ld+json">{
    "@context": "https:\/\/schema.org",
    "@type": "NewsArticle",
    "headline": "Kyle Busch joins Lexus for 2020 Rolex 24",
    "image": "https:\/\/i2.wp.com\/www.thecheckeredflag.co.uk\/wp-content\/uploads\/2019\/11\/MENCS-Sonoma-Kyle-Busch-2019.jpg?fit=800%2C533&ssl=1",
    "datePublished": "2019-11-04",
    "datemodified": "2019-11-04",
    "description": "Kyle Busch has joined AIM Vasser Sullivan for the 2020 Rolex 24 at Daytona, where he will drive the Lexus RC F GT3 in his maiden IMSA start.",
    "mainEntityOfPage": "https:\/\/www.thecheckeredflag.co.uk\/2019\/11\/kyle-busch-joins-lexus-for-2020-rolex-24\/",
    "publisher": {
        "@type": "Organization",
        "name": "The Checkered Flag",
        "logo": {
            "@type": "ImageObject",
            "url": "https:\/\/www.thecheckeredflag.co.uk\/wp-content\/uploads\/2019\/08\/TCF-Square.jpg"
        }
    },
    "author": {
        "@type": "Person",
        "name": "Justin Nguyen"
    }
}</script><link rel="amphtml" href="https://www.thecheckeredflag.co.uk/amp/2019/11/kyle-busch-joins-lexus-for-2020-rolex-24/" /><link rel="icon" href="https://i2.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2016/02/cropped-TCF.png?fit=32%2C32&#038;ssl=1" sizes="32x32" />
<link rel="icon" href="https://i2.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2016/02/cropped-TCF.png?fit=192%2C192&#038;ssl=1" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="https://i2.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2016/02/cropped-TCF.png?fit=180%2C180&#038;ssl=1" />
<meta name="msapplication-TileImage" content="https://i2.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2016/02/cropped-TCF.png?fit=270%2C270&#038;ssl=1" />
</head>
<body data-rsssl=1 class="post-template-default single single-post postid-325145 single-format-standard">
<a id="close-sidebar-nav" class="header-5"><i class="penci-faicon fa fa-close"></i></a>
<nav id="sidebar-nav" class="header-5" role="navigation" itemscope itemtype="https://schema.org/SiteNavigationElement">
<div id="sidebar-nav-logo">
<a href="https://www.thecheckeredflag.co.uk/"><img class="penci-lazy" src="https://www.thecheckeredflag.co.uk/wp-content/themes/soledad/images/penci-holder.png" data-src="https://www.thecheckeredflag.co.uk/wp-content/uploads/2018/11/TCF-black.jpg" alt="The Checkered Flag" /></a>
</div>
<div class="header-social sidebar-nav-social">
<div class="inner-header-social">
<a href="https://facebook.com/TheCheckeredFlag" rel="nofollow" target="_blank"><i class="penci-faicon fa fa-facebook"></i></a>
<a href="https://twitter.com/TheCheckerFlag" rel="nofollow" target="_blank"><i class="penci-faicon fa fa-twitter"></i></a>
<a href="https://instagram.com/thecheckeredflag/" rel="nofollow" target="_blank"><i class="penci-faicon fa fa-instagram"></i></a>
<a href="https://www.linkedin.com/company/thecheckeredflag/" rel="nofollow" target="_blank"><i class="penci-faicon fa fa-linkedin"></i></a>
<a href="https://www.youtube.com/channel/UCueRVoGbSE4GF2RszehXIgw" rel="nofollow" target="_blank"><i class="penci-faicon fa fa-youtube-play"></i></a>
<a href="https://www.thecheckeredflag.co.uk/feed" rel="nofollow" target="_blank"><i class="penci-faicon fa fa-rss"></i></a>
</div> </div>
<ul id="menu-2015" class="menu"><li id="menu-item-131887" class="menu-item menu-item-type-taxonomy menu-item-object-category penci-mega-menu menu-item-131887"><a href="https://www.thecheckeredflag.co.uk/formula-1/">F1</a>
<ul class="sub-menu">
<li id="menu-item-0" class="menu-item-0"><div class="penci-megamenu">
<div class="penci-content-megamenu">
<div class="penci-mega-latest-posts col-mn-5 mega-row-1">
<div class="penci-mega-row penci-mega-3 row-active">
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.thecheckeredflag.co.uk/formula-1/">
Formula 1 </a>
</span>
<a class="penci-image-holder penci-lazy" data-src="https://i1.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2019/11/max-verstappen-aston-martin-red-bull-racing-2019-formula-1-united-states-grand-prix-circuit-of-the-americas-race.jpg?resize=585%2C390&amp;ssl=1" href="https://www.thecheckeredflag.co.uk/2019/11/verstappen-and-albon-complete-strong-drives-to-leave-austin-in-good-shape/" title="Verstappen and Albon complete strong drives to leave Austin in good shape">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.thecheckeredflag.co.uk/2019/11/verstappen-and-albon-complete-strong-drives-to-leave-austin-in-good-shape/" title="Verstappen and Albon complete strong drives to leave Austin in good shape">Verstappen and Albon complete strong drives to leave&#8230;</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2019-11-04T19:03:43+00:00">November 4, 2019</time></p>
</div>
</div>
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.thecheckeredflag.co.uk/formula-1/">
Formula 1 </a>
</span>
<a class="penci-image-holder penci-lazy" data-src="https://i0.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2019/11/Valtteri-Bottas-30.jpg?resize=585%2C390&amp;ssl=1" href="https://www.thecheckeredflag.co.uk/2019/11/bottas-eager-for-more-close-fights-with-hamilton-in-2020-after-us-grand-prix-triumph/" title="Bottas Eager for More Close Fights with Hamilton in 2020 after US Grand Prix Triumph">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.thecheckeredflag.co.uk/2019/11/bottas-eager-for-more-close-fights-with-hamilton-in-2020-after-us-grand-prix-triumph/" title="Bottas Eager for More Close Fights with Hamilton in 2020 after US Grand Prix Triumph">Bottas Eager for More Close Fights with Hamilton&#8230;</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2019-11-04T18:23:13+00:00">November 4, 2019</time></p>
</div>
</div>
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.thecheckeredflag.co.uk/formula-1/">
Formula 1 </a>
</span>
<a class="penci-image-holder penci-lazy" data-src="https://i0.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2019/11/F1-2019.jpg?resize=585%2C390&amp;ssl=1" href="https://www.thecheckeredflag.co.uk/2019/11/codemasters-extend-f1-partnership/" title="Codemasters extend F1 partnership">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.thecheckeredflag.co.uk/2019/11/codemasters-extend-f1-partnership/" title="Codemasters extend F1 partnership">Codemasters extend F1 partnership</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2019-11-04T13:12:51+00:00">November 4, 2019</time></p>
</div>
</div>
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.thecheckeredflag.co.uk/formula-1/">
Formula 1 </a>
</span>
<a class="penci-image-holder penci-lazy" data-src="https://i1.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2019/11/lh_usgp_2019_rs.jpg?resize=585%2C390&amp;ssl=1" href="https://www.thecheckeredflag.co.uk/2019/11/lewis-hamilton-sets-sights-on-michael-schumacher-records-with-historic-sixth-title-win/" title="Lewis Hamilton sets sights on Schumacher&#8217;s records with historic sixth title win">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.thecheckeredflag.co.uk/2019/11/lewis-hamilton-sets-sights-on-michael-schumacher-records-with-historic-sixth-title-win/" title="Lewis Hamilton sets sights on Schumacher&#8217;s records with historic sixth title win">Lewis Hamilton sets sights on Schumacher&#8217;s records with&#8230;</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2019-11-03T22:00:25+00:00">November 3, 2019</time></p>
</div>
</div>
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.thecheckeredflag.co.uk/formula-1/">
Formula 1 </a>
</span>
<a class="penci-image-holder penci-lazy" data-src="https://i1.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2019/11/Start.jpg?resize=585%2C390&amp;ssl=1" href="https://www.thecheckeredflag.co.uk/2019/11/bottas-wins-feisty-usgp-as-hamilton-becomes-a-six-time-world-championship/" title="Bottas wins feisty US GP as Hamilton becomes a six-time World Champion">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.thecheckeredflag.co.uk/2019/11/bottas-wins-feisty-usgp-as-hamilton-becomes-a-six-time-world-championship/" title="Bottas wins feisty US GP as Hamilton becomes a six-time World Champion">Bottas wins feisty US GP as Hamilton becomes&#8230;</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2019-11-03T21:39:23+00:00">November 3, 2019</time></p>
</div>
</div>
</div>
</div>
</div>
</div></li>
</ul>
</li>
<li id="menu-item-131940" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-131940"><a href="https://www.thecheckeredflag.co.uk/open-wheel/">Open Wheel</a>
<ul class="sub-menu">
<li id="menu-item-131942" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131942"><a href="https://www.thecheckeredflag.co.uk/open-wheel/formula-e/">FIA Formula E</a></li>
<li id="menu-item-131943" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131943"><a href="https://www.thecheckeredflag.co.uk/open-wheel/indycar/">IndyCar</a></li>
<li id="menu-item-218310" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-218310"><a href="https://www.thecheckeredflag.co.uk/open-wheel/fia-formula-2/">FIA Formula 2</a></li>
<li id="menu-item-296601" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-296601"><a href="https://www.thecheckeredflag.co.uk/open-wheel/formula-3/fia-formula-3-championship/">FIA Formula 3</a></li>
<li id="menu-item-321059" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-321059"><a href="https://www.thecheckeredflag.co.uk/open-wheel/w-series/">W Series</a></li>
<li id="menu-item-180961" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-180961"><a href="https://www.thecheckeredflag.co.uk/open-wheel/formula-3/british-f3-formula-3/">British F3</a></li>
<li id="menu-item-131897" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131897"><a href="https://www.thecheckeredflag.co.uk/open-wheel/msa-formula/">F4 British Championship</a></li>
<li id="menu-item-131946" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131946"><a href="https://www.thecheckeredflag.co.uk/open-wheel/formula-3/euroformula-open/">EuroFormula Open</a></li>
<li id="menu-item-131989" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131989"><a href="https://www.thecheckeredflag.co.uk/open-wheel/renault-world-series/formula-renault-2-0-renault-world-series/">Formula Renault 2.0</a></li>
</ul>
</li>
<li id="menu-item-131952" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor menu-item-has-children menu-item-131952"><a href="https://www.thecheckeredflag.co.uk/sportscars/">Sportscars</a>
<ul class="sub-menu">
<li id="menu-item-131956" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131956"><a href="https://www.thecheckeredflag.co.uk/sportscars/endurance/fiawec/">FIA WEC</a></li>
<li id="menu-item-131957" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131957"><a href="https://www.thecheckeredflag.co.uk/sportscars/endurance/blancpain-endurance-series/">Blancpain Endurance</a></li>
<li id="menu-item-148232" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-148232"><a href="https://www.thecheckeredflag.co.uk/sportscars/endurance/blancpain-sprint/">Blancpain Sprint</a></li>
<li id="menu-item-131954" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131954"><a href="https://www.thecheckeredflag.co.uk/sportscars/gt-sportscars/british-gt/">British GT</a></li>
<li id="menu-item-290801" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-290801"><a href="https://www.thecheckeredflag.co.uk/sportscars/ginetta/">Ginetta Series</a></li>
<li id="menu-item-303742" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-303742"><a href="https://www.thecheckeredflag.co.uk/sportscars/porsche/">Porsche Series</a></li>
</ul>
</li>
<li id="menu-item-131899" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-131899"><a href="https://www.thecheckeredflag.co.uk/touring-cars/">Touring Cars</a>
<ul class="sub-menu">
<li id="menu-item-131904" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131904"><a href="https://www.thecheckeredflag.co.uk/touring-cars/btcc/">BTCC</a></li>
<li id="menu-item-192543" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-192543"><a href="https://www.thecheckeredflag.co.uk/touring-cars/dtm/">DTM</a></li>
<li id="menu-item-255598" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-255598"><a href="https://www.thecheckeredflag.co.uk/touring-cars/wtcr/">WTCR</a></li>
<li id="menu-item-303746" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-303746"><a href="https://www.thecheckeredflag.co.uk/touring-cars/tcr-europe/">TCR Europe</a></li>
<li id="menu-item-131951" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131951"><a href="https://www.thecheckeredflag.co.uk/touring-cars/renault-clio-cup/">Renault UK Clio Cup</a></li>
<li id="menu-item-317944" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-317944"><a href="https://www.thecheckeredflag.co.uk/touring-cars/jaguar-i-pace-etrophy/">Jaguar I-PACE eTROPHY</a></li>
</ul>
</li>
<li id="menu-item-131918" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-131918"><a href="https://www.thecheckeredflag.co.uk/motorcycles/">Motorcycles</a>
<ul class="sub-menu">
<li id="menu-item-131922" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131922"><a href="https://www.thecheckeredflag.co.uk/motorcycles/motogp/">MotoGP</a></li>
<li id="menu-item-131920" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131920"><a href="https://www.thecheckeredflag.co.uk/motorcycles/moto2/">Moto2</a></li>
<li id="menu-item-131921" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131921"><a href="https://www.thecheckeredflag.co.uk/motorcycles/moto3/">Moto3</a></li>
<li id="menu-item-131923" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131923"><a href="https://www.thecheckeredflag.co.uk/motorcycles/british-superbike/">British Superbike</a></li>
<li id="menu-item-131924" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131924"><a href="https://www.thecheckeredflag.co.uk/motorcycles/world-superbike/">World Superbike</a></li>
<li id="menu-item-131949" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131949"><a href="https://www.thecheckeredflag.co.uk/motorcycles/road-racing/">Road Racing</a></li>
</ul>
</li>
<li id="menu-item-290798" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-290798"><a href="https://www.thecheckeredflag.co.uk/offroad/">Off Road</a>
<ul class="sub-menu">
<li id="menu-item-254211" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-254211"><a href="https://www.thecheckeredflag.co.uk/offroad/rally/fiawrc/">FIA WRC</a></li>
<li id="menu-item-138301" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-138301"><a href="https://www.thecheckeredflag.co.uk/offroad/rally/fia-erc/">FIA ERC</a></li>
<li id="menu-item-131910" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131910"><a href="https://www.thecheckeredflag.co.uk/offroad/rally/british-rally-championship/">British Rally Championship</a></li>
<li id="menu-item-290799" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-290799"><a href="https://www.thecheckeredflag.co.uk/offroad/dakar/">Dakar</a></li>
<li id="menu-item-131917" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131917"><a href="https://www.thecheckeredflag.co.uk/offroad/rallycross/world-rallycross/">FIA World RX</a></li>
<li id="menu-item-131913" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131913"><a href="https://www.thecheckeredflag.co.uk/offroad/rallycross/european-rallycross/">FIA European RX</a></li>
</ul>
</li>
<li id="menu-item-290800" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor penci-mega-menu menu-item-290800"><a href="https://www.thecheckeredflag.co.uk/nascar/">NASCAR</a>
<ul class="sub-menu">
<li class="menu-item-0"><div class="penci-megamenu"> <div class="penci-mega-child-categories">
<a class="mega-cat-child" href="https://www.thecheckeredflag.co.uk/nascar/sprint-cup/" data-id="penci-mega-2741"><span>Monster Energy NASCAR Cup Series</span></a>
<a class="mega-cat-child" href="https://www.thecheckeredflag.co.uk/nascar/nascar-trucks/" data-id="penci-mega-18305"><span>NASCAR Gander Outdoors Truck Series</span></a>
<a class="mega-cat-child" href="https://www.thecheckeredflag.co.uk/nascar/euro-racecar/" data-id="penci-mega-8304"><span>NASCAR Whelen Euro Series</span></a>
<a class="mega-cat-child" href="https://www.thecheckeredflag.co.uk/nascar/nascar-xfinity-series/" data-id="penci-mega-2742"><span>NASCAR Xfinity Series</span></a>
<a class="mega-cat-child cat-active all-style" href="https://www.thecheckeredflag.co.uk/nascar/" data-id="penci-mega-108"><span>All</span></a>
</div>
<div class="penci-content-megamenu">
<div class="penci-mega-latest-posts col-mn-4 mega-row-1">
<div class="penci-mega-row penci-mega-2741">
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.thecheckeredflag.co.uk/sportscars/endurance/united-sportscar/">IMSA</a> </span>
<a class="penci-image-holder penci-lazy" data-src="https://i2.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2019/11/MENCS-Sonoma-Kyle-Busch-2019.jpg?resize=585%2C390&amp;ssl=1" href="https://www.thecheckeredflag.co.uk/2019/11/kyle-busch-joins-lexus-for-2020-rolex-24/" title="Kyle Busch joins Lexus for 2020 Rolex 24">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.thecheckeredflag.co.uk/2019/11/kyle-busch-joins-lexus-for-2020-rolex-24/" title="Kyle Busch joins Lexus for 2020 Rolex 24">Kyle Busch joins Lexus for 2020 Rolex 24</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2019-11-04T18:48:41+00:00">November 4, 2019</time></p>
</div>
</div>
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.thecheckeredflag.co.uk/nascar/sprint-cup/">Monster Energy NASCAR Cup Series</a> </span>
<a class="penci-image-holder penci-lazy" data-src="https://i1.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2019/11/TMS2_MENCS_Harvick_Stage1_110319.jpg?resize=585%2C390&amp;ssl=1" href="https://www.thecheckeredflag.co.uk/2019/11/kevin-harvick-leads-ford-stewart-haas-domination-in-aaa-texas-500-win/" title="Kevin Harvick leads Ford, Stewart-Haas domination in AAA Texas 500 win">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.thecheckeredflag.co.uk/2019/11/kevin-harvick-leads-ford-stewart-haas-domination-in-aaa-texas-500-win/" title="Kevin Harvick leads Ford, Stewart-Haas domination in AAA Texas 500 win">Kevin Harvick leads Ford, Stewart-Haas domination in AAA&#8230;</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2019-11-04T00:15:15+00:00">November 4, 2019</time></p>
</div>
</div>
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.thecheckeredflag.co.uk/nascar/sprint-cup/">Monster Energy NASCAR Cup Series</a> </span>
<a class="penci-image-holder penci-lazy" data-src="https://i1.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2019/11/mencs_ks_kubuarmpump_71319.jpg?resize=585%2C390&amp;ssl=1" href="https://www.thecheckeredflag.co.uk/2019/11/kurt-busch-monster-energy-multi-year-extension-with-ganassi/" title="Kurt Busch, Monster Energy multi-year extension with Ganassi">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.thecheckeredflag.co.uk/2019/11/kurt-busch-monster-energy-multi-year-extension-with-ganassi/" title="Kurt Busch, Monster Energy multi-year extension with Ganassi">Kurt Busch, Monster Energy multi-year extension with Ganassi</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2019-11-03T01:10:18+00:00">November 3, 2019</time></p>
</div>
</div>
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.thecheckeredflag.co.uk/nascar/sprint-cup/">Monster Energy NASCAR Cup Series</a> </span>
<a class="penci-image-holder penci-lazy" data-src="https://i0.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2019/11/lajoie_2019mencs_carshot.jpg?resize=585%2C390&amp;ssl=1" href="https://www.thecheckeredflag.co.uk/2019/11/go-fas-racing-partners-with-stewart-haas-racing-for-2020/" title="Go Fas Racing partners with Stewart-Haas Racing for 2020">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.thecheckeredflag.co.uk/2019/11/go-fas-racing-partners-with-stewart-haas-racing-for-2020/" title="Go Fas Racing partners with Stewart-Haas Racing for 2020">Go Fas Racing partners with Stewart-Haas Racing for&#8230;</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2019-11-01T17:54:03+00:00">November 1, 2019</time></p>
</div>
</div>
</div>
<div class="penci-mega-row penci-mega-18305">
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.thecheckeredflag.co.uk/nascar/nascar-trucks/">NASCAR Gander Outdoors Truck Series</a> </span>
<a class="penci-image-holder penci-lazy" data-src="https://i0.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2019/10/Tanner-Gray-Dover-KNE-2019.jpg?resize=585%2C390&amp;ssl=1" href="https://www.thecheckeredflag.co.uk/2019/10/former-nhra-champ-tanner-gray-to-make-nascar-national-series-debut-at-martinsville/" title="Former NHRA champ Tanner Gray to make NASCAR national series debut at Martinsville">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.thecheckeredflag.co.uk/2019/10/former-nhra-champ-tanner-gray-to-make-nascar-national-series-debut-at-martinsville/" title="Former NHRA champ Tanner Gray to make NASCAR national series debut at Martinsville">Former NHRA champ Tanner Gray to make NASCAR&#8230;</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2019-10-16T18:48:41+00:00">October 16, 2019</time></p>
</div>
</div>
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.thecheckeredflag.co.uk/nascar/nascar-trucks/">NASCAR Gander Outdoors Truck Series</a> </span>
<a class="penci-image-holder penci-lazy" data-src="https://i2.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2019/08/Dippel-2019NGOTS-TruckShot.jpg?resize=585%2C390&amp;ssl=1" href="https://www.thecheckeredflag.co.uk/2019/08/misdemeanour-charges-against-suspended-tyler-dippel-dropped/" title="Misdemeanour charges against suspended Tyler Dippel dropped, reinstated">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.thecheckeredflag.co.uk/2019/08/misdemeanour-charges-against-suspended-tyler-dippel-dropped/" title="Misdemeanour charges against suspended Tyler Dippel dropped, reinstated">Misdemeanour charges against suspended Tyler Dippel dropped, reinstated</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2019-08-29T01:46:16+00:00">August 29, 2019</time></p>
</div>
</div>
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.thecheckeredflag.co.uk/nascar/nascar-trucks/">NASCAR Gander Outdoors Truck Series</a> </span>
<a class="penci-image-holder penci-lazy" data-src="https://i1.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2019/08/Tyler-Dippel-Stewart-Friesen-GOTS-Kansas-2019.jpg?resize=585%2C390&amp;ssl=1" href="https://www.thecheckeredflag.co.uk/2019/08/tyler-dippel-indefinitely-suspended-by-nascar/" title="Tyler Dippel indefinitely suspended by NASCAR">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.thecheckeredflag.co.uk/2019/08/tyler-dippel-indefinitely-suspended-by-nascar/" title="Tyler Dippel indefinitely suspended by NASCAR">Tyler Dippel indefinitely suspended by NASCAR</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2019-08-24T03:08:21+00:00">August 24, 2019</time></p>
</div>
</div>
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.thecheckeredflag.co.uk/nascar/nascar-trucks/">NASCAR Gander Outdoors Truck Series</a> </span>
<a class="penci-image-holder penci-lazy" data-src="https://i2.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2019/08/Greg-Biffle-NGOTS-2019-Texas.jpg?resize=585%2C390&amp;ssl=1" href="https://www.thecheckeredflag.co.uk/2019/08/2020-xfinity-truck-driver-rules-set/" title="2020 Xfinity, Truck driver rules set">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.thecheckeredflag.co.uk/2019/08/2020-xfinity-truck-driver-rules-set/" title="2020 Xfinity, Truck driver rules set">2020 Xfinity, Truck driver rules set</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2019-08-21T19:37:28+00:00">August 21, 2019</time></p>
</div>
</div>
</div>
<div class="penci-mega-row penci-mega-8304">
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.thecheckeredflag.co.uk/nascar/euro-racecar/">NASCAR Whelen Euro Series</a> </span>
<a class="penci-image-holder penci-lazy" data-src="https://i0.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2019/10/Memphis-Racing-23-2019-NWES.jpg?resize=585%2C390&amp;ssl=1" href="https://www.thecheckeredflag.co.uk/2019/10/2020-nascar-whelen-euro-series-schedule-released/" title="2020 NASCAR Whelen Euro Series schedule released">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.thecheckeredflag.co.uk/2019/10/2020-nascar-whelen-euro-series-schedule-released/" title="2020 NASCAR Whelen Euro Series schedule released">2020 NASCAR Whelen Euro Series schedule released</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2019-10-22T17:43:44+00:00">October 22, 2019</time></p>
</div>
</div>
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.thecheckeredflag.co.uk/nascar/euro-racecar/">NASCAR Whelen Euro Series</a> </span>
<a class="penci-image-holder penci-lazy" data-src="https://i0.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2019/10/NWES-Team-FJ-2030-partnership.jpg?resize=585%2C390&amp;ssl=1" href="https://www.thecheckeredflag.co.uk/2019/10/nascar-team-fj-sign-ten-year-extension-for-whelen-euro-series-sanction/" title="NASCAR, Team FJ sign ten-year extension for Whelen Euro Series sanction">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.thecheckeredflag.co.uk/2019/10/nascar-team-fj-sign-ten-year-extension-for-whelen-euro-series-sanction/" title="NASCAR, Team FJ sign ten-year extension for Whelen Euro Series sanction">NASCAR, Team FJ sign ten-year extension for Whelen&#8230;</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2019-10-04T16:25:28+00:00">October 4, 2019</time></p>
</div>
</div>
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.thecheckeredflag.co.uk/nascar/euro-racecar/">NASCAR Whelen Euro Series</a> </span>
<a class="penci-image-holder penci-lazy" data-src="https://i2.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2019/04/Ander-Vilarino-Valencia-2019-NWES.jpg?resize=585%2C390&amp;ssl=1" href="https://www.thecheckeredflag.co.uk/2019/04/vilarino-maggi-risitano-kick-off-2019-euro-series-with-valencia-victories/" title="Vilarino, Maggi, Risitano kick off 2019 Euro Series with Valencia victories">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.thecheckeredflag.co.uk/2019/04/vilarino-maggi-risitano-kick-off-2019-euro-series-with-valencia-victories/" title="Vilarino, Maggi, Risitano kick off 2019 Euro Series with Valencia victories">Vilarino, Maggi, Risitano kick off 2019 Euro Series&#8230;</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2019-04-15T05:25:02+00:00">April 15, 2019</time></p>
</div>
</div>
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.thecheckeredflag.co.uk/nascar/euro-racecar/">NASCAR Whelen Euro Series</a> </span>
<a class="penci-image-holder penci-lazy" data-src="https://i2.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2019/04/Euro-NASCAR-18-32-paddock.jpg?resize=585%2C390&amp;ssl=1" href="https://www.thecheckeredflag.co.uk/2019/04/nascar-gp-of-spain-featuring-decorated-grid/" title="NASCAR GP of Spain featuring decorated grid">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.thecheckeredflag.co.uk/2019/04/nascar-gp-of-spain-featuring-decorated-grid/" title="NASCAR GP of Spain featuring decorated grid">NASCAR GP of Spain featuring decorated grid</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2019-04-10T18:07:18+00:00">April 10, 2019</time></p>
</div>
</div>
</div>
<div class="penci-mega-row penci-mega-2742">
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.thecheckeredflag.co.uk/nascar/nascar-xfinity-series/">NASCAR Xfinity Series</a> </span>
<a class="penci-image-holder penci-lazy" data-src="https://i2.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2019/10/Andy-Seuss-Our-Motorsports-02-2020-NXS.jpg?resize=585%2C390&amp;ssl=1" href="https://www.thecheckeredflag.co.uk/2019/10/our-motorsports-to-run-full-xfinity-campaign-in-2020/" title="Our Motorsports to run full Xfinity campaign in 2020">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.thecheckeredflag.co.uk/2019/10/our-motorsports-to-run-full-xfinity-campaign-in-2020/" title="Our Motorsports to run full Xfinity campaign in 2020">Our Motorsports to run full Xfinity campaign in&#8230;</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2019-10-30T20:17:08+00:00">October 30, 2019</time></p>
</div>
</div>
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.thecheckeredflag.co.uk/nascar/nascar-xfinity-series/">NASCAR Xfinity Series</a> </span>
<a class="penci-image-holder penci-lazy" data-src="https://i1.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2019/10/nxs_cls_chastainxs_062819.jpg?resize=585%2C390&amp;ssl=1" href="https://www.thecheckeredflag.co.uk/2019/10/kaulig-jtg-daugherty-racing-haulers-involved-in-incidents-before-kansas-weekend/" title="Kaulig, JTG Daugherty Racing haulers involved in incidents before Kansas weekend">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.thecheckeredflag.co.uk/2019/10/kaulig-jtg-daugherty-racing-haulers-involved-in-incidents-before-kansas-weekend/" title="Kaulig, JTG Daugherty Racing haulers involved in incidents before Kansas weekend">Kaulig, JTG Daugherty Racing haulers involved in incidents&#8230;</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2019-10-18T03:00:43+00:00">October 18, 2019</time></p>
</div>
</div>
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.thecheckeredflag.co.uk/nascar/nascar-xfinity-series/">NASCAR Xfinity Series</a> </span>
<a class="penci-image-holder penci-lazy" data-src="https://i0.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2019/09/2019-NASCAR-Xfinity-playoff-grid.jpg?resize=585%2C390&amp;ssl=1" href="https://www.thecheckeredflag.co.uk/2019/09/nascar-xfinity-series-playoff-field-finalised/" title="NASCAR Xfinity Series playoff field finalised">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.thecheckeredflag.co.uk/2019/09/nascar-xfinity-series-playoff-field-finalised/" title="NASCAR Xfinity Series playoff field finalised">NASCAR Xfinity Series playoff field finalised</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2019-09-15T04:06:11+00:00">September 15, 2019</time></p>
</div>
</div>
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.thecheckeredflag.co.uk/nascar/nascar-xfinity-series/">NASCAR Xfinity Series</a> </span>
<a class="penci-image-holder penci-lazy" data-src="https://i1.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2019/09/Elliott-Sadler-Richmond-NXS-2018.jpg?resize=585%2C390&amp;ssl=1" href="https://www.thecheckeredflag.co.uk/2019/09/elliott-sadler-to-run-special-livery-for-855th-and-final-nascar-start/" title="Elliott Sadler to run special livery for 855th and final NASCAR start">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.thecheckeredflag.co.uk/2019/09/elliott-sadler-to-run-special-livery-for-855th-and-final-nascar-start/" title="Elliott Sadler to run special livery for 855th and final NASCAR start">Elliott Sadler to run special livery for 855th&#8230;</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2019-09-10T20:36:55+00:00">September 10, 2019</time></p>
</div>
</div>
</div>
<div class="penci-mega-row penci-mega-108 row-active">
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.thecheckeredflag.co.uk/nascar/">NASCAR</a> </span>
<a class="penci-image-holder penci-lazy" data-src="https://i2.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2019/11/MENCS-Sonoma-Kyle-Busch-2019.jpg?resize=585%2C390&amp;ssl=1" href="https://www.thecheckeredflag.co.uk/2019/11/kyle-busch-joins-lexus-for-2020-rolex-24/" title="Kyle Busch joins Lexus for 2020 Rolex 24">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.thecheckeredflag.co.uk/2019/11/kyle-busch-joins-lexus-for-2020-rolex-24/" title="Kyle Busch joins Lexus for 2020 Rolex 24">Kyle Busch joins Lexus for 2020 Rolex 24</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2019-11-04T18:48:41+00:00">November 4, 2019</time></p>
</div>
</div>
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.thecheckeredflag.co.uk/nascar/">NASCAR</a> </span>
<a class="penci-image-holder penci-lazy" data-src="https://i1.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2019/11/TMS2_MENCS_Harvick_Stage1_110319.jpg?resize=585%2C390&amp;ssl=1" href="https://www.thecheckeredflag.co.uk/2019/11/kevin-harvick-leads-ford-stewart-haas-domination-in-aaa-texas-500-win/" title="Kevin Harvick leads Ford, Stewart-Haas domination in AAA Texas 500 win">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.thecheckeredflag.co.uk/2019/11/kevin-harvick-leads-ford-stewart-haas-domination-in-aaa-texas-500-win/" title="Kevin Harvick leads Ford, Stewart-Haas domination in AAA Texas 500 win">Kevin Harvick leads Ford, Stewart-Haas domination in AAA&#8230;</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2019-11-04T00:15:15+00:00">November 4, 2019</time></p>
</div>
</div>
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.thecheckeredflag.co.uk/nascar/">NASCAR</a> </span>
<a class="penci-image-holder penci-lazy" data-src="https://i1.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2019/11/mencs_ks_kubuarmpump_71319.jpg?resize=585%2C390&amp;ssl=1" href="https://www.thecheckeredflag.co.uk/2019/11/kurt-busch-monster-energy-multi-year-extension-with-ganassi/" title="Kurt Busch, Monster Energy multi-year extension with Ganassi">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.thecheckeredflag.co.uk/2019/11/kurt-busch-monster-energy-multi-year-extension-with-ganassi/" title="Kurt Busch, Monster Energy multi-year extension with Ganassi">Kurt Busch, Monster Energy multi-year extension with Ganassi</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2019-11-03T01:10:18+00:00">November 3, 2019</time></p>
</div>
</div>
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.thecheckeredflag.co.uk/nascar/">NASCAR</a> </span>
<a class="penci-image-holder penci-lazy" data-src="https://i0.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2019/11/lajoie_2019mencs_carshot.jpg?resize=585%2C390&amp;ssl=1" href="https://www.thecheckeredflag.co.uk/2019/11/go-fas-racing-partners-with-stewart-haas-racing-for-2020/" title="Go Fas Racing partners with Stewart-Haas Racing for 2020">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.thecheckeredflag.co.uk/2019/11/go-fas-racing-partners-with-stewart-haas-racing-for-2020/" title="Go Fas Racing partners with Stewart-Haas Racing for 2020">Go Fas Racing partners with Stewart-Haas Racing for&#8230;</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2019-11-01T17:54:03+00:00">November 1, 2019</time></p>
</div>
</div>
</div>
</div>
</div>
</div></li>
</ul>
</li>
<li id="menu-item-293110" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-293110"><a href="https://www.thecheckeredflag.co.uk/features/">Features</a>
<ul class="sub-menu">
<li id="menu-item-293115" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-293115"><a href="https://www.thecheckeredflag.co.uk/features/opinion/">Opinion</a></li>
<li id="menu-item-293113" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-293113"><a href="https://www.thecheckeredflag.co.uk/features/interviews/">Interviews</a></li>
<li id="menu-item-293114" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-293114"><a href="https://www.thecheckeredflag.co.uk/features/gallery/">Gallery</a></li>
<li id="menu-item-293111" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-293111"><a href="https://www.thecheckeredflag.co.uk/features/product-review/">Product Review</a></li>
<li id="menu-item-293112" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-293112"><a href="https://www.thecheckeredflag.co.uk/features/season-review/">Season Review</a></li>
<li id="menu-item-293118" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-293118"><a href="https://www.thecheckeredflag.co.uk/other/esports/">eSports</a></li>
<li id="menu-item-293117" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-293117"><a href="https://www.thecheckeredflag.co.uk/other/video-games/">Sim Racing</a></li>
</ul>
</li>
</ul> </nav>
<div class="wrapper-boxed header-style-header-5 penci-hlogo-center">
<div class="penci-header-wrap"><div class="penci-top-bar">
<div class="container">
<div class="penci-headline" role="navigation" itemscope itemtype="https://schema.org/SiteNavigationElement">
<span class="headline-title">Latest</span>
<div class="penci-topbar-social">
<div class="inner-header-social">
<a href="https://facebook.com/TheCheckeredFlag" rel="nofollow" target="_blank"><i class="penci-faicon fa fa-facebook"></i></a>
<a href="https://twitter.com/TheCheckerFlag" rel="nofollow" target="_blank"><i class="penci-faicon fa fa-twitter"></i></a>
<a href="https://instagram.com/thecheckeredflag/" rel="nofollow" target="_blank"><i class="penci-faicon fa fa-instagram"></i></a>
<a href="https://www.linkedin.com/company/thecheckeredflag/" rel="nofollow" target="_blank"><i class="penci-faicon fa fa-linkedin"></i></a>
<a href="https://www.youtube.com/channel/UCueRVoGbSE4GF2RszehXIgw" rel="nofollow" target="_blank"><i class="penci-faicon fa fa-youtube-play"></i></a>
<a href="https://www.thecheckeredflag.co.uk/feed" rel="nofollow" target="_blank"><i class="penci-faicon fa fa-rss"></i></a>
</div> </div>
<div class="penci-owl-carousel penci-owl-carousel-slider penci-headline-posts" data-auto="true" data-autotime="3000" data-speed="200">
<div>
<a class="penci-topbar-post-title" href="https://www.thecheckeredflag.co.uk/2019/11/verstappen-and-albon-complete-strong-drives-to-leave-austin-in-good-shape/">Verstappen and Albon complete strong drives to leave Austin in good shape</a>
</div>
<div>
<a class="penci-topbar-post-title" href="https://www.thecheckeredflag.co.uk/2019/11/kyle-busch-joins-lexus-for-2020-rolex-24/">Kyle Busch joins Lexus for 2020 Rolex 24</a>
</div>
<div>
<a class="penci-topbar-post-title" href="https://www.thecheckeredflag.co.uk/2019/11/bottas-eager-for-more-close-fights-with-hamilton-in-2020-after-us-grand-prix-triumph/">Bottas Eager for More Close Fights with Hamilton in 2020 after US Grand Prix Triumph</a>
</div>
<div>
<a class="penci-topbar-post-title" href="https://www.thecheckeredflag.co.uk/2019/11/volkswagen-retire-beetle-from-rallycross/">Volkswagen retire Beetle from rallycross</a>
</div>
<div>
<a class="penci-topbar-post-title" href="https://www.thecheckeredflag.co.uk/2019/11/codemasters-extend-f1-partnership/">Codemasters extend F1 partnership</a>
</div>
<div>
<a class="penci-topbar-post-title" href="https://www.thecheckeredflag.co.uk/2019/11/michael-fassbender-on-the-road-to-le-mans-with-porsche/">Michael Fassbender on the Road to Le Mans with Porsche</a>
</div>
<div>
<a class="penci-topbar-post-title" href="https://www.thecheckeredflag.co.uk/2019/11/kevin-harvick-leads-ford-stewart-haas-domination-in-aaa-texas-500-win/">Kevin Harvick leads Ford, Stewart-Haas domination in AAA Texas 500 win</a>
</div>
<div>
<a class="penci-topbar-post-title" href="https://www.thecheckeredflag.co.uk/2019/11/lundgaard-headed-the-way-in-fia-formula-3-post-season-testing/">Lundgaard leads the way in FIA Formula 3 Post-Season Testing</a>
</div>
<div>
<a class="penci-topbar-post-title" href="https://www.thecheckeredflag.co.uk/2019/11/lewis-hamilton-sets-sights-on-michael-schumacher-records-with-historic-sixth-title-win/">Lewis Hamilton sets sights on Schumacher&#8217;s records with historic sixth title win</a>
</div>
<div>
<a class="penci-topbar-post-title" href="https://www.thecheckeredflag.co.uk/2019/11/bottas-wins-feisty-usgp-as-hamilton-becomes-a-six-time-world-championship/">Bottas wins feisty US GP as Hamilton becomes a six-time World Champion</a>
</div>
</div>
</div>
</div>
</div><header id="header" class="header-header-5 has-bottom-line" itemscope="itemscope" itemtype="https://schema.org/WPHeader">
<div class="inner-header penci-header-second">
<div class="container container-fullwidth">
<div id="logo">
<a href="https://www.thecheckeredflag.co.uk/"><img src="https://www.thecheckeredflag.co.uk/wp-content/uploads/2019/10/TCF-Header-2019.png" alt="The Checkered Flag" /></a> </div>
</div>
</div>
<nav id="navigation" class="header-layout-bottom header-5 menu-style-2 menu-item-padding" role="navigation" itemscope itemtype="https://schema.org/SiteNavigationElement">
<div class="container container-fullwidth">
<div class="button-menu-mobile header-5"><i class="penci-faicon fa fa-bars"></i></div>
<ul id="menu-2016" class="menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category penci-mega-menu menu-item-131887"><a href="https://www.thecheckeredflag.co.uk/formula-1/">F1</a>
<ul class="sub-menu">
<li class="menu-item-0"><div class="penci-megamenu">
<div class="penci-content-megamenu">
<div class="penci-mega-latest-posts col-mn-5 mega-row-1">
<div class="penci-mega-row penci-mega-3 row-active">
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.thecheckeredflag.co.uk/formula-1/">
Formula 1 </a>
</span>
<a class="penci-image-holder penci-lazy" data-src="https://i1.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2019/11/max-verstappen-aston-martin-red-bull-racing-2019-formula-1-united-states-grand-prix-circuit-of-the-americas-race.jpg?resize=585%2C390&amp;ssl=1" href="https://www.thecheckeredflag.co.uk/2019/11/verstappen-and-albon-complete-strong-drives-to-leave-austin-in-good-shape/" title="Verstappen and Albon complete strong drives to leave Austin in good shape">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.thecheckeredflag.co.uk/2019/11/verstappen-and-albon-complete-strong-drives-to-leave-austin-in-good-shape/" title="Verstappen and Albon complete strong drives to leave Austin in good shape">Verstappen and Albon complete strong drives to leave&#8230;</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2019-11-04T19:03:43+00:00">November 4, 2019</time></p>
</div>
</div>
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.thecheckeredflag.co.uk/formula-1/">
Formula 1 </a>
</span>
<a class="penci-image-holder penci-lazy" data-src="https://i0.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2019/11/Valtteri-Bottas-30.jpg?resize=585%2C390&amp;ssl=1" href="https://www.thecheckeredflag.co.uk/2019/11/bottas-eager-for-more-close-fights-with-hamilton-in-2020-after-us-grand-prix-triumph/" title="Bottas Eager for More Close Fights with Hamilton in 2020 after US Grand Prix Triumph">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.thecheckeredflag.co.uk/2019/11/bottas-eager-for-more-close-fights-with-hamilton-in-2020-after-us-grand-prix-triumph/" title="Bottas Eager for More Close Fights with Hamilton in 2020 after US Grand Prix Triumph">Bottas Eager for More Close Fights with Hamilton&#8230;</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2019-11-04T18:23:13+00:00">November 4, 2019</time></p>
</div>
</div>
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.thecheckeredflag.co.uk/formula-1/">
Formula 1 </a>
</span>
<a class="penci-image-holder penci-lazy" data-src="https://i0.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2019/11/F1-2019.jpg?resize=585%2C390&amp;ssl=1" href="https://www.thecheckeredflag.co.uk/2019/11/codemasters-extend-f1-partnership/" title="Codemasters extend F1 partnership">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.thecheckeredflag.co.uk/2019/11/codemasters-extend-f1-partnership/" title="Codemasters extend F1 partnership">Codemasters extend F1 partnership</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2019-11-04T13:12:51+00:00">November 4, 2019</time></p>
</div>
</div>
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.thecheckeredflag.co.uk/formula-1/">
Formula 1 </a>
</span>
<a class="penci-image-holder penci-lazy" data-src="https://i1.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2019/11/lh_usgp_2019_rs.jpg?resize=585%2C390&amp;ssl=1" href="https://www.thecheckeredflag.co.uk/2019/11/lewis-hamilton-sets-sights-on-michael-schumacher-records-with-historic-sixth-title-win/" title="Lewis Hamilton sets sights on Schumacher&#8217;s records with historic sixth title win">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.thecheckeredflag.co.uk/2019/11/lewis-hamilton-sets-sights-on-michael-schumacher-records-with-historic-sixth-title-win/" title="Lewis Hamilton sets sights on Schumacher&#8217;s records with historic sixth title win">Lewis Hamilton sets sights on Schumacher&#8217;s records with&#8230;</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2019-11-03T22:00:25+00:00">November 3, 2019</time></p>
</div>
</div>
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.thecheckeredflag.co.uk/formula-1/">
Formula 1 </a>
</span>
<a class="penci-image-holder penci-lazy" data-src="https://i1.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2019/11/Start.jpg?resize=585%2C390&amp;ssl=1" href="https://www.thecheckeredflag.co.uk/2019/11/bottas-wins-feisty-usgp-as-hamilton-becomes-a-six-time-world-championship/" title="Bottas wins feisty US GP as Hamilton becomes a six-time World Champion">
 </a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.thecheckeredflag.co.uk/2019/11/bottas-wins-feisty-usgp-as-hamilton-becomes-a-six-time-world-championship/" title="Bottas wins feisty US GP as Hamilton becomes a six-time World Champion">Bottas wins feisty US GP as Hamilton becomes&#8230;</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2019-11-03T21:39:23+00:00">November 3, 2019</time></p>
</div>
</div>
</div>
</div>
</div>
</div></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-131940"><a href="https://www.thecheckeredflag.co.uk/open-wheel/">Open Wheel</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131942"><a href="https://www.thecheckeredflag.co.uk/open-wheel/formula-e/">FIA Formula E</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131943"><a href="https://www.thecheckeredflag.co.uk/open-wheel/indycar/">IndyCar</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-218310"><a href="https://www.thecheckeredflag.co.uk/open-wheel/fia-formula-2/">FIA Formula 2</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-296601"><a href="https://www.thecheckeredflag.co.uk/open-wheel/formula-3/fia-formula-3-championship/">FIA Formula 3</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-321059"><a href="https://www.thecheckeredflag.co.uk/open-wheel/w-series/">W Series</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-180961"><a href="https://www.thecheckeredflag.co.uk/open-wheel/formula-3/british-f3-formula-3/">British F3</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131897"><a href="https://www.thecheckeredflag.co.uk/open-wheel/msa-formula/">F4 British Championship</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131946"><a href="https://www.thecheckeredflag.co.uk/open-wheel/formula-3/euroformula-open/">EuroFormula Open</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131989"><a href="https://www.thecheckeredflag.co.uk/open-wheel/renault-world-series/formula-renault-2-0-renault-world-series/">Formula Renault 2.0</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor menu-item-has-children menu-item-131952"><a href="https://www.thecheckeredflag.co.uk/sportscars/">Sportscars</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131956"><a href="https://www.thecheckeredflag.co.uk/sportscars/endurance/fiawec/">FIA WEC</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131957"><a href="https://www.thecheckeredflag.co.uk/sportscars/endurance/blancpain-endurance-series/">Blancpain Endurance</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-148232"><a href="https://www.thecheckeredflag.co.uk/sportscars/endurance/blancpain-sprint/">Blancpain Sprint</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131954"><a href="https://www.thecheckeredflag.co.uk/sportscars/gt-sportscars/british-gt/">British GT</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-290801"><a href="https://www.thecheckeredflag.co.uk/sportscars/ginetta/">Ginetta Series</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-303742"><a href="https://www.thecheckeredflag.co.uk/sportscars/porsche/">Porsche Series</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-131899"><a href="https://www.thecheckeredflag.co.uk/touring-cars/">Touring Cars</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131904"><a href="https://www.thecheckeredflag.co.uk/touring-cars/btcc/">BTCC</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-192543"><a href="https://www.thecheckeredflag.co.uk/touring-cars/dtm/">DTM</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-255598"><a href="https://www.thecheckeredflag.co.uk/touring-cars/wtcr/">WTCR</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-303746"><a href="https://www.thecheckeredflag.co.uk/touring-cars/tcr-europe/">TCR Europe</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131951"><a href="https://www.thecheckeredflag.co.uk/touring-cars/renault-clio-cup/">Renault UK Clio Cup</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-317944"><a href="https://www.thecheckeredflag.co.uk/touring-cars/jaguar-i-pace-etrophy/">Jaguar I-PACE eTROPHY</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-131918"><a href="https://www.thecheckeredflag.co.uk/motorcycles/">Motorcycles</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131922"><a href="https://www.thecheckeredflag.co.uk/motorcycles/motogp/">MotoGP</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131920"><a href="https://www.thecheckeredflag.co.uk/motorcycles/moto2/">Moto2</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131921"><a href="https://www.thecheckeredflag.co.uk/motorcycles/moto3/">Moto3</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131923"><a href="https://www.thecheckeredflag.co.uk/motorcycles/british-superbike/">British Superbike</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131924"><a href="https://www.thecheckeredflag.co.uk/motorcycles/world-superbike/">World Superbike</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131949"><a href="https://www.thecheckeredflag.co.uk/motorcycles/road-racing/">Road Racing</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-290798"><a href="https://www.thecheckeredflag.co.uk/offroad/">Off Road</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-254211"><a href="https://www.thecheckeredflag.co.uk/offroad/rally/fiawrc/">FIA WRC</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-138301"><a href="https://www.thecheckeredflag.co.uk/offroad/rally/fia-erc/">FIA ERC</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131910"><a href="https://www.thecheckeredflag.co.uk/offroad/rally/british-rally-championship/">British Rally Championship</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-290799"><a href="https://www.thecheckeredflag.co.uk/offroad/dakar/">Dakar</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131917"><a href="https://www.thecheckeredflag.co.uk/offroad/rallycross/world-rallycross/">FIA World RX</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131913"><a href="https://www.thecheckeredflag.co.uk/offroad/rallycross/european-rallycross/">FIA European RX</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor penci-mega-menu menu-item-290800"><a href="https://www.thecheckeredflag.co.uk/nascar/">NASCAR</a>
<ul class="sub-menu">
<li class="menu-item-0"><div class="penci-megamenu"> <div class="penci-mega-child-categories">
<a class="mega-cat-child" href="https://www.thecheckeredflag.co.uk/nascar/sprint-cup/" data-id="penci-mega-2741"><span>Monster Energy NASCAR Cup Series</span></a>
<a class="mega-cat-child" href="https://www.thecheckeredflag.co.uk/nascar/nascar-trucks/" data-id="penci-mega-18305"><span>NASCAR Gander Outdoors Truck Series</span></a>
<a class="mega-cat-child" href="https://www.thecheckeredflag.co.uk/nascar/euro-racecar/" data-id="penci-mega-8304"><span>NASCAR Whelen Euro Series</span></a>
<a class="mega-cat-child" href="https://www.thecheckeredflag.co.uk/nascar/nascar-xfinity-series/" data-id="penci-mega-2742"><span>NASCAR Xfinity Series</span></a>
<a class="mega-cat-child cat-active all-style" href="https://www.thecheckeredflag.co.uk/nascar/" data-id="penci-mega-108"><span>All</span></a>
</div>
<div class="penci-content-megamenu">
<div class="penci-mega-latest-posts col-mn-4 mega-row-1">
<div class="penci-mega-row penci-mega-2741">
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.thecheckeredflag.co.uk/sportscars/endurance/united-sportscar/">IMSA</a> </span>
<a class="penci-image-holder penci-lazy" data-src="https://i2.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2019/11/MENCS-Sonoma-Kyle-Busch-2019.jpg?resize=585%2C390&amp;ssl=1" href="https://www.thecheckeredflag.co.uk/2019/11/kyle-busch-joins-lexus-for-2020-rolex-24/" title="Kyle Busch joins Lexus for 2020 Rolex 24">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.thecheckeredflag.co.uk/2019/11/kyle-busch-joins-lexus-for-2020-rolex-24/" title="Kyle Busch joins Lexus for 2020 Rolex 24">Kyle Busch joins Lexus for 2020 Rolex 24</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2019-11-04T18:48:41+00:00">November 4, 2019</time></p>
</div>
</div>
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.thecheckeredflag.co.uk/nascar/sprint-cup/">Monster Energy NASCAR Cup Series</a> </span>
<a class="penci-image-holder penci-lazy" data-src="https://i1.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2019/11/TMS2_MENCS_Harvick_Stage1_110319.jpg?resize=585%2C390&amp;ssl=1" href="https://www.thecheckeredflag.co.uk/2019/11/kevin-harvick-leads-ford-stewart-haas-domination-in-aaa-texas-500-win/" title="Kevin Harvick leads Ford, Stewart-Haas domination in AAA Texas 500 win">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.thecheckeredflag.co.uk/2019/11/kevin-harvick-leads-ford-stewart-haas-domination-in-aaa-texas-500-win/" title="Kevin Harvick leads Ford, Stewart-Haas domination in AAA Texas 500 win">Kevin Harvick leads Ford, Stewart-Haas domination in AAA&#8230;</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2019-11-04T00:15:15+00:00">November 4, 2019</time></p>
</div>
</div>
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.thecheckeredflag.co.uk/nascar/sprint-cup/">Monster Energy NASCAR Cup Series</a> </span>
<a class="penci-image-holder penci-lazy" data-src="https://i1.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2019/11/mencs_ks_kubuarmpump_71319.jpg?resize=585%2C390&amp;ssl=1" href="https://www.thecheckeredflag.co.uk/2019/11/kurt-busch-monster-energy-multi-year-extension-with-ganassi/" title="Kurt Busch, Monster Energy multi-year extension with Ganassi">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.thecheckeredflag.co.uk/2019/11/kurt-busch-monster-energy-multi-year-extension-with-ganassi/" title="Kurt Busch, Monster Energy multi-year extension with Ganassi">Kurt Busch, Monster Energy multi-year extension with Ganassi</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2019-11-03T01:10:18+00:00">November 3, 2019</time></p>
</div>
</div>
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.thecheckeredflag.co.uk/nascar/sprint-cup/">Monster Energy NASCAR Cup Series</a> </span>
<a class="penci-image-holder penci-lazy" data-src="https://i0.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2019/11/lajoie_2019mencs_carshot.jpg?resize=585%2C390&amp;ssl=1" href="https://www.thecheckeredflag.co.uk/2019/11/go-fas-racing-partners-with-stewart-haas-racing-for-2020/" title="Go Fas Racing partners with Stewart-Haas Racing for 2020">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.thecheckeredflag.co.uk/2019/11/go-fas-racing-partners-with-stewart-haas-racing-for-2020/" title="Go Fas Racing partners with Stewart-Haas Racing for 2020">Go Fas Racing partners with Stewart-Haas Racing for&#8230;</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2019-11-01T17:54:03+00:00">November 1, 2019</time></p>
</div>
</div>
</div>
<div class="penci-mega-row penci-mega-18305">
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.thecheckeredflag.co.uk/nascar/nascar-trucks/">NASCAR Gander Outdoors Truck Series</a> </span>
<a class="penci-image-holder penci-lazy" data-src="https://i0.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2019/10/Tanner-Gray-Dover-KNE-2019.jpg?resize=585%2C390&amp;ssl=1" href="https://www.thecheckeredflag.co.uk/2019/10/former-nhra-champ-tanner-gray-to-make-nascar-national-series-debut-at-martinsville/" title="Former NHRA champ Tanner Gray to make NASCAR national series debut at Martinsville">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.thecheckeredflag.co.uk/2019/10/former-nhra-champ-tanner-gray-to-make-nascar-national-series-debut-at-martinsville/" title="Former NHRA champ Tanner Gray to make NASCAR national series debut at Martinsville">Former NHRA champ Tanner Gray to make NASCAR&#8230;</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2019-10-16T18:48:41+00:00">October 16, 2019</time></p>
</div>
</div>
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.thecheckeredflag.co.uk/nascar/nascar-trucks/">NASCAR Gander Outdoors Truck Series</a> </span>
<a class="penci-image-holder penci-lazy" data-src="https://i2.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2019/08/Dippel-2019NGOTS-TruckShot.jpg?resize=585%2C390&amp;ssl=1" href="https://www.thecheckeredflag.co.uk/2019/08/misdemeanour-charges-against-suspended-tyler-dippel-dropped/" title="Misdemeanour charges against suspended Tyler Dippel dropped, reinstated">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.thecheckeredflag.co.uk/2019/08/misdemeanour-charges-against-suspended-tyler-dippel-dropped/" title="Misdemeanour charges against suspended Tyler Dippel dropped, reinstated">Misdemeanour charges against suspended Tyler Dippel dropped, reinstated</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2019-08-29T01:46:16+00:00">August 29, 2019</time></p>
</div>
</div>
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.thecheckeredflag.co.uk/nascar/nascar-trucks/">NASCAR Gander Outdoors Truck Series</a> </span>
<a class="penci-image-holder penci-lazy" data-src="https://i1.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2019/08/Tyler-Dippel-Stewart-Friesen-GOTS-Kansas-2019.jpg?resize=585%2C390&amp;ssl=1" href="https://www.thecheckeredflag.co.uk/2019/08/tyler-dippel-indefinitely-suspended-by-nascar/" title="Tyler Dippel indefinitely suspended by NASCAR">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.thecheckeredflag.co.uk/2019/08/tyler-dippel-indefinitely-suspended-by-nascar/" title="Tyler Dippel indefinitely suspended by NASCAR">Tyler Dippel indefinitely suspended by NASCAR</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2019-08-24T03:08:21+00:00">August 24, 2019</time></p>
</div>
</div>
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.thecheckeredflag.co.uk/nascar/nascar-trucks/">NASCAR Gander Outdoors Truck Series</a> </span>
<a class="penci-image-holder penci-lazy" data-src="https://i2.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2019/08/Greg-Biffle-NGOTS-2019-Texas.jpg?resize=585%2C390&amp;ssl=1" href="https://www.thecheckeredflag.co.uk/2019/08/2020-xfinity-truck-driver-rules-set/" title="2020 Xfinity, Truck driver rules set">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.thecheckeredflag.co.uk/2019/08/2020-xfinity-truck-driver-rules-set/" title="2020 Xfinity, Truck driver rules set">2020 Xfinity, Truck driver rules set</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2019-08-21T19:37:28+00:00">August 21, 2019</time></p>
</div>
</div>
</div>
<div class="penci-mega-row penci-mega-8304">
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.thecheckeredflag.co.uk/nascar/euro-racecar/">NASCAR Whelen Euro Series</a> </span>
<a class="penci-image-holder penci-lazy" data-src="https://i0.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2019/10/Memphis-Racing-23-2019-NWES.jpg?resize=585%2C390&amp;ssl=1" href="https://www.thecheckeredflag.co.uk/2019/10/2020-nascar-whelen-euro-series-schedule-released/" title="2020 NASCAR Whelen Euro Series schedule released">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.thecheckeredflag.co.uk/2019/10/2020-nascar-whelen-euro-series-schedule-released/" title="2020 NASCAR Whelen Euro Series schedule released">2020 NASCAR Whelen Euro Series schedule released</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2019-10-22T17:43:44+00:00">October 22, 2019</time></p>
</div>
</div>
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.thecheckeredflag.co.uk/nascar/euro-racecar/">NASCAR Whelen Euro Series</a> </span>
<a class="penci-image-holder penci-lazy" data-src="https://i0.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2019/10/NWES-Team-FJ-2030-partnership.jpg?resize=585%2C390&amp;ssl=1" href="https://www.thecheckeredflag.co.uk/2019/10/nascar-team-fj-sign-ten-year-extension-for-whelen-euro-series-sanction/" title="NASCAR, Team FJ sign ten-year extension for Whelen Euro Series sanction">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.thecheckeredflag.co.uk/2019/10/nascar-team-fj-sign-ten-year-extension-for-whelen-euro-series-sanction/" title="NASCAR, Team FJ sign ten-year extension for Whelen Euro Series sanction">NASCAR, Team FJ sign ten-year extension for Whelen&#8230;</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2019-10-04T16:25:28+00:00">October 4, 2019</time></p>
</div>
</div>
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.thecheckeredflag.co.uk/nascar/euro-racecar/">NASCAR Whelen Euro Series</a> </span>
<a class="penci-image-holder penci-lazy" data-src="https://i2.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2019/04/Ander-Vilarino-Valencia-2019-NWES.jpg?resize=585%2C390&amp;ssl=1" href="https://www.thecheckeredflag.co.uk/2019/04/vilarino-maggi-risitano-kick-off-2019-euro-series-with-valencia-victories/" title="Vilarino, Maggi, Risitano kick off 2019 Euro Series with Valencia victories">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.thecheckeredflag.co.uk/2019/04/vilarino-maggi-risitano-kick-off-2019-euro-series-with-valencia-victories/" title="Vilarino, Maggi, Risitano kick off 2019 Euro Series with Valencia victories">Vilarino, Maggi, Risitano kick off 2019 Euro Series&#8230;</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2019-04-15T05:25:02+00:00">April 15, 2019</time></p>
</div>
</div>
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.thecheckeredflag.co.uk/nascar/euro-racecar/">NASCAR Whelen Euro Series</a> </span>
<a class="penci-image-holder penci-lazy" data-src="https://i2.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2019/04/Euro-NASCAR-18-32-paddock.jpg?resize=585%2C390&amp;ssl=1" href="https://www.thecheckeredflag.co.uk/2019/04/nascar-gp-of-spain-featuring-decorated-grid/" title="NASCAR GP of Spain featuring decorated grid">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.thecheckeredflag.co.uk/2019/04/nascar-gp-of-spain-featuring-decorated-grid/" title="NASCAR GP of Spain featuring decorated grid">NASCAR GP of Spain featuring decorated grid</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2019-04-10T18:07:18+00:00">April 10, 2019</time></p>
</div>
</div>
</div>
<div class="penci-mega-row penci-mega-2742">
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.thecheckeredflag.co.uk/nascar/nascar-xfinity-series/">NASCAR Xfinity Series</a> </span>
<a class="penci-image-holder penci-lazy" data-src="https://i2.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2019/10/Andy-Seuss-Our-Motorsports-02-2020-NXS.jpg?resize=585%2C390&amp;ssl=1" href="https://www.thecheckeredflag.co.uk/2019/10/our-motorsports-to-run-full-xfinity-campaign-in-2020/" title="Our Motorsports to run full Xfinity campaign in 2020">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.thecheckeredflag.co.uk/2019/10/our-motorsports-to-run-full-xfinity-campaign-in-2020/" title="Our Motorsports to run full Xfinity campaign in 2020">Our Motorsports to run full Xfinity campaign in&#8230;</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2019-10-30T20:17:08+00:00">October 30, 2019</time></p>
</div>
</div>
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.thecheckeredflag.co.uk/nascar/nascar-xfinity-series/">NASCAR Xfinity Series</a> </span>
<a class="penci-image-holder penci-lazy" data-src="https://i1.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2019/10/nxs_cls_chastainxs_062819.jpg?resize=585%2C390&amp;ssl=1" href="https://www.thecheckeredflag.co.uk/2019/10/kaulig-jtg-daugherty-racing-haulers-involved-in-incidents-before-kansas-weekend/" title="Kaulig, JTG Daugherty Racing haulers involved in incidents before Kansas weekend">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.thecheckeredflag.co.uk/2019/10/kaulig-jtg-daugherty-racing-haulers-involved-in-incidents-before-kansas-weekend/" title="Kaulig, JTG Daugherty Racing haulers involved in incidents before Kansas weekend">Kaulig, JTG Daugherty Racing haulers involved in incidents&#8230;</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2019-10-18T03:00:43+00:00">October 18, 2019</time></p>
</div>
</div>
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.thecheckeredflag.co.uk/nascar/nascar-xfinity-series/">NASCAR Xfinity Series</a> </span>
<a class="penci-image-holder penci-lazy" data-src="https://i0.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2019/09/2019-NASCAR-Xfinity-playoff-grid.jpg?resize=585%2C390&amp;ssl=1" href="https://www.thecheckeredflag.co.uk/2019/09/nascar-xfinity-series-playoff-field-finalised/" title="NASCAR Xfinity Series playoff field finalised">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.thecheckeredflag.co.uk/2019/09/nascar-xfinity-series-playoff-field-finalised/" title="NASCAR Xfinity Series playoff field finalised">NASCAR Xfinity Series playoff field finalised</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2019-09-15T04:06:11+00:00">September 15, 2019</time></p>
</div>
</div>
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.thecheckeredflag.co.uk/nascar/nascar-xfinity-series/">NASCAR Xfinity Series</a> </span>
<a class="penci-image-holder penci-lazy" data-src="https://i1.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2019/09/Elliott-Sadler-Richmond-NXS-2018.jpg?resize=585%2C390&amp;ssl=1" href="https://www.thecheckeredflag.co.uk/2019/09/elliott-sadler-to-run-special-livery-for-855th-and-final-nascar-start/" title="Elliott Sadler to run special livery for 855th and final NASCAR start">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.thecheckeredflag.co.uk/2019/09/elliott-sadler-to-run-special-livery-for-855th-and-final-nascar-start/" title="Elliott Sadler to run special livery for 855th and final NASCAR start">Elliott Sadler to run special livery for 855th&#8230;</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2019-09-10T20:36:55+00:00">September 10, 2019</time></p>
</div>
</div>
</div>
<div class="penci-mega-row penci-mega-108 row-active">
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.thecheckeredflag.co.uk/nascar/">NASCAR</a> </span>
<a class="penci-image-holder penci-lazy" data-src="https://i2.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2019/11/MENCS-Sonoma-Kyle-Busch-2019.jpg?resize=585%2C390&amp;ssl=1" href="https://www.thecheckeredflag.co.uk/2019/11/kyle-busch-joins-lexus-for-2020-rolex-24/" title="Kyle Busch joins Lexus for 2020 Rolex 24">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.thecheckeredflag.co.uk/2019/11/kyle-busch-joins-lexus-for-2020-rolex-24/" title="Kyle Busch joins Lexus for 2020 Rolex 24">Kyle Busch joins Lexus for 2020 Rolex 24</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2019-11-04T18:48:41+00:00">November 4, 2019</time></p>
</div>
</div>
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.thecheckeredflag.co.uk/nascar/">NASCAR</a> </span>
<a class="penci-image-holder penci-lazy" data-src="https://i1.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2019/11/TMS2_MENCS_Harvick_Stage1_110319.jpg?resize=585%2C390&amp;ssl=1" href="https://www.thecheckeredflag.co.uk/2019/11/kevin-harvick-leads-ford-stewart-haas-domination-in-aaa-texas-500-win/" title="Kevin Harvick leads Ford, Stewart-Haas domination in AAA Texas 500 win">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.thecheckeredflag.co.uk/2019/11/kevin-harvick-leads-ford-stewart-haas-domination-in-aaa-texas-500-win/" title="Kevin Harvick leads Ford, Stewart-Haas domination in AAA Texas 500 win">Kevin Harvick leads Ford, Stewart-Haas domination in AAA&#8230;</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2019-11-04T00:15:15+00:00">November 4, 2019</time></p>
</div>
</div>
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.thecheckeredflag.co.uk/nascar/">NASCAR</a> </span>
<a class="penci-image-holder penci-lazy" data-src="https://i1.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2019/11/mencs_ks_kubuarmpump_71319.jpg?resize=585%2C390&amp;ssl=1" href="https://www.thecheckeredflag.co.uk/2019/11/kurt-busch-monster-energy-multi-year-extension-with-ganassi/" title="Kurt Busch, Monster Energy multi-year extension with Ganassi">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.thecheckeredflag.co.uk/2019/11/kurt-busch-monster-energy-multi-year-extension-with-ganassi/" title="Kurt Busch, Monster Energy multi-year extension with Ganassi">Kurt Busch, Monster Energy multi-year extension with Ganassi</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2019-11-03T01:10:18+00:00">November 3, 2019</time></p>
</div>
</div>
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.thecheckeredflag.co.uk/nascar/">NASCAR</a> </span>
<a class="penci-image-holder penci-lazy" data-src="https://i0.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2019/11/lajoie_2019mencs_carshot.jpg?resize=585%2C390&amp;ssl=1" href="https://www.thecheckeredflag.co.uk/2019/11/go-fas-racing-partners-with-stewart-haas-racing-for-2020/" title="Go Fas Racing partners with Stewart-Haas Racing for 2020">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.thecheckeredflag.co.uk/2019/11/go-fas-racing-partners-with-stewart-haas-racing-for-2020/" title="Go Fas Racing partners with Stewart-Haas Racing for 2020">Go Fas Racing partners with Stewart-Haas Racing for&#8230;</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2019-11-01T17:54:03+00:00">November 1, 2019</time></p>
</div>
</div>
</div>
</div>
</div>
</div></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-293110"><a href="https://www.thecheckeredflag.co.uk/features/">Features</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-293115"><a href="https://www.thecheckeredflag.co.uk/features/opinion/">Opinion</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-293113"><a href="https://www.thecheckeredflag.co.uk/features/interviews/">Interviews</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-293114"><a href="https://www.thecheckeredflag.co.uk/features/gallery/">Gallery</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-293111"><a href="https://www.thecheckeredflag.co.uk/features/product-review/">Product Review</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-293112"><a href="https://www.thecheckeredflag.co.uk/features/season-review/">Season Review</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-293118"><a href="https://www.thecheckeredflag.co.uk/other/esports/">eSports</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-293117"><a href="https://www.thecheckeredflag.co.uk/other/video-games/">Sim Racing</a></li>
</ul>
</li>
</ul>
<div id="top-search" class="dfdf">
<a class="search-click"><i class="penci-faicon fa fa-search"></i></a>
<div class="show-search">
<form role="search" method="get" id="searchform" action="https://www.thecheckeredflag.co.uk/">
<div>
<input type="text" class="search-input" placeholder="Type and hit enter..." name="s" id="s" />
</div>
</form> <a class="search-click close-search"><i class="penci-faicon fa fa-close"></i></a>
</div>
</div> </div>
</nav>
</header>
</div>
<div class="container container-single container-single-magazine penci_sidebar  penci-enable-lightbox">
<div id="main">
<div class="theiaStickySidebar">
<article id="post-325145" class="post type-post status-publish hentry">
<div class="header-standard header-classic single-header">
<div class="penci-standard-cat"><span class="cat"><a class="penci-cat-name" href="https://www.thecheckeredflag.co.uk/sportscars/endurance/united-sportscar/" rel="category tag">IMSA</a><a class="penci-cat-name" href="https://www.thecheckeredflag.co.uk/nascar/sprint-cup/" rel="category tag">Monster Energy NASCAR Cup Series</a></span></div>
<h1 class="post-title single-post-title entry-title">Kyle Busch joins Lexus for 2020 Rolex 24</h1>
<div class="penci-hide-tagupdated">
<span class="author-italic author vcard">by <a class="url fn n" href="https://www.thecheckeredflag.co.uk/author/jnguyen/">Justin Nguyen</a></span>
<time class="entry-date published" datetime="2019-11-04T18:48:41+00:00">November 4, 2019</time>
</div>
<div class="post-box-meta-single">
<span class="author-post byline"><span class="author vcard">written by <a class="author-url url fn n" href="https://www.thecheckeredflag.co.uk/author/jnguyen/">Justin Nguyen</a></span></span>
<span><time class="entry-date published" datetime="2019-11-04T18:48:41+00:00">November 4, 2019</time></span>
</div>
</div>
<div class="post-image">
<a href="https://www.thecheckeredflag.co.uk/wp-content/uploads/2019/11/MENCS-Sonoma-Kyle-Busch-2019.jpg" data-rel="penci-gallery-image-content"> <img width="800" height="533" src="https://i2.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2019/11/MENCS-Sonoma-Kyle-Busch-2019.jpg?fit=800%2C533&amp;ssl=1" class="attachment-penci-full-thumb size-penci-full-thumb wp-post-image" alt="" srcset="https://i2.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2019/11/MENCS-Sonoma-Kyle-Busch-2019.jpg?w=800&amp;ssl=1 800w, https://i2.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2019/11/MENCS-Sonoma-Kyle-Busch-2019.jpg?resize=240%2C160&amp;ssl=1 240w, https://i2.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2019/11/MENCS-Sonoma-Kyle-Busch-2019.jpg?resize=768%2C512&amp;ssl=1 768w, https://i2.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2019/11/MENCS-Sonoma-Kyle-Busch-2019.jpg?resize=585%2C390&amp;ssl=1 585w, https://i2.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2019/11/MENCS-Sonoma-Kyle-Busch-2019.jpg?resize=263%2C175&amp;ssl=1 263w" sizes="(max-width: 800px) 100vw, 800px" /> </a><div class="penci-featured-caption">Credit: Jonathan Ferrey/Getty Images</div> </div>
<div class="post-entry blockquote-style-1">
<div class="inner-post-entry entry-content" id="penci-post-entry-inner">
<p>The <strong>2020 Rolex 24 at Daytona</strong> will receive some <strong>NASCAR </strong>flavour. On Monday, <strong>Lexus Motorsports</strong> and <strong>AIM Vasser Sullivan</strong> <a href="https://www.imsa.com/news/112019/kyle-busch-compete-2020-rolex-24-daytona-set-drive-lexus-rc-f-gt3-aim-vasser-sullivan">announced </a><strong>Kyle Busch</strong> would race in <strong>IMSA </strong>and the Rolex 24 for the first time, driving AIMVS&#8217;s <strong>Lexus RC F GT3</strong> in the GTD class.</p>
<p><em>&#8220;We&#8217;re thrilled to have a racer of Kyle&#8217;s caliber join AIM VASSER SULLIVAN to open our 2020 season at the Rolex 24 at Daytona,&#8221;</em> team co-owner <strong>Jimmy Vasser</strong> stated. <em>&#8220;Kyle has proven he can compete and win in many forms of motorsports and we look forward to having him drive the Lexus RC F GT3 at Daytona.&#8221;</em></p>
<p>Busch is currently fighting for his second <strong>Monster Energy Cup Series</strong> championship. Driving for <strong>Joe Gibbs Racing</strong> (a <strong>Toyota </strong>team), he sits third in points with four wins and is in position to make the Championship Round. Although he has neither raced in the Rolex 24 nor IMSA before, he has enjoyed success on NASCAR&#8217;s road courses with four Cup victories on such tracks (two apiece at <strong>Sonoma Raceway</strong> and <strong>Watkins Glen International</strong>).</p>
<p>He also has two road race victories in the <strong>NASCAR Xfinity Series</strong>, winning at Watkins Glen in 2017 and the <strong>Autódromo Hermanos Rodríguez</strong> in 2008.</p>
<p><em>&#8220;Kyle has been a fixture in our Toyota family for over a decade and is the winningest driver in the Toyota NASCAR program,&#8221;</em> Lexus&#8217; Vice President of Marketing <strong>Lisa Materazzo</strong> said. <em>&#8220;He has accomplished so many firsts for Toyota throughout his tenure and we couldn’t be happier to have him join AIM VASSER SULLIVAN and drive the Lexus RC F GT3 in a world class event like the Rolex 24 at Daytona.&#8221;</em></p>
<p>NASCAR and IMSA have crossed over on numerous occasions over the years. The 2019 Rolex 24 saw <strong>Juan Pablo Montoya</strong>, who has two Cup wins, finish eighth overall. <strong>Justin Marks</strong> and former Cup race winner <strong>A.J. Allmendinger</strong> were team-mates, while Xfinity regular <strong>Austin Cindric</strong> raced for AIM Vasser Sullivan. <strong>Jack Hawksworth</strong>, one of Cindric&#8217;s partners that race, <a href="https://www.thecheckeredflag.co.uk/2019/08/jack-hawksworth-joins-joe-gibbs-racing-for-xfinity-debut-at-mid-ohio/">made his Xfinity début</a> in August with JGR at the <strong>Mid-Ohio Sports Car Course</strong>; coincidentally, Cindric won that event.</p>
<p>On Twitter, Busch posted a video expressing his excitement for competing:</p>
<figure class="wp-block-embed-twitter wp-block-embed is-type-rich is-provider-twitter"><div class="wp-block-embed__wrapper">
<blockquote class="twitter-tweet" data-width="550" data-dnt="true"><p lang="en" dir="ltr">Thanks <a href="https://twitter.com/lexusracingusa?ref_src=twsrc%5Etfw">@LexusRacingUSA</a> and <a href="https://twitter.com/AVSautosport?ref_src=twsrc%5Etfw">@AVSautosport</a> for the opportunity! <a href="https://twitter.com/hashtag/Rolex24?src=hash&amp;ref_src=twsrc%5Etfw">#Rolex24</a> <a href="https://t.co/poxB2mj5f9">pic.twitter.com/poxB2mj5f9</a></p>&mdash; Kyle Busch (@KyleBusch) <a href="https://twitter.com/KyleBusch/status/1191418611929403394?ref_src=twsrc%5Etfw">November 4, 2019</a></blockquote>
</div></figure>
<div class="penci-single-link-pages">
</div>
<div class="post-tags">
<a href="https://www.thecheckeredflag.co.uk/tag/2020-rolex-24-hours-at-daytona/" rel="tag">2020 Rolex 24 Hours at Daytona</a><a href="https://www.thecheckeredflag.co.uk/tag/aim-vasser-sullivan/" rel="tag">AIM Vasser Sullivan</a><a href="https://www.thecheckeredflag.co.uk/tag/kyle-busch/" rel="tag">Kyle Busch</a><a href="https://www.thecheckeredflag.co.uk/tag/lexus-rc-f-gt3/" rel="tag">Lexus RC-F GT3</a> </div>
</div>
</div>
<div class="penci-google-adsense-2">

<ins class="adsbygoogle" style="display:inline-block;width:728px;height:90px" data-ad-client="ca-pub-9159179884377372" data-ad-slot="6495511074"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script> </div>
<div class="tags-share-box center-box tags-share-box-s1">
<span class="single-comment-o"><i class="penci-faicon fa fa-comment-o"></i><span class="dsq-postid" data-dsqidentifier="325145 https://www.thecheckeredflag.co.uk/?p=325145">0 comment</span></span>
<div class="post-share">
<span class="post-share-item post-share-plike"><span class="count-number-like">0</span><a class="penci-post-like single-like-button" data-post_id="325145" title="Like" data-like="Like" data-unlike="Unlike"><i class="penci-faicon fa fa-heart-o"></i></a></span>
<div class="list-posts-share"><a class="post-share-item post-share-facebook" target="_blank" rel="nofollow" href="https://www.facebook.com/sharer/sharer.php?u=https://www.thecheckeredflag.co.uk/2019/11/kyle-busch-joins-lexus-for-2020-rolex-24/"><i class="penci-faicon fa fa-facebook"></i><span class="dt-share">Facebook</span></a><a class="post-share-item post-share-twitter" target="_blank" rel="nofollow" href="https://twitter.com/intent/tweet?text=Check%20out%20this%20article:%20Kyle%20Busch%20joins%20Lexus%20for%202020%20Rolex%2024%20-%20https://www.thecheckeredflag.co.uk/2019/11/kyle-busch-joins-lexus-for-2020-rolex-24/"><i class="penci-faicon fa fa-twitter"></i><span class="dt-share">Twitter</span></a><a class="post-share-item post-share-pinterest" data-pin-do="none" rel="nofollow noreferrer noopener" onclick="var e=document.createElement('script');e.setAttribute('type','text/javascript');e.setAttribute('charset','UTF-8');e.setAttribute('src','//assets.pinterest.com/js/pinmarklet.js?r='+Math.random()*99999999);document.body.appendChild(e);"><i class="penci-faicon fa fa-pinterest"></i><span class="dt-share">Pinterest</span></a><a class="post-share-item post-share-linkedin" target="_blank" rel="nofollow" href="https://www.linkedin.com/shareArticle?mini=true&#038;url=https%3A%2F%2Fwww.thecheckeredflag.co.uk%2F2019%2F11%2Fkyle-busch-joins-lexus-for-2020-rolex-24%2F&#038;title=Kyle%20Busch%20joins%20Lexus%20for%202020%20Rolex%2024"><i class="penci-faicon fa fa-linkedin"></i><span class="dt-share">Linkedin</span></a><a class="post-share-item post-share-reddit" target="_blank" rel="nofollow" href="https://reddit.com/submit?url=https%3A%2F%2Fwww.thecheckeredflag.co.uk%2F2019%2F11%2Fkyle-busch-joins-lexus-for-2020-rolex-24%2F&#038;title=Kyle%20Busch%20joins%20Lexus%20for%202020%20Rolex%2024"><i class="penci-faicon fa fa-reddit-alien"></i><span class="dt-share">Reddit</span></a><a class="post-share-item post-share-whatsapp" target="_blank" rel="nofollow" href="https://api.whatsapp.com/send?text=Kyle%20Busch%20joins%20Lexus%20for%202020%20Rolex%2024 %0A%0A https%3A%2F%2Fwww.thecheckeredflag.co.uk%2F2019%2F11%2Fkyle-busch-joins-lexus-for-2020-rolex-24%2F"><i class="penci-faicon fa fa-whatsapp"></i><span class="dt-share">Whatsapp</span></a><a class="post-share-item post-share-email" target="_blank" rel="nofollow" href="/cdn-cgi/l/email-protection#97a8e4e2f5fdf2f4e3aadceefbf2b2a5a7d5e2e4f4ffb2a5a7fdf8fef9e4b2a5a7dbf2efe2e4b2a5a7f1f8e5b2a5a7a5a7a5a7b2a5a7c5f8fbf2efb2a5a7a5a3b1b4a7a4afacd5d8d3ceaaffe3e3e7e4adb8b8e0e0e0b9e3fff2f4fff2f4fcf2e5f2f3f1fbf6f0b9f4f8b9e2fcb8a5a7a6aeb8a6a6b8fceefbf2baf5e2e4f4ffbafdf8fef9e4bafbf2efe2e4baf1f8e5baa5a7a5a7bae5f8fbf2efbaa5a3b8"><i class="penci-faicon fa fa-envelope"></i><span class="dt-share">Email</span></a></div> </div>
</div>
<div class="post-author">
<div class="author-img">
<img alt='Justin Nguyen' src='https://www.thecheckeredflag.co.uk/wp-content/uploads/2019/05/Justin-Nguyen-avatar-100x100.jpg' class='avatar avatar-100 photo' height='100' width='100' /> </div>
<div class="author-content">
<h5><a href="https://www.thecheckeredflag.co.uk/author/jnguyen/" title="Posts by Justin Nguyen" rel="author">Justin Nguyen</a></h5>
<p>American and lifelong motorsports fan who covers NASCAR and the Stadium Super Trucks. Follow him on Twitter at @ZappaOMatic</p>
<a target="_blank" class="author-social" href="https://zappaomatic.wordpress.com"><i class="penci-faicon fa fa-globe"></i></a>
<a target="_blank" class="author-social" href="https://twitter.com/ZappaOMatic"><i class="penci-faicon fa fa-twitter"></i></a>
<a class="author-social" href="/cdn-cgi/l/email-protection#c68cb3b5b2afa8e888a1b3bfa3a886b2aea3a5aea3a5ada3b4a3a2a0aaa7a1e8a5a9e8b3ad"><i class="penci-faicon fa fa-envelope"></i></a>
</div>
</div>
<div class="post-related">
<div class="post-title-box"><h4 class="post-box-title">Related articles</h4></div>
<div class="penci-owl-carousel penci-owl-carousel-slider penci-related-carousel" data-lazy="true" data-item="3" data-desktop="3" data-tablet="2" data-tabsmall="2" data-auto="false" data-speed="300" data-dots="true" data-nav="false">
<div class="item-related">
<a class="related-thumb penci-image-holder" style="background-image: url('https://i0.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2019/09/mencs_rr_truex_092019.jpg?resize=585%2C390&amp;ssl=1');" href="https://www.thecheckeredflag.co.uk/2019/09/martin-truex-jr-sweeps-richmond-wins-federated-auto-parts-400/" title="Martin Truex Jr. sweeps Richmond, wins Federated Auto Parts 400">
</a>
<h3><a href="https://www.thecheckeredflag.co.uk/2019/09/martin-truex-jr-sweeps-richmond-wins-federated-auto-parts-400/">Martin Truex Jr. sweeps Richmond, wins Federated Auto Parts 400</a></h3>
<span class="date"><time class="entry-date published" datetime="2019-09-22T03:50:00+00:00">September 22, 2019</time></span>
</div>
<div class="item-related">
<a class="related-thumb penci-image-holder" style="background-image: url('https://i1.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2019/09/MENCS_IMS_Playoff_Photo_090819.jpg?resize=585%2C390&amp;ssl=1');" href="https://www.thecheckeredflag.co.uk/2019/09/2019-nascar-cup-playoff-grid-set/" title="2019 NASCAR Cup playoff grid set">
</a>
<h3><a href="https://www.thecheckeredflag.co.uk/2019/09/2019-nascar-cup-playoff-grid-set/">2019 NASCAR Cup playoff grid set</a></h3>
<span class="date"><time class="entry-date published" datetime="2019-09-09T04:26:13+00:00">September 9, 2019</time></span>
</div>
<div class="item-related">
<a class="related-thumb penci-image-holder" style="background-image: url('https://i0.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2019/09/Jones_Erik_Darlington_2019.jpg?resize=585%2C390&amp;ssl=1');" href="https://www.thecheckeredflag.co.uk/2019/09/erik-jones-wins-southern-500-in-100th-cup-start/" title="Erik Jones wins Southern 500 in 100th Cup start">
</a>
<h3><a href="https://www.thecheckeredflag.co.uk/2019/09/erik-jones-wins-southern-500-in-100th-cup-start/">Erik Jones wins Southern 500 in 100th Cup start</a></h3>
<span class="date"><time class="entry-date published" datetime="2019-09-02T07:02:45+00:00">September 2, 2019</time></span>
</div>
<div class="item-related">
<a class="related-thumb penci-image-holder" style="background-image: url('https://i0.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2019/07/MENCS_KS_KuBuCheckeredFlag_71319.jpg?resize=585%2C390&amp;ssl=1');" href="https://www.thecheckeredflag.co.uk/2019/07/kurt-busch-wins-brother-battle-quaker-state-400/" title="Kurt Busch wins brother battle, Quaker State 400">
</a>
<h3><a href="https://www.thecheckeredflag.co.uk/2019/07/kurt-busch-wins-brother-battle-quaker-state-400/">Kurt Busch wins brother battle, Quaker State 400</a></h3>
<span class="date"><time class="entry-date published" datetime="2019-07-16T20:54:29+00:00">July 16, 2019</time></span>
</div>
<div class="item-related">
<a class="related-thumb penci-image-holder" style="background-image: url('https://i0.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2019/06/MENCS_PR1_KyBusch_Prac1_053119.jpg?resize=585%2C390&amp;ssl=1');" href="https://www.thecheckeredflag.co.uk/2019/06/kyle-busch-wins-pocono-400/" title="Kyle Busch wins Pocono 400">
</a>
<h3><a href="https://www.thecheckeredflag.co.uk/2019/06/kyle-busch-wins-pocono-400/">Kyle Busch wins Pocono 400</a></h3>
<span class="date"><time class="entry-date published" datetime="2019-06-02T22:07:15+00:00">June 2, 2019</time></span>
</div>
<div class="item-related">
<a class="related-thumb penci-image-holder" style="background-image: url('https://i1.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2019/04/mencs_bms_kybuschprac1_040519.jpg?resize=585%2C390&amp;ssl=1');" href="https://www.thecheckeredflag.co.uk/2019/04/kyle-busch-overcomes-early-spin-wins-food-city-500/" title="Kyle Busch overcomes early spin, wins Food City 500">
</a>
<h3><a href="https://www.thecheckeredflag.co.uk/2019/04/kyle-busch-overcomes-early-spin-wins-food-city-500/">Kyle Busch overcomes early spin, wins Food City 500</a></h3>
<span class="date"><time class="entry-date published" datetime="2019-04-07T23:25:07+00:00">April 7, 2019</time></span>
</div>
<div class="item-related">
<a class="related-thumb penci-image-holder" style="background-image: url('https://i2.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2019/04/TCF-NASCAR-2019-Hamlin-Texas-Win.jpg?resize=585%2C390&amp;ssl=1');" href="https://www.thecheckeredflag.co.uk/2019/04/hamlin-rebounds-from-two-pit-penalties-to-take-texas-victory/" title="Hamlin rebounds from two pit penalties to take Texas victory">
</a>
<h3><a href="https://www.thecheckeredflag.co.uk/2019/04/hamlin-rebounds-from-two-pit-penalties-to-take-texas-victory/">Hamlin rebounds from two pit penalties to take Texas victory</a></h3>
<span class="date"><time class="entry-date published" datetime="2019-04-01T01:21:29+00:00">April 1, 2019</time></span>
</div>
<div class="item-related">
<a class="related-thumb penci-image-holder" style="background-image: url('https://i2.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2019/03/Greg-Biffle-CMS-NSCS-GB-051515.jpg?resize=585%2C390&amp;ssl=1');" href="https://www.thecheckeredflag.co.uk/2019/03/greg-biffle-officially-returns-to-nascar-with-july-truck-race/" title="Greg Biffle officially returns to NASCAR with July Truck race">
</a>
<h3><a href="https://www.thecheckeredflag.co.uk/2019/03/greg-biffle-officially-returns-to-nascar-with-july-truck-race/">Greg Biffle officially returns to NASCAR with July Truck race</a></h3>
<span class="date"><time class="entry-date published" datetime="2019-03-28T22:07:07+00:00">March 28, 2019</time></span>
</div>
<div class="item-related">
<a class="related-thumb penci-image-holder" style="background-image: url('https://i2.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2019/03/Greg-Biffle-MIS-NSCS-2015.jpg?resize=585%2C390&amp;ssl=1');" href="https://www.thecheckeredflag.co.uk/2019/03/greg-biffle-returning-to-nascar-for-truck-series-practice/" title="Greg Biffle returning to NASCAR for Truck Series practice">
</a>
<h3><a href="https://www.thecheckeredflag.co.uk/2019/03/greg-biffle-returning-to-nascar-for-truck-series-practice/">Greg Biffle returning to NASCAR for Truck Series practice</a></h3>
<span class="date"><time class="entry-date published" datetime="2019-03-28T02:31:52+00:00">March 28, 2019</time></span>
</div>
</div></div>
<div id="disqus_thread"></div>
<div class="post-pagination">
<div class="prev-post">
<div class="prev-post-inner">
<div class="prev-post-title">
<span>previous post</span>
</div>
<a href="https://www.thecheckeredflag.co.uk/2019/11/bottas-eager-for-more-close-fights-with-hamilton-in-2020-after-us-grand-prix-triumph/">
<div class="pagi-text">
<h5 class="prev-title">Bottas Eager for More Close Fights with Hamilton in 2020 after US Grand Prix Triumph</h5>
</div>
</a>
</div>
</div>
<div class="next-post">
<div class="next-post-inner">
<div class="prev-post-title next-post-title">
<span>next post</span>
</div>
<a href="https://www.thecheckeredflag.co.uk/2019/11/verstappen-and-albon-complete-strong-drives-to-leave-austin-in-good-shape/">
<div class="pagi-text">
<h5 class="next-title">Verstappen and Albon complete strong drives to leave Austin in good shape</h5>
</div>
</a>
</div>
</div>
</div>
</article> </div>
</div>
<div id="sidebar" class="penci-sidebar-right penci-sidebar-content style-1 pcalign-center">
<div class="theiaStickySidebar">
<aside id="custom_html-11" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget">

<ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-9159179884377372" data-ad-slot="4409003789" data-ad-format="auto" data-full-width-responsive="true"></ins>
<script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script></div></aside><aside id="penci_slider_posts_news_widget-2" class="widget penci_slider_posts_news_widget"><h4 class="widget-title penci-border-arrow"><span class="inner-arrow">Latest articles</span></h4> <div id="penci-postslidewg-2028" class="penci-owl-carousel penci-owl-carousel-slider penci-widget-slider penci-post-slider-style-1" data-lazy="true">
<div class="penci-slide-widget">
<div class="penci-slide-content">
<span class="penci-image-holder" style="background-image: url('https://i1.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2019/11/max-verstappen-aston-martin-red-bull-racing-2019-formula-1-united-states-grand-prix-circuit-of-the-americas-race.jpg?resize=585%2C390&amp;ssl=1');" title="Verstappen and Albon complete strong drives to leave Austin in good shape"></span>
<a href="https://www.thecheckeredflag.co.uk/2019/11/verstappen-and-albon-complete-strong-drives-to-leave-austin-in-good-shape/" class="penci-widget-slider-overlay" title="Verstappen and Albon complete strong drives to leave Austin in good shape"></a>
<div class="penci-widget-slide-detail">
<h4>
<a href="https://www.thecheckeredflag.co.uk/2019/11/verstappen-and-albon-complete-strong-drives-to-leave-austin-in-good-shape/" rel="bookmark" title="Verstappen and Albon complete strong drives to leave Austin in good shape">Verstappen and Albon complete strong drives to leave...</a>
</h4>
<span class="slide-item-date">Nov 4, 2019</span>
</div>
</div>
</div>
<div class="penci-slide-widget">
<div class="penci-slide-content">
<span class="penci-image-holder" style="background-image: url('https://i2.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2019/11/MENCS-Sonoma-Kyle-Busch-2019.jpg?resize=585%2C390&amp;ssl=1');" title="Kyle Busch joins Lexus for 2020 Rolex 24"></span>
<a href="https://www.thecheckeredflag.co.uk/2019/11/kyle-busch-joins-lexus-for-2020-rolex-24/" class="penci-widget-slider-overlay" title="Kyle Busch joins Lexus for 2020 Rolex 24"></a>
<div class="penci-widget-slide-detail">
<h4>
<a href="https://www.thecheckeredflag.co.uk/2019/11/kyle-busch-joins-lexus-for-2020-rolex-24/" rel="bookmark" title="Kyle Busch joins Lexus for 2020 Rolex 24">Kyle Busch joins Lexus for 2020 Rolex 24</a>
</h4>
<span class="slide-item-date">Nov 4, 2019</span>
</div>
</div>
</div>
<div class="penci-slide-widget">
<div class="penci-slide-content">
<span class="penci-image-holder" style="background-image: url('https://i0.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2019/11/Valtteri-Bottas-30.jpg?resize=585%2C390&amp;ssl=1');" title="Bottas Eager for More Close Fights with Hamilton in 2020 after US Grand Prix Triumph"></span>
<a href="https://www.thecheckeredflag.co.uk/2019/11/bottas-eager-for-more-close-fights-with-hamilton-in-2020-after-us-grand-prix-triumph/" class="penci-widget-slider-overlay" title="Bottas Eager for More Close Fights with Hamilton in 2020 after US Grand Prix Triumph"></a>
<div class="penci-widget-slide-detail">
<h4>
<a href="https://www.thecheckeredflag.co.uk/2019/11/bottas-eager-for-more-close-fights-with-hamilton-in-2020-after-us-grand-prix-triumph/" rel="bookmark" title="Bottas Eager for More Close Fights with Hamilton in 2020 after US Grand Prix Triumph">Bottas Eager for More Close Fights with Hamilton...</a>
</h4>
<span class="slide-item-date">Nov 4, 2019</span>
</div>
</div>
</div>
<div class="penci-slide-widget">
<div class="penci-slide-content">
<span class="penci-image-holder" style="background-image: url('https://i2.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2018/05/SeanMaynardFoustTwitterTCF.jpg?resize=585%2C390&amp;ssl=1');" title="Volkswagen retire Beetle from rallycross"></span>
<a href="https://www.thecheckeredflag.co.uk/2019/11/volkswagen-retire-beetle-from-rallycross/" class="penci-widget-slider-overlay" title="Volkswagen retire Beetle from rallycross"></a>
<div class="penci-widget-slide-detail">
<h4>
<a href="https://www.thecheckeredflag.co.uk/2019/11/volkswagen-retire-beetle-from-rallycross/" rel="bookmark" title="Volkswagen retire Beetle from rallycross">Volkswagen retire Beetle from rallycross</a>
</h4>
<span class="slide-item-date">Nov 4, 2019</span>
</div>
</div>
</div>
<div class="penci-slide-widget">
<div class="penci-slide-content">
<span class="penci-image-holder" style="background-image: url('https://i0.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2019/11/F1-2019.jpg?resize=585%2C390&amp;ssl=1');" title="Codemasters extend F1 partnership"></span>
<a href="https://www.thecheckeredflag.co.uk/2019/11/codemasters-extend-f1-partnership/" class="penci-widget-slider-overlay" title="Codemasters extend F1 partnership"></a>
<div class="penci-widget-slide-detail">
<h4>
<a href="https://www.thecheckeredflag.co.uk/2019/11/codemasters-extend-f1-partnership/" rel="bookmark" title="Codemasters extend F1 partnership">Codemasters extend F1 partnership</a>
</h4>
<span class="slide-item-date">Nov 4, 2019</span>
</div>
</div>
</div>
</div>
</aside><aside id="penci_popular_news_widget-5" class="widget penci_popular_news_widget"><h4 class="widget-title penci-border-arrow"><span class="inner-arrow">Popular on TCF</span></h4> <ul id="penci-popularwg-5711" class="side-newsfeed">
<li class="penci-feed featured-news">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder" rel="bookmark" style="background-image: url('https://i0.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2019/11/Michael-Fassbender-Porsche-Le-Mans.jpg?resize=585%2C390&amp;ssl=1');" href="https://www.thecheckeredflag.co.uk/2019/11/michael-fassbender-on-the-road-to-le-mans-with-porsche/" title="Michael Fassbender on the Road to Le Mans with Porsche"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.thecheckeredflag.co.uk/2019/11/michael-fassbender-on-the-road-to-le-mans-with-porsche/" rel="bookmark" title="Michael Fassbender on the Road to Le Mans with Porsche">
Michael Fassbender on the Road to Le Mans with Porsche </a>
</h4>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder small-fix-size" rel="bookmark" style="background-image: url('https://i2.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2019/11/Kubica.jpg?resize=263%2C175&amp;ssl=1');" href="https://www.thecheckeredflag.co.uk/2019/11/williams-misery-continues/" title="Williams&#8217; misery continues"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.thecheckeredflag.co.uk/2019/11/williams-misery-continues/" rel="bookmark" title="Williams&#8217; misery continues">
Williams&#8217; misery continues </a>
</h4>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder small-fix-size" rel="bookmark" style="background-image: url('https://i1.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2019/11/Start.jpg?resize=263%2C175&amp;ssl=1');" href="https://www.thecheckeredflag.co.uk/2019/11/bottas-wins-feisty-usgp-as-hamilton-becomes-a-six-time-world-championship/" title="Bottas wins feisty US GP as Hamilton becomes a six-time World Champion"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.thecheckeredflag.co.uk/2019/11/bottas-wins-feisty-usgp-as-hamilton-becomes-a-six-time-world-championship/" rel="bookmark" title="Bottas wins feisty US GP as Hamilton becomes a six-time World Champion">
Bottas wins feisty US GP as Hamilton becomes a six-time World Champion </a>
</h4>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder small-fix-size" rel="bookmark" style="background-image: url('https://i1.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2019/11/lh_usgp_2019_rs.jpg?resize=263%2C175&amp;ssl=1');" href="https://www.thecheckeredflag.co.uk/2019/11/lewis-hamilton-sets-sights-on-michael-schumacher-records-with-historic-sixth-title-win/" title="Lewis Hamilton sets sights on Schumacher&#8217;s records with historic sixth title win"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.thecheckeredflag.co.uk/2019/11/lewis-hamilton-sets-sights-on-michael-schumacher-records-with-historic-sixth-title-win/" rel="bookmark" title="Lewis Hamilton sets sights on Schumacher&#8217;s records with historic sixth title win">
Lewis Hamilton sets sights on Schumacher&#8217;s records with historic sixth title win </a>
</h4>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder small-fix-size" rel="bookmark" style="background-image: url('https://i2.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2019/11/Miguel_Oliveira_Surgery.jpg?resize=263%2C175&amp;ssl=1');" href="https://www.thecheckeredflag.co.uk/2019/11/miguel-oliveira-undergoes-successful-shoulder-surgery/" title="Miguel Oliveira undergoes successful shoulder surgery"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.thecheckeredflag.co.uk/2019/11/miguel-oliveira-undergoes-successful-shoulder-surgery/" rel="bookmark" title="Miguel Oliveira undergoes successful shoulder surgery">
Miguel Oliveira undergoes successful shoulder surgery </a>
</h4>
</div>
</div>
</li>
</ul>
</aside><aside id="nav_menu-4" class="widget widget_nav_menu"><div class="menu-top-container"><ul id="menu-top" class="menu"><li id="menu-item-131978" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-131978"><a href="https://www.thecheckeredflag.co.uk/latest-news/">News</a></li>
<li id="menu-item-131965" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131965"><a href="https://www.thecheckeredflag.co.uk/features/">Features</a></li>
<li id="menu-item-173707" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-173707"><a href="https://www.thecheckeredflag.co.uk/features/gallery/">Photos</a></li>
<li id="menu-item-131884" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131884"><a href="https://www.thecheckeredflag.co.uk/tcf-blogs/">TCF Blogs</a></li>
<li id="menu-item-131986" class="menu-item menu-item-type-taxonomy menu-item-object-post_format menu-item-131986"><a href="https://www.thecheckeredflag.co.uk/type/video/">Videos</a></li>
<li id="menu-item-131967" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-131967"><a href="https://www.thecheckeredflag.co.uk/contribute/">Contribute</a></li>
<li id="menu-item-131966" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-131966"><a href="https://www.thecheckeredflag.co.uk/contact/">Contact Us</a></li>
</ul></div></aside><aside id="text-12" class="widget widget_text"> <div class="textwidget"><p><a href="https://www.facebook.com/groups/porschemotorsportcommunity/" target="_blank" rel="noopener noreferrer"><img class="aligncenter size-full wp-image-310781" src="https://i2.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2019/06/PMC-Square-1.jpg?resize=400%2C400&#038;ssl=1" alt="Porsche Motorsport Community" width="400" height="400" data-recalc-dims="1" /></a></p>
</div>
</aside><aside id="custom_html-8" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget">
<ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-9159179884377372" data-ad-slot="2468886887" data-ad-format="auto"></ins>
<script>
window.setTimeout(function(){ 
  (adsbygoogle = window.adsbygoogle || []).push({}); 
}, 200); 
</script></div></aside><aside id="penci_social_widget-2" class="widget penci_social_widget"><h4 class="widget-title penci-border-arrow"><span class="inner-arrow">Keep in touch</span></h4>
<div class="widget-social pc_aligncenter">
<a href="https://facebook.com/TheCheckeredFlag" rel="nofollow" target="_blank"><i class="penci-faicon fa fa-facebook" style="font-size: 18px"></i><span style="font-size: 13px">Facebook</span></a>
<a href="https://twitter.com/TheCheckerFlag" rel="nofollow" target="_blank"><i class="penci-faicon fa fa-twitter" style="font-size: 18px"></i><span style="font-size: 13px">Twitter</span></a>
<a href="https://instagram.com/thecheckeredflag/" rel="nofollow" target="_blank"><i class="penci-faicon fa fa-instagram" style="font-size: 18px"></i><span style="font-size: 13px">Instagram</span></a>
<a href="https://www.linkedin.com/company/thecheckeredflag/" rel="nofollow" target="_blank"><i class="penci-faicon fa fa-linkedin" style="font-size: 18px"></i><span style="font-size: 13px">Linkedin</span></a>
<a href="https://www.youtube.com/channel/UCueRVoGbSE4GF2RszehXIgw" rel="nofollow" target="_blank"><i class="penci-faicon fa fa-youtube-play" style="font-size: 18px"></i><span style="font-size: 13px">Youtube</span></a>
<a href="https://www.thecheckeredflag.co.uk/feed" rel="nofollow" target="_blank"><i class="penci-faicon fa fa-rss" style="font-size: 18px"></i><span style="font-size: 13px">RSS</span></a>
</div>
</aside><aside id="penci_latest_news_widget-2" class="widget penci_latest_news_widget"><h4 class="widget-title penci-border-arrow"><span class="inner-arrow">Recent Features</span></h4> <ul id="penci-latestwg-5067" class="side-newsfeed penci-feed-2columns penci-2columns-feed">
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder small-fix-size" rel="bookmark" style="background-image: url('https://i1.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2019/11/lh_usgp_2019_rs.jpg?resize=263%2C175&amp;ssl=1');" href="https://www.thecheckeredflag.co.uk/2019/11/lewis-hamilton-sets-sights-on-michael-schumacher-records-with-historic-sixth-title-win/" title="Lewis Hamilton sets sights on Schumacher&#8217;s records with historic sixth title win"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.thecheckeredflag.co.uk/2019/11/lewis-hamilton-sets-sights-on-michael-schumacher-records-with-historic-sixth-title-win/" rel="bookmark" title="Lewis Hamilton sets sights on Schumacher&#8217;s records with historic sixth title win">
Lewis Hamilton sets sights on Schumacher&#8217;s records with historic sixth title win </a>
</h4>
<span class="side-item-meta"><time class="entry-date published" datetime="2019-11-03T22:00:25+00:00">November 3, 2019</time></span>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder small-fix-size" rel="bookmark" style="background-image: url('https://i1.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2019/10/3.jpg?resize=263%2C175&amp;ssl=1');" href="https://www.thecheckeredflag.co.uk/2019/10/mud-sweat-gears-tcf-talks-citroen-c3-wrc-with-pierre-budar/" title="Mud, Sweat &#038; Gears &#8211; TCF talks Citroën C3 WRC with Pierre Budar"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.thecheckeredflag.co.uk/2019/10/mud-sweat-gears-tcf-talks-citroen-c3-wrc-with-pierre-budar/" rel="bookmark" title="Mud, Sweat &#038; Gears &#8211; TCF talks Citroën C3 WRC with Pierre Budar">
Mud, Sweat &#038; Gears &#8211; TCF talks Citroën C3 WRC with Pierre Budar </a>
</h4>
<span class="side-item-meta"><time class="entry-date published" datetime="2019-10-30T16:34:24+00:00">October 30, 2019</time></span>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder small-fix-size" rel="bookmark" style="background-image: url('https://i1.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2019/10/Webp.net-resizeimage-58.jpg?resize=263%2C175&amp;ssl=1');" href="https://www.thecheckeredflag.co.uk/2019/10/2019-mexican-grand-prix-the-rookie-report/" title="2019 Mexican Grand Prix &#8211; The Rookie Report"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.thecheckeredflag.co.uk/2019/10/2019-mexican-grand-prix-the-rookie-report/" rel="bookmark" title="2019 Mexican Grand Prix &#8211; The Rookie Report">
2019 Mexican Grand Prix &#8211; The Rookie Report </a>
</h4>
<span class="side-item-meta"><time class="entry-date published" datetime="2019-10-30T07:00:43+00:00">October 30, 2019</time></span>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder small-fix-size" rel="bookmark" style="background-image: url('https://i1.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2019/10/Perez-Hamilton-Mexico-2019.jpg?resize=263%2C175&amp;ssl=1');" href="https://www.thecheckeredflag.co.uk/2019/10/analysis-formula-1-2019-mexican-grand-prix-assessing-the-field/" title="Analysis: Formula 1 2019 Mexican Grand Prix – Assessing the field"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.thecheckeredflag.co.uk/2019/10/analysis-formula-1-2019-mexican-grand-prix-assessing-the-field/" rel="bookmark" title="Analysis: Formula 1 2019 Mexican Grand Prix – Assessing the field">
Analysis: Formula 1 2019 Mexican Grand Prix – Assessing the field </a>
</h4>
<span class="side-item-meta"><time class="entry-date published" datetime="2019-10-28T20:55:28+00:00">October 28, 2019</time></span>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder small-fix-size" rel="bookmark" style="background-image: url('https://i2.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2019/10/hamilton_mexicangp_rs.jpg?resize=263%2C175&amp;ssl=1');" href="https://www.thecheckeredflag.co.uk/2019/10/lewis-hamilton-wins-the-tactical-battle-at-the-mexican-grand-prix/" title="Lewis Hamilton Wins the Tactical Battle at the Mexican Grand Prix"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.thecheckeredflag.co.uk/2019/10/lewis-hamilton-wins-the-tactical-battle-at-the-mexican-grand-prix/" rel="bookmark" title="Lewis Hamilton Wins the Tactical Battle at the Mexican Grand Prix">
Lewis Hamilton Wins the Tactical Battle at the Mexican Grand Prix </a>
</h4>
<span class="side-item-meta"><time class="entry-date published" datetime="2019-10-27T23:06:04+00:00">October 27, 2019</time></span>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder small-fix-size" rel="bookmark" style="background-image: url('https://i2.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2019/10/grid_renault_r26.jpg?resize=263%2C175&amp;ssl=1');" href="https://www.thecheckeredflag.co.uk/2019/10/review-grid-the-return-of-an-icon/" title="REVIEW: GRID &#8211; The return of an icon"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.thecheckeredflag.co.uk/2019/10/review-grid-the-return-of-an-icon/" rel="bookmark" title="REVIEW: GRID &#8211; The return of an icon">
REVIEW: GRID &#8211; The return of an icon </a>
</h4>
<span class="side-item-meta"><time class="entry-date published" datetime="2019-10-25T08:58:03+00:00">October 25, 2019</time></span>
</div>
</div>
</li>
</ul>
</aside> </div>
</div>
</div>
<div class="clear-footer"></div>
<div class="footer-subscribe">
<aside id="mc4wp_form_widget-2" class="widget widget_mc4wp_form_widget"><script>(function() {
	if (!window.mc4wp) {
		window.mc4wp = {
			listeners: [],
			forms    : {
				on: function (event, callback) {
					window.mc4wp.listeners.push({
						event   : event,
						callback: callback
					});
				}
			}
		}
	}
})();
</script><form id="mc4wp-form-1" class="mc4wp-form mc4wp-form-293151" method="post" data-id="293151" data-name="TCF Daily Headlines to your Inbox"><div class="mc4wp-form-fields"><p class="mdes">Get the latest headlines from TCF in a daily roundup, straight to your inbox</p>
<p class="memail"><input type="email" id="mc4wp_email" name="EMAIL" placeholder="Email..." required /></p>
<p class="msubmit"><input type="submit" value="Subscribe" /></p></div><label style="display: none !important;">Leave this field empty if you're human: <input type="text" name="_mc4wp_honeypot" value="" tabindex="-1" autocomplete="off" /></label><input type="hidden" name="_mc4wp_timestamp" value="1572894321" /><input type="hidden" name="_mc4wp_form_id" value="293151" /><input type="hidden" name="_mc4wp_form_element_id" value="mc4wp-form-1" /><div class="mc4wp-response"></div></form></aside> </div>
<footer id="footer-section" class="penci-footer-social-media penci-lazy" itemscope itemtype="https://schema.org/WPFooter">
<div class="container">
<div class="footer-socials-section">
<ul class="footer-socials">
<li><a href="https://facebook.com/TheCheckeredFlag" rel="nofollow" target="_blank"><i class="penci-faicon fa fa-facebook"></i><span>Facebook</span></a></li>
<li><a href="https://twitter.com/TheCheckerFlag" rel="nofollow" target="_blank"><i class="penci-faicon fa fa-twitter"></i><span>Twitter</span></a></li>
<li><a href="https://instagram.com/thecheckeredflag/" rel="nofollow" target="_blank"><i class="penci-faicon fa fa-instagram"></i><span>Instagram</span></a></li>
<li><a href="https://www.linkedin.com/company/thecheckeredflag/" rel="nofollow" target="_blank"><i class="penci-faicon fa fa-linkedin"></i><span>Linkedin</span></a></li>
<li><a href="https://www.youtube.com/channel/UCueRVoGbSE4GF2RszehXIgw" rel="nofollow" target="_blank"><i class="penci-faicon fa fa-youtube-play"></i><span>Youtube</span></a></li>
<li><a href="https://www.thecheckeredflag.co.uk/feed" rel="nofollow" target="_blank"><i class="penci-faicon fa fa-rss"></i><span>RSS</span></a></li>
</ul>
</div>
<div class="footer-logo-copyright footer-not-logo">
<div id="footer-copyright">
<p><a href="https://www.thecheckeredflag.co.uk/contact/">Contact Us</a> | <a href="https://www.thecheckeredflag.co.uk/contribute/">Contribute</a> | <a href="https://www.thecheckeredflag.co.uk/about-us">About Us</a><br />
<a href="https://www.thecheckeredflag.co.uk/tcf-partners/">TCF Friends & Partners</a> | <a href="https://www.thecheckeredflag.co.uk/submitting-news/">Submitting News</a> | <a href="https://www.thecheckeredflag.co.uk/terms-and-conditions/">T & C</a> | <a href="https://www.thecheckeredflag.co.uk/privacy-policy/">Privacy Policy</a> | <a href="https://www.thecheckeredflag.co.uk/cookies-in-use-on-this-site/">Cookie Policy</a><br />
©Copyright MMXIX - The Checkered Flag - All Rights Reserved</p>
</div>
<div class="go-to-top-parent"><a href="#" class="go-to-top"><span><i class="penci-faicon fa fa-angle-up"></i> <br>Back To Top</span></a></div>
</div>
</div>
</footer>
</div>
<div id="fb-root"></div>
<div class="penci-wrap-gprd-law penci-wrap-gprd-law-close penci-close-all">
<div class="penci-gprd-law">
<p>
This website uses cookies to improve your experience. We&#039;ll assume you&#039;re ok with this, but you can opt-out if you wish. <a class="penci-gprd-accept" href="#">Accept</a> <a class="penci-gprd-more" href="#">Read More</a> </p>
</div>
</div>

<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-MG875N"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<script>(function() {function addEventListener(element,event,handler) {
	if(element.addEventListener) {
		element.addEventListener(event,handler, false);
	} else if(element.attachEvent){
		element.attachEvent('on'+event,handler);
	}
}function maybePrefixUrlField() {
	if(this.value.trim() !== '' && this.value.indexOf('http') !== 0) {
		this.value = "http://" + this.value;
	}
}

var urlFields = document.querySelectorAll('.mc4wp-form input[type="url"]');
if( urlFields && urlFields.length > 0 ) {
	for( var j=0; j < urlFields.length; j++ ) {
		addEventListener(urlFields[j],'blur',maybePrefixUrlField);
	}
}/* test if browser supports date fields */
var testInput = document.createElement('input');
testInput.setAttribute('type', 'date');
if( testInput.type !== 'date') {

	/* add placeholder & pattern to all date fields */
	var dateFields = document.querySelectorAll('.mc4wp-form input[type="date"]');
	for(var i=0; i<dateFields.length; i++) {
		if(!dateFields[i].placeholder) {
			dateFields[i].placeholder = 'YYYY-MM-DD';
		}
		if(!dateFields[i].pattern) {
			dateFields[i].pattern = '[0-9]{4}-(0[1-9]|1[012])-(0[1-9]|1[0-9]|2[0-9]|3[01])';
		}
	}
}

})();</script>
<script type='text/javascript'>
( 'fetch' in window ) || document.write( '<script src="https://www.thecheckeredflag.co.uk/wp-includes/js/dist/vendor/wp-polyfill-fetch.min.js?ver=3.0.0"></scr' + 'ipt>' );( document.contains ) || document.write( '<script src="https://www.thecheckeredflag.co.uk/wp-includes/js/dist/vendor/wp-polyfill-node-contains.min.js?ver=3.26.0-0"></scr' + 'ipt>' );( window.FormData && window.FormData.prototype.keys ) || document.write( '<script src="https://www.thecheckeredflag.co.uk/wp-includes/js/dist/vendor/wp-polyfill-formdata.min.js?ver=3.0.12"></scr' + 'ipt>' );( Element.prototype.matches && Element.prototype.closest ) || document.write( '<script src="https://www.thecheckeredflag.co.uk/wp-includes/js/dist/vendor/wp-polyfill-element-closest.min.js?ver=2.0.2"></scr' + 'ipt>' );
</script>
<script type='text/javascript'>
/* <![CDATA[ */
var countVars = {"disqusShortname":"thecheckerdflag"};
/* ]]> */
</script>
<script type='text/javascript'>
/* <![CDATA[ */
var embedVars = {"disqusConfig":{"integration":"wordpress 3.0.17"},"disqusIdentifier":"325145 https:\/\/www.thecheckeredflag.co.uk\/?p=325145","disqusShortname":"thecheckerdflag","disqusTitle":"Kyle Busch joins Lexus for 2020 Rolex 24","disqusUrl":"https:\/\/www.thecheckeredflag.co.uk\/2019\/11\/kyle-busch-joins-lexus-for-2020-rolex-24\/","postId":"325145"};
/* ]]> */
</script>
<script type='text/javascript'>
/* <![CDATA[ */
var ajax_var_more = {"url":"https:\/\/www.thecheckeredflag.co.uk\/wp-admin\/admin-ajax.php","nonce":"5757ed8174","errorPass":"<p class=\"message message-error\">Password does not match the confirm password<\/p>","login":"Email Address","password":"Password"};
/* ]]> */
</script>
<script type='text/javascript'>
/* <![CDATA[ */
var ajax_var = {"url":"https:\/\/www.thecheckeredflag.co.uk\/wp-admin\/admin-ajax.php","nonce":"5757ed8174","errorPass":"<p class=\"message message-error\">Password does not match the confirm password<\/p>","login":"Email Address","password":"Password"};
/* ]]> */
</script>
<script type='text/javascript'>
/* <![CDATA[ */
var SOLEDADLOCALIZE = {"url":"https:\/\/www.thecheckeredflag.co.uk\/wp-admin\/admin-ajax.php","nonce":"5757ed8174","errorPass":"<p class=\"message message-error\">Password does not match the confirm password<\/p>","login":"Email Address","password":"Password"};
/* ]]> */
</script>
<script type='text/javascript'>
/* <![CDATA[ */
var mc4wp_forms_config = [];
/* ]]> */
</script>
<!--[if lte IE 9]>
<script type='text/javascript' src='https://www.thecheckeredflag.co.uk/wp-content/plugins/mailchimp-for-wp/assets/js/third-party/placeholders.min.js?ver=4.6.2'></script>
<![endif]-->
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:7.8',blog:'9437658',post:'325145',tz:'0',srv:'www.thecheckeredflag.co.uk'} ]);
	_stq.push([ 'clickTrackerInit', '9437658', '325145' ]);
</script>
<script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script><script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><script type='text/javascript' src='https://c0.wp.com/c/5.2.4/wp-includes/js/dist/vendor/wp-polyfill.min.js'></script><script type='text/javascript' src='https://c0.wp.com/c/5.2.4/wp-includes/js/dist/dom-ready.min.js'></script><script type='text/javascript' src='https://c0.wp.com/p/jetpack/7.8/_inc/build/photon/photon.min.js'></script><script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201945'></script><script type='text/javascript' src='https://c0.wp.com/c/5.2.4/wp-includes/js/wp-embed.min.js'></script><script type='text/javascript' src='https://stats.wp.com/e-201945.js' async='async' defer='defer'></script><script data-optimized='1' src='https://www.thecheckeredflag.co.uk/min/5d288.js'></script></body>
</html>
