<!DOCTYPE html>
<html lang="en-GB">
<head>
<meta charset="UTF-8"><link rel='stylesheet' id='penci-fonts-css' href='//fonts.googleapis.com/css?family=PT+Serif%3A300%2C300italic%2C400%2C400italic%2C500%2C500italic%2C700%2C700italic%2C800%2C800italic%7CPlayfair+Display+SC%3A300%2C300italic%2C400%2C400italic%2C500%2C500italic%2C700%2C700italic%2C800%2C800italic%7CMontserrat%3A300%2C300italic%2C400%2C400italic%2C500%2C500italic%2C700%2C700italic%2C800%2C800italic%7CRoboto%3A300%2C300italic%2C400%2C400italic%2C500%2C500italic%2C700%2C700italic%2C800%2C800italic%7CLato%3A300%2C300italic%2C400%2C400italic%2C500%2C500italic%2C700%2C700italic%2C800%2C800italic%7CFira+Sans%3A300%2C300italic%2C400%2C400italic%2C500%2C500italic%2C700%2C700italic%2C800%2C800italic%26subset%3Dcyrillic%2Ccyrillic-ext%2Cgreek%2Cgreek-ext%2Clatin-ext&#038;ver=1.0' type='text/css' media='all' /><link data-optimized='2' rel='stylesheet' href='https://www.thecheckeredflag.co.uk/min/1f28e.css' /><script type='text/javascript' src='https://www.thecheckeredflag.co.uk/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script><script data-optimized='1' src='https://www.thecheckeredflag.co.uk/min/d3fe9.js'></script>
<meta http-equiv="X-UA-Compatible" content="IE=edge">
<meta name="viewport" content="width=device-width, initial-scale=1">
<link rel="profile" href="https://gmpg.org/xfn/11" />
<link rel="shortcut icon" href="https://www.thecheckeredflag.co.uk/wp-content/uploads/2018/11/TCF-black.jpg" type="image/x-icon" />
<link rel="apple-touch-icon" sizes="180x180" href="https://www.thecheckeredflag.co.uk/wp-content/uploads/2018/11/TCF-black.jpg">
<link rel="alternate" type="application/rss+xml" title="The Checkered Flag RSS Feed" href="https://www.thecheckeredflag.co.uk/feed/" />
<link rel="alternate" type="application/atom+xml" title="The Checkered Flag Atom Feed" href="https://www.thecheckeredflag.co.uk/feed/atom/" />
<link rel="pingback" href="https://www.thecheckeredflag.co.uk/xmlrpc.php" />
<!--[if lt IE 9]>
	<script src="https://www.thecheckeredflag.co.uk/wp-content/themes/soledad/js/html5.js"></script>
	<![endif]-->
<title>Ryan Sieg joins Premium Motorsports for Cup return at Indianapolis - The Checkered Flag</title>

<script data-cfasync="false" data-pagespeed-no-defer type="text/javascript">//<![CDATA[
	var gtm4wp_datalayer_name = "dataLayer";
	var dataLayer = dataLayer || [];
//]]>
</script>


<meta name="description" content="Ryan Sieg will run his first Cup Series race since 2017 at Indianapolis, driving the #27 for Premium Motorsports." />
<link rel="canonical" href="https://www.thecheckeredflag.co.uk/2019/08/ryan-sieg-joins-premium-motorsports-for-cup-return-at-indianapolis/" />
<meta property="og:locale" content="en_GB" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Ryan Sieg joins Premium Motorsports for Cup return at Indianapolis - The Checkered Flag" />
<meta property="og:description" content="Ryan Sieg will run his first Cup Series race since 2017 at Indianapolis, driving the #27 for Premium Motorsports." />
<meta property="og:url" content="https://www.thecheckeredflag.co.uk/2019/08/ryan-sieg-joins-premium-motorsports-for-cup-return-at-indianapolis/" />
<meta property="og:site_name" content="The Checkered Flag" />
<meta property="article:publisher" content="http://www.facebook.com/TheCheckeredFlag" />
<meta property="article:tag" content="2019 Big Machine Vodka 400 at the Brickyard" />
<meta property="article:tag" content="2019 Brickyard 400" />
<meta property="article:tag" content="2019 Monster Energy NASCAR Cup Series" />
<meta property="article:tag" content="2019 NASCAR Cup Debuts" />
<meta property="article:tag" content="Indianapolis Motor Speedway" />
<meta property="article:tag" content="Premium Motorsports" />
<meta property="article:tag" content="Ryan Sieg" />
<meta property="article:section" content="Monster Energy NASCAR Cup Series" />
<meta property="article:published_time" content="2019-08-21T20:00:40+00:00" />
<meta property="article:modified_time" content="2019-08-21T20:02:09+00:00" />
<meta property="og:updated_time" content="2019-08-21T20:02:09+00:00" />
<meta property="fb:app_id" content="135274436510698" />
<meta property="og:image" content="https://www.thecheckeredflag.co.uk/wp-content/uploads/2019/08/NXS-TMS-Ryan-Sieg-Practice-033019.jpg" />
<meta property="og:image:secure_url" content="https://www.thecheckeredflag.co.uk/wp-content/uploads/2019/08/NXS-TMS-Ryan-Sieg-Practice-033019.jpg" />
<meta property="og:image:width" content="800" />
<meta property="og:image:height" content="533" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:description" content="Ryan Sieg will run his first Cup Series race since 2017 at Indianapolis, driving the #27 for Premium Motorsports." />
<meta name="twitter:title" content="Ryan Sieg joins Premium Motorsports for Cup return at Indianapolis - The Checkered Flag" />
<meta name="twitter:site" content="@thecheckerflag" />
<meta name="twitter:image" content="https://www.thecheckeredflag.co.uk/wp-content/uploads/2019/08/NXS-TMS-Ryan-Sieg-Practice-033019.jpg" />
<meta name="twitter:creator" content="@ZappaOMatic" />
<script type='application/ld+json' class='yoast-schema-graph yoast-schema-graph--main'>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</script>

<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="The Checkered Flag &raquo; Feed" href="https://www.thecheckeredflag.co.uk/feed/" />
<link rel="alternate" type="application/rss+xml" title="The Checkered Flag &raquo; Comments Feed" href="https://www.thecheckeredflag.co.uk/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="The Checkered Flag &raquo; Ryan Sieg joins Premium Motorsports for Cup return at Indianapolis Comments Feed" href="https://www.thecheckeredflag.co.uk/2019/08/ryan-sieg-joins-premium-motorsports-for-cup-return-at-indianapolis/feed/" />
<!--[if !IE]><!-->
<!--<![endif]-->
<link rel='https://api.w.org/' href='https://www.thecheckeredflag.co.uk/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.thecheckeredflag.co.uk/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.thecheckeredflag.co.uk/wp-includes/wlwmanifest.xml" />
<link rel='shortlink' href='https://www.thecheckeredflag.co.uk/?p=318590' />
<link rel="alternate" type="application/json+oembed" href="https://www.thecheckeredflag.co.uk/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.thecheckeredflag.co.uk%2F2019%2F08%2Fryan-sieg-joins-premium-motorsports-for-cup-return-at-indianapolis%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.thecheckeredflag.co.uk/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.thecheckeredflag.co.uk%2F2019%2F08%2Fryan-sieg-joins-premium-motorsports-for-cup-return-at-indianapolis%2F&#038;format=xml" />

<script data-cfasync="false" data-pagespeed-no-defer type="text/javascript">//<![CDATA[
	var dataLayer_content = {"pageTitle":"Ryan Sieg joins Premium Motorsports for Cup return at Indianapolis - The Checkered Flag","pageCategory":["sprint-cup"],"pageAttributes":["2019-big-machine-vodka-400-at-the-brickyard","2019-brickyard-400","2019-monster-energy-nascar-cup-series","2019-nascar-cup-debuts","indianapolis-motor-speedway","premium-motorsports","ryan-sieg"],"pagePostAuthor":"Justin Nguyen"};
	dataLayer.push( dataLayer_content );//]]>
</script>
<script data-cfasync="false">//<![CDATA[
(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'//www.googletagmanager.com/gtm.'+'js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-MG875N');//]]>
</script>

 <style type="text/css">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</style>
<script type="application/ld+json">{
    "@context": "https:\/\/schema.org\/",
    "@type": "organization",
    "@id": "#organization",
    "logo": {
        "@type": "ImageObject",
        "url": "https:\/\/www.thecheckeredflag.co.uk\/wp-content\/uploads\/2018\/11\/TCF-2018-1.png"
    },
    "url": "https:\/\/www.thecheckeredflag.co.uk\/",
    "name": "The Checkered Flag",
    "description": "Independent motor sport news since 2009"
}</script><script type="application/ld+json">{
    "@context": "https:\/\/schema.org\/",
    "@type": "WebSite",
    "name": "The Checkered Flag",
    "alternateName": "Independent motor sport news since 2009",
    "url": "https:\/\/www.thecheckeredflag.co.uk\/"
}</script><script type="application/ld+json">{
    "@context": "https:\/\/schema.org\/",
    "@type": "BlogPosting",
    "headline": "Ryan Sieg joins Premium Motorsports for Cup return at Indianapolis",
    "description": "Ryan Sieg will run his first Cup Series race since 2017 at Indianapolis, driving the #27 for Premium Motorsports.",
    "datePublished": "2019-08-21",
    "datemodified": "2019-08-21",
    "mainEntityOfPage": "https:\/\/www.thecheckeredflag.co.uk\/2019\/08\/ryan-sieg-joins-premium-motorsports-for-cup-return-at-indianapolis\/",
    "image": {
        "@type": "ImageObject",
        "url": "https:\/\/www.thecheckeredflag.co.uk\/wp-content\/uploads\/2019\/08\/NXS-TMS-Ryan-Sieg-Practice-033019.jpg",
        "width": 800,
        "height": 533
    },
    "publisher": {
        "@type": "Organization",
        "name": "The Checkered Flag",
        "logo": {
            "@type": "ImageObject",
            "url": "https:\/\/www.thecheckeredflag.co.uk\/wp-content\/uploads\/2018\/11\/TCF-2018-1.png"
        }
    },
    "author": {
        "@type": "Person",
        "@id": "#person-JustinNguyen",
        "name": "Justin Nguyen"
    }
}</script><script type="application/ld+json">{
    "@context": "https:\/\/schema.org",
    "@type": "NewsArticle",
    "headline": "Ryan Sieg joins Premium Motorsports for Cup return at Indianapolis",
    "image": "https:\/\/www.thecheckeredflag.co.uk\/wp-content\/uploads\/2019\/08\/NXS-TMS-Ryan-Sieg-Practice-033019.jpg",
    "datePublished": "2019-08-21",
    "datemodified": "2019-08-21",
    "description": "Ryan Sieg will run his first Cup Series race since 2017 at Indianapolis, driving the #27 for Premium Motorsports.",
    "mainEntityOfPage": "https:\/\/www.thecheckeredflag.co.uk\/2019\/08\/ryan-sieg-joins-premium-motorsports-for-cup-return-at-indianapolis\/",
    "publisher": {
        "@type": "Organization",
        "name": "The Checkered Flag",
        "logo": {
            "@type": "ImageObject",
            "url": "https:\/\/www.thecheckeredflag.co.uk\/wp-content\/uploads\/2018\/11\/TCF-2018-1.png"
        }
    },
    "author": {
        "@type": "Person",
        "name": "Justin Nguyen"
    }
}</script><link rel="amphtml" href="https://www.thecheckeredflag.co.uk/amp/2019/08/ryan-sieg-joins-premium-motorsports-for-cup-return-at-indianapolis/" /><link rel="icon" href="https://www.thecheckeredflag.co.uk/wp-content/uploads/2016/02/cropped-TCF-32x32.png" sizes="32x32" />
<link rel="icon" href="https://www.thecheckeredflag.co.uk/wp-content/uploads/2016/02/cropped-TCF-200x200.png" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="https://www.thecheckeredflag.co.uk/wp-content/uploads/2016/02/cropped-TCF-200x200.png" />
<meta name="msapplication-TileImage" content="https://www.thecheckeredflag.co.uk/wp-content/uploads/2016/02/cropped-TCF-500x500.png" />
</head>
<body data-rsssl=1 class="post-template-default single single-post postid-318590 single-format-standard">
<a id="close-sidebar-nav" class="header-3"><i class="fa fa-close"></i></a>
<nav id="sidebar-nav" class="header-3" role="navigation" itemscope itemtype="https://schema.org/SiteNavigationElement">
<div id="sidebar-nav-logo">
<a href="https://www.thecheckeredflag.co.uk/"><img class="penci-lazy" src="https://www.thecheckeredflag.co.uk/wp-content/themes/soledad/images/penci-holder.png" data-src="https://www.thecheckeredflag.co.uk/wp-content/uploads/2018/11/TCF-black.jpg" alt="The Checkered Flag" /></a>
</div>
<div class="header-social sidebar-nav-social">
<div class="inner-header-social">
<a href="https://facebook.com/TheCheckeredFlag" rel="nofollow" target="_blank"><i class="fa fa-facebook"></i></a>
<a href="https://twitter.com/TheCheckerFlag" rel="nofollow" target="_blank"><i class="fa fa-twitter"></i></a>
<a href="https://instagram.com/thecheckeredflag/" rel="nofollow" target="_blank"><i class="fa fa-instagram"></i></a>
<a href="https://www.linkedin.com/company/the-checkered-flag/" rel="nofollow" target="_blank"><i class="fa fa-linkedin"></i></a>
<a href="https://www.youtube.com/channel/UCueRVoGbSE4GF2RszehXIgw" rel="nofollow" target="_blank"><i class="fa fa-youtube-play"></i></a>
<a href="https://www.thecheckeredflag.co.uk/feed" rel="nofollow" target="_blank"><i class="fa fa-rss"></i></a>
</div> </div>
<ul id="menu-2015" class="menu"><li id="menu-item-131887" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-131887"><a href="https://www.thecheckeredflag.co.uk/formula-1/">Formula 1</a>
<ul class="sub-menu">
<li id="menu-item-274866" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-274866"><a href="https://www.thecheckeredflag.co.uk/formula-1/">Formula 1 News</a></li>
<li id="menu-item-290802" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-290802"><a href="https://www.thecheckeredflag.co.uk/open-wheel/fia-formula-2/">FIA Formula 2</a></li>
<li id="menu-item-293116" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-293116"><a href="https://www.thecheckeredflag.co.uk/open-wheel/formula-3/fia-formula-3-championship/">FIA Formula 3</a></li>
<li id="menu-item-290804" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-290804"><a href="https://www.thecheckeredflag.co.uk/sportscars/porsche/porsche-supercup/">Porsche Mobil 1 Supercup</a></li>
</ul>
</li>
<li id="menu-item-131892" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-131892"><a href="https://www.thecheckeredflag.co.uk/touring-cars/btcc/">BTCC</a>
<ul class="sub-menu">
<li id="menu-item-291757" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-291757"><a href="https://www.thecheckeredflag.co.uk/open-wheel/msa-formula/">F4 British Championship</a></li>
<li id="menu-item-291754" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-291754"><a href="https://www.thecheckeredflag.co.uk/sportscars/ginetta/ginetta-gt-supercup/">Ginetta GT4 Supercup</a></li>
<li id="menu-item-291755" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-291755"><a href="https://www.thecheckeredflag.co.uk/sportscars/ginetta/ginetta-junior/">Ginetta Junior</a></li>
<li id="menu-item-291753" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-291753"><a href="https://www.thecheckeredflag.co.uk/sportscars/porsche/carrera-cup-gb/">Porsche Carrera Cup GB</a></li>
<li id="menu-item-291756" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-291756"><a href="https://www.thecheckeredflag.co.uk/touring-cars/renault-clio-cup/">Renault UK Clio Cup</a></li>
</ul>
</li>
<li id="menu-item-131940" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-131940"><a href="https://www.thecheckeredflag.co.uk/open-wheel/">Open Wheel</a>
<ul class="sub-menu">
<li id="menu-item-131942" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131942"><a href="https://www.thecheckeredflag.co.uk/open-wheel/formula-e/">FIA Formula E</a></li>
<li id="menu-item-131943" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131943"><a href="https://www.thecheckeredflag.co.uk/open-wheel/indycar/">IndyCar</a></li>
<li id="menu-item-218310" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-218310"><a href="https://www.thecheckeredflag.co.uk/open-wheel/fia-formula-2/">FIA Formula 2</a></li>
<li id="menu-item-296601" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-296601"><a href="https://www.thecheckeredflag.co.uk/open-wheel/formula-3/fia-formula-3-championship/">FIA Formula 3</a></li>
<li id="menu-item-131946" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131946"><a href="https://www.thecheckeredflag.co.uk/open-wheel/formula-3/euroformula-open/">EuroFormula Open</a></li>
<li id="menu-item-131945" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131945"><a href="https://www.thecheckeredflag.co.uk/open-wheel/formula-3/european-f3-championship/">European Formula 3</a></li>
<li id="menu-item-131989" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131989"><a href="https://www.thecheckeredflag.co.uk/open-wheel/renault-world-series/formula-renault-2-0-renault-world-series/">Formula Renault 2.0</a></li>
<li id="menu-item-180961" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-180961"><a href="https://www.thecheckeredflag.co.uk/open-wheel/formula-3/british-f3-formula-3/">British F3</a></li>
<li id="menu-item-131897" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131897"><a href="https://www.thecheckeredflag.co.uk/open-wheel/msa-formula/">F4 British Championship</a></li>
</ul>
</li>
<li id="menu-item-131952" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-131952"><a href="https://www.thecheckeredflag.co.uk/sportscars/">Sportscars</a>
<ul class="sub-menu">
<li id="menu-item-131956" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131956"><a href="https://www.thecheckeredflag.co.uk/sportscars/endurance/fiawec/">FIA WEC</a></li>
<li id="menu-item-133799" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-133799"><a href="https://www.thecheckeredflag.co.uk/sportscars/endurance/united-sportscar/">IMSA</a></li>
<li id="menu-item-131958" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131958"><a href="https://www.thecheckeredflag.co.uk/sportscars/endurance/elms/">FIA ELMS</a></li>
<li id="menu-item-131957" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131957"><a href="https://www.thecheckeredflag.co.uk/sportscars/endurance/blancpain-endurance-series/">Blancpain Endurance</a></li>
<li id="menu-item-148232" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-148232"><a href="https://www.thecheckeredflag.co.uk/sportscars/endurance/blancpain-sprint/">Blancpain Sprint</a></li>
<li id="menu-item-131954" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131954"><a href="https://www.thecheckeredflag.co.uk/sportscars/gt-sportscars/british-gt/">British GT</a></li>
<li id="menu-item-290801" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-290801"><a href="https://www.thecheckeredflag.co.uk/sportscars/ginetta/">Ginetta Series</a></li>
<li id="menu-item-303742" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-303742"><a href="https://www.thecheckeredflag.co.uk/sportscars/porsche/">Porsche Series</a></li>
</ul>
</li>
<li id="menu-item-131899" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-131899"><a href="https://www.thecheckeredflag.co.uk/touring-cars/">Touring Cars</a>
<ul class="sub-menu">
<li id="menu-item-131904" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131904"><a href="https://www.thecheckeredflag.co.uk/touring-cars/btcc/">BTCC</a></li>
<li id="menu-item-192543" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-192543"><a href="https://www.thecheckeredflag.co.uk/touring-cars/dtm/">DTM</a></li>
<li id="menu-item-255598" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-255598"><a href="https://www.thecheckeredflag.co.uk/touring-cars/wtcr/">WTCR</a></li>
<li id="menu-item-303746" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-303746"><a href="https://www.thecheckeredflag.co.uk/touring-cars/tcr-europe/">TCR Europe</a></li>
<li id="menu-item-255597" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-255597"><a href="https://www.thecheckeredflag.co.uk/touring-cars/tcr-uk/">TCR UK</a></li>
<li id="menu-item-131951" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131951"><a href="https://www.thecheckeredflag.co.uk/touring-cars/renault-clio-cup/">Renault UK Clio Cup</a></li>
<li id="menu-item-317944" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-317944"><a href="https://www.thecheckeredflag.co.uk/touring-cars/jaguar-i-pace-etrophy/">Jaguar I-PACE eTROPHY</a></li>
</ul>
</li>
<li id="menu-item-131918" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-131918"><a href="https://www.thecheckeredflag.co.uk/motorcycles/">Motorcycles</a>
<ul class="sub-menu">
<li id="menu-item-131922" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131922"><a href="https://www.thecheckeredflag.co.uk/motorcycles/motogp/">MotoGP</a></li>
<li id="menu-item-131920" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131920"><a href="https://www.thecheckeredflag.co.uk/motorcycles/moto2/">Moto2</a></li>
<li id="menu-item-131921" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131921"><a href="https://www.thecheckeredflag.co.uk/motorcycles/moto3/">Moto3</a></li>
<li id="menu-item-131923" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131923"><a href="https://www.thecheckeredflag.co.uk/motorcycles/british-superbike/">British Superbike</a></li>
<li id="menu-item-131924" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131924"><a href="https://www.thecheckeredflag.co.uk/motorcycles/world-superbike/">World Superbike</a></li>
<li id="menu-item-131949" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131949"><a href="https://www.thecheckeredflag.co.uk/motorcycles/road-racing/">Road Racing</a></li>
</ul>
</li>
<li id="menu-item-290798" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-290798"><a href="https://www.thecheckeredflag.co.uk/offroad/">Off Road</a>
<ul class="sub-menu">
<li id="menu-item-254211" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-254211"><a href="https://www.thecheckeredflag.co.uk/offroad/rally/fiawrc/">FIA WRC</a></li>
<li id="menu-item-138301" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-138301"><a href="https://www.thecheckeredflag.co.uk/offroad/rally/fia-erc/">FIA ERC</a></li>
<li id="menu-item-131910" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131910"><a href="https://www.thecheckeredflag.co.uk/offroad/rally/british-rally-championship/">British Rally Championship</a></li>
<li id="menu-item-290799" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-290799"><a href="https://www.thecheckeredflag.co.uk/offroad/dakar/">Dakar</a></li>
<li id="menu-item-131917" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131917"><a href="https://www.thecheckeredflag.co.uk/offroad/rallycross/world-rallycross/">FIA World RX</a></li>
<li id="menu-item-131913" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131913"><a href="https://www.thecheckeredflag.co.uk/offroad/rallycross/european-rallycross/">FIA European RX</a></li>
<li id="menu-item-131911" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131911"><a href="https://www.thecheckeredflag.co.uk/offroad/rallycross/british-rallycross/">British RX</a></li>
<li id="menu-item-266701" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-266701"><a href="https://www.thecheckeredflag.co.uk/offroad/rallycross/americas-rallycross-championship/">Americas Rallycross Championship</a></li>
</ul>
</li>
<li id="menu-item-290800" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor menu-item-290800"><a href="https://www.thecheckeredflag.co.uk/nascar/">NASCAR</a></li>
<li id="menu-item-293110" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-293110"><a href="https://www.thecheckeredflag.co.uk/features/">Features</a>
<ul class="sub-menu">
<li id="menu-item-293115" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-293115"><a href="https://www.thecheckeredflag.co.uk/features/opinion/">Opinion</a></li>
<li id="menu-item-293113" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-293113"><a href="https://www.thecheckeredflag.co.uk/features/interviews/">Interviews</a></li>
<li id="menu-item-293114" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-293114"><a href="https://www.thecheckeredflag.co.uk/features/gallery/">Gallery</a></li>
<li id="menu-item-293111" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-293111"><a href="https://www.thecheckeredflag.co.uk/features/product-review/">Product Review</a></li>
<li id="menu-item-293112" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-293112"><a href="https://www.thecheckeredflag.co.uk/features/season-review/">Season Review</a></li>
<li id="menu-item-293118" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-293118"><a href="https://www.thecheckeredflag.co.uk/other/esports/">eSports</a></li>
<li id="menu-item-293117" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-293117"><a href="https://www.thecheckeredflag.co.uk/other/video-games/">Sim Racing</a></li>
</ul>
</li>
</ul></nav>

<div class="wrapper-boxed header-style-header-3">


<div class="penci-top-bar">
<div class="container">
<div class="penci-headline" role="navigation" itemscope itemtype="https://schema.org/SiteNavigationElement">
<span class="headline-title">Latest</span>
<div class="penci-topbar-social">
<div class="inner-header-social">
<a href="https://facebook.com/TheCheckeredFlag" rel="nofollow" target="_blank"><i class="fa fa-facebook"></i></a>
<a href="https://twitter.com/TheCheckerFlag" rel="nofollow" target="_blank"><i class="fa fa-twitter"></i></a>
<a href="https://instagram.com/thecheckeredflag/" rel="nofollow" target="_blank"><i class="fa fa-instagram"></i></a>
<a href="https://www.linkedin.com/company/the-checkered-flag/" rel="nofollow" target="_blank"><i class="fa fa-linkedin"></i></a>
<a href="https://www.youtube.com/channel/UCueRVoGbSE4GF2RszehXIgw" rel="nofollow" target="_blank"><i class="fa fa-youtube-play"></i></a>
<a href="https://www.thecheckeredflag.co.uk/feed" rel="nofollow" target="_blank"><i class="fa fa-rss"></i></a>
</div> </div>
<div class="penci-owl-carousel penci-owl-carousel-slider penci-headline-posts" data-auto="true" data-autotime="3000" data-speed="200">
<div>
<a class="penci-topbar-post-title" href="https://www.thecheckeredflag.co.uk/2019/08/ryan-sieg-joins-premium-motorsports-for-cup-return-at-indianapolis/">Ryan Sieg joins Premium Motorsports for Cup return at Indianapolis</a>
</div>
<div>
<a class="penci-topbar-post-title" href="https://www.thecheckeredflag.co.uk/2019/08/2020-xfinity-truck-driver-rules-set/">2020 Xfinity, Truck driver rules set</a>
</div>
<div>
<a class="penci-topbar-post-title" href="https://www.thecheckeredflag.co.uk/2019/08/preview-2019-ntt-indycar-series-gateway/">PREVIEW: 2019 NTT IndyCar Series &#8211; Gateway</a>
</div>
<div>
<a class="penci-topbar-post-title" href="https://www.thecheckeredflag.co.uk/2019/08/christopher-polvoorde-to-make-sst-debut-at-road-america/">Christopher Polvoorde to make SST debut at Road America</a>
</div>
<div>
<a class="penci-topbar-post-title" href="https://www.thecheckeredflag.co.uk/2019/08/albon-gasly-red-bull-swap-will-be-added-in-f1-2019-game-after-summer-break/">Albon/Gasly Red Bull Swap Will Be Added in F1 2019 Game After Summer Break</a>
</div>
<div>
<a class="penci-topbar-post-title" href="https://www.thecheckeredflag.co.uk/2019/08/rosenqvist-cleared-to-race-at-gateway-after-pocono-crash/">Rosenqvist cleared to race at Gateway after Pocono crash</a>
</div>
<div>
<a class="penci-topbar-post-title" href="https://www.thecheckeredflag.co.uk/2019/08/f2-duo-calderon-correa-to-get-private-f1-test-with-alfa-romeo/">F2 Duo Calderón, Correa To Get Private F1 Test With Alfa Romeo</a>
</div>
<div>
<a class="penci-topbar-post-title" href="https://www.thecheckeredflag.co.uk/2019/08/matvey-furazhkin-signs-for-esmotorsport-labasgas/">Matvey Furazhkin Signs for ESMotorsport-LabasGAS</a>
</div>
<div>
<a class="penci-topbar-post-title" href="https://www.thecheckeredflag.co.uk/2019/08/analysis-2019-brdc-british-f3-round-seven-silverstone-gp-circuit-novalak-overcomes-qualifying-calamity-to-turn-points-loss-into-points-gain/">ANALYSIS: 2019 BRDC British F3 Round Seven Silverstone GP circuit &#8211; Novalak overcomes qualifying calamity...</a>
</div>
<div>
<a class="penci-topbar-post-title" href="https://www.thecheckeredflag.co.uk/2019/08/danny-buchan-claims-his-second-british-superbike-win-at-cadwell-park/">Danny Buchan claims his second British Superbike win at Cadwell Park</a>
</div>
</div>
</div>
</div>
</div>
<header id="header" class="header-header-3 has-bottom-line" itemscope="itemscope" itemtype="https://schema.org/WPHeader">
<div class="inner-header">
<div class="container align-left-logo has-banner">
<div id="logo">
<a href="https://www.thecheckeredflag.co.uk/"><img src="https://www.thecheckeredflag.co.uk/wp-content/uploads/2018/11/TCF-2018-1.png" alt="The Checkered Flag" /></a>
</div>
<div class="header-banner header-style-3">
<span style="max-height:100px;">

<ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-9159179884377372" data-ad-slot="2468886887" data-ad-format="auto" data-full-width-responsive="true"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></span> </div>
</div>
</div>

<nav id="navigation" class="header-layout-bottom menu-style-1 header-3 menu-item-padding" role="navigation" itemscope itemtype="https://schema.org/SiteNavigationElement">
<div class="container">
<div class="button-menu-mobile header-3"><i class="fa fa-bars"></i></div>
<ul id="menu-2016" class="menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-131887"><a href="https://www.thecheckeredflag.co.uk/formula-1/">Formula 1</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-274866"><a href="https://www.thecheckeredflag.co.uk/formula-1/">Formula 1 News</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-290802"><a href="https://www.thecheckeredflag.co.uk/open-wheel/fia-formula-2/">FIA Formula 2</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-293116"><a href="https://www.thecheckeredflag.co.uk/open-wheel/formula-3/fia-formula-3-championship/">FIA Formula 3</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-290804"><a href="https://www.thecheckeredflag.co.uk/sportscars/porsche/porsche-supercup/">Porsche Mobil 1 Supercup</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-131892"><a href="https://www.thecheckeredflag.co.uk/touring-cars/btcc/">BTCC</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-291757"><a href="https://www.thecheckeredflag.co.uk/open-wheel/msa-formula/">F4 British Championship</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-291754"><a href="https://www.thecheckeredflag.co.uk/sportscars/ginetta/ginetta-gt-supercup/">Ginetta GT4 Supercup</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-291755"><a href="https://www.thecheckeredflag.co.uk/sportscars/ginetta/ginetta-junior/">Ginetta Junior</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-291753"><a href="https://www.thecheckeredflag.co.uk/sportscars/porsche/carrera-cup-gb/">Porsche Carrera Cup GB</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-291756"><a href="https://www.thecheckeredflag.co.uk/touring-cars/renault-clio-cup/">Renault UK Clio Cup</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-131940"><a href="https://www.thecheckeredflag.co.uk/open-wheel/">Open Wheel</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131942"><a href="https://www.thecheckeredflag.co.uk/open-wheel/formula-e/">FIA Formula E</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131943"><a href="https://www.thecheckeredflag.co.uk/open-wheel/indycar/">IndyCar</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-218310"><a href="https://www.thecheckeredflag.co.uk/open-wheel/fia-formula-2/">FIA Formula 2</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-296601"><a href="https://www.thecheckeredflag.co.uk/open-wheel/formula-3/fia-formula-3-championship/">FIA Formula 3</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131946"><a href="https://www.thecheckeredflag.co.uk/open-wheel/formula-3/euroformula-open/">EuroFormula Open</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131945"><a href="https://www.thecheckeredflag.co.uk/open-wheel/formula-3/european-f3-championship/">European Formula 3</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131989"><a href="https://www.thecheckeredflag.co.uk/open-wheel/renault-world-series/formula-renault-2-0-renault-world-series/">Formula Renault 2.0</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-180961"><a href="https://www.thecheckeredflag.co.uk/open-wheel/formula-3/british-f3-formula-3/">British F3</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131897"><a href="https://www.thecheckeredflag.co.uk/open-wheel/msa-formula/">F4 British Championship</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-131952"><a href="https://www.thecheckeredflag.co.uk/sportscars/">Sportscars</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131956"><a href="https://www.thecheckeredflag.co.uk/sportscars/endurance/fiawec/">FIA WEC</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-133799"><a href="https://www.thecheckeredflag.co.uk/sportscars/endurance/united-sportscar/">IMSA</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131958"><a href="https://www.thecheckeredflag.co.uk/sportscars/endurance/elms/">FIA ELMS</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131957"><a href="https://www.thecheckeredflag.co.uk/sportscars/endurance/blancpain-endurance-series/">Blancpain Endurance</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-148232"><a href="https://www.thecheckeredflag.co.uk/sportscars/endurance/blancpain-sprint/">Blancpain Sprint</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131954"><a href="https://www.thecheckeredflag.co.uk/sportscars/gt-sportscars/british-gt/">British GT</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-290801"><a href="https://www.thecheckeredflag.co.uk/sportscars/ginetta/">Ginetta Series</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-303742"><a href="https://www.thecheckeredflag.co.uk/sportscars/porsche/">Porsche Series</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-131899"><a href="https://www.thecheckeredflag.co.uk/touring-cars/">Touring Cars</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131904"><a href="https://www.thecheckeredflag.co.uk/touring-cars/btcc/">BTCC</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-192543"><a href="https://www.thecheckeredflag.co.uk/touring-cars/dtm/">DTM</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-255598"><a href="https://www.thecheckeredflag.co.uk/touring-cars/wtcr/">WTCR</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-303746"><a href="https://www.thecheckeredflag.co.uk/touring-cars/tcr-europe/">TCR Europe</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-255597"><a href="https://www.thecheckeredflag.co.uk/touring-cars/tcr-uk/">TCR UK</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131951"><a href="https://www.thecheckeredflag.co.uk/touring-cars/renault-clio-cup/">Renault UK Clio Cup</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-317944"><a href="https://www.thecheckeredflag.co.uk/touring-cars/jaguar-i-pace-etrophy/">Jaguar I-PACE eTROPHY</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-131918"><a href="https://www.thecheckeredflag.co.uk/motorcycles/">Motorcycles</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131922"><a href="https://www.thecheckeredflag.co.uk/motorcycles/motogp/">MotoGP</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131920"><a href="https://www.thecheckeredflag.co.uk/motorcycles/moto2/">Moto2</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131921"><a href="https://www.thecheckeredflag.co.uk/motorcycles/moto3/">Moto3</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131923"><a href="https://www.thecheckeredflag.co.uk/motorcycles/british-superbike/">British Superbike</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131924"><a href="https://www.thecheckeredflag.co.uk/motorcycles/world-superbike/">World Superbike</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131949"><a href="https://www.thecheckeredflag.co.uk/motorcycles/road-racing/">Road Racing</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-290798"><a href="https://www.thecheckeredflag.co.uk/offroad/">Off Road</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-254211"><a href="https://www.thecheckeredflag.co.uk/offroad/rally/fiawrc/">FIA WRC</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-138301"><a href="https://www.thecheckeredflag.co.uk/offroad/rally/fia-erc/">FIA ERC</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131910"><a href="https://www.thecheckeredflag.co.uk/offroad/rally/british-rally-championship/">British Rally Championship</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-290799"><a href="https://www.thecheckeredflag.co.uk/offroad/dakar/">Dakar</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131917"><a href="https://www.thecheckeredflag.co.uk/offroad/rallycross/world-rallycross/">FIA World RX</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131913"><a href="https://www.thecheckeredflag.co.uk/offroad/rallycross/european-rallycross/">FIA European RX</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131911"><a href="https://www.thecheckeredflag.co.uk/offroad/rallycross/british-rallycross/">British RX</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-266701"><a href="https://www.thecheckeredflag.co.uk/offroad/rallycross/americas-rallycross-championship/">Americas Rallycross Championship</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor menu-item-290800"><a href="https://www.thecheckeredflag.co.uk/nascar/">NASCAR</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-293110"><a href="https://www.thecheckeredflag.co.uk/features/">Features</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-293115"><a href="https://www.thecheckeredflag.co.uk/features/opinion/">Opinion</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-293113"><a href="https://www.thecheckeredflag.co.uk/features/interviews/">Interviews</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-293114"><a href="https://www.thecheckeredflag.co.uk/features/gallery/">Gallery</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-293111"><a href="https://www.thecheckeredflag.co.uk/features/product-review/">Product Review</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-293112"><a href="https://www.thecheckeredflag.co.uk/features/season-review/">Season Review</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-293118"><a href="https://www.thecheckeredflag.co.uk/other/esports/">eSports</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-293117"><a href="https://www.thecheckeredflag.co.uk/other/video-games/">Sim Racing</a></li>
</ul>
</li>
</ul>
<div id="top-search">
<a class="search-click"><i class="fa fa-search"></i></a>
<div class="show-search">
<form role="search" method="get" id="searchform" action="https://www.thecheckeredflag.co.uk/">
<div>
<input type="text" class="search-input" placeholder="Type and hit enter..." name="s" id="s" />
</div>
</form> <a class="search-click close-search"><i class="fa fa-close"></i></a>
</div>
</div>
</div>
</nav>
</header>

<div class="container container-single container-single-magazine penci_sidebar right-sidebar penci-enable-lightbox">
<div id="main">
<div class="theiaStickySidebar">
<article id="post-318590" class="post type-post status-publish hentry">
<div class="header-standard header-classic single-header">
<div class="penci-standard-cat"><span class="cat"><a class="penci-cat-name" href="https://www.thecheckeredflag.co.uk/nascar/sprint-cup/" rel="category tag">Monster Energy NASCAR Cup Series</a></span></div>
<h1 class="post-title single-post-title entry-title">Ryan Sieg joins Premium Motorsports for Cup return at Indianapolis</h1>
<div class="penci-hide-tagupdated">
<span class="author-italic author vcard">by <a class="url fn n" href="https://www.thecheckeredflag.co.uk/author/jnguyen/">Justin Nguyen</a></span>
<time class="entry-date published" datetime="2019-08-21T21:00:40+01:00">August 21, 2019</time> </div>
<div class="post-box-meta-single">
<span class="author-post byline"><span class="author vcard">written by <a class="author-url url fn n" href="https://www.thecheckeredflag.co.uk/author/jnguyen/">Justin Nguyen</a></span></span>
<span><time class="entry-date published" datetime="2019-08-21T21:00:40+01:00">August 21, 2019</time></span>
</div>
</div>
<div class="post-image">
<a href="https://www.thecheckeredflag.co.uk/wp-content/uploads/2019/08/NXS-TMS-Ryan-Sieg-Practice-033019.jpg" data-rel="penci-gallery-image-content"> <img width="800" height="533" src="https://www.thecheckeredflag.co.uk/wp-content/uploads/2019/08/NXS-TMS-Ryan-Sieg-Practice-033019.jpg" class="attachment-penci-full-thumb size-penci-full-thumb wp-post-image" alt="" srcset="https://www.thecheckeredflag.co.uk/wp-content/uploads/2019/08/NXS-TMS-Ryan-Sieg-Practice-033019.jpg 800w, https://www.thecheckeredflag.co.uk/wp-content/uploads/2019/08/NXS-TMS-Ryan-Sieg-Practice-033019-240x160.jpg 240w, https://www.thecheckeredflag.co.uk/wp-content/uploads/2019/08/NXS-TMS-Ryan-Sieg-Practice-033019-768x512.jpg 768w, https://www.thecheckeredflag.co.uk/wp-content/uploads/2019/08/NXS-TMS-Ryan-Sieg-Practice-033019-585x390.jpg 585w, https://www.thecheckeredflag.co.uk/wp-content/uploads/2019/08/NXS-TMS-Ryan-Sieg-Practice-033019-263x175.jpg 263w" sizes="(max-width: 800px) 100vw, 800px" /> </a><div class="penci-featured-caption">Credit: Jared C. Tilton/Getty Images</div> </div>
<div class="post-entry blockquote-style-1">
<div class="inner-post-entry entry-content" id="penci-post-entry-inner">
<p>In September, Ryan Sieg will run his first <strong>Monster Energy Cup Series</strong> race in two years when he competes in the <strong>Big Machine Vodka 400</strong> at <strong>Indianapolis Motor Speedway</strong>. As announced on Wednesday, he will drive the #27 <strong>Chevrolet Camaro</strong> for <strong>Premium Motorsports</strong> with sponsorship from <strong>Sci-Aps</strong>.</p>
<p><em>&#8220;I&#8217;m so excited to join Premium Motorsports at Indianapolis for one of the biggest races of the year,&#8221;</em> Sieg commented in a statement. <em>&#8220;I can&#8217;t thank Sci-Aps and everyone at Premium Motorsports for making this possible.&#8221;</em></p>
<p>A <strong>NASCAR Xfinity Series</strong> veteran, Sieg ran five Cup races for the now-defunct <strong>BK Racing</strong> in 2017, recording a best finish of twenty-sixth in his maiden start at <strong>Dover International Speedway</strong>, driving the #83 <strong>Toyota Camry</strong>. After moving to BK&#8217;s #83 for the <strong>Michigan International Speedway</strong> event (thirty-third), he piloted the #23 to fortieth, twenty-seventh, and thirty-second-place runs at <strong>Daytona International Speedway</strong>, <strong>Kentucky Speedway</strong>, and <strong>New Hampshire Motor Speedway</strong>, respectively.</p>
<p>In the Xfinity Series, he is currently twelfth in points driving for his <strong>RSS Racing</strong> organisation with eight top-ten finishes, two top fives, and a best run of fourth at Daytona in February. Racing full-time in the series since 2014, he has seventeen career top tens and five top fives, with his highest placement being second at <strong>Iowa Speedway</strong> in 2017.</p>
<p>Premium, who fields the #15 full-time for primarily <strong>Ross Chastain</strong>, has operated the #27 on a limited basis in 2019. After <strong>Casey Mears</strong> raced the number under the <strong>Germain Racing</strong> banner at the <strong>Daytona 500</strong>, Premium used it for mostly <strong>Reed Sorenson</strong>, with Chastain and <strong>Quin Houff</strong> also making starts in the #27. With 15 starts so far, Sorenson holds the number&#8217;s best finish of the season of eighteenth at <strong>Talladega Superspeedway</strong>. In the owners&#8217; points, the #27 is thirty-eighth.</p>
<div class="penci-single-link-pages">
</div>
<div class="post-tags">
<a href="https://www.thecheckeredflag.co.uk/tag/2019-big-machine-vodka-400-at-the-brickyard/" rel="tag">2019 Big Machine Vodka 400 at the Brickyard</a><a href="https://www.thecheckeredflag.co.uk/tag/2019-brickyard-400/" rel="tag">2019 Brickyard 400</a><a href="https://www.thecheckeredflag.co.uk/tag/2019-monster-energy-nascar-cup-series/" rel="tag">2019 Monster Energy NASCAR Cup Series</a><a href="https://www.thecheckeredflag.co.uk/tag/2019-nascar-cup-debuts/" rel="tag">2019 NASCAR Cup Debuts</a><a href="https://www.thecheckeredflag.co.uk/tag/indianapolis-motor-speedway/" rel="tag">Indianapolis Motor Speedway</a><a href="https://www.thecheckeredflag.co.uk/tag/premium-motorsports/" rel="tag">Premium Motorsports</a><a href="https://www.thecheckeredflag.co.uk/tag/ryan-sieg/" rel="tag">Ryan Sieg</a> </div>
</div>
</div>
<div class="penci-google-adsense-2">

<ins class="adsbygoogle" style="display:inline-block;width:728px;height:90px" data-ad-client="ca-pub-9159179884377372" data-ad-slot="6495511074"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script> </div>
<div class="tags-share-box center-box">
<span class="single-comment-o"><i class="fa fa-comment-o"></i><span class="dsq-postid" data-dsqidentifier="318590 https://www.thecheckeredflag.co.uk/?p=318590">0 comment</span></span>
<div class="post-share">
<span class="count-number-like">0</span><a class="penci-post-like single-like-button" data-post_id="318590" title="Like" data-like="Like" data-unlike="Unlike"><i class="fa fa-heart-o"></i></a> <div class="list-posts-share"><a target="_blank" rel="nofollow" href="https://www.facebook.com/sharer/sharer.php?u=https://www.thecheckeredflag.co.uk/2019/08/ryan-sieg-joins-premium-motorsports-for-cup-return-at-indianapolis/"><i class="fa fa-facebook"></i><span class="dt-share">Facebook</span></a><a target="_blank" rel="nofollow" href="https://twitter.com/intent/tweet?text=Check%20out%20this%20article:%20Ryan%20Sieg%20joins%20Premium%20Motorsports%20for%20Cup%20return%20at%20Indianapolis%20-%20https://www.thecheckeredflag.co.uk/2019/08/ryan-sieg-joins-premium-motorsports-for-cup-return-at-indianapolis/"><i class="fa fa-twitter"></i><span class="dt-share">Twitter</span></a><a data-pin-do="none" rel="nofollow noreferrer noopener" onclick="var e=document.createElement('script');e.setAttribute('type','text/javascript');e.setAttribute('charset','UTF-8');e.setAttribute('src','//assets.pinterest.com/js/pinmarklet.js?r='+Math.random()*99999999);document.body.appendChild(e);"><i class="fa fa-pinterest"></i><span class="dt-share">Pinterest</span></a><a target="_blank" rel="nofollow" href="https://www.linkedin.com/shareArticle?mini=true&#038;url=https%3A%2F%2Fwww.thecheckeredflag.co.uk%2F2019%2F08%2Fryan-sieg-joins-premium-motorsports-for-cup-return-at-indianapolis%2F&#038;title=Ryan%20Sieg%20joins%20Premium%20Motorsports%20for%20Cup%20return%20at%20Indianapolis"><i class="fa fa-linkedin"></i><span class="dt-share">Linkedin</span></a><a target="_blank" rel="nofollow" href="https://reddit.com/submit?url=https%3A%2F%2Fwww.thecheckeredflag.co.uk%2F2019%2F08%2Fryan-sieg-joins-premium-motorsports-for-cup-return-at-indianapolis%2F&#038;title=Ryan%20Sieg%20joins%20Premium%20Motorsports%20for%20Cup%20return%20at%20Indianapolis"><i class="fa fa-reddit"></i><span class="dt-share">Reddit</span></a><a target="_blank" rel="nofollow" href="whatsapp://send?text=Ryan%20Sieg%20joins%20Premium%20Motorsports%20for%20Cup%20return%20at%20Indianapolis %0A%0A https%3A%2F%2Fwww.thecheckeredflag.co.uk%2F2019%2F08%2Fryan-sieg-joins-premium-motorsports-for-cup-return-at-indianapolis%2F"><i class="fa fa-whatsapp"></i><span class="dt-share">Whatsapp</span></a><a target="_blank" rel="nofollow" href="/cdn-cgi/l/email-protection#89b6fafcebe3eceafdb4dbf0e8e7acbbb9dae0eceeacbbb9e3e6e0e7faacbbb9d9fbece4e0fce4acbbb9c4e6fde6fbfaf9e6fbfdfaacbbb9efe6fbacbbb9cafcf9acbbb9fbecfdfcfbe7acbbb9e8fdacbbb9c0e7ede0e8e7e8f9e6e5e0faafaab9bab1b2cbc6cdd0b4e1fdfdf9fab3a6a6fefefea7fde1eceae1eceae2ecfbecedefe5e8eea7eae6a7fce2a6bbb9b8b0a6b9b1a6fbf0e8e7a4fae0eceea4e3e6e0e7faa4f9fbece4e0fce4a4e4e6fde6fbfaf9e6fbfdfaa4efe6fba4eafcf9a4fbecfdfcfbe7a4e8fda4e0e7ede0e8e7e8f9e6e5e0faa6"><i class="fa fa-envelope"></i><span class="dt-share">Email</span></a></div> </div>
</div>
<div class="post-author">
<div class="author-img">
<img alt='Justin Nguyen' src='https://www.thecheckeredflag.co.uk/wp-content/uploads/2019/05/Justin-Nguyen-avatar-100x100.jpg' class='avatar avatar-100 photo' height='100' width='100' /> </div>
<div class="author-content">
<h5><a href="https://www.thecheckeredflag.co.uk/author/jnguyen/" title="Posts by Justin Nguyen" rel="author">Justin Nguyen</a></h5>
<p>Justin is an American-based reporter who covers NASCAR and the Stadium Super Trucks. Follow him on Twitter at @ZappaOMatic</p>
<a target="_blank" class="author-social" href="https://zappaomatic.wordpress.com"><i class="fa fa-globe"></i></a>
<a target="_blank" class="author-social" href="https://twitter.com/ZappaOMatic"><i class="fa fa-twitter"></i></a>
<a target="_blank" class="author-social" href="https://instagram.com/zappaomatic"><i class="fa fa-instagram"></i></a>
<a class="author-social" href="/cdn-cgi/l/email-protection#e0aa959394898eceae879599858ea0948885838885838b85928584868c8187ce838fce958b"><i class="fa fa-envelope-o"></i></a>
</div>
</div>
<div class="post-pagination">
<div class="prev-post">
<div class="prev-post-inner">
<div class="prev-post-title">
<span>previous post</span>
</div>
<a href="https://www.thecheckeredflag.co.uk/2019/08/2020-xfinity-truck-driver-rules-set/">
<div class="pagi-text">
<h5 class="prev-title">2020 Xfinity, Truck driver rules set</h5>
</div>
</a>
</div>
</div>
</div>
<div class="post-related">
<div class="post-title-box"><h4 class="post-box-title">Related articles</h4></div>
<div class="penci-owl-carousel penci-owl-carousel-slider penci-related-carousel" data-lazy="true" data-item="3" data-desktop="3" data-tablet="2" data-tabsmall="2" data-auto="false" data-speed="300" data-dots="true" data-nav="false">
<div class="item-related">
<a class="related-thumb penci-image-holder" style="background-image: url('https://www.thecheckeredflag.co.uk/wp-content/uploads/2019/08/TCF-IndyCar-2018-Pocono-Red-Flag-585x390.jpg');" href="https://www.thecheckeredflag.co.uk/2019/08/opinion-why-indycar-should-not-return-to-pocono-raceway/" title="OPINION: Why IndyCar should not return to Pocono Raceway">
</a>
<h3><a href="https://www.thecheckeredflag.co.uk/2019/08/opinion-why-indycar-should-not-return-to-pocono-raceway/">OPINION: Why IndyCar should not return to Pocono...</a></h3>
<span class="date"><time class="entry-date published" datetime="2019-08-19T20:00:58+01:00">August 19, 2019</time></span>
</div>
<div class="item-related">
<a class="related-thumb penci-image-holder" style="background-image: url('https://www.thecheckeredflag.co.uk/wp-content/uploads/2019/08/MENCS_BMS2_Starting_Field_081719-585x390.jpg');" href="https://www.thecheckeredflag.co.uk/2019/08/denny-hamlin-triumphs-in-late-battle-wins-bass-pro-nra-night-race/" title="Denny Hamlin triumphs in late battle, wins Bass Pro NRA Night Race">
</a>
<h3><a href="https://www.thecheckeredflag.co.uk/2019/08/denny-hamlin-triumphs-in-late-battle-wins-bass-pro-nra-night-race/">Denny Hamlin triumphs in late battle, wins Bass...</a></h3>
<span class="date"><time class="entry-date published" datetime="2019-08-18T03:56:43+01:00">August 18, 2019</time></span>
</div>
<div class="item-related">
<a class="related-thumb penci-image-holder" style="background-image: url('https://www.thecheckeredflag.co.uk/wp-content/uploads/2019/08/Bayley-Currey-Ross-Chastain-2019-MENCS-Chicagoland-585x390.jpg');" href="https://www.thecheckeredflag.co.uk/2019/08/bayley-currey-indefinitely-suspended-after-failed-drug-test/" title="Bayley Currey indefinitely suspended after failed drug test">
</a>
<h3><a href="https://www.thecheckeredflag.co.uk/2019/08/bayley-currey-indefinitely-suspended-after-failed-drug-test/">Bayley Currey indefinitely suspended after failed drug test</a></h3>
<span class="date"><time class="entry-date published" datetime="2019-08-16T02:50:10+01:00">August 16, 2019</time></span>
</div>
<div class="item-related">
<a class="related-thumb penci-image-holder" style="background-image: url('https://www.thecheckeredflag.co.uk/wp-content/uploads/2019/08/dibenedetto_2019mencs_carshot-585x390.jpg');" href="https://www.thecheckeredflag.co.uk/2019/08/matt-dibenedetto-out-at-leavine-family-racing-after-2019/" title="Matt DiBenedetto out at Leavine Family Racing after 2019">
</a>
<h3><a href="https://www.thecheckeredflag.co.uk/2019/08/matt-dibenedetto-out-at-leavine-family-racing-after-2019/">Matt DiBenedetto out at Leavine Family Racing after...</a></h3>
<span class="date"><time class="entry-date published" datetime="2019-08-15T17:31:19+01:00">August 15, 2019</time></span>
</div>
<div class="item-related">
<a class="related-thumb penci-image-holder" style="background-image: url('https://www.thecheckeredflag.co.uk/wp-content/uploads/2019/08/tss1_mencs_raganprac_042619-585x390.jpg');" href="https://www.thecheckeredflag.co.uk/2019/08/david-ragan-stepping-away-from-full-time-nascar-racing-after-2019/" title="David Ragan stepping away from full-time NASCAR racing after 2019">
</a>
<h3><a href="https://www.thecheckeredflag.co.uk/2019/08/david-ragan-stepping-away-from-full-time-nascar-racing-after-2019/">David Ragan stepping away from full-time NASCAR racing...</a></h3>
<span class="date"><time class="entry-date published" datetime="2019-08-14T17:38:07+01:00">August 14, 2019</time></span>
</div>
<div class="item-related">
<a class="related-thumb penci-image-holder" style="background-image: url('https://www.thecheckeredflag.co.uk/wp-content/uploads/2019/08/MENCS_MIS2_Trophy_081119-585x390.jpg');" href="https://www.thecheckeredflag.co.uk/2019/08/kevin-harvick-wins-consumers-energy-400/" title="Kevin Harvick wins Consumers Energy 400">
</a>
<h3><a href="https://www.thecheckeredflag.co.uk/2019/08/kevin-harvick-wins-consumers-energy-400/">Kevin Harvick wins Consumers Energy 400</a></h3>
<span class="date"><time class="entry-date published" datetime="2019-08-12T01:34:15+01:00">August 12, 2019</time></span>
</div>
<div class="item-related">
<a class="related-thumb penci-image-holder" style="background-image: url('https://www.thecheckeredflag.co.uk/wp-content/uploads/2019/08/JJ-Yeley-2019-MENCS-Pocono-52-585x390.jpg');" href="https://www.thecheckeredflag.co.uk/2019/08/rick-ware-racing-forms-fourth-team-j-j-yeley-to-debut-at-bristol/" title="Rick Ware Racing forms fourth team, J.J. Yeley to debut at Bristol">
</a>
<h3><a href="https://www.thecheckeredflag.co.uk/2019/08/rick-ware-racing-forms-fourth-team-j-j-yeley-to-debut-at-bristol/">Rick Ware Racing forms fourth team, J.J. Yeley...</a></h3>
<span class="date"><time class="entry-date published" datetime="2019-08-09T17:51:19+01:00">August 9, 2019</time></span>
</div>
<div class="item-related">
<a class="related-thumb penci-image-holder" style="background-image: url('https://www.thecheckeredflag.co.uk/wp-content/uploads/2019/08/Boyd-2019NGOTS-CarShot-585x390.jpg');" href="https://www.thecheckeredflag.co.uk/2019/08/spencer-boyd-to-make-maiden-cup-start-at-michigan/" title="Spencer Boyd to make maiden Cup start at Michigan">
</a>
<h3><a href="https://www.thecheckeredflag.co.uk/2019/08/spencer-boyd-to-make-maiden-cup-start-at-michigan/">Spencer Boyd to make maiden Cup start at...</a></h3>
<span class="date"><time class="entry-date published" datetime="2019-08-07T17:13:01+01:00">August 7, 2019</time></span>
</div>
<div class="item-related">
<a class="related-thumb penci-image-holder" style="background-image: url('https://www.thecheckeredflag.co.uk/wp-content/uploads/2019/08/Chase-Elliott-2019-MENCS-Watkins-Glen-practice-585x390.jpg');" href="https://www.thecheckeredflag.co.uk/2019/08/chase-elliott-wins-watkins-glen-from-pole/" title="Chase Elliott wins Watkins Glen from pole">
</a>
<h3><a href="https://www.thecheckeredflag.co.uk/2019/08/chase-elliott-wins-watkins-glen-from-pole/">Chase Elliott wins Watkins Glen from pole</a></h3>
<span class="date"><time class="entry-date published" datetime="2019-08-04T22:43:21+01:00">August 4, 2019</time></span>
</div>
</div></div>
<div id="disqus_thread"></div>
</article> </div>
</div>
<div id="sidebar" class="penci-sidebar-content style-1 pcalign-center">
<div class="theiaStickySidebar">
<aside id="penci_slider_posts_news_widget-2" class="widget penci_slider_posts_news_widget"><h4 class="widget-title penci-border-arrow"><span class="inner-arrow">Latest articles</span></h4> <div id="penci-postslidewg-5158" class="penci-owl-carousel penci-owl-carousel-slider penci-widget-slider penci-post-slider-style-1" data-lazy="true">
<div class="penci-slide-widget">
<div class="penci-slide-content">
<span class="penci-image-holder" style="background-image: url('https://www.thecheckeredflag.co.uk/wp-content/uploads/2019/08/NXS-TMS-Ryan-Sieg-Practice-033019-585x390.jpg');" title="Ryan Sieg joins Premium Motorsports for Cup return at Indianapolis"></span>
<a href="https://www.thecheckeredflag.co.uk/2019/08/ryan-sieg-joins-premium-motorsports-for-cup-return-at-indianapolis/" class="penci-widget-slider-overlay" title="Ryan Sieg joins Premium Motorsports for Cup return at Indianapolis"></a>
<div class="penci-widget-slide-detail">
<h4>
<a href="https://www.thecheckeredflag.co.uk/2019/08/ryan-sieg-joins-premium-motorsports-for-cup-return-at-indianapolis/" rel="bookmark" title="Ryan Sieg joins Premium Motorsports for Cup return at Indianapolis">Ryan Sieg joins Premium Motorsports for Cup return...</a>
</h4>
<span class="slide-item-date">Aug 21, 2019</span>
</div>
</div>
</div>
<div class="penci-slide-widget">
<div class="penci-slide-content">
<span class="penci-image-holder" style="background-image: url('https://www.thecheckeredflag.co.uk/wp-content/uploads/2019/08/Greg-Biffle-NGOTS-2019-Texas-585x390.jpg');" title="2020 Xfinity, Truck driver rules set"></span>
<a href="https://www.thecheckeredflag.co.uk/2019/08/2020-xfinity-truck-driver-rules-set/" class="penci-widget-slider-overlay" title="2020 Xfinity, Truck driver rules set"></a>
<div class="penci-widget-slide-detail">
<h4>
<a href="https://www.thecheckeredflag.co.uk/2019/08/2020-xfinity-truck-driver-rules-set/" rel="bookmark" title="2020 Xfinity, Truck driver rules set">2020 Xfinity, Truck driver rules set</a>
</h4>
<span class="slide-item-date">Aug 21, 2019</span>
</div>
</div>
</div>
<div class="penci-slide-widget">
<div class="penci-slide-content">
<span class="penci-image-holder" style="background-image: url('https://www.thecheckeredflag.co.uk/wp-content/uploads/2019/08/TCF-IndyCar-2018-Gateway-Race-Start-585x390.jpg');" title="PREVIEW: 2019 NTT IndyCar Series &#8211; Gateway"></span>
<a href="https://www.thecheckeredflag.co.uk/2019/08/preview-2019-ntt-indycar-series-gateway/" class="penci-widget-slider-overlay" title="PREVIEW: 2019 NTT IndyCar Series &#8211; Gateway"></a>
<div class="penci-widget-slide-detail">
<h4>
<a href="https://www.thecheckeredflag.co.uk/2019/08/preview-2019-ntt-indycar-series-gateway/" rel="bookmark" title="PREVIEW: 2019 NTT IndyCar Series &#8211; Gateway">PREVIEW: 2019 NTT IndyCar Series &#8211; Gateway</a>
</h4>
<span class="slide-item-date">Aug 21, 2019</span>
</div>
</div>
</div>
<div class="penci-slide-widget">
<div class="penci-slide-content">
<span class="penci-image-holder" style="background-image: url('https://www.thecheckeredflag.co.uk/wp-content/uploads/2019/08/Christopher-Polvoorde-SST-2019-585x390.jpg');" title="Christopher Polvoorde to make SST debut at Road America"></span>
<a href="https://www.thecheckeredflag.co.uk/2019/08/christopher-polvoorde-to-make-sst-debut-at-road-america/" class="penci-widget-slider-overlay" title="Christopher Polvoorde to make SST debut at Road America"></a>
<div class="penci-widget-slide-detail">
<h4>
<a href="https://www.thecheckeredflag.co.uk/2019/08/christopher-polvoorde-to-make-sst-debut-at-road-america/" rel="bookmark" title="Christopher Polvoorde to make SST debut at Road America">Christopher Polvoorde to make SST debut at Road...</a>
</h4>
<span class="slide-item-date">Aug 21, 2019</span>
</div>
</div>
</div>
<div class="penci-slide-widget">
<div class="penci-slide-content">
<span class="penci-image-holder" style="background-image: url('https://www.thecheckeredflag.co.uk/wp-content/uploads/2019/05/F1-2019-Albon-Toro-Rosso-585x390.jpg');" title="Albon/Gasly Red Bull Swap Will Be Added in F1 2019 Game After Summer Break"></span>
<a href="https://www.thecheckeredflag.co.uk/2019/08/albon-gasly-red-bull-swap-will-be-added-in-f1-2019-game-after-summer-break/" class="penci-widget-slider-overlay" title="Albon/Gasly Red Bull Swap Will Be Added in F1 2019 Game After Summer Break"></a>
<div class="penci-widget-slide-detail">
<h4>
<a href="https://www.thecheckeredflag.co.uk/2019/08/albon-gasly-red-bull-swap-will-be-added-in-f1-2019-game-after-summer-break/" rel="bookmark" title="Albon/Gasly Red Bull Swap Will Be Added in F1 2019 Game After Summer Break">Albon/Gasly Red Bull Swap Will Be Added in...</a>
</h4>
<span class="slide-item-date">Aug 21, 2019</span>
</div>
</div>
</div>
</div>
</aside><aside id="penci_popular_news_widget-5" class="widget penci_popular_news_widget"><h4 class="widget-title penci-border-arrow"><span class="inner-arrow">Popular on TCF</span></h4> <ul id="penci-popularwg-4362" class="side-newsfeed">
<li class="penci-feed featured-news">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder" rel="bookmark" style="background-image: url('https://www.thecheckeredflag.co.uk/wp-content/uploads/2019/06/8-TOYOTA-GAZOO-RACING-JPN-_...-585x390.jpg');" href="https://www.thecheckeredflag.co.uk/2019/06/analysis-2019-24-hours-of-le-mans-lmp1/" title="Analysis: 2019 24 Hours of Le Mans &#8211; LMP1"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.thecheckeredflag.co.uk/2019/06/analysis-2019-24-hours-of-le-mans-lmp1/" rel="bookmark" title="Analysis: 2019 24 Hours of Le Mans &#8211; LMP1">
Analysis: 2019 24 Hours of Le Mans &#8211; LMP1 </a>
</h4>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder small-fix-size" rel="bookmark" style="background-image: url('https://www.thecheckeredflag.co.uk/wp-content/uploads/2018/11/MO-NXS-Day-081316.jpg');" href="https://www.thecheckeredflag.co.uk/2018/11/nascar-bids-farewell-to-dodge-after-2018/" title="NASCAR bids farewell to Dodge after 2018"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.thecheckeredflag.co.uk/2018/11/nascar-bids-farewell-to-dodge-after-2018/" rel="bookmark" title="NASCAR bids farewell to Dodge after 2018">
NASCAR bids farewell to Dodge after 2018 </a>
</h4>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder small-fix-size" rel="bookmark" style="background-image: url('https://www.thecheckeredflag.co.uk/wp-content/uploads/2019/08/williams_3-263x175.jpg');" href="https://www.thecheckeredflag.co.uk/2019/08/williams-doubles-up-for-jhr-1-2/" title="Williams doubles up for JHR Developments 1-2"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.thecheckeredflag.co.uk/2019/08/williams-doubles-up-for-jhr-1-2/" rel="bookmark" title="Williams doubles up for JHR Developments 1-2">
Williams doubles up for JHR Developments 1-2 </a>
</h4>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder small-fix-size" rel="bookmark" style="background-image: url('https://www.thecheckeredflag.co.uk/wp-content/uploads/2019/08/Nicolas-Longuet-F1-Esports-263x175.jpg');" href="https://www.thecheckeredflag.co.uk/2019/08/nicolas-longuet-red-bull-f1-esports-drive/" title="How Nicolas Longuet Went From Bedroom To Red Bull F1 Esports Drive In 12 Months"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.thecheckeredflag.co.uk/2019/08/nicolas-longuet-red-bull-f1-esports-drive/" rel="bookmark" title="How Nicolas Longuet Went From Bedroom To Red Bull F1 Esports Drive In 12 Months">
How Nicolas Longuet Went From Bedroom To Red Bull F1 Esports Drive In 12 Months </a>
</h4>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder small-fix-size" rel="bookmark" style="background-image: url('https://www.thecheckeredflag.co.uk/wp-content/uploads/2019/08/qiddiya-saudi-arabia-f1-263x175.jpg');" href="https://www.thecheckeredflag.co.uk/2019/08/saudi-arabia-in-discussions-with-liberty-media-over-hosting-f1-race/" title="Saudi Arabia in discussions with Liberty Media over hosting F1 race"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.thecheckeredflag.co.uk/2019/08/saudi-arabia-in-discussions-with-liberty-media-over-hosting-f1-race/" rel="bookmark" title="Saudi Arabia in discussions with Liberty Media over hosting F1 race">
Saudi Arabia in discussions with Liberty Media over hosting F1 race </a>
</h4>
</div>
</div>
</li>
</ul>
</aside><aside id="nav_menu-4" class="widget widget_nav_menu"><div class="menu-top-container"><ul id="menu-top" class="menu"><li id="menu-item-131978" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-131978"><a href="https://www.thecheckeredflag.co.uk/latest-news/">News</a></li>
<li id="menu-item-131965" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131965"><a href="https://www.thecheckeredflag.co.uk/features/">Features</a></li>
<li id="menu-item-173707" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-173707"><a href="https://www.thecheckeredflag.co.uk/features/gallery/">Photos</a></li>
<li id="menu-item-131884" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131884"><a href="https://www.thecheckeredflag.co.uk/tcf-blogs/">TCF Blogs</a></li>
<li id="menu-item-131986" class="menu-item menu-item-type-taxonomy menu-item-object-post_format menu-item-131986"><a href="https://www.thecheckeredflag.co.uk/type/video/">Videos</a></li>
<li id="menu-item-131967" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-131967"><a href="https://www.thecheckeredflag.co.uk/contribute/">Contribute</a></li>
<li id="menu-item-131966" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-131966"><a href="https://www.thecheckeredflag.co.uk/contact/">Contact Us</a></li>
</ul></div></aside><aside id="text-12" class="widget widget_text"> <div class="textwidget"><p><a href="https://www.facebook.com/groups/porschemotorsportcommunity/" target="_blank" rel="noopener noreferrer"><img class="aligncenter size-full wp-image-310781" src="https://www.thecheckeredflag.co.uk/wp-content/uploads/2019/06/PMC-Square-1.jpg" alt="Porsche Motorsport Community" width="400" height="400" /></a></p>
</div>
</aside><aside id="custom_html-8" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget">
<ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-9159179884377372" data-ad-slot="2468886887" data-ad-format="auto"></ins>
<script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script>
window.setTimeout(function(){ 
  (adsbygoogle = window.adsbygoogle || []).push({}); 
}, 200); 
</script></div></aside><aside id="penci_social_widget-2" class="widget penci_social_widget"><h4 class="widget-title penci-border-arrow"><span class="inner-arrow">Keep in touch</span></h4>
<div class="widget-social pc_aligncenter">
<a href="https://facebook.com/TheCheckeredFlag" rel="nofollow" target="_blank"><i class="fa fa-facebook" style="font-size: 18px"></i><span style="font-size: 13px">Facebook</span></a>
<a href="https://twitter.com/TheCheckerFlag" rel="nofollow" target="_blank"><i class="fa fa-twitter" style="font-size: 18px"></i><span style="font-size: 13px">Twitter</span></a>
<a href="https://instagram.com/thecheckeredflag/" rel="nofollow" target="_blank"><i class="fa fa-instagram" style="font-size: 18px"></i><span style="font-size: 13px">Instagram</span></a>
<a href="https://www.linkedin.com/company/the-checkered-flag/" rel="nofollow" target="_blank"><i class="fa fa-linkedin" style="font-size: 18px"></i><span style="font-size: 13px">Linkedin</span></a>
<a href="https://www.youtube.com/channel/UCueRVoGbSE4GF2RszehXIgw" rel="nofollow" target="_blank"><i class="fa fa-youtube-play" style="font-size: 18px"></i><span style="font-size: 13px">Youtube</span></a>
<a href="https://www.thecheckeredflag.co.uk/feed" rel="nofollow" target="_blank"><i class="fa fa-rss" style="font-size: 18px"></i><span style="font-size: 13px">RSS</span></a>
</div>
</aside><aside id="penci_latest_news_widget-2" class="widget penci_latest_news_widget"><h4 class="widget-title penci-border-arrow"><span class="inner-arrow">Recent Features</span></h4> <ul id="penci-latestwg-4275" class="side-newsfeed penci-feed-2columns penci-2columns-feed">
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder small-fix-size" rel="bookmark" style="background-image: url('https://www.thecheckeredflag.co.uk/wp-content/uploads/2019/08/Nicolas-Longuet-F1-Esports-263x175.jpg');" href="https://www.thecheckeredflag.co.uk/2019/08/nicolas-longuet-red-bull-f1-esports-drive/" title="How Nicolas Longuet Went From Bedroom To Red Bull F1 Esports Drive In 12 Months"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.thecheckeredflag.co.uk/2019/08/nicolas-longuet-red-bull-f1-esports-drive/" rel="bookmark" title="How Nicolas Longuet Went From Bedroom To Red Bull F1 Esports Drive In 12 Months">
How Nicolas Longuet Went From Bedroom To Red Bull F1 Esports Drive In 12 Months </a>
</h4>
<span class="side-item-meta"><time class="entry-date published" datetime="2019-08-20T14:04:21+01:00">August 20, 2019</time></span>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder small-fix-size" rel="bookmark" style="background-image: url('https://www.thecheckeredflag.co.uk/wp-content/uploads/2019/08/TCF-IndyCar-2018-Pocono-Red-Flag-263x175.jpg');" href="https://www.thecheckeredflag.co.uk/2019/08/opinion-why-indycar-should-not-return-to-pocono-raceway/" title="OPINION: Why IndyCar should not return to Pocono Raceway"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.thecheckeredflag.co.uk/2019/08/opinion-why-indycar-should-not-return-to-pocono-raceway/" rel="bookmark" title="OPINION: Why IndyCar should not return to Pocono Raceway">
OPINION: Why IndyCar should not return to Pocono Raceway </a>
</h4>
<span class="side-item-meta"><time class="entry-date published" datetime="2019-08-19T20:00:58+01:00">August 19, 2019</time></span>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder small-fix-size" rel="bookmark" style="background-image: url('https://www.thecheckeredflag.co.uk/wp-content/uploads/2019/08/Top3-263x175.jpg');" href="https://www.thecheckeredflag.co.uk/2019/08/2018-19-formula-e-driver-rankings-part-two/" title="2018-19 FORMULA E DRIVER RANKINGS: PART TWO"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.thecheckeredflag.co.uk/2019/08/2018-19-formula-e-driver-rankings-part-two/" rel="bookmark" title="2018-19 FORMULA E DRIVER RANKINGS: PART TWO">
2018-19 FORMULA E DRIVER RANKINGS: PART TWO </a>
</h4>
<span class="side-item-meta"><time class="entry-date published" datetime="2019-08-15T15:38:22+01:00">August 15, 2019</time></span>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder small-fix-size" rel="bookmark" style="background-image: url('https://www.thecheckeredflag.co.uk/wp-content/uploads/2019/08/Drivers2-263x175.jpg');" href="https://www.thecheckeredflag.co.uk/2019/08/2018-19-formula-e-driver-rankings-part-one/" title="2018-19 Formula E driver rankings: Part One"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.thecheckeredflag.co.uk/2019/08/2018-19-formula-e-driver-rankings-part-one/" rel="bookmark" title="2018-19 Formula E driver rankings: Part One">
2018-19 Formula E driver rankings: Part One </a>
</h4>
<span class="side-item-meta"><time class="entry-date published" datetime="2019-08-14T14:35:06+01:00">August 14, 2019</time></span>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder small-fix-size" rel="bookmark" style="background-image: url('https://www.thecheckeredflag.co.uk/wp-content/uploads/2019/08/BGT-DP-_-135-263x175.jpg');" href="https://www.thecheckeredflag.co.uk/2019/08/2019-silverstone-classic-rocking-n-racing/" title="2019 Silverstone Classic: Rocking &#8216;n&#8217; Racing"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.thecheckeredflag.co.uk/2019/08/2019-silverstone-classic-rocking-n-racing/" rel="bookmark" title="2019 Silverstone Classic: Rocking &#8216;n&#8217; Racing">
2019 Silverstone Classic: Rocking &#8216;n&#8217; Racing </a>
</h4>
<span class="side-item-meta"><time class="entry-date published" datetime="2019-08-14T11:32:08+01:00">August 14, 2019</time></span>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder small-fix-size" rel="bookmark" style="background-image: url('https://www.thecheckeredflag.co.uk/wp-content/uploads/2019/08/Jamie-Chadwick-W-Series-Champion-263x175.jpg');" href="https://www.thecheckeredflag.co.uk/2019/08/whats-next-for-jamie-chadwick-after-w-series-success/" title="What&#8217;s Next For Jamie Chadwick After W Series Success?"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.thecheckeredflag.co.uk/2019/08/whats-next-for-jamie-chadwick-after-w-series-success/" rel="bookmark" title="What&#8217;s Next For Jamie Chadwick After W Series Success?">
What&#8217;s Next For Jamie Chadwick After W Series Success? </a>
</h4>
<span class="side-item-meta"><time class="entry-date published" datetime="2019-08-14T09:00:18+01:00">August 14, 2019</time></span>
</div>
</div>
</li>
</ul>
</aside> </div>
</div>

</div>
<div class="clear-footer"></div>
<div class="footer-subscribe">
<aside id="mc4wp_form_widget-2" class="widget widget_mc4wp_form_widget"><script>(function() {
	if (!window.mc4wp) {
		window.mc4wp = {
			listeners: [],
			forms    : {
				on: function (event, callback) {
					window.mc4wp.listeners.push({
						event   : event,
						callback: callback
					});
				}
			}
		}
	}
})();
</script><form id="mc4wp-form-1" class="mc4wp-form mc4wp-form-293151" method="post" data-id="293151" data-name="TCF Daily Headlines to your Inbox"><div class="mc4wp-form-fields"><p class="mdes">Get the latest headlines from TCF in a daily roundup, straight to your inbox</p>
<p class="memail"><input type="email" id="mc4wp_email" name="EMAIL" placeholder="Email..." required /></p>
<p class="msubmit"><input type="submit" value="Subscribe" /></p></div><label style="display: none !important;">Leave this field empty if you're human: <input type="text" name="_mc4wp_honeypot" value="" tabindex="-1" autocomplete="off" /></label><input type="hidden" name="_mc4wp_timestamp" value="1566425490" /><input type="hidden" name="_mc4wp_form_id" value="293151" /><input type="hidden" name="_mc4wp_form_element_id" value="mc4wp-form-1" /><div class="mc4wp-response"></div></form></aside> </div>
<footer id="footer-section" class="penci-footer-social-media penci-lazy" itemscope itemtype="https://schema.org/WPFooter">
<div class="container">
<div class="footer-socials-section">
<ul class="footer-socials">
<li><a href="https://facebook.com/TheCheckeredFlag" rel="nofollow" target="_blank"><i class="fa fa-facebook"></i><span>Facebook</span></a></li>
<li><a href="https://twitter.com/TheCheckerFlag" rel="nofollow" target="_blank"><i class="fa fa-twitter"></i><span>Twitter</span></a></li>
<li><a href="https://instagram.com/thecheckeredflag/" rel="nofollow" target="_blank"><i class="fa fa-instagram"></i><span>Instagram</span></a></li>
<li><a href="https://www.linkedin.com/company/the-checkered-flag/" rel="nofollow" target="_blank"><i class="fa fa-linkedin"></i><span>Linkedin</span></a></li>
<li><a href="https://www.youtube.com/channel/UCueRVoGbSE4GF2RszehXIgw" rel="nofollow" target="_blank"><i class="fa fa-youtube-play"></i><span>Youtube</span></a></li>
<li><a href="https://www.thecheckeredflag.co.uk/feed" rel="nofollow" target="_blank"><i class="fa fa-rss"></i><span>RSS</span></a></li>
</ul>
</div>
<div class="footer-logo-copyright footer-not-logo">
<div id="footer-copyright">
<p><a href="https://www.thecheckeredflag.co.uk/contact/">Contact Us</a> | <a href="https://www.thecheckeredflag.co.uk/contribute/">Contribute</a> | <a href="https://www.thecheckeredflag.co.uk/about-us">About Us</a><br />
<a href="https://www.thecheckeredflag.co.uk/tcf-partners/">TCF Friends & Partners</a> | <a href="https://www.thecheckeredflag.co.uk/submitting-news/">Submitting News</a> | <a href="https://www.thecheckeredflag.co.uk/terms-and-conditions/">T & C</a> | <a href="https://www.thecheckeredflag.co.uk/privacy-policy/">Privacy Policy</a> | <a href="https://www.thecheckeredflag.co.uk/cookies-in-use-on-this-site/">Cookie Policy</a><br />
©Copyright MMXIX - The Checkered Flag - All Rights Reserved</p>
</div>
<div class="go-to-top-parent"><a href="#" class="go-to-top"><span><i class="fa fa-angle-up"></i><br>Back To Top</span></a></div>
</div>
</div>
</footer>
</div>
<div id="fb-root"></div>
<div class="penci-wrap-gprd-law penci-wrap-gprd-law-close penci-close-all">
<div class="penci-gprd-law">
<p>
This website uses cookies to improve your experience. We&#039;ll assume you&#039;re ok with this, but you can opt-out if you wish. <a class="penci-gprd-accept" href="#">Accept</a> <a class="penci-gprd-more" href="#">Read More</a> </p>
</div>
</div>

<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-MG875N"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<script>(function() {function addEventListener(element,event,handler) {
	if(element.addEventListener) {
		element.addEventListener(event,handler, false);
	} else if(element.attachEvent){
		element.attachEvent('on'+event,handler);
	}
}function maybePrefixUrlField() {
	if(this.value.trim() !== '' && this.value.indexOf('http') !== 0) {
		this.value = "http://" + this.value;
	}
}

var urlFields = document.querySelectorAll('.mc4wp-form input[type="url"]');
if( urlFields && urlFields.length > 0 ) {
	for( var j=0; j < urlFields.length; j++ ) {
		addEventListener(urlFields[j],'blur',maybePrefixUrlField);
	}
}/* test if browser supports date fields */
var testInput = document.createElement('input');
testInput.setAttribute('type', 'date');
if( testInput.type !== 'date') {

	/* add placeholder & pattern to all date fields */
	var dateFields = document.querySelectorAll('.mc4wp-form input[type="date"]');
	for(var i=0; i<dateFields.length; i++) {
		if(!dateFields[i].placeholder) {
			dateFields[i].placeholder = 'YYYY-MM-DD';
		}
		if(!dateFields[i].pattern) {
			dateFields[i].pattern = '[0-9]{4}-(0[1-9]|1[012])-(0[1-9]|1[0-9]|2[0-9]|3[01])';
		}
	}
}

})();</script><script type='text/javascript'>
/* <![CDATA[ */
var countVars = {"disqusShortname":"thecheckerdflag"};
/* ]]> */
</script>
<script type='text/javascript'>
/* <![CDATA[ */
var embedVars = {"disqusConfig":{"integration":"wordpress 3.0.17"},"disqusIdentifier":"318590 https:\/\/www.thecheckeredflag.co.uk\/?p=318590","disqusShortname":"thecheckerdflag","disqusTitle":"Ryan Sieg joins Premium Motorsports for Cup return at Indianapolis","disqusUrl":"https:\/\/www.thecheckeredflag.co.uk\/2019\/08\/ryan-sieg-joins-premium-motorsports-for-cup-return-at-indianapolis\/","postId":"318590"};
/* ]]> */
</script>
<script type='text/javascript'>
/* <![CDATA[ */
var ajax_var_more = {"url":"https:\/\/www.thecheckeredflag.co.uk\/wp-admin\/admin-ajax.php","nonce":"68c69b0547"};
/* ]]> */
</script>
<script type='text/javascript'>
/* <![CDATA[ */
var ajax_var = {"url":"https:\/\/www.thecheckeredflag.co.uk\/wp-admin\/admin-ajax.php","nonce":"68c69b0547"};
/* ]]> */
</script>
<script type='text/javascript'>
/* <![CDATA[ */
var SOLEDADLOCALIZE = {"url":"https:\/\/www.thecheckeredflag.co.uk\/wp-admin\/admin-ajax.php","nonce":"68c69b0547"};
/* ]]> */
</script>
<script type='text/javascript'>
/* <![CDATA[ */
var mc4wp_forms_config = [];
/* ]]> */
</script>
<!--[if lte IE 9]>
<script type='text/javascript' src='https://www.thecheckeredflag.co.uk/wp-content/plugins/mailchimp-for-wp/assets/js/third-party/placeholders.min.js?ver=4.5.3'></script>
<![endif]-->
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><script data-optimized='1' src='https://www.thecheckeredflag.co.uk/min/9a727.js'></script></body>
</html>
