<!DOCTYPE html>
<html lang="en-GB">
<head>
<meta charset="UTF-8"><link rel='stylesheet' id='wp-editor-font-css' href='https://fonts.googleapis.com/css?family=Noto+Serif%3A400%2C400i%2C700%2C700i&#038;ver=5.4.2' type='text/css' media='all' /><link rel='stylesheet' id='penci-fonts-css' href='//fonts.googleapis.com/css?family=Playfair+Display+SC%3A300%2C300italic%2C400%2C400italic%2C500%2C500italic%2C700%2C700italic%2C800%2C800italic%7CMontserrat%3A300%2C300italic%2C400%2C400italic%2C500%2C500italic%2C700%2C700italic%2C800%2C800italic%7CAnton%3A300%2C300italic%2C400%2C400italic%2C500%2C500italic%2C700%2C700italic%2C800%2C800italic%7CMerriweather%3A300%2C300italic%2C400%2C400italic%2C500%2C500italic%2C700%2C700italic%2C800%2C800italic%7CRoboto%3A300%2C300italic%2C400%2C400italic%2C500%2C500italic%2C700%2C700italic%2C800%2C800italic%26subset%3Dlatin%2Ccyrillic%2Ccyrillic-ext%2Cgreek%2Cgreek-ext%2Clatin-ext&#038;display=swap&#038;ver=1.0' type='text/css' media='all' /><link data-optimized="2" rel="stylesheet" href="https://www.thecheckeredflag.co.uk/wp-content/litespeed/cssjs/cdcb6.css" /><link data-optimized="2" rel="stylesheet" href="https://www.thecheckeredflag.co.uk/wp-content/litespeed/cssjs/b8851.css" /><script type='text/javascript' src='https://www.thecheckeredflag.co.uk/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script><script data-optimized="1" src="https://www.thecheckeredflag.co.uk/wp-content/litespeed/cssjs/a082b.js"></script>
<meta http-equiv="X-UA-Compatible" content="IE=edge">
<meta name="viewport" content="width=device-width, initial-scale=1">
<link rel="profile" href="https://gmpg.org/xfn/11" />
<link rel="shortcut icon" href="https://www.thecheckeredflag.co.uk/wp-content/uploads/2018/11/TCF-black.jpg" type="image/x-icon" />
<link rel="apple-touch-icon" sizes="180x180" href="https://www.thecheckeredflag.co.uk/wp-content/uploads/2018/11/TCF-black.jpg">
<link rel="alternate" type="application/rss+xml" title="The Checkered Flag RSS Feed" href="https://www.thecheckeredflag.co.uk/feed/" />
<link rel="alternate" type="application/atom+xml" title="The Checkered Flag Atom Feed" href="https://www.thecheckeredflag.co.uk/feed/atom/" />
<link rel="pingback" href="https://www.thecheckeredflag.co.uk/xmlrpc.php" />
<!--[if lt IE 9]>
	<script src="https://www.thecheckeredflag.co.uk/wp-content/themes/soledad/js/html5.js"></script>
	<![endif]-->

<script data-cfasync="false" data-pagespeed-no-defer>//<![CDATA[
	var gtm4wp_datalayer_name = "dataLayer";
	var dataLayer = dataLayer || [];
//]]>
</script>


<title>Rick Ware Racing Joining with James Davison for Indy 500 Entry - The Checkered Flag</title>
<meta name="description" content="Rick Ware Racing and James Davison are teaming up for another NASCAR and IndyCar crossover at the Indy 500, adding to a hectic month of August for Davison and RWR." />
<meta name="robots" content="index, follow" />
<meta name="googlebot" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
<meta name="bingbot" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
<link rel="canonical" href="https://www.thecheckeredflag.co.uk/2020/08/rick-ware-racing-joining-with-james-davison-for-indy-500-entry/" />
<meta property="og:locale" content="en_GB" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Rick Ware Racing Joining with James Davison for Indy 500 Entry - The Checkered Flag" />
<meta property="og:description" content="Rick Ware Racing and James Davison are teaming up for another NASCAR and IndyCar crossover at the Indy 500, adding to a hectic month of August for Davison and RWR." />
<meta property="og:url" content="https://www.thecheckeredflag.co.uk/2020/08/rick-ware-racing-joining-with-james-davison-for-indy-500-entry/" />
<meta property="og:site_name" content="The Checkered Flag" />
<meta property="article:publisher" content="http://www.facebook.com/TheCheckeredFlag" />
<meta property="article:published_time" content="2020-08-06T17:19:54+00:00" />
<meta property="article:modified_time" content="2020-08-06T17:20:17+00:00" />
<meta property="og:image" content="https://www.thecheckeredflag.co.uk/wp-content/uploads/2020/08/James_Davison.jpg" />
<meta property="og:image:width" content="800" />
<meta property="og:image:height" content="532" />
<meta property="fb:app_id" content="135274436510698" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:creator" content="@GSchmoyer55" />
<meta name="twitter:site" content="@thecheckerflag" />
<script type="application/ld+json" class="yoast-schema-graph">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</script>

<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="The Checkered Flag &raquo; Feed" href="https://www.thecheckeredflag.co.uk/feed/" />
<link rel="alternate" type="application/rss+xml" title="The Checkered Flag &raquo; Comments Feed" href="https://www.thecheckeredflag.co.uk/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="The Checkered Flag &raquo; Rick Ware Racing Joining with James Davison for Indy 500 Entry Comments Feed" href="https://www.thecheckeredflag.co.uk/2020/08/rick-ware-racing-joining-with-james-davison-for-indy-500-entry/feed/" />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.thecheckeredflag.co.uk/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.thecheckeredflag.co.uk/wp-includes/wlwmanifest.xml" />
<meta name="generator" content="WordPress 5.4.2" />
<link rel='shortlink' href='https://www.thecheckeredflag.co.uk/?p=344498' />
<link rel="alternate" type="application/json+oembed" href="https://www.thecheckeredflag.co.uk/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.thecheckeredflag.co.uk%2F2020%2F08%2Frick-ware-racing-joining-with-james-davison-for-indy-500-entry%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.thecheckeredflag.co.uk/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.thecheckeredflag.co.uk%2F2020%2F08%2Frick-ware-racing-joining-with-james-davison-for-indy-500-entry%2F&#038;format=xml" />

<script data-cfasync="false" data-pagespeed-no-defer>//<![CDATA[
	var dataLayer_content = {"pageTitle":"Rick Ware Racing Joining with James Davison for Indy 500 Entry - The Checkered Flag","pageCategory":["indycar","nascar","sprint-cup"],"pageAttributes":["dale-coyne-racing","indianapolis-500","james-davison","rick-ware-racing"],"pagePostAuthor":"Griffin Schmoyer"};
	dataLayer.push( dataLayer_content );//]]>
</script>
<script data-cfasync="false">//<![CDATA[
(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'//www.googletagmanager.com/gtm.'+'js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-MG875N');//]]>
</script>

<style type="text/css">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</style><script>
var penciBlocksArray=[];
var portfolioDataJs = portfolioDataJs || [];var PENCILOCALCACHE = {};
		(function () {
				"use strict";
		
				PENCILOCALCACHE = {
					data: {},
					remove: function ( ajaxFilterItem ) {
						delete PENCILOCALCACHE.data[ajaxFilterItem];
					},
					exist: function ( ajaxFilterItem ) {
						return PENCILOCALCACHE.data.hasOwnProperty( ajaxFilterItem ) && PENCILOCALCACHE.data[ajaxFilterItem] !== null;
					},
					get: function ( ajaxFilterItem ) {
						return PENCILOCALCACHE.data[ajaxFilterItem];
					},
					set: function ( ajaxFilterItem, cachedData ) {
						PENCILOCALCACHE.remove( ajaxFilterItem );
						PENCILOCALCACHE.data[ajaxFilterItem] = cachedData;
					}
				};
			}
		)();function penciBlock() {
		    this.atts_json = '';
		    this.content = '';
		}</script>
<script type="application/ld+json">{
    "@context": "https:\/\/schema.org\/",
    "@type": "organization",
    "@id": "#organization",
    "logo": {
        "@type": "ImageObject",
        "url": "https:\/\/www.thecheckeredflag.co.uk\/wp-content\/uploads\/2019\/08\/TCF-Square.jpg"
    },
    "url": "https:\/\/www.thecheckeredflag.co.uk\/",
    "name": "The Checkered Flag",
    "description": "Independent motor sport news since 2009"
}</script><script type="application/ld+json">{
    "@context": "https:\/\/schema.org\/",
    "@type": "WebSite",
    "name": "The Checkered Flag",
    "alternateName": "Independent motor sport news since 2009",
    "url": "https:\/\/www.thecheckeredflag.co.uk\/"
}</script><script type="application/ld+json">{
    "@context": "https:\/\/schema.org\/",
    "@type": "BlogPosting",
    "headline": "Rick Ware Racing Joining with James Davison for Indy 500 Entry",
    "description": "Rick Ware Racing and James Davison are teaming up for another NASCAR and IndyCar crossover at the Indy 500, adding to a hectic month of August for Davison and RWR.",
    "datePublished": "2020-08-06",
    "datemodified": "2020-08-06",
    "mainEntityOfPage": "https:\/\/www.thecheckeredflag.co.uk\/2020\/08\/rick-ware-racing-joining-with-james-davison-for-indy-500-entry\/",
    "image": {
        "@type": "ImageObject",
        "url": "https:\/\/www.thecheckeredflag.co.uk\/wp-content\/uploads\/2020\/08\/James_Davison.jpg",
        "width": 800,
        "height": 532
    },
    "publisher": {
        "@type": "Organization",
        "name": "The Checkered Flag",
        "logo": {
            "@type": "ImageObject",
            "url": "https:\/\/www.thecheckeredflag.co.uk\/wp-content\/uploads\/2019\/08\/TCF-Square.jpg"
        }
    },
    "author": {
        "@type": "Person",
        "@id": "#person-GriffinSchmoyer",
        "name": "Griffin Schmoyer"
    }
}</script><script type="application/ld+json">{
    "@context": "https:\/\/schema.org",
    "@type": "NewsArticle",
    "headline": "Rick Ware Racing Joining with James Davison for Indy 500 Entry",
    "image": "https:\/\/www.thecheckeredflag.co.uk\/wp-content\/uploads\/2020\/08\/James_Davison.jpg",
    "datePublished": "2020-08-06",
    "datemodified": "2020-08-06",
    "description": "Rick Ware Racing and James Davison are teaming up for another NASCAR and IndyCar crossover at the Indy 500, adding to a hectic month of August for Davison and RWR.",
    "mainEntityOfPage": "https:\/\/www.thecheckeredflag.co.uk\/2020\/08\/rick-ware-racing-joining-with-james-davison-for-indy-500-entry\/",
    "publisher": {
        "@type": "Organization",
        "name": "The Checkered Flag",
        "logo": {
            "@type": "ImageObject",
            "url": "https:\/\/www.thecheckeredflag.co.uk\/wp-content\/uploads\/2019\/08\/TCF-Square.jpg"
        }
    },
    "author": {
        "@type": "Person",
        "name": "Griffin Schmoyer"
    }
}</script><link rel="amphtml" href="https://www.thecheckeredflag.co.uk/amp/2020/08/rick-ware-racing-joining-with-james-davison-for-indy-500-entry/" /><link rel="icon" href="https://www.thecheckeredflag.co.uk/wp-content/uploads/2016/02/cropped-TCF-32x32.png" sizes="32x32" />
<link rel="icon" href="https://www.thecheckeredflag.co.uk/wp-content/uploads/2016/02/cropped-TCF-200x200.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://www.thecheckeredflag.co.uk/wp-content/uploads/2016/02/cropped-TCF-200x200.png" />
<meta name="msapplication-TileImage" content="https://www.thecheckeredflag.co.uk/wp-content/uploads/2016/02/cropped-TCF-500x500.png" />
</head>
<body data-rsssl=1 class="post-template-default single single-post postid-344498 single-format-standard">
<a id="close-sidebar-nav" class="header-5"><i class="penci-faicon fa fa-close"></i></a>
<nav id="sidebar-nav" class="header-5" role="navigation" itemscope itemtype="https://schema.org/SiteNavigationElement">
<div id="sidebar-nav-logo">
<a href="https://www.thecheckeredflag.co.uk/"><img src="https://www.thecheckeredflag.co.uk/wp-content/uploads/2018/11/TCF-black.jpg" alt="The Checkered Flag" /></a>
</div>
<div class="header-social sidebar-nav-social">
<div class="inner-header-social">
<a href="https://facebook.com/TheCheckeredFlag" rel="nofollow" target="_blank"><i class="penci-faicon fa fa-facebook"></i></a>
<a href="https://twitter.com/TheCheckerFlag" rel="nofollow" target="_blank"><i class="penci-faicon fa fa-twitter"></i></a>
<a href="https://instagram.com/thecheckeredflag/" rel="nofollow" target="_blank"><i class="penci-faicon fa fa-instagram"></i></a>
<a href="https://www.linkedin.com/company/thecheckeredflag/" rel="nofollow" target="_blank"><i class="penci-faicon fa fa-linkedin"></i></a>
<a href="https://www.youtube.com/channel/UCueRVoGbSE4GF2RszehXIgw" rel="nofollow" target="_blank"><i class="penci-faicon fa fa-youtube-play"></i></a>
<a href="https://www.thecheckeredflag.co.uk/feed" rel="nofollow" target="_blank"><i class="penci-faicon fa fa-rss"></i></a>
</div> </div>
<ul id="menu-2015" class="menu"><li id="menu-item-131887" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131887"><a href="https://www.thecheckeredflag.co.uk/formula-1/">F1</a></li>
<li id="menu-item-131940" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor menu-item-has-children menu-item-131940"><a href="https://www.thecheckeredflag.co.uk/open-wheel/">Open Wheel</a>
<ul class="sub-menu">
<li id="menu-item-131942" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131942"><a href="https://www.thecheckeredflag.co.uk/open-wheel/formula-e/">FIA Formula E</a></li>
<li id="menu-item-131943" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-131943"><a href="https://www.thecheckeredflag.co.uk/open-wheel/indycar/">IndyCar</a></li>
<li id="menu-item-333871" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-333871"><a href="https://www.thecheckeredflag.co.uk/open-wheel/fia-formula-2-championship/">FIA Formula 2</a></li>
<li id="menu-item-296601" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-296601"><a href="https://www.thecheckeredflag.co.uk/open-wheel/formula-3/fia-formula-3-championship/">FIA Formula 3</a></li>
<li id="menu-item-335473" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-335473"><a href="https://www.thecheckeredflag.co.uk/open-wheel/super-formula/">Super Formula</a></li>
<li id="menu-item-321059" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-321059"><a href="https://www.thecheckeredflag.co.uk/open-wheel/w-series/">W Series</a></li>
<li id="menu-item-180961" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-180961"><a href="https://www.thecheckeredflag.co.uk/open-wheel/formula-3/british-f3-formula-3/">British F3</a></li>
<li id="menu-item-131897" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131897"><a href="https://www.thecheckeredflag.co.uk/open-wheel/msa-formula/">F4 British Championship</a></li>
<li id="menu-item-131946" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131946"><a href="https://www.thecheckeredflag.co.uk/open-wheel/formula-3/euroformula-open/">EuroFormula Open</a></li>
<li id="menu-item-330918" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-330918"><a href="https://www.thecheckeredflag.co.uk/open-wheel/formula-renault-eurocup/">Formula Renault Eurocup</a></li>
<li id="menu-item-330987" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-330987"><a href="https://www.thecheckeredflag.co.uk/open-wheel/formula-3/formula-regional-european-championship/">Formula Regional European Championship</a></li>
</ul>
</li>
<li id="menu-item-131952" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-131952"><a href="https://www.thecheckeredflag.co.uk/sportscars/">Sportscars</a>
<ul class="sub-menu">
<li id="menu-item-131956" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131956"><a href="https://www.thecheckeredflag.co.uk/sportscars/endurance/fiawec/">FIA WEC</a></li>
<li id="menu-item-131957" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131957"><a href="https://www.thecheckeredflag.co.uk/sportscars/endurance/blancpain-endurance-series/">GT World Challenge Europe Endurance Cup</a></li>
<li id="menu-item-148232" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-148232"><a href="https://www.thecheckeredflag.co.uk/sportscars/endurance/blancpain-sprint/">GT World Challenge Europe</a></li>
<li id="menu-item-131954" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131954"><a href="https://www.thecheckeredflag.co.uk/sportscars/gt-sportscars/british-gt/">British GT</a></li>
<li id="menu-item-290801" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-290801"><a href="https://www.thecheckeredflag.co.uk/sportscars/ginetta/">Ginetta Series</a></li>
<li id="menu-item-303742" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-303742"><a href="https://www.thecheckeredflag.co.uk/sportscars/porsche/">Porsche Series</a></li>
</ul>
</li>
<li id="menu-item-131899" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-131899"><a href="https://www.thecheckeredflag.co.uk/touring-cars/">Touring Cars</a>
<ul class="sub-menu">
<li id="menu-item-131904" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131904"><a href="https://www.thecheckeredflag.co.uk/touring-cars/btcc/">BTCC</a></li>
<li id="menu-item-192543" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-192543"><a href="https://www.thecheckeredflag.co.uk/touring-cars/dtm/">DTM</a></li>
<li id="menu-item-317944" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-317944"><a href="https://www.thecheckeredflag.co.uk/touring-cars/jaguar-i-pace-etrophy/">Jaguar I-PACE eTROPHY</a></li>
</ul>
</li>
<li id="menu-item-131918" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-131918"><a href="https://www.thecheckeredflag.co.uk/motorcycles/">Motorcycles</a>
<ul class="sub-menu">
<li id="menu-item-131922" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131922"><a href="https://www.thecheckeredflag.co.uk/motorcycles/motogp/">MotoGP</a></li>
<li id="menu-item-131920" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131920"><a href="https://www.thecheckeredflag.co.uk/motorcycles/moto2/">Moto2</a></li>
<li id="menu-item-131921" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131921"><a href="https://www.thecheckeredflag.co.uk/motorcycles/moto3/">Moto3</a></li>
</ul>
</li>
<li id="menu-item-290798" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-290798"><a href="https://www.thecheckeredflag.co.uk/offroad/">Off Road</a>
<ul class="sub-menu">
<li id="menu-item-254211" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-254211"><a href="https://www.thecheckeredflag.co.uk/offroad/rally/fiawrc/">FIA WRC</a></li>
<li id="menu-item-138301" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-138301"><a href="https://www.thecheckeredflag.co.uk/offroad/rally/fia-erc/">FIA ERC</a></li>
<li id="menu-item-131910" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131910"><a href="https://www.thecheckeredflag.co.uk/offroad/rally/british-rally-championship/">British Rally Championship</a></li>
<li id="menu-item-131917" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131917"><a href="https://www.thecheckeredflag.co.uk/offroad/rallycross/world-rallycross/">FIA World RX</a></li>
<li id="menu-item-131913" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131913"><a href="https://www.thecheckeredflag.co.uk/offroad/rallycross/european-rallycross/">FIA European RX</a></li>
<li id="menu-item-330919" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-330919"><a href="https://www.thecheckeredflag.co.uk/offroad/rallycross/british-rallycross/">British Rallycross</a></li>
<li id="menu-item-332829" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-332829"><a href="https://www.thecheckeredflag.co.uk/offroad/rallycross/rallyx-nordic/">RallyX Nordic</a></li>
</ul>
</li>
<li id="menu-item-290800" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-290800"><a href="https://www.thecheckeredflag.co.uk/nascar/">NASCAR</a></li>
<li id="menu-item-293110" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-293110"><a href="https://www.thecheckeredflag.co.uk/features/">Features</a>
<ul class="sub-menu">
<li id="menu-item-330921" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-330921"><a href="https://www.thecheckeredflag.co.uk/tcf-blogs/">TCF Blogs</a></li>
<li id="menu-item-293115" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-293115"><a href="https://www.thecheckeredflag.co.uk/features/opinion/">Opinion</a></li>
<li id="menu-item-293113" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-293113"><a href="https://www.thecheckeredflag.co.uk/features/interviews/">Interviews</a></li>
<li id="menu-item-293114" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-293114"><a href="https://www.thecheckeredflag.co.uk/features/gallery/">Gallery</a></li>
<li id="menu-item-293111" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-293111"><a href="https://www.thecheckeredflag.co.uk/features/product-review/">Product Review</a></li>
<li id="menu-item-293112" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-293112"><a href="https://www.thecheckeredflag.co.uk/features/season-review/">Season Review</a></li>
<li id="menu-item-293118" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-293118"><a href="https://www.thecheckeredflag.co.uk/other/esports/">eSports</a></li>
<li id="menu-item-293117" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-293117"><a href="https://www.thecheckeredflag.co.uk/other/video-games/">Sim Racing</a></li>
</ul>
</li>
</ul> </nav>
<div class="wrapper-boxed header-style-header-5 penci-hlogo-center">
<div class="penci-header-wrap"><div class="penci-top-bar">
<div class="container">
<div class="penci-headline" role="navigation" itemscope itemtype="https://schema.org/SiteNavigationElement">
<span class="headline-title">Latest</span>
<div class="penci-topbar-social">
<div class="inner-header-social">
<a href="https://facebook.com/TheCheckeredFlag" rel="nofollow" target="_blank"><i class="penci-faicon fa fa-facebook"></i></a>
<a href="https://twitter.com/TheCheckerFlag" rel="nofollow" target="_blank"><i class="penci-faicon fa fa-twitter"></i></a>
<a href="https://instagram.com/thecheckeredflag/" rel="nofollow" target="_blank"><i class="penci-faicon fa fa-instagram"></i></a>
<a href="https://www.linkedin.com/company/thecheckeredflag/" rel="nofollow" target="_blank"><i class="penci-faicon fa fa-linkedin"></i></a>
<a href="https://www.youtube.com/channel/UCueRVoGbSE4GF2RszehXIgw" rel="nofollow" target="_blank"><i class="penci-faicon fa fa-youtube-play"></i></a>
<a href="https://www.thecheckeredflag.co.uk/feed" rel="nofollow" target="_blank"><i class="penci-faicon fa fa-rss"></i></a>
</div> </div>
<div class="penci-owl-carousel penci-owl-carousel-slider penci-headline-posts" data-auto="true" data-autotime="3000" data-speed="200">
<div>
<a class="penci-topbar-post-title" href="https://www.thecheckeredflag.co.uk/2020/08/2020-nascar-playoff-schedules-finalised/">2020 NASCAR playoff schedules finalised</a>
</div>
<div>
<a class="penci-topbar-post-title" href="https://www.thecheckeredflag.co.uk/2020/08/rick-ware-racing-joining-with-james-davison-for-indy-500-entry/">Rick Ware Racing Joining with James Davison for Indy 500 Entry</a>
</div>
<div>
<a class="penci-topbar-post-title" href="https://www.thecheckeredflag.co.uk/2020/08/prema-powerteam-trio-take-victories-in-frec-opener-at-misano/">Prema Powerteam Trio Take Victories in FREC Opener at Misano</a>
</div>
<div>
<a class="penci-topbar-post-title" href="https://www.thecheckeredflag.co.uk/2020/08/da-costa-dominates-qualifying-again-in-berlin/">Da Costa dominates qualifying again in Berlin</a>
</div>
<div>
<a class="penci-topbar-post-title" href="https://www.thecheckeredflag.co.uk/2020/08/bottas-to-race-with-mercedes-until-at-least-the-end-of-2021/">Bottas to race with Mercedes until at least the end of 2021</a>
</div>
<div>
<a class="penci-topbar-post-title" href="https://www.thecheckeredflag.co.uk/2020/08/block-back-in-rallycross-with-projekt-e/">Block Back in Rallycross with Projekt E</a>
</div>
<div>
<a class="penci-topbar-post-title" href="https://www.thecheckeredflag.co.uk/2020/08/barry-boes-third-confirmed-sst-newcomer-for-road-america/">Barry Boes third confirmed SST newcomer for Road America</a>
</div>
<div>
<a class="penci-topbar-post-title" href="https://www.thecheckeredflag.co.uk/2020/08/preview-rallyx-nordic-arvika-home-hero-hero-kristoffersson-aims-for-two-in-a-row/">PREVIEW: RallyX Nordic: Arvika &#8211; Home Hero Kristoffersson Aims For Two in a Row</a>
</div>
<div>
<a class="penci-topbar-post-title" href="https://www.thecheckeredflag.co.uk/2020/08/felix-da-costa-wins-on-formula-e-return-in-berlin-to-extend-championship-lead/">Felix Da Costa wins on Formula E return in Berlin to extend championship lead</a>
</div>
<div>
<a class="penci-topbar-post-title" href="https://www.thecheckeredflag.co.uk/2020/08/toto-wolff-hopes-to-avoid-tyre-trouble-this-weekend-after-bitter-sweet-british-grand-prix/">Toto Wolff Hopes to Avoid Tyre Trouble This Weekend After &#8220;Bitter-Sweet&#8221; British Grand Prix</a>
</div>
</div>
</div>
</div>
</div><header id="header" class="header-header-5 has-bottom-line" itemscope="itemscope" itemtype="https://schema.org/WPHeader">
<div class="inner-header penci-header-second">
<div class="container container-fullwidth">
<div id="logo">
<a href="https://www.thecheckeredflag.co.uk/"><img src="https://www.thecheckeredflag.co.uk/wp-content/uploads/2019/10/TCF-Header-2019.png" alt="The Checkered Flag" /></a> </div>
</div>
</div>
<nav id="navigation" class="header-layout-bottom header-5 menu-style-2 menu-item-padding" role="navigation" itemscope itemtype="https://schema.org/SiteNavigationElement">
<div class="container container-fullwidth">
<div class="button-menu-mobile header-5"><i class="penci-faicon fa fa-bars"></i></div>
<ul id="menu-2016" class="menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131887"><a href="https://www.thecheckeredflag.co.uk/formula-1/">F1</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor menu-item-has-children menu-item-131940"><a href="https://www.thecheckeredflag.co.uk/open-wheel/">Open Wheel</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131942"><a href="https://www.thecheckeredflag.co.uk/open-wheel/formula-e/">FIA Formula E</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-131943"><a href="https://www.thecheckeredflag.co.uk/open-wheel/indycar/">IndyCar</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-333871"><a href="https://www.thecheckeredflag.co.uk/open-wheel/fia-formula-2-championship/">FIA Formula 2</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-296601"><a href="https://www.thecheckeredflag.co.uk/open-wheel/formula-3/fia-formula-3-championship/">FIA Formula 3</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-335473"><a href="https://www.thecheckeredflag.co.uk/open-wheel/super-formula/">Super Formula</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-321059"><a href="https://www.thecheckeredflag.co.uk/open-wheel/w-series/">W Series</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-180961"><a href="https://www.thecheckeredflag.co.uk/open-wheel/formula-3/british-f3-formula-3/">British F3</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131897"><a href="https://www.thecheckeredflag.co.uk/open-wheel/msa-formula/">F4 British Championship</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131946"><a href="https://www.thecheckeredflag.co.uk/open-wheel/formula-3/euroformula-open/">EuroFormula Open</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-330918"><a href="https://www.thecheckeredflag.co.uk/open-wheel/formula-renault-eurocup/">Formula Renault Eurocup</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-330987"><a href="https://www.thecheckeredflag.co.uk/open-wheel/formula-3/formula-regional-european-championship/">Formula Regional European Championship</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-131952"><a href="https://www.thecheckeredflag.co.uk/sportscars/">Sportscars</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131956"><a href="https://www.thecheckeredflag.co.uk/sportscars/endurance/fiawec/">FIA WEC</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131957"><a href="https://www.thecheckeredflag.co.uk/sportscars/endurance/blancpain-endurance-series/">GT World Challenge Europe Endurance Cup</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-148232"><a href="https://www.thecheckeredflag.co.uk/sportscars/endurance/blancpain-sprint/">GT World Challenge Europe</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131954"><a href="https://www.thecheckeredflag.co.uk/sportscars/gt-sportscars/british-gt/">British GT</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-290801"><a href="https://www.thecheckeredflag.co.uk/sportscars/ginetta/">Ginetta Series</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-303742"><a href="https://www.thecheckeredflag.co.uk/sportscars/porsche/">Porsche Series</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-131899"><a href="https://www.thecheckeredflag.co.uk/touring-cars/">Touring Cars</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131904"><a href="https://www.thecheckeredflag.co.uk/touring-cars/btcc/">BTCC</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-192543"><a href="https://www.thecheckeredflag.co.uk/touring-cars/dtm/">DTM</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-317944"><a href="https://www.thecheckeredflag.co.uk/touring-cars/jaguar-i-pace-etrophy/">Jaguar I-PACE eTROPHY</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-131918"><a href="https://www.thecheckeredflag.co.uk/motorcycles/">Motorcycles</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131922"><a href="https://www.thecheckeredflag.co.uk/motorcycles/motogp/">MotoGP</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131920"><a href="https://www.thecheckeredflag.co.uk/motorcycles/moto2/">Moto2</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131921"><a href="https://www.thecheckeredflag.co.uk/motorcycles/moto3/">Moto3</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-290798"><a href="https://www.thecheckeredflag.co.uk/offroad/">Off Road</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-254211"><a href="https://www.thecheckeredflag.co.uk/offroad/rally/fiawrc/">FIA WRC</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-138301"><a href="https://www.thecheckeredflag.co.uk/offroad/rally/fia-erc/">FIA ERC</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131910"><a href="https://www.thecheckeredflag.co.uk/offroad/rally/british-rally-championship/">British Rally Championship</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131917"><a href="https://www.thecheckeredflag.co.uk/offroad/rallycross/world-rallycross/">FIA World RX</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131913"><a href="https://www.thecheckeredflag.co.uk/offroad/rallycross/european-rallycross/">FIA European RX</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-330919"><a href="https://www.thecheckeredflag.co.uk/offroad/rallycross/british-rallycross/">British Rallycross</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-332829"><a href="https://www.thecheckeredflag.co.uk/offroad/rallycross/rallyx-nordic/">RallyX Nordic</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-290800"><a href="https://www.thecheckeredflag.co.uk/nascar/">NASCAR</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-293110"><a href="https://www.thecheckeredflag.co.uk/features/">Features</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-330921"><a href="https://www.thecheckeredflag.co.uk/tcf-blogs/">TCF Blogs</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-293115"><a href="https://www.thecheckeredflag.co.uk/features/opinion/">Opinion</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-293113"><a href="https://www.thecheckeredflag.co.uk/features/interviews/">Interviews</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-293114"><a href="https://www.thecheckeredflag.co.uk/features/gallery/">Gallery</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-293111"><a href="https://www.thecheckeredflag.co.uk/features/product-review/">Product Review</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-293112"><a href="https://www.thecheckeredflag.co.uk/features/season-review/">Season Review</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-293118"><a href="https://www.thecheckeredflag.co.uk/other/esports/">eSports</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-293117"><a href="https://www.thecheckeredflag.co.uk/other/video-games/">Sim Racing</a></li>
</ul>
</li>
</ul>
<div id="top-search" class="dfdf">
<a class="search-click"><i class="penci-faicon fa fa-search"></i></a>
<div class="show-search">
<form role="search" method="get" id="searchform" action="https://www.thecheckeredflag.co.uk/">
<div>
<input type="text" class="search-input" placeholder="Type and hit enter..." name="s" id="s" />
</div>
</form> <a class="search-click close-search"><i class="penci-faicon fa fa-close"></i></a>
</div>
</div> </div>
</nav>
</header>
</div>
<div class="container container-single container-single-magazine penci_sidebar right-sidebar penci-enable-lightbox">
<div id="main">
<div class="theiaStickySidebar">
<article id="post-344498" class="post type-post status-publish">
<div class="header-standard header-classic single-header">
<div class="penci-standard-cat"><span class="cat"><a class="penci-cat-name penci-cat-133" href="https://www.thecheckeredflag.co.uk/open-wheel/indycar/" rel="category tag">IndyCar</a><a class="penci-cat-name penci-cat-108" href="https://www.thecheckeredflag.co.uk/nascar/" rel="category tag">NASCAR</a><a class="penci-cat-name penci-cat-2741" href="https://www.thecheckeredflag.co.uk/nascar/sprint-cup/" rel="category tag">NASCAR Cup Series</a></span></div>
<h1 class="post-title single-post-title entry-title">Rick Ware Racing Joining with James Davison for Indy 500 Entry</h1>
<div class="penci-hide-tagupdated">
<span class="author-italic author vcard">by <a class="url fn n" href="https://www.thecheckeredflag.co.uk/author/gschmoyer/">Griffin Schmoyer</a></span>
<time class="entry-date published" datetime="2020-08-06T18:19:54+01:00">August 6, 2020</time> </div>
<div class="post-box-meta-single">
<span class="author-post byline"><span class="author vcard">written by <a class="author-url url fn n" href="https://www.thecheckeredflag.co.uk/author/gschmoyer/">Griffin Schmoyer</a></span></span>
<span><time class="entry-date published" datetime="2020-08-06T18:19:54+01:00">August 6, 2020</time></span>
</div>
</div>
<div class="post-image">
<a href="https://www.thecheckeredflag.co.uk/wp-content/uploads/2020/08/James_Davison.jpg" data-rel="penci-gallery-image-content"> <img width="800" height="532" src="https://www.thecheckeredflag.co.uk/wp-content/uploads/2020/08/James_Davison.jpg" class="attachment-penci-full-thumb size-penci-full-thumb wp-post-image" alt="" srcset="https://www.thecheckeredflag.co.uk/wp-content/uploads/2020/08/James_Davison.jpg 800w, https://www.thecheckeredflag.co.uk/wp-content/uploads/2020/08/James_Davison-240x160.jpg 240w, https://www.thecheckeredflag.co.uk/wp-content/uploads/2020/08/James_Davison-768x511.jpg 768w, https://www.thecheckeredflag.co.uk/wp-content/uploads/2020/08/James_Davison-585x389.jpg 585w, https://www.thecheckeredflag.co.uk/wp-content/uploads/2020/08/James_Davison-263x175.jpg 263w" sizes="(max-width: 800px) 100vw, 800px" /> </a><div class="penci-featured-caption">Photo Credit: Chris Owens / Courtesy of IndyCar</div> </div>
<div class="post-entry blockquote-style-1">
<div class="inner-post-entry entry-content" id="penci-post-entry-inner">
<p>In another surprising <strong>IndyCar</strong> and <strong>NASCAR</strong> crossover,<strong> Rick Ware Racing</strong> and driver <strong>James Davison</strong> will be entering this year’s <strong>Indianapolis 500</strong>, as well as three other NASCAR events.</p>
<p>Davison will pilot the #51 Dallara Honda with sponsorship from Jacobs Construction for the race as an entry with <strong>Dale Coyne Racing</strong> and RWR. He joins former <strong>NASCAR Cup Series</strong> crew chief <strong>Cole Pearn</strong> as another NASCAR tie on this year’s grid.</p>
<p><em>“This is a bucket list item that is huge for me personally,”</em> Ware said<a href="https://motorsports.nbcsports.com/2020/08/06/rick-ware-racing-james-davison-indycar-nascar-indy-500-entry/"> in an interview with NBC Sports</a>. </p>
<p><em>“I’ve actually never even been to the Indianapolis 500. Throughout my whole career, I’ve always been somewhere racing on Memorial Day (weekend).</em></p>
<p><em>“I’m ecstatic about even being able to be there and be able to participate has been a huge dream of mine.”</em></p>
<p>The month of August will be an audacious one for Davison and Ware as they will be running plenty of Cup Series events as well.&nbsp;</p>
<p>Davison will be running the two Cup races at <strong>Michigan International Raceway</strong> this weekend before flying back to Indianapolis to start three days of practice on 12 August, and to qualify for the 500 on 15 August. Davison will then fly to <strong>Daytona International Speedway</strong> to run the road course on 16 August, and will return on Friday 21 August for Carb Day practice and of course the 500 that Sunday. After that, he will make one last trip to Daytona to run the <strong>Coke Zero 400 </strong>on 29 August. </p>
<p><em>“Being a smaller team, we’ve had just a lot of interest and a lot of excitement about doing something so unique,”</em> said Ware.&nbsp;</p>
<p><em>“It’s just a really cool deal. People just got excited about the value add as a race team. I’ll be doing a lot of traveling back and forth, but we’re still focusing on (NASCAR). We’ve had multiple top 30s with several of our cars the last several races in Cup.</em></p>
<p><em>“We’re making baby steps. So we’re improving, and our sponsors there are really happy. (The Indy 500) is not a diversion. It’s really a value add. So we’ll do whatever we can to make this happen. It’s going to be a lot of miles driven.”</em></p>
<p>Ware will not be at the track for the 500 itself due to commitments with NASCAR at <strong>Dover International Speedway</strong> that weekend, but hopes to attend some practices and qualifying with the team. </p>
<p>Davison has seven starts to his name in the <strong>NTT IndyCar Series</strong> and will be attempting his sixth Indy 500, finishing a career-best 12th in last year’s race. He went on to finish thirtieth his first Cup race with RWR last Sunday at <strong>New Hampshire Motor Speedway</strong>.</p>
<div class="penci-single-link-pages">
</div>
<div class="post-tags">
<a href="https://www.thecheckeredflag.co.uk/tag/dale-coyne-racing/" rel="tag">Dale Coyne Racing</a><a href="https://www.thecheckeredflag.co.uk/tag/indianapolis-500/" rel="tag">Indianapolis 500</a><a href="https://www.thecheckeredflag.co.uk/tag/james-davison/" rel="tag">James Davison</a><a href="https://www.thecheckeredflag.co.uk/tag/rick-ware-racing/" rel="tag">Rick Ware Racing</a> </div>
</div>
</div>
<div class="penci-google-adsense-2">

<ins class="adsbygoogle" style="display:inline-block;width:728px;height:90px" data-ad-client="ca-pub-9159179884377372" data-ad-slot="6495511074"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script> </div>
<div class="tags-share-box center-box tags-share-box-s1">
<span class="single-comment-o"><i class="penci-faicon fa fa-comment-o"></i><span class="dsq-postid" data-dsqidentifier="344498 https://www.thecheckeredflag.co.uk/?p=344498">0 comment</span></span>
<div class="post-share">
<span class="post-share-item post-share-plike">
<span class="count-number-like">0</span><a class="penci-post-like single-like-button" data-post_id="344498" title="Like" data-like="Like" data-unlike="Unlike"><i class="penci-faicon fa fa-heart-o"></i></a> </span>
<div class="list-posts-share"><a class="post-share-item post-share-facebook" target="_blank" rel="nofollow" href="https://www.facebook.com/sharer/sharer.php?u=https://www.thecheckeredflag.co.uk/2020/08/rick-ware-racing-joining-with-james-davison-for-indy-500-entry/"><i class="penci-faicon fa fa-facebook"></i><span class="dt-share">Facebook</span></a><a class="post-share-item post-share-twitter" target="_blank" rel="nofollow" href="https://twitter.com/intent/tweet?text=Check%20out%20this%20article:%20Rick%20Ware%20Racing%20Joining%20with%20James%20Davison%20for%20Indy%20500%20Entry%20-%20https://www.thecheckeredflag.co.uk/2020/08/rick-ware-racing-joining-with-james-davison-for-indy-500-entry/"><i class="penci-faicon fa fa-twitter"></i><span class="dt-share">Twitter</span></a><a class="post-share-item post-share-pinterest" data-pin-do="none" rel="nofollow noreferrer noopener" onclick="var e=document.createElement('script');e.setAttribute('type','text/javascript');e.setAttribute('charset','UTF-8');e.setAttribute('src','//assets.pinterest.com/js/pinmarklet.js?r='+Math.random()*99999999);document.body.appendChild(e);"><i class="penci-faicon fa fa-pinterest"></i><span class="dt-share">Pinterest</span></a><a class="post-share-item post-share-linkedin" target="_blank" rel="nofollow" href="https://www.linkedin.com/shareArticle?mini=true&#038;url=https%3A%2F%2Fwww.thecheckeredflag.co.uk%2F2020%2F08%2Frick-ware-racing-joining-with-james-davison-for-indy-500-entry%2F&#038;title=Rick%20Ware%20Racing%20Joining%20with%20James%20Davison%20for%20Indy%20500%20Entry"><i class="penci-faicon fa fa-linkedin"></i><span class="dt-share">Linkedin</span></a><a class="post-share-item post-share-reddit" target="_blank" rel="nofollow" href="https://reddit.com/submit?url=https%3A%2F%2Fwww.thecheckeredflag.co.uk%2F2020%2F08%2Frick-ware-racing-joining-with-james-davison-for-indy-500-entry%2F&#038;title=Rick%20Ware%20Racing%20Joining%20with%20James%20Davison%20for%20Indy%20500%20Entry"><i class="penci-faicon fa fa-reddit-alien"></i><span class="dt-share">Reddit</span></a><a class="post-share-item post-share-whatsapp" target="_blank" rel="nofollow" href="https://api.whatsapp.com/send?text=Rick%20Ware%20Racing%20Joining%20with%20James%20Davison%20for%20Indy%20500%20Entry %0A%0A https%3A%2F%2Fwww.thecheckeredflag.co.uk%2F2020%2F08%2Frick-ware-racing-joining-with-james-davison-for-indy-500-entry%2F"><i class="penci-faicon fa fa-whatsapp"></i><span class="dt-share">Whatsapp</span></a><a class="post-share-item post-share-email" target="_blank" rel="nofollow" href="/cdn-cgi/l/email-protection#427d313720282721367f102b2129677072152330276770721023212b2c25677072082d2b2c2b2c25677072352b362a67707208232f27316770720623342b312d2c677072242d306770720b2c263b677072777272677072072c36303b646172717a79000d061b7f2a36363231786d6d3535356c362a27212a27212927302726242e23256c212d6c37296d707270726d727a6d302b21296f352330276f3023212b2c256f282d2b2c2b2c256f352b362a6f28232f27316f2623342b312d2c6f242d306f2b2c263b6f7772726f272c36303b6d"><i class="penci-faicon fa fa-envelope"></i><span class="dt-share">Email</span></a></div> </div>
</div>
<div class="post-author">
<div class="author-img">
<img alt='' src='https://secure.gravatar.com/avatar/a2388d33ca3ce4dc5bee85ba7ec80c63?s=100&#038;d=https%3A%2F%2Fwww.thecheckeredflag.co.uk%2Fwp-content%2Fuploads%2F2018%2F11%2FTCF-black.jpg&#038;r=g' srcset='https://secure.gravatar.com/avatar/a2388d33ca3ce4dc5bee85ba7ec80c63?s=200&#038;d=https%3A%2F%2Fwww.thecheckeredflag.co.uk%2Fwp-content%2Fuploads%2F2018%2F11%2FTCF-black.jpg&#038;r=g 2x' class='avatar avatar-100 photo' height='100' width='100' /> </div>
<div class="author-content">
<h5><a href="https://www.thecheckeredflag.co.uk/author/gschmoyer/" title="Posts by Griffin Schmoyer" rel="author">Griffin Schmoyer</a></h5>
<p>Lifelong sports junkie, currently studying Broadcast Journalism at Hofstra University. Lead writer for Indycar at The Checkered Flag.</p>
<a rel="nofollow" target="_blank" class="author-social" href="http://schmoyerssoapbox.sport.blog"><i class="penci-faicon fa fa-globe"></i></a>
<a rel="nofollow" target="_blank" class="author-social" href="https://twitter.com/@GSchmoyer55"><i class="penci-faicon fa fa-twitter"></i></a>
<a rel="nofollow" target="_blank" class="author-social" href="https://www.linkedin.com/in/griffinschmoyer/"><i class="penci-faicon fa fa-linkedin"></i></a>
<a rel="nofollow" class="author-social" href="/cdn-cgi/l/email-protection#94f3e6fdf2f2fdfabae7f7fcf9fbedf1e6d4e0fcf1f7fcf1f7fff1e6f1f0f2f8f5f3baf7fbbae1ff"><i class="penci-faicon fa fa-envelope"></i></a>
</div>
</div>
<div class="post-related">
<div class="post-title-box"><h4 class="post-box-title">Related articles</h4></div>
<div class="penci-owl-carousel penci-owl-carousel-slider penci-related-carousel" data-lazy="true" data-item="3" data-desktop="3" data-tablet="2" data-tabsmall="2" data-auto="false" data-speed="300" data-dots="true" data-nav="false">
<div class="item-related">
<a class="related-thumb penci-image-holder" style="background-image: url('https://www.thecheckeredflag.co.uk/wp-content/uploads/2020/08/Indy_500-585x390.jpg');" href="https://www.thecheckeredflag.co.uk/2020/08/roger-penske-makes-tough-decision-to-not-allow-fans-at-the-indianapolis-500/" title="Roger Penske Makes Tough Decision to Not Allow Fans at the Indianapolis 500">
</a>
<h3><a href="https://www.thecheckeredflag.co.uk/2020/08/roger-penske-makes-tough-decision-to-not-allow-fans-at-the-indianapolis-500/">Roger Penske Makes Tough Decision to Not Allow Fans at the Indianapolis...</a></h3>
<span class="date"><time class="entry-date published" datetime="2020-08-04T18:38:23+01:00">August 4, 2020</time></span>
</div>
<div class="item-related">
<a class="related-thumb penci-image-holder" style="background-image: url('https://www.thecheckeredflag.co.uk/wp-content/uploads/2020/06/James-Davison-2019-Indianapolis-500-33-585x390.jpg');" href="https://www.thecheckeredflag.co.uk/2020/06/james-davison-disapproved-for-talladega-cup-debut-pushed-to-pocono/" title="James Davison disapproved for Talladega, Cup debut pushed to Pocono">
</a>
<h3><a href="https://www.thecheckeredflag.co.uk/2020/06/james-davison-disapproved-for-talladega-cup-debut-pushed-to-pocono/">James Davison disapproved for Talladega, Cup debut pushed to Pocono</a></h3>
<span class="date"><time class="entry-date published" datetime="2020-06-18T18:42:44+01:00">June 18, 2020</time></span>
</div>
<div class="item-related">
<a class="related-thumb penci-image-holder" style="background-image: url('https://www.thecheckeredflag.co.uk/wp-content/uploads/2020/06/James-Davison-2019-Indianapolis-500-announcement-585x390.jpg');" href="https://www.thecheckeredflag.co.uk/2020/06/james-davison-joins-spire-for-talladega-cup-debut/" title="James Davison joins Spire for Talladega, Cup debut">
</a>
<h3><a href="https://www.thecheckeredflag.co.uk/2020/06/james-davison-joins-spire-for-talladega-cup-debut/">James Davison joins Spire for Talladega, Cup debut</a></h3>
<span class="date"><time class="entry-date published" datetime="2020-06-16T19:14:23+01:00">June 16, 2020</time></span>
</div>
<div class="item-related">
<a class="related-thumb penci-image-holder" style="background-image: url('https://www.thecheckeredflag.co.uk/wp-content/uploads/2020/06/TCF-IndyCar-VeeKay-Texas-2020-585x390.jpg');" href="https://www.thecheckeredflag.co.uk/2020/06/veekay-apologises-after-crashing-twice-during-debut-indycar-event/" title="VeeKay apologises after crashing twice during debut IndyCar event">
</a>
<h3><a href="https://www.thecheckeredflag.co.uk/2020/06/veekay-apologises-after-crashing-twice-during-debut-indycar-event/">VeeKay apologises after crashing twice during debut IndyCar event</a></h3>
<span class="date"><time class="entry-date published" datetime="2020-06-10T16:00:16+01:00">June 10, 2020</time></span>
</div>
<div class="item-related">
<a class="related-thumb penci-image-holder" style="background-image: url('https://www.thecheckeredflag.co.uk/wp-content/uploads/2020/06/David-Starr-NCS-Ware-53-car-Martinsville-2020-585x390.jpg');" href="https://www.thecheckeredflag.co.uk/2020/06/david-starr-joins-ware-for-first-cup-start-since-2018/" title="David Starr joins Ware for first Cup start since 2018">
</a>
<h3><a href="https://www.thecheckeredflag.co.uk/2020/06/david-starr-joins-ware-for-first-cup-start-since-2018/">David Starr joins Ware for first Cup start since 2018</a></h3>
<span class="date"><time class="entry-date published" datetime="2020-06-09T19:29:08+01:00">June 9, 2020</time></span>
</div>
<div class="item-related">
<a class="related-thumb penci-image-holder" style="background-image: url('https://www.thecheckeredflag.co.uk/wp-content/uploads/2020/06/TCF-IndyCar-2020-COTA-Palou-Test-585x390.jpg');" href="https://www.thecheckeredflag.co.uk/2020/06/palou-prepared-for-dive-into-the-deep-end-on-indycar-debut/" title="Palou prepared for dive into the deep end on IndyCar debut">
</a>
<h3><a href="https://www.thecheckeredflag.co.uk/2020/06/palou-prepared-for-dive-into-the-deep-end-on-indycar-debut/">Palou prepared for dive into the deep end on IndyCar debut</a></h3>
<span class="date"><time class="entry-date published" datetime="2020-06-05T17:00:15+01:00">June 5, 2020</time></span>
</div>
<div class="item-related">
<a class="related-thumb penci-image-holder" style="background-image: url('https://www.thecheckeredflag.co.uk/wp-content/uploads/2020/01/TCF-IndyCar-2020-Rosenqvist-COTA-Test-585x390.jpg');" href="https://www.thecheckeredflag.co.uk/2020/06/season-preview-2020-ntt-indycar-series-2/" title="SEASON PREVIEW: 2020 NTT IndyCar Series">
</a>
<h3><a href="https://www.thecheckeredflag.co.uk/2020/06/season-preview-2020-ntt-indycar-series-2/">SEASON PREVIEW: 2020 NTT IndyCar Series</a></h3>
<span class="date"><time class="entry-date published" datetime="2020-06-03T19:00:16+01:00">June 3, 2020</time></span>
</div>
<div class="item-related">
<a class="related-thumb penci-image-holder" style="background-image: url('https://www.thecheckeredflag.co.uk/wp-content/uploads/2020/05/Gray-Gaulding-Panini-2020-NCS-car-585x390.jpg');" href="https://www.thecheckeredflag.co.uk/2020/05/gray-gaulding-running-darlington-cup-race-with-ware/" title="Gray Gaulding running Darlington Cup race with Ware">
</a>
<h3><a href="https://www.thecheckeredflag.co.uk/2020/05/gray-gaulding-running-darlington-cup-race-with-ware/">Gray Gaulding running Darlington Cup race with Ware</a></h3>
<span class="date"><time class="entry-date published" datetime="2020-05-13T21:20:51+01:00">May 13, 2020</time></span>
</div>
<div class="item-related">
<a class="related-thumb penci-image-holder" style="background-image: url('https://www.thecheckeredflag.co.uk/wp-content/uploads/2020/04/TCF-IndyCar-iRacing-McLaughlin-585x390.jpg');" href="https://www.thecheckeredflag.co.uk/2020/04/mclaughlin-holds-off-power-to-win-iracing-indycar-challenge-at-barber/" title="McLaughlin holds off Power to win IndyCar iRacing Challenge at Barber">
</a>
<h3><a href="https://www.thecheckeredflag.co.uk/2020/04/mclaughlin-holds-off-power-to-win-iracing-indycar-challenge-at-barber/">McLaughlin holds off Power to win IndyCar iRacing Challenge at Barber</a></h3>
<span class="date"><time class="entry-date published" datetime="2020-04-04T19:32:07+01:00">April 4, 2020</time></span>
</div>
</div></div>
<div id="disqus_thread">
</div>
</article> </div>
</div>
<div id="sidebar" class="penci-sidebar-right penci-sidebar-content style-1 pcalign-center">
<div class="theiaStickySidebar">
<aside id="media_image-2" class="widget widget_media_image"><h4 class="widget-title penci-border-arrow"><span class="inner-arrow">Support Driven by Diversity</span></h4><a href="http://www.drivenbydiversity.com/" target="_blank" rel="noopener noreferrer"><img width="600" height="600" src="https://www.thecheckeredflag.co.uk/wp-content/uploads/2020/07/DbD-600px.png" class="image wp-image-343664  attachment-full size-full" alt="Driven by Diversity - www.drivenbydiversity.com" style="max-width: 100%; height: auto;" title="TCF Merchandise" srcset="https://www.thecheckeredflag.co.uk/wp-content/uploads/2020/07/DbD-600px.png 600w, https://www.thecheckeredflag.co.uk/wp-content/uploads/2020/07/DbD-600px-160x160.png 160w, https://www.thecheckeredflag.co.uk/wp-content/uploads/2020/07/DbD-600px-533x533.png 533w, https://www.thecheckeredflag.co.uk/wp-content/uploads/2020/07/DbD-600px-240x240.png 240w, https://www.thecheckeredflag.co.uk/wp-content/uploads/2020/07/DbD-600px-585x585.png 585w, https://www.thecheckeredflag.co.uk/wp-content/uploads/2020/07/DbD-600px-550x550.png 550w, https://www.thecheckeredflag.co.uk/wp-content/uploads/2020/07/DbD-600px-470x470.png 470w" sizes="(max-width: 600px) 100vw, 600px" /></a></aside><aside id="penci_latest_news_widget-12" class="widget penci_latest_news_widget"><h4 class="widget-title penci-border-arrow"><span class="inner-arrow">Latest Articles</span></h4> <ul id="penci-latestwg-5966" class="side-newsfeed">
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder small-fix-size" rel="bookmark" style="background-image: url('https://www.thecheckeredflag.co.uk/wp-content/uploads/2020/08/2020-Toyota-500-Darlington-green-flag-NCS-263x175.jpg');" href="https://www.thecheckeredflag.co.uk/2020/08/2020-nascar-playoff-schedules-finalised/" title="2020 NASCAR playoff schedules finalised"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.thecheckeredflag.co.uk/2020/08/2020-nascar-playoff-schedules-finalised/" rel="bookmark" title="2020 NASCAR playoff schedules finalised">
2020 NASCAR playoff schedules finalised </a>
</h4>
<span class="side-item-meta"><time class="entry-date published" datetime="2020-08-06T19:18:40+01:00">August 6, 2020</time></span>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder small-fix-size" rel="bookmark" style="background-image: url('https://www.thecheckeredflag.co.uk/wp-content/uploads/2020/08/James_Davison-263x175.jpg');" href="https://www.thecheckeredflag.co.uk/2020/08/rick-ware-racing-joining-with-james-davison-for-indy-500-entry/" title="Rick Ware Racing Joining with James Davison for Indy 500 Entry"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.thecheckeredflag.co.uk/2020/08/rick-ware-racing-joining-with-james-davison-for-indy-500-entry/" rel="bookmark" title="Rick Ware Racing Joining with James Davison for Indy 500 Entry">
Rick Ware Racing Joining with James Davison for Indy 500 Entry </a>
</h4>
<span class="side-item-meta"><time class="entry-date published" datetime="2020-08-06T18:19:54+01:00">August 6, 2020</time></span>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder small-fix-size" rel="bookmark" style="background-image: url('https://www.thecheckeredflag.co.uk/wp-content/uploads/2020/08/Oliver-Rasmussen-03-263x175.jpg');" href="https://www.thecheckeredflag.co.uk/2020/08/prema-powerteam-trio-take-victories-in-frec-opener-at-misano/" title="Prema Powerteam Trio Take Victories in FREC Opener at Misano"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.thecheckeredflag.co.uk/2020/08/prema-powerteam-trio-take-victories-in-frec-opener-at-misano/" rel="bookmark" title="Prema Powerteam Trio Take Victories in FREC Opener at Misano">
Prema Powerteam Trio Take Victories in FREC Opener at Misano </a>
</h4>
<span class="side-item-meta"><time class="entry-date published" datetime="2020-08-06T17:32:25+01:00">August 6, 2020</time></span>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder small-fix-size" rel="bookmark" style="background-image: url('https://www.thecheckeredflag.co.uk/wp-content/uploads/2020/08/DACPole2-263x175.jpg');" href="https://www.thecheckeredflag.co.uk/2020/08/da-costa-dominates-qualifying-again-in-berlin/" title="Da Costa dominates qualifying again in Berlin"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.thecheckeredflag.co.uk/2020/08/da-costa-dominates-qualifying-again-in-berlin/" rel="bookmark" title="Da Costa dominates qualifying again in Berlin">
Da Costa dominates qualifying again in Berlin </a>
</h4>
<span class="side-item-meta"><time class="entry-date published" datetime="2020-08-06T14:33:26+01:00">August 6, 2020</time></span>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder small-fix-size" rel="bookmark" style="background-image: url('https://www.thecheckeredflag.co.uk/wp-content/uploads/2020/08/Webp.net-resizeimage-8-263x175.jpg');" href="https://www.thecheckeredflag.co.uk/2020/08/bottas-to-race-with-mercedes-until-at-least-the-end-of-2021/" title="Bottas to race with Mercedes until at least the end of 2021"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.thecheckeredflag.co.uk/2020/08/bottas-to-race-with-mercedes-until-at-least-the-end-of-2021/" rel="bookmark" title="Bottas to race with Mercedes until at least the end of 2021">
Bottas to race with Mercedes until at least the end of 2021 </a>
</h4>
<span class="side-item-meta"><time class="entry-date published" datetime="2020-08-06T14:23:58+01:00">August 6, 2020</time></span>
</div>
</div>
</li>
</ul>
</aside><aside id="custom_html-11" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget">

<ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-9159179884377372" data-ad-slot="4409003789" data-ad-format="auto" data-full-width-responsive="true"></ins>
<script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script></div></aside><aside id="penci_latest_news_widget-11" class="widget penci_latest_news_widget"><h4 class="widget-title penci-border-arrow"><span class="inner-arrow">Latest Features</span></h4> <ul id="penci-latestwg-5421" class="side-newsfeed">
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder small-fix-size" rel="bookmark" style="background-image: url('https://www.thecheckeredflag.co.uk/wp-content/uploads/2020/08/Hamilton_BritishGP2020-263x175.jpg');" href="https://www.thecheckeredflag.co.uk/2020/08/analysis-2020-british-grand-prix-assessing-the-field/" title="ANALYSIS: 2020 British Grand Prix &#8211; Assessing the field"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.thecheckeredflag.co.uk/2020/08/analysis-2020-british-grand-prix-assessing-the-field/" rel="bookmark" title="ANALYSIS: 2020 British Grand Prix &#8211; Assessing the field">
ANALYSIS: 2020 British Grand Prix &#8211; Assessing the field </a>
</h4>
<span class="side-item-meta"><time class="entry-date published" datetime="2020-08-03T10:59:19+01:00">August 3, 2020</time></span>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder small-fix-size" rel="bookmark" style="background-image: url('https://www.thecheckeredflag.co.uk/wp-content/uploads/2020/04/Rindt-1-263x175.jpg');" href="https://www.thecheckeredflag.co.uk/2020/07/jochen-rindt-50-years-on/" title="Jochen Rindt – 50 Years On"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.thecheckeredflag.co.uk/2020/07/jochen-rindt-50-years-on/" rel="bookmark" title="Jochen Rindt – 50 Years On">
Jochen Rindt – 50 Years On </a>
</h4>
<span class="side-item-meta"><time class="entry-date published" datetime="2020-07-31T09:00:12+01:00">July 31, 2020</time></span>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder small-fix-size" rel="bookmark" style="background-image: url('https://www.thecheckeredflag.co.uk/wp-content/uploads/2020/07/Hamilton_Wins-263x175.jpg');" href="https://www.thecheckeredflag.co.uk/2020/07/analysis-assessing-the-field-2020-hungarian-grand-prix/" title="ANALYSIS: Assessing the field &#8211; 2020 Hungarian Grand Prix"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.thecheckeredflag.co.uk/2020/07/analysis-assessing-the-field-2020-hungarian-grand-prix/" rel="bookmark" title="ANALYSIS: Assessing the field &#8211; 2020 Hungarian Grand Prix">
ANALYSIS: Assessing the field &#8211; 2020 Hungarian Grand Prix </a>
</h4>
<span class="side-item-meta"><time class="entry-date published" datetime="2020-07-21T22:59:27+01:00">July 21, 2020</time></span>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder small-fix-size" rel="bookmark" style="background-image: url('https://www.thecheckeredflag.co.uk/wp-content/uploads/2020/07/Codemasters-f1-2020-2-263x175.jpg');" href="https://www.thecheckeredflag.co.uk/2020/07/review-f1-2020/" title="REVIEW: F1 2020"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.thecheckeredflag.co.uk/2020/07/review-f1-2020/" rel="bookmark" title="REVIEW: F1 2020">
REVIEW: F1 2020 </a>
</h4>
<span class="side-item-meta"><time class="entry-date published" datetime="2020-07-21T12:52:19+01:00">July 21, 2020</time></span>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder small-fix-size" rel="bookmark" style="background-image: url('https://www.thecheckeredflag.co.uk/wp-content/uploads/2020/07/Felix_Rosenqvist-263x175.jpg');" href="https://www.thecheckeredflag.co.uk/2020/07/felix-rosenqvist-its-the-most-difficult-series-ive-driven-in/" title="Felix Rosenqvist: &#8220;It&#8217;s the most difficult series I&#8217;ve driven in&#8221;"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.thecheckeredflag.co.uk/2020/07/felix-rosenqvist-its-the-most-difficult-series-ive-driven-in/" rel="bookmark" title="Felix Rosenqvist: &#8220;It&#8217;s the most difficult series I&#8217;ve driven in&#8221;">
Felix Rosenqvist: &#8220;It&#8217;s the most difficult series I&#8217;ve driven in&#8221; </a>
</h4>
<span class="side-item-meta"><time class="entry-date published" datetime="2020-07-16T18:55:58+01:00">July 16, 2020</time></span>
</div>
</div>
</li>
</ul>
</aside><aside id="custom_html-8" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget">
<ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-9159179884377372" data-ad-slot="2468886887" data-ad-format="auto"></ins>
<script>
window.setTimeout(function(){ 
  (adsbygoogle = window.adsbygoogle || []).push({}); 
}, 200); 
</script></div></aside> </div>
</div>
</div>
<div class="clear-footer"></div>
<div class="footer-subscribe">
<aside id="mc4wp_form_widget-2" class="widget widget_mc4wp_form_widget"><script>(function() {
	window.mc4wp = window.mc4wp || {
		listeners: [],
		forms: {
			on: function(evt, cb) {
				window.mc4wp.listeners.push(
					{
						event   : evt,
						callback: cb
					}
				);
			}
		}
	}
})();
</script><form id="mc4wp-form-1" class="mc4wp-form mc4wp-form-293151" method="post" data-id="293151" data-name="TCF Daily Headlines to your Inbox"><div class="mc4wp-form-fields"><p class="mdes">Get the latest headlines from TCF in a daily roundup, straight to your inbox</p>
<p class="memail"><input type="email" id="mc4wp_email" name="EMAIL" placeholder="Email..." required /></p>
<p class="msubmit"><input type="submit" value="Subscribe" /></p></div><label style="display: none !important;">Leave this field empty if you're human: <input type="text" name="_mc4wp_honeypot" value="" tabindex="-1" autocomplete="off" /></label><input type="hidden" name="_mc4wp_timestamp" value="1596738058" /><input type="hidden" name="_mc4wp_form_id" value="293151" /><input type="hidden" name="_mc4wp_form_element_id" value="mc4wp-form-1" /><div class="mc4wp-response"></div></form></aside> </div>
<footer id="footer-section" class="penci-footer-social-media penci-lazy" itemscope itemtype="https://schema.org/WPFooter">
<div class="container">
<div class="footer-socials-section">
<ul class="footer-socials">
<li><a href="https://facebook.com/TheCheckeredFlag" rel="nofollow" target="_blank"><i class="penci-faicon fa fa-facebook"></i><span>Facebook</span></a></li>
<li><a href="https://twitter.com/TheCheckerFlag" rel="nofollow" target="_blank"><i class="penci-faicon fa fa-twitter"></i><span>Twitter</span></a></li>
<li><a href="https://instagram.com/thecheckeredflag/" rel="nofollow" target="_blank"><i class="penci-faicon fa fa-instagram"></i><span>Instagram</span></a></li>
<li><a href="https://www.linkedin.com/company/thecheckeredflag/" rel="nofollow" target="_blank"><i class="penci-faicon fa fa-linkedin"></i><span>Linkedin</span></a></li>
<li><a href="https://www.youtube.com/channel/UCueRVoGbSE4GF2RszehXIgw" rel="nofollow" target="_blank"><i class="penci-faicon fa fa-youtube-play"></i><span>Youtube</span></a></li>
<li><a href="https://www.thecheckeredflag.co.uk/feed" rel="nofollow" target="_blank"><i class="penci-faicon fa fa-rss"></i><span>RSS</span></a></li>
</ul>
</div>
<div class="footer-logo-copyright footer-not-logo">
<div id="footer-copyright">
<p><a href="https://www.thecheckeredflag.co.uk/contact/">Contact Us</a> | <a href="https://www.thecheckeredflag.co.uk/contribute/">Contribute</a> | <a href="https://www.thecheckeredflag.co.uk/about-us">About Us</a><br />
<a href="https://www.thecheckeredflag.co.uk/tcf-partners/">TCF Friends & Partners</a> | <a href="https://www.thecheckeredflag.co.uk/submitting-news/">Submitting News</a> | <a href="https://www.thecheckeredflag.co.uk/terms-and-conditions/">T & C</a> | <a href="https://www.thecheckeredflag.co.uk/privacy-policy/">Privacy Policy</a> | <a href="https://www.thecheckeredflag.co.uk/cookies-in-use-on-this-site/">Cookie Policy</a><br />
©Copyright MMXX - The Checkered Flag - All Rights Reserved</p>
</div>
<div class="go-to-top-parent"><a href="#" class="go-to-top"><span><i class="penci-faicon fa fa-angle-up"></i> <br>Back To Top</span></a></div>
</div>
</div>
</footer>
</div>
<div id="fb-root"></div>
<div class="penci-wrap-gprd-law penci-wrap-gprd-law-close penci-close-all">
<div class="penci-gprd-law">
<p>
This website uses cookies to improve your experience. We&#039;ll assume you&#039;re ok with this, but you can opt-out if you wish. <a class="penci-gprd-accept" href="#">Accept</a> <a class="penci-gprd-more" href="#">Read More</a> </p>
</div>
</div>
<script>(function() {function maybePrefixUrlField() {
	if (this.value.trim() !== '' && this.value.indexOf('http') !== 0) {
		this.value = "http://" + this.value;
	}
}

var urlFields = document.querySelectorAll('.mc4wp-form input[type="url"]');
if (urlFields) {
	for (var j=0; j < urlFields.length; j++) {
		urlFields[j].addEventListener('blur', maybePrefixUrlField);
	}
}
})();</script>

<noscript><iframe data-lazyloaded="1" src="about:blank" data-src="https://www.googletagmanager.com/ns.html?id=GTM-MG875N"
height="0" width="0" style="display:none;visibility:hidden"></iframe><noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-MG875N"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript></noscript>
<script type='text/javascript'>
/* <![CDATA[ */
var countVars = {"disqusShortname":"thecheckerdflag"};
var embedVars = {"disqusConfig":{"integration":"wordpress 3.0.17"},"disqusIdentifier":"344498 https:\/\/www.thecheckeredflag.co.uk\/?p=344498","disqusShortname":"thecheckerdflag","disqusTitle":"Rick Ware Racing Joining with James Davison for Indy 500 Entry","disqusUrl":"https:\/\/www.thecheckeredflag.co.uk\/2020\/08\/rick-ware-racing-joining-with-james-davison-for-indy-500-entry\/","postId":"344498"};
var dclCustomVars = {"dcl_progress_text":"Loading..."};
/* ]]> */
</script>
<script type='text/javascript'>
/* <![CDATA[ */
var ajax_var_more = {"url":"https:\/\/www.thecheckeredflag.co.uk\/wp-admin\/admin-ajax.php","nonce":"47f5dc3c36","errorPass":"<p class=\"message message-error\">Password does not match the confirm password<\/p>","login":"Email Address","password":"Password"};
/* ]]> */
</script>
<script type='text/javascript'>
/* <![CDATA[ */
var ajax_var = {"url":"https:\/\/www.thecheckeredflag.co.uk\/wp-admin\/admin-ajax.php","nonce":"47f5dc3c36","errorPass":"<p class=\"message message-error\">Password does not match the confirm password<\/p>","login":"Email Address","password":"Password"};
/* ]]> */
</script>
<script type='text/javascript'>
/* <![CDATA[ */
var SOLEDADLOCALIZE = {"url":"https:\/\/www.thecheckeredflag.co.uk\/wp-admin\/admin-ajax.php","nonce":"47f5dc3c36","errorPass":"<p class=\"message message-error\">Password does not match the confirm password<\/p>","login":"Email Address","password":"Password"};
/* ]]> */
</script>
<script>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</script><script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><script data-optimized="1" src="https://www.thecheckeredflag.co.uk/wp-content/litespeed/cssjs/d2f42.js"></script></body>
</html>



