<!DOCTYPE html>
<html lang="en-GB">
<head>
<meta charset="UTF-8"><link rel='stylesheet' id='wp-block-library-css' href='https://c0.wp.com/c/5.3.2/wp-includes/css/dist/block-library/style.min.css' type='text/css' media='all' /><link rel='stylesheet' id='wp-block-library-theme-css' href='https://c0.wp.com/c/5.3.2/wp-includes/css/dist/block-library/theme.min.css' type='text/css' media='all' /><link rel='stylesheet' id='penci-fonts-css' href='//fonts.googleapis.com/css?family=Playfair+Display+SC%3A300%2C300italic%2C400%2C400italic%2C500%2C500italic%2C700%2C700italic%2C800%2C800italic%7CMontserrat%3A300%2C300italic%2C400%2C400italic%2C500%2C500italic%2C700%2C700italic%2C800%2C800italic%7CRoboto%3A300%2C300italic%2C400%2C400italic%2C500%2C500italic%2C700%2C700italic%2C800%2C800italic%7CArial%3A300%2C300italic%2C400%2C400italic%2C500%2C500italic%2C700%2C700italic%2C800%2C800italic%26subset%3Dlatin%2Ccyrillic%2Ccyrillic-ext%2Cgreek%2Cgreek-ext%2Clatin-ext&#038;ver=1.0' type='text/css' media='all' /><link rel='stylesheet' id='jetpack_css-css' href='https://c0.wp.com/p/jetpack/8.1/css/jetpack.css' type='text/css' media='all' /><link data-optimized='2' rel='stylesheet' href='https://www.thecheckeredflag.co.uk/min/8e1da.css' /><script type='text/javascript' src='https://c0.wp.com/c/5.3.2/wp-includes/js/jquery/jquery.js'></script><script type='text/javascript' src='https://c0.wp.com/c/5.3.2/wp-includes/js/jquery/jquery-migrate.min.js'></script><script data-optimized='1' src='https://www.thecheckeredflag.co.uk/min/03740.js'></script>
<meta http-equiv="X-UA-Compatible" content="IE=edge">
<meta name="viewport" content="width=device-width, initial-scale=1">
<link rel="profile" href="https://gmpg.org/xfn/11" />
<link rel="shortcut icon" href="https://www.thecheckeredflag.co.uk/wp-content/uploads/2018/11/TCF-black.jpg" type="image/x-icon" />
<link rel="apple-touch-icon" sizes="180x180" href="https://www.thecheckeredflag.co.uk/wp-content/uploads/2018/11/TCF-black.jpg">
<link rel="alternate" type="application/rss+xml" title="The Checkered Flag RSS Feed" href="https://www.thecheckeredflag.co.uk/feed/" />
<link rel="alternate" type="application/atom+xml" title="The Checkered Flag Atom Feed" href="https://www.thecheckeredflag.co.uk/feed/atom/" />
<link rel="pingback" href="https://www.thecheckeredflag.co.uk/xmlrpc.php" />
<!--[if lt IE 9]>
	<script src="https://www.thecheckeredflag.co.uk/wp-content/themes/soledad/js/html5.js"></script>
	<![endif]-->
<title>Carmichael to enter the new Motorsport UK National Championship - The Checkered Flag</title>

<script data-cfasync="false" data-pagespeed-no-defer type="text/javascript">//<![CDATA[
	var gtm4wp_datalayer_name = "dataLayer";
	var dataLayer = dataLayer || [];
//]]>
</script>


<meta name="description" content="Northern Irishman Alan Carmichael commits to enter the Motorsport UK National Championship in a right-hand-drive Ford Fiesta R5." />
<meta name="robots" content="max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
<link rel="canonical" href="https://www.thecheckeredflag.co.uk/2020/01/carmichael-to-enter-the-new-motorsport-uk-national-championship/" />
<meta property="og:locale" content="en_GB" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Carmichael to enter the new Motorsport UK National Championship - The Checkered Flag" />
<meta property="og:description" content="Northern Irishman Alan Carmichael commits to enter the Motorsport UK National Championship in a right-hand-drive Ford Fiesta R5." />
<meta property="og:url" content="https://www.thecheckeredflag.co.uk/2020/01/carmichael-to-enter-the-new-motorsport-uk-national-championship/" />
<meta property="og:site_name" content="The Checkered Flag" />
<meta property="article:publisher" content="http://www.facebook.com/TheCheckeredFlag" />
<meta property="article:author" content="pontus.lindroos.1" />
<meta property="article:tag" content="2020 British Rally Championship" />
<meta property="article:tag" content="Motorsport UK National Championship" />
<meta property="article:tag" content="Northern Ireland Rally Championship" />
<meta property="article:section" content="British Rally Championship" />
<meta property="article:published_time" content="2020-01-22T07:31:48+00:00" />
<meta property="article:modified_time" content="2020-01-22T08:54:18+00:00" />
<meta property="og:updated_time" content="2020-01-22T08:54:18+00:00" />
<meta property="fb:app_id" content="135274436510698" />
<meta property="og:image" content="https://i2.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/01/BRC-Fiesta.jpg?fit=800%2C533&#038;ssl=1" />
<meta property="og:image:secure_url" content="https://i2.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/01/BRC-Fiesta.jpg?fit=800%2C533&#038;ssl=1" />
<meta property="og:image:width" content="800" />
<meta property="og:image:height" content="533" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:description" content="Northern Irishman Alan Carmichael commits to enter the Motorsport UK National Championship in a right-hand-drive Ford Fiesta R5." />
<meta name="twitter:title" content="Carmichael to enter the new Motorsport UK National Championship - The Checkered Flag" />
<meta name="twitter:site" content="@thecheckerflag" />
<meta name="twitter:image" content="https://i2.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/01/BRC-Fiesta.jpg?fit=800%2C533&#038;ssl=1" />
<meta name="twitter:creator" content="@RXtheWorld" />
<script type='application/ld+json' class='yoast-schema-graph yoast-schema-graph--main'>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</script>

<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="The Checkered Flag &raquo; Feed" href="https://www.thecheckeredflag.co.uk/feed/" />
<link rel="alternate" type="application/rss+xml" title="The Checkered Flag &raquo; Comments Feed" href="https://www.thecheckeredflag.co.uk/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="The Checkered Flag &raquo; Carmichael to enter the new Motorsport UK National Championship Comments Feed" href="https://www.thecheckeredflag.co.uk/2020/01/carmichael-to-enter-the-new-motorsport-uk-national-championship/feed/" />
<style id='wp-block-library-inline-css' type='text/css'>
.has-text-align-justify{text-align:justify;}
</style>
<!--[if !IE]><!-->
<!--<![endif]-->
<link rel='https://api.w.org/' href='https://www.thecheckeredflag.co.uk/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.thecheckeredflag.co.uk/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.thecheckeredflag.co.uk/wp-includes/wlwmanifest.xml" />
<link rel='shortlink' href='https://www.thecheckeredflag.co.uk/?p=329697' />
<link rel="alternate" type="application/json+oembed" href="https://www.thecheckeredflag.co.uk/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.thecheckeredflag.co.uk%2F2020%2F01%2Fcarmichael-to-enter-the-new-motorsport-uk-national-championship%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.thecheckeredflag.co.uk/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.thecheckeredflag.co.uk%2F2020%2F01%2Fcarmichael-to-enter-the-new-motorsport-uk-national-championship%2F&#038;format=xml" />

<script data-cfasync="false" data-pagespeed-no-defer type="text/javascript">//<![CDATA[
	var dataLayer_content = {"pageTitle":"Carmichael to enter the new Motorsport UK National Championship - The Checkered Flag","pageCategory":["british-rally-championship","other"],"pageAttributes":["2020-british-rally-championship","motorsport-uk-national-championship","northern-ireland-rally-championship"],"pagePostAuthor":"Pontus Lindroos"};
	dataLayer.push( dataLayer_content );//]]>
</script>
<script data-cfasync="false">//<![CDATA[
(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'//www.googletagmanager.com/gtm.'+'js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-MG875N');//]]>
</script>


<link rel='dns-prefetch' href='//c0.wp.com' />
<link rel='dns-prefetch' href='//i0.wp.com' />
<link rel='dns-prefetch' href='//i1.wp.com' />
<link rel='dns-prefetch' href='//i2.wp.com' />
<style type='text/css'>img#wpstats{display:none}</style> <style type="text/css">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</style>
<script>
var penciBlocksArray=[];
var portfolioDataJs = portfolioDataJs || [];var PENCILOCALCACHE = {};
		(function () {
				"use strict";
		
				PENCILOCALCACHE = {
					data: {},
					remove: function ( ajaxFilterItem ) {
						delete PENCILOCALCACHE.data[ajaxFilterItem];
					},
					exist: function ( ajaxFilterItem ) {
						return PENCILOCALCACHE.data.hasOwnProperty( ajaxFilterItem ) && PENCILOCALCACHE.data[ajaxFilterItem] !== null;
					},
					get: function ( ajaxFilterItem ) {
						return PENCILOCALCACHE.data[ajaxFilterItem];
					},
					set: function ( ajaxFilterItem, cachedData ) {
						PENCILOCALCACHE.remove( ajaxFilterItem );
						PENCILOCALCACHE.data[ajaxFilterItem] = cachedData;
					}
				};
			}
		)();function penciBlock() {
		    this.atts_json = '';
		    this.content = '';
		}</script>
<script type="application/ld+json">{
    "@context": "https:\/\/schema.org\/",
    "@type": "organization",
    "@id": "#organization",
    "logo": {
        "@type": "ImageObject",
        "url": "https:\/\/www.thecheckeredflag.co.uk\/wp-content\/uploads\/2019\/08\/TCF-Square.jpg"
    },
    "url": "https:\/\/www.thecheckeredflag.co.uk\/",
    "name": "The Checkered Flag",
    "description": "Independent motor sport news since 2009"
}</script><script type="application/ld+json">{
    "@context": "https:\/\/schema.org\/",
    "@type": "WebSite",
    "name": "The Checkered Flag",
    "alternateName": "Independent motor sport news since 2009",
    "url": "https:\/\/www.thecheckeredflag.co.uk\/"
}</script><script type="application/ld+json">{
    "@context": "https:\/\/schema.org\/",
    "@type": "BlogPosting",
    "headline": "Carmichael to enter the new Motorsport UK National Championship",
    "description": "Northern Irishman Alan Carmichael commits to enter the Motorsport UK National Championship in a right-hand-drive Ford Fiesta R5.",
    "datePublished": "2020-01-22",
    "datemodified": "2020-01-22",
    "mainEntityOfPage": "https:\/\/www.thecheckeredflag.co.uk\/2020\/01\/carmichael-to-enter-the-new-motorsport-uk-national-championship\/",
    "image": {
        "@type": "ImageObject",
        "url": "https:\/\/i2.wp.com\/www.thecheckeredflag.co.uk\/wp-content\/uploads\/2020\/01\/BRC-Fiesta.jpg?fit=800%2C533&ssl=1",
        "width": 800,
        "height": 533
    },
    "publisher": {
        "@type": "Organization",
        "name": "The Checkered Flag",
        "logo": {
            "@type": "ImageObject",
            "url": "https:\/\/www.thecheckeredflag.co.uk\/wp-content\/uploads\/2019\/08\/TCF-Square.jpg"
        }
    },
    "author": {
        "@type": "Person",
        "@id": "#person-PontusLindroos",
        "name": "Pontus Lindroos"
    }
}</script><script type="application/ld+json">{
    "@context": "https:\/\/schema.org",
    "@type": "NewsArticle",
    "headline": "Carmichael to enter the new Motorsport UK National Championship",
    "image": "https:\/\/i2.wp.com\/www.thecheckeredflag.co.uk\/wp-content\/uploads\/2020\/01\/BRC-Fiesta.jpg?fit=800%2C533&ssl=1",
    "datePublished": "2020-01-22",
    "datemodified": "2020-01-22",
    "description": "Northern Irishman Alan Carmichael commits to enter the Motorsport UK National Championship in a right-hand-drive Ford Fiesta R5.",
    "mainEntityOfPage": "https:\/\/www.thecheckeredflag.co.uk\/2020\/01\/carmichael-to-enter-the-new-motorsport-uk-national-championship\/",
    "publisher": {
        "@type": "Organization",
        "name": "The Checkered Flag",
        "logo": {
            "@type": "ImageObject",
            "url": "https:\/\/www.thecheckeredflag.co.uk\/wp-content\/uploads\/2019\/08\/TCF-Square.jpg"
        }
    },
    "author": {
        "@type": "Person",
        "name": "Pontus Lindroos"
    }
}</script><link rel="amphtml" href="https://www.thecheckeredflag.co.uk/amp/2020/01/carmichael-to-enter-the-new-motorsport-uk-national-championship/" /><link rel="icon" href="https://i0.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2016/02/cropped-TCF.png?fit=32%2C32&#038;ssl=1" sizes="32x32" />
<link rel="icon" href="https://i0.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2016/02/cropped-TCF.png?fit=192%2C192&#038;ssl=1" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="https://i0.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2016/02/cropped-TCF.png?fit=180%2C180&#038;ssl=1" />
<meta name="msapplication-TileImage" content="https://i0.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2016/02/cropped-TCF.png?fit=270%2C270&#038;ssl=1" />
</head>
<body data-rsssl=1 class="post-template-default single single-post postid-329697 single-format-standard">
<a id="close-sidebar-nav" class="header-5"><i class="penci-faicon fa fa-close"></i></a>
<nav id="sidebar-nav" class="header-5" role="navigation" itemscope itemtype="https://schema.org/SiteNavigationElement">
<div id="sidebar-nav-logo">
<a href="https://www.thecheckeredflag.co.uk/"><img class="penci-lazy" src="https://www.thecheckeredflag.co.uk/wp-content/themes/soledad/images/penci-holder.png" data-src="https://www.thecheckeredflag.co.uk/wp-content/uploads/2018/11/TCF-black.jpg" alt="The Checkered Flag" /></a>
</div>
<div class="header-social sidebar-nav-social">
<div class="inner-header-social">
<a href="https://facebook.com/TheCheckeredFlag" rel="nofollow" target="_blank"><i class="penci-faicon fa fa-facebook"></i></a>
<a href="https://twitter.com/TheCheckerFlag" rel="nofollow" target="_blank"><i class="penci-faicon fa fa-twitter"></i></a>
<a href="https://instagram.com/thecheckeredflag/" rel="nofollow" target="_blank"><i class="penci-faicon fa fa-instagram"></i></a>
<a href="https://www.linkedin.com/company/thecheckeredflag/" rel="nofollow" target="_blank"><i class="penci-faicon fa fa-linkedin"></i></a>
<a href="https://www.youtube.com/channel/UCueRVoGbSE4GF2RszehXIgw" rel="nofollow" target="_blank"><i class="penci-faicon fa fa-youtube-play"></i></a>
<a href="https://www.thecheckeredflag.co.uk/feed" rel="nofollow" target="_blank"><i class="penci-faicon fa fa-rss"></i></a>
</div> </div>
<ul id="menu-2015" class="menu"><li id="menu-item-131887" class="menu-item menu-item-type-taxonomy menu-item-object-category penci-mega-menu menu-item-131887"><a href="https://www.thecheckeredflag.co.uk/formula-1/">F1</a>
<ul class="sub-menu">
<li id="menu-item-0" class="menu-item-0"><div class="penci-megamenu">
<div class="penci-content-megamenu">
<div class="penci-mega-latest-posts col-mn-5 mega-row-1">
<div class="penci-mega-row penci-mega-3 row-active">
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.thecheckeredflag.co.uk/formula-1/">
Formula 1 </a>
</span>
<a class="penci-image-holder penci-lazy" data-src="https://i2.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/01/Sean-Bratches.jpg?resize=585%2C390&#038;ssl=1" href="https://www.thecheckeredflag.co.uk/2020/01/bratches-steps-down-as-formula-1s-head-of-commercial-operations/" title="Bratches steps down as Formula 1&#8217;s head of commercial operations">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.thecheckeredflag.co.uk/2020/01/bratches-steps-down-as-formula-1s-head-of-commercial-operations/" title="Bratches steps down as Formula 1&#8217;s head of commercial operations">Bratches steps down as Formula 1&#8217;s head of&#8230;</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2020-01-21T14:47:46+00:00">January 21, 2020</time></p>
</div>
</div>
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.thecheckeredflag.co.uk/formula-1/">
Formula 1 </a>
</span>
<a class="penci-image-holder penci-lazy" data-src="https://i1.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/01/Webp.net-resizeimage-86.jpg?resize=585%2C390&#038;ssl=1" href="https://www.thecheckeredflag.co.uk/2020/01/latifi-chooses-number-six-for-maiden-f1-season/" title="Latifi chooses number six for maiden F1 season">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.thecheckeredflag.co.uk/2020/01/latifi-chooses-number-six-for-maiden-f1-season/" title="Latifi chooses number six for maiden F1 season">Latifi chooses number six for maiden F1 season</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2020-01-21T12:44:57+00:00">January 21, 2020</time></p>
</div>
</div>
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.thecheckeredflag.co.uk/formula-1/">
Formula 1 </a>
</span>
<a class="penci-image-holder penci-lazy" data-src="https://i1.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/01/Roy-Nissany-Foto-REUTERS-Corinna-Kern.jpg?resize=585%2C390&#038;ssl=1" href="https://www.thecheckeredflag.co.uk/2020/01/roy-nissanys-test-driver-role-linked-to-2021-israeli-grand-prix-push/" title="Roy Nissany&#8217;s test driver role linked to 2021 Israeli Grand Prix push">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.thecheckeredflag.co.uk/2020/01/roy-nissanys-test-driver-role-linked-to-2021-israeli-grand-prix-push/" title="Roy Nissany&#8217;s test driver role linked to 2021 Israeli Grand Prix push">Roy Nissany&#8217;s test driver role linked to 2021&#8230;</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2020-01-20T05:20:56+00:00">January 20, 2020</time></p>
</div>
</div>
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.thecheckeredflag.co.uk/formula-1/">
Formula 1 </a>
</span>
<a class="penci-image-holder penci-lazy" data-src="https://i1.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/01/Sergio-Perez-47.jpg?resize=585%2C390&#038;ssl=1" href="https://www.thecheckeredflag.co.uk/2020/01/perez-on-racing-points-2020-chances-there-is-very-big-huge-potential-in-this-team/" title="Pérez on Racing Point’s 2020 Chances: “There is very big, huge potential in this team”">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.thecheckeredflag.co.uk/2020/01/perez-on-racing-points-2020-chances-there-is-very-big-huge-potential-in-this-team/" title="Pérez on Racing Point’s 2020 Chances: “There is very big, huge potential in this team”">Pérez on Racing Point’s 2020 Chances: “There is&#8230;</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2020-01-19T17:54:19+00:00">January 19, 2020</time></p>
</div>
</div>
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.thecheckeredflag.co.uk/formula-1/">
Formula 1 </a>
</span>
<a class="penci-image-holder penci-lazy" data-src="https://i2.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/01/Claire-Williams-01.jpg?resize=585%2C390&#038;ssl=1" href="https://www.thecheckeredflag.co.uk/2020/01/no-concerns-over-williams-2020-racing-budget-claire-williams/" title="‘No Concerns’ over Williams’ 2020 Racing Budget – Claire Williams">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.thecheckeredflag.co.uk/2020/01/no-concerns-over-williams-2020-racing-budget-claire-williams/" title="‘No Concerns’ over Williams’ 2020 Racing Budget – Claire Williams">‘No Concerns’ over Williams’ 2020 Racing Budget –&#8230;</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2020-01-19T17:15:23+00:00">January 19, 2020</time></p>
</div>
</div>
</div>
</div>
</div>
</div></li>
</ul>
</li>
<li id="menu-item-131940" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-131940"><a href="https://www.thecheckeredflag.co.uk/open-wheel/">Open Wheel</a>
<ul class="sub-menu">
<li id="menu-item-131942" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131942"><a href="https://www.thecheckeredflag.co.uk/open-wheel/formula-e/">FIA Formula E</a></li>
<li id="menu-item-131943" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131943"><a href="https://www.thecheckeredflag.co.uk/open-wheel/indycar/">IndyCar</a></li>
<li id="menu-item-218310" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-218310"><a href="https://www.thecheckeredflag.co.uk/open-wheel/fia-formula-2/">FIA Formula 2</a></li>
<li id="menu-item-296601" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-296601"><a href="https://www.thecheckeredflag.co.uk/open-wheel/formula-3/fia-formula-3-championship/">FIA Formula 3</a></li>
<li id="menu-item-321059" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-321059"><a href="https://www.thecheckeredflag.co.uk/open-wheel/w-series/">W Series</a></li>
<li id="menu-item-180961" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-180961"><a href="https://www.thecheckeredflag.co.uk/open-wheel/formula-3/british-f3-formula-3/">British F3</a></li>
<li id="menu-item-131897" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131897"><a href="https://www.thecheckeredflag.co.uk/open-wheel/msa-formula/">F4 British Championship</a></li>
<li id="menu-item-131946" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131946"><a href="https://www.thecheckeredflag.co.uk/open-wheel/formula-3/euroformula-open/">EuroFormula Open</a></li>
<li id="menu-item-131989" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131989"><a href="https://www.thecheckeredflag.co.uk/open-wheel/renault-world-series/formula-renault-2-0-renault-world-series/">Formula Renault 2.0</a></li>
</ul>
</li>
<li id="menu-item-131952" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-131952"><a href="https://www.thecheckeredflag.co.uk/sportscars/">Sportscars</a>
<ul class="sub-menu">
<li id="menu-item-131956" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131956"><a href="https://www.thecheckeredflag.co.uk/sportscars/endurance/fiawec/">FIA WEC</a></li>
<li id="menu-item-131957" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131957"><a href="https://www.thecheckeredflag.co.uk/sportscars/endurance/blancpain-endurance-series/">Blancpain Endurance</a></li>
<li id="menu-item-148232" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-148232"><a href="https://www.thecheckeredflag.co.uk/sportscars/endurance/blancpain-sprint/">GT World Challenge Europe</a></li>
<li id="menu-item-131954" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131954"><a href="https://www.thecheckeredflag.co.uk/sportscars/gt-sportscars/british-gt/">British GT</a></li>
<li id="menu-item-290801" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-290801"><a href="https://www.thecheckeredflag.co.uk/sportscars/ginetta/">Ginetta Series</a></li>
<li id="menu-item-303742" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-303742"><a href="https://www.thecheckeredflag.co.uk/sportscars/porsche/">Porsche Series</a></li>
</ul>
</li>
<li id="menu-item-131899" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-131899"><a href="https://www.thecheckeredflag.co.uk/touring-cars/">Touring Cars</a>
<ul class="sub-menu">
<li id="menu-item-131904" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131904"><a href="https://www.thecheckeredflag.co.uk/touring-cars/btcc/">BTCC</a></li>
<li id="menu-item-192543" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-192543"><a href="https://www.thecheckeredflag.co.uk/touring-cars/dtm/">DTM</a></li>
<li id="menu-item-317944" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-317944"><a href="https://www.thecheckeredflag.co.uk/touring-cars/jaguar-i-pace-etrophy/">Jaguar I-PACE eTROPHY</a></li>
</ul>
</li>
<li id="menu-item-131918" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-131918"><a href="https://www.thecheckeredflag.co.uk/motorcycles/">Motorcycles</a>
<ul class="sub-menu">
<li id="menu-item-131922" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131922"><a href="https://www.thecheckeredflag.co.uk/motorcycles/motogp/">MotoGP</a></li>
<li id="menu-item-131920" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131920"><a href="https://www.thecheckeredflag.co.uk/motorcycles/moto2/">Moto2</a></li>
<li id="menu-item-131921" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131921"><a href="https://www.thecheckeredflag.co.uk/motorcycles/moto3/">Moto3</a></li>
</ul>
</li>
<li id="menu-item-290798" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor menu-item-has-children menu-item-290798"><a href="https://www.thecheckeredflag.co.uk/offroad/">Off Road</a>
<ul class="sub-menu">
<li id="menu-item-254211" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-254211"><a href="https://www.thecheckeredflag.co.uk/offroad/rally/fiawrc/">FIA WRC</a></li>
<li id="menu-item-138301" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-138301"><a href="https://www.thecheckeredflag.co.uk/offroad/rally/fia-erc/">FIA ERC</a></li>
<li id="menu-item-131910" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-131910"><a href="https://www.thecheckeredflag.co.uk/offroad/rally/british-rally-championship/">British Rally Championship</a></li>
<li id="menu-item-131917" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131917"><a href="https://www.thecheckeredflag.co.uk/offroad/rallycross/world-rallycross/">FIA World RX</a></li>
<li id="menu-item-131913" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131913"><a href="https://www.thecheckeredflag.co.uk/offroad/rallycross/european-rallycross/">FIA European RX</a></li>
</ul>
</li>
<li id="menu-item-290800" class="menu-item menu-item-type-taxonomy menu-item-object-category penci-mega-menu menu-item-290800"><a href="https://www.thecheckeredflag.co.uk/nascar/">NASCAR</a>
<ul class="sub-menu">
<li class="menu-item-0"><div class="penci-megamenu"> <div class="penci-mega-child-categories">
<a class="mega-cat-child" href="https://www.thecheckeredflag.co.uk/nascar/sprint-cup/" data-id="penci-mega-2741"><span>NASCAR Cup Series</span></a>
<a class="mega-cat-child" href="https://www.thecheckeredflag.co.uk/nascar/nascar-trucks/" data-id="penci-mega-18305"><span>NASCAR Gander Trucks</span></a>
<a class="mega-cat-child" href="https://www.thecheckeredflag.co.uk/nascar/euro-racecar/" data-id="penci-mega-8304"><span>NASCAR Whelen Euro Series</span></a>
<a class="mega-cat-child" href="https://www.thecheckeredflag.co.uk/nascar/nascar-xfinity-series/" data-id="penci-mega-2742"><span>NASCAR Xfinity Series</span></a>
<a class="mega-cat-child cat-active all-style" href="https://www.thecheckeredflag.co.uk/nascar/" data-id="penci-mega-108"><span>All</span></a>
</div>
<div class="penci-content-megamenu">
<div class="penci-mega-latest-posts col-mn-4 mega-row-1">
<div class="penci-mega-row penci-mega-2741">
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.thecheckeredflag.co.uk/nascar/sprint-cup/">NASCAR Cup Series</a> </span>
<a class="penci-image-holder penci-lazy" data-src="https://i0.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/01/mcdowell_michael_600miles_2019.jpg?resize=585%2C390&#038;ssl=1" href="https://www.thecheckeredflag.co.uk/2020/01/front-row-motorsports-sign-extension-with-ford/" title="Front Row Motorsports sign extension with Ford">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.thecheckeredflag.co.uk/2020/01/front-row-motorsports-sign-extension-with-ford/" title="Front Row Motorsports sign extension with Ford">Front Row Motorsports sign extension with Ford</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2020-01-21T18:10:41+00:00">January 21, 2020</time></p>
</div>
</div>
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.thecheckeredflag.co.uk/nascar/sprint-cup/">NASCAR Cup Series</a> </span>
<a class="penci-image-holder penci-lazy" data-src="https://i2.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/01/kligerman_parker_600miles_2019.jpg?resize=585%2C390&#038;ssl=1" href="https://www.thecheckeredflag.co.uk/2020/01/parker-kligerman-not-returning-to-gaunt-brothers-racing/" title="Parker Kligerman not returning to Gaunt Brothers Racing">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.thecheckeredflag.co.uk/2020/01/parker-kligerman-not-returning-to-gaunt-brothers-racing/" title="Parker Kligerman not returning to Gaunt Brothers Racing">Parker Kligerman not returning to Gaunt Brothers Racing</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2020-01-18T01:31:10+00:00">January 18, 2020</time></p>
</div>
</div>
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.thecheckeredflag.co.uk/nascar/sprint-cup/">NASCAR Cup Series</a> </span>
<a class="penci-image-holder penci-lazy" data-src="https://i0.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/01/Erik-Jones-NextGen-Homestead-test-2020.jpg?resize=585%2C390&#038;ssl=1" href="https://www.thecheckeredflag.co.uk/2020/01/erik-jones-tests-next-gen-car-at-homestead/" title="Erik Jones tests Next Gen car at Homestead">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.thecheckeredflag.co.uk/2020/01/erik-jones-tests-next-gen-car-at-homestead/" title="Erik Jones tests Next Gen car at Homestead">Erik Jones tests Next Gen car at Homestead</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2020-01-17T03:36:08+00:00">January 17, 2020</time></p>
</div>
</div>
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.thecheckeredflag.co.uk/nascar/sprint-cup/">NASCAR Cup Series</a> </span>
<a class="penci-image-holder penci-lazy" data-src="https://i2.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/01/Chase-Elliott-Truex-Watkins-Glen-2019-MENCS.jpg?resize=585%2C390&#038;ssl=1" href="https://www.thecheckeredflag.co.uk/2020/01/nascar-cup-series-lowers-downforce-for-road-shorter-ovals/" title="NASCAR Cup Series lowers downforce for road, shorter ovals">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.thecheckeredflag.co.uk/2020/01/nascar-cup-series-lowers-downforce-for-road-shorter-ovals/" title="NASCAR Cup Series lowers downforce for road, shorter ovals">NASCAR Cup Series lowers downforce for road, shorter&#8230;</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2020-01-14T19:39:44+00:00">January 14, 2020</time></p>
</div>
</div>
</div>
<div class="penci-mega-row penci-mega-18305">
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.thecheckeredflag.co.uk/nascar/nascar-trucks/">NASCAR Gander Trucks</a> </span>
<a class="penci-image-holder penci-lazy" data-src="https://i1.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/01/Howie-DiSavino-ARCA-2019.jpg?resize=585%2C390&#038;ssl=1" href="https://www.thecheckeredflag.co.uk/2020/01/win-tron-racing-returning-to-truck-series-with-howie-disavino-iii/" title="Win-Tron Racing returning to Truck Series with Howie DiSavino III">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.thecheckeredflag.co.uk/2020/01/win-tron-racing-returning-to-truck-series-with-howie-disavino-iii/" title="Win-Tron Racing returning to Truck Series with Howie DiSavino III">Win-Tron Racing returning to Truck Series with Howie&#8230;</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2020-01-21T22:12:18+00:00">January 21, 2020</time></p>
</div>
</div>
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.thecheckeredflag.co.uk/nascar/nascar-trucks/">NASCAR Gander Trucks</a> </span>
<a class="penci-image-holder penci-lazy" data-src="https://i1.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2019/08/MIS2_NGOTS_PlayoffDrivers_081019.jpg?resize=585%2C390&#038;ssl=1" href="https://www.thecheckeredflag.co.uk/2020/01/truck-series-playoffs-expands-to-ten-drivers/" title="Truck Series playoffs expands to ten drivers">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.thecheckeredflag.co.uk/2020/01/truck-series-playoffs-expands-to-ten-drivers/" title="Truck Series playoffs expands to ten drivers">Truck Series playoffs expands to ten drivers</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2020-01-21T19:48:59+00:00">January 21, 2020</time></p>
</div>
</div>
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.thecheckeredflag.co.uk/nascar/nascar-trucks/">NASCAR Gander Trucks</a> </span>
<a class="penci-image-holder penci-lazy" data-src="https://i0.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/01/Derek-Kraus-NGOTS-2019-Martinsville-truck.jpg?resize=585%2C390&#038;ssl=1" href="https://www.thecheckeredflag.co.uk/2020/01/mcanally-hilgemann-racing-formed-to-field-gander-truck-ride-for-derek-kraus/" title="McAnally-Hilgemann Racing formed, to field Gander Truck ride for Derek Kraus">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.thecheckeredflag.co.uk/2020/01/mcanally-hilgemann-racing-formed-to-field-gander-truck-ride-for-derek-kraus/" title="McAnally-Hilgemann Racing formed, to field Gander Truck ride for Derek Kraus">McAnally-Hilgemann Racing formed, to field Gander Truck ride&#8230;</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2020-01-13T20:30:05+00:00">January 13, 2020</time></p>
</div>
</div>
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.thecheckeredflag.co.uk/nascar/nascar-trucks/">NASCAR Gander Trucks</a> </span>
<a class="penci-image-holder penci-lazy" data-src="https://i1.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/01/Todd-Gilliland-NGOTS-2019-Martinsville-VL.jpg?resize=585%2C390&#038;ssl=1" href="https://www.thecheckeredflag.co.uk/2020/01/front-row-motorsports-forms-gander-trucks-team-to-field-todd-gilliland/" title="Front Row Motorsports forms Gander Trucks team, to field Todd Gilliland">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.thecheckeredflag.co.uk/2020/01/front-row-motorsports-forms-gander-trucks-team-to-field-todd-gilliland/" title="Front Row Motorsports forms Gander Trucks team, to field Todd Gilliland">Front Row Motorsports forms Gander Trucks team, to&#8230;</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2020-01-13T18:16:10+00:00">January 13, 2020</time></p>
</div>
</div>
</div>
<div class="penci-mega-row penci-mega-8304">
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.thecheckeredflag.co.uk/nascar/euro-racecar/">NASCAR Whelen Euro Series</a> </span>
<a class="penci-image-holder penci-lazy" data-src="https://i0.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2019/10/Memphis-Racing-23-2019-NWES.jpg?resize=585%2C390&#038;ssl=1" href="https://www.thecheckeredflag.co.uk/2019/10/2020-nascar-whelen-euro-series-schedule-released/" title="2020 NASCAR Whelen Euro Series schedule released">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.thecheckeredflag.co.uk/2019/10/2020-nascar-whelen-euro-series-schedule-released/" title="2020 NASCAR Whelen Euro Series schedule released">2020 NASCAR Whelen Euro Series schedule released</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2019-10-22T17:43:44+01:00">October 22, 2019</time></p>
</div>
</div>
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.thecheckeredflag.co.uk/nascar/euro-racecar/">NASCAR Whelen Euro Series</a> </span>
<a class="penci-image-holder penci-lazy" data-src="https://i0.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2019/10/NWES-Team-FJ-2030-partnership.jpg?resize=585%2C390&#038;ssl=1" href="https://www.thecheckeredflag.co.uk/2019/10/nascar-team-fj-sign-ten-year-extension-for-whelen-euro-series-sanction/" title="NASCAR, Team FJ sign ten-year extension for Whelen Euro Series sanction">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.thecheckeredflag.co.uk/2019/10/nascar-team-fj-sign-ten-year-extension-for-whelen-euro-series-sanction/" title="NASCAR, Team FJ sign ten-year extension for Whelen Euro Series sanction">NASCAR, Team FJ sign ten-year extension for Whelen&#8230;</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2019-10-04T16:25:28+01:00">October 4, 2019</time></p>
</div>
</div>
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.thecheckeredflag.co.uk/nascar/euro-racecar/">NASCAR Whelen Euro Series</a> </span>
<a class="penci-image-holder penci-lazy" data-src="https://i0.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2019/04/Ander-Vilarino-Valencia-2019-NWES.jpg?resize=585%2C390&#038;ssl=1" href="https://www.thecheckeredflag.co.uk/2019/04/vilarino-maggi-risitano-kick-off-2019-euro-series-with-valencia-victories/" title="Vilarino, Maggi, Risitano kick off 2019 Euro Series with Valencia victories">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.thecheckeredflag.co.uk/2019/04/vilarino-maggi-risitano-kick-off-2019-euro-series-with-valencia-victories/" title="Vilarino, Maggi, Risitano kick off 2019 Euro Series with Valencia victories">Vilarino, Maggi, Risitano kick off 2019 Euro Series&#8230;</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2019-04-15T05:25:02+01:00">April 15, 2019</time></p>
</div>
</div>
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.thecheckeredflag.co.uk/nascar/euro-racecar/">NASCAR Whelen Euro Series</a> </span>
<a class="penci-image-holder penci-lazy" data-src="https://i1.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2019/04/Euro-NASCAR-18-32-paddock.jpg?resize=585%2C390&#038;ssl=1" href="https://www.thecheckeredflag.co.uk/2019/04/nascar-gp-of-spain-featuring-decorated-grid/" title="NASCAR GP of Spain featuring decorated grid">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.thecheckeredflag.co.uk/2019/04/nascar-gp-of-spain-featuring-decorated-grid/" title="NASCAR GP of Spain featuring decorated grid">NASCAR GP of Spain featuring decorated grid</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2019-04-10T18:07:18+01:00">April 10, 2019</time></p>
</div>
</div>
</div>
<div class="penci-mega-row penci-mega-2742">
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.thecheckeredflag.co.uk/nascar/nascar-xfinity-series/">NASCAR Xfinity Series</a> </span>
<a class="penci-image-holder penci-lazy" data-src="https://i2.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/01/harmon_2019nxs_carshot.jpg?resize=585%2C390&#038;ssl=1" href="https://www.thecheckeredflag.co.uk/2020/01/mike-harmon-racing-opens-second-car-for-2020-xfinity-series/" title="Mike Harmon Racing opens second car for 2020 Xfinity Series">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.thecheckeredflag.co.uk/2020/01/mike-harmon-racing-opens-second-car-for-2020-xfinity-series/" title="Mike Harmon Racing opens second car for 2020 Xfinity Series">Mike Harmon Racing opens second car for 2020&#8230;</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2020-01-19T23:19:38+00:00">January 19, 2020</time></p>
</div>
</div>
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.thecheckeredflag.co.uk/nascar/nascar-xfinity-series/">NASCAR Xfinity Series</a> </span>
<a class="penci-image-holder penci-lazy" data-src="https://i2.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/01/mencs_ks_hemric_car_101919.jpg?resize=585%2C390&#038;ssl=1" href="https://www.thecheckeredflag.co.uk/2020/01/daniel-hemric-reveals-21-race-xfinity-schedule/" title="Daniel Hemric reveals 21-race Xfinity schedule">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.thecheckeredflag.co.uk/2020/01/daniel-hemric-reveals-21-race-xfinity-schedule/" title="Daniel Hemric reveals 21-race Xfinity schedule">Daniel Hemric reveals 21-race Xfinity schedule</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2020-01-16T20:09:25+00:00">January 16, 2020</time></p>
</div>
</div>
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.thecheckeredflag.co.uk/nascar/nascar-xfinity-series/">NASCAR Xfinity Series</a> </span>
<a class="penci-image-holder penci-lazy" data-src="https://i0.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/01/Joe-Graf-Jr-NXS-Iowa-2019.jpg?resize=585%2C390&#038;ssl=1" href="https://www.thecheckeredflag.co.uk/2020/01/joe-graf-jr-joins-ss-green-light-for-2020-xfinity-season/" title="Joe Graf Jr. joins SS-Green Light for 2020 Xfinity season">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.thecheckeredflag.co.uk/2020/01/joe-graf-jr-joins-ss-green-light-for-2020-xfinity-season/" title="Joe Graf Jr. joins SS-Green Light for 2020 Xfinity season">Joe Graf Jr. joins SS-Green Light for 2020&#8230;</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2020-01-16T18:47:32+00:00">January 16, 2020</time></p>
</div>
</div>
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.thecheckeredflag.co.uk/nascar/nascar-xfinity-series/">NASCAR Xfinity Series</a> </span>
<a class="penci-image-holder penci-lazy" data-src="https://i2.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/01/Kyle-Busch-IMS-NXS-2019-checkered.jpg?resize=585%2C390&#038;ssl=1" href="https://www.thecheckeredflag.co.uk/2020/01/xfinity-series-to-run-indianapolis-road-course/" title="Xfinity Series to run Indianapolis road course">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.thecheckeredflag.co.uk/2020/01/xfinity-series-to-run-indianapolis-road-course/" title="Xfinity Series to run Indianapolis road course">Xfinity Series to run Indianapolis road course</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2020-01-16T04:15:14+00:00">January 16, 2020</time></p>
</div>
</div>
</div>
<div class="penci-mega-row penci-mega-108 row-active">
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.thecheckeredflag.co.uk/nascar/">NASCAR</a> </span>
<a class="penci-image-holder penci-lazy" data-src="https://i1.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/01/Howie-DiSavino-ARCA-2019.jpg?resize=585%2C390&#038;ssl=1" href="https://www.thecheckeredflag.co.uk/2020/01/win-tron-racing-returning-to-truck-series-with-howie-disavino-iii/" title="Win-Tron Racing returning to Truck Series with Howie DiSavino III">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.thecheckeredflag.co.uk/2020/01/win-tron-racing-returning-to-truck-series-with-howie-disavino-iii/" title="Win-Tron Racing returning to Truck Series with Howie DiSavino III">Win-Tron Racing returning to Truck Series with Howie&#8230;</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2020-01-21T22:12:18+00:00">January 21, 2020</time></p>
</div>
</div>
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.thecheckeredflag.co.uk/nascar/">NASCAR</a> </span>
<a class="penci-image-holder penci-lazy" data-src="https://i1.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2019/08/MIS2_NGOTS_PlayoffDrivers_081019.jpg?resize=585%2C390&#038;ssl=1" href="https://www.thecheckeredflag.co.uk/2020/01/truck-series-playoffs-expands-to-ten-drivers/" title="Truck Series playoffs expands to ten drivers">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.thecheckeredflag.co.uk/2020/01/truck-series-playoffs-expands-to-ten-drivers/" title="Truck Series playoffs expands to ten drivers">Truck Series playoffs expands to ten drivers</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2020-01-21T19:48:59+00:00">January 21, 2020</time></p>
</div>
</div>
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.thecheckeredflag.co.uk/nascar/">NASCAR</a> </span>
<a class="penci-image-holder penci-lazy" data-src="https://i0.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/01/mcdowell_michael_600miles_2019.jpg?resize=585%2C390&#038;ssl=1" href="https://www.thecheckeredflag.co.uk/2020/01/front-row-motorsports-sign-extension-with-ford/" title="Front Row Motorsports sign extension with Ford">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.thecheckeredflag.co.uk/2020/01/front-row-motorsports-sign-extension-with-ford/" title="Front Row Motorsports sign extension with Ford">Front Row Motorsports sign extension with Ford</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2020-01-21T18:10:41+00:00">January 21, 2020</time></p>
</div>
</div>
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.thecheckeredflag.co.uk/nascar/">NASCAR</a> </span>
<a class="penci-image-holder penci-lazy" data-src="https://i2.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/01/harmon_2019nxs_carshot.jpg?resize=585%2C390&#038;ssl=1" href="https://www.thecheckeredflag.co.uk/2020/01/mike-harmon-racing-opens-second-car-for-2020-xfinity-series/" title="Mike Harmon Racing opens second car for 2020 Xfinity Series">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.thecheckeredflag.co.uk/2020/01/mike-harmon-racing-opens-second-car-for-2020-xfinity-series/" title="Mike Harmon Racing opens second car for 2020 Xfinity Series">Mike Harmon Racing opens second car for 2020&#8230;</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2020-01-19T23:19:38+00:00">January 19, 2020</time></p>
</div>
</div>
</div>
</div>
</div>
</div></li>
</ul>
</li>
<li id="menu-item-293110" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-293110"><a href="https://www.thecheckeredflag.co.uk/features/">Features</a>
<ul class="sub-menu">
<li id="menu-item-293115" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-293115"><a href="https://www.thecheckeredflag.co.uk/features/opinion/">Opinion</a></li>
<li id="menu-item-293113" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-293113"><a href="https://www.thecheckeredflag.co.uk/features/interviews/">Interviews</a></li>
<li id="menu-item-293114" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-293114"><a href="https://www.thecheckeredflag.co.uk/features/gallery/">Gallery</a></li>
<li id="menu-item-293111" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-293111"><a href="https://www.thecheckeredflag.co.uk/features/product-review/">Product Review</a></li>
<li id="menu-item-293112" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-293112"><a href="https://www.thecheckeredflag.co.uk/features/season-review/">Season Review</a></li>
<li id="menu-item-293118" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-293118"><a href="https://www.thecheckeredflag.co.uk/other/esports/">eSports</a></li>
<li id="menu-item-293117" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-293117"><a href="https://www.thecheckeredflag.co.uk/other/video-games/">Sim Racing</a></li>
</ul>
</li>
</ul> </nav>
<div class="wrapper-boxed header-style-header-5 penci-hlogo-center">
<div class="penci-header-wrap"><div class="penci-top-bar">
<div class="container">
<div class="penci-headline" role="navigation" itemscope itemtype="https://schema.org/SiteNavigationElement">
<span class="headline-title">Latest</span>
<div class="penci-topbar-social">
<div class="inner-header-social">
<a href="https://facebook.com/TheCheckeredFlag" rel="nofollow" target="_blank"><i class="penci-faicon fa fa-facebook"></i></a>
<a href="https://twitter.com/TheCheckerFlag" rel="nofollow" target="_blank"><i class="penci-faicon fa fa-twitter"></i></a>
<a href="https://instagram.com/thecheckeredflag/" rel="nofollow" target="_blank"><i class="penci-faicon fa fa-instagram"></i></a>
<a href="https://www.linkedin.com/company/thecheckeredflag/" rel="nofollow" target="_blank"><i class="penci-faicon fa fa-linkedin"></i></a>
<a href="https://www.youtube.com/channel/UCueRVoGbSE4GF2RszehXIgw" rel="nofollow" target="_blank"><i class="penci-faicon fa fa-youtube-play"></i></a>
<a href="https://www.thecheckeredflag.co.uk/feed" rel="nofollow" target="_blank"><i class="penci-faicon fa fa-rss"></i></a>
</div> </div>
<div class="penci-owl-carousel penci-owl-carousel-slider penci-headline-posts" data-auto="true" data-autotime="3000" data-speed="200">
<div>
<a class="penci-topbar-post-title" href="https://www.thecheckeredflag.co.uk/2020/01/preview-2020-fia-world-rally-championship-rally-monte-carlo-all-change-at-the-top-for-2020/">PREVIEW: 2020 FIA World Rally Championship – Rally Monte-Carlo: All Change at the Top for...</a>
</div>
<div>
<a class="penci-topbar-post-title" href="https://www.thecheckeredflag.co.uk/2020/01/creighton-aiming-for-jwrc-2021-bid-with-2020-jbrc-title-challenge/">Creighton aiming for JWRC 2021 bid with 2020 JBRC title challenge</a>
</div>
<div>
<a class="penci-topbar-post-title" href="https://www.thecheckeredflag.co.uk/2020/01/esmee-hawkey-targeting-porsche-carrera-cup-gb-title-with-team-parker-racing/">Esmee Hawkey targeting Porsche Carrera Cup GB title with Team Parker Racing</a>
</div>
<div>
<a class="penci-topbar-post-title" href="https://www.thecheckeredflag.co.uk/2020/01/newcomer-jackson-hopes-to-secure-the-title-in-jbrc/">Newcomer Jackson hopes to secure the title in JBRC</a>
</div>
<div>
<a class="penci-topbar-post-title" href="https://www.thecheckeredflag.co.uk/2020/01/brc-academy-trophy-to-be-introduced-this-year-for-youngsters-to-shine/">BRC Academy Trophy to be introduced this year for youngsters to shine</a>
</div>
<div>
<a class="penci-topbar-post-title" href="https://www.thecheckeredflag.co.uk/2020/01/carmichael-to-enter-the-new-motorsport-uk-national-championship/">Carmichael to enter the new Motorsport UK National Championship</a>
</div>
<div>
<a class="penci-topbar-post-title" href="https://www.thecheckeredflag.co.uk/2020/01/win-tron-racing-returning-to-truck-series-with-howie-disavino-iii/">Win-Tron Racing returning to Truck Series with Howie DiSavino III</a>
</div>
<div>
<a class="penci-topbar-post-title" href="https://www.thecheckeredflag.co.uk/2020/01/season-review-2019-f4-british-championship-maloney-seals-one-of-the-closest-title-fights-yet/">SEASON REVIEW: 2019 F4 BRITISH CHAMPIONSHIP – MALONEY SEALS ONE OF THE CLOSEST TITLE FIGHTS...</a>
</div>
<div>
<a class="penci-topbar-post-title" href="https://www.thecheckeredflag.co.uk/2020/01/truck-series-playoffs-expands-to-ten-drivers/">Truck Series playoffs expands to ten drivers</a>
</div>
<div>
<a class="penci-topbar-post-title" href="https://www.thecheckeredflag.co.uk/2020/01/belgian-motorcycle-academy-the-latest-to-become-a-pathway-to-motogp/">Belgian Motorcycle Academy the latest to become a Pathway to MotoGP</a>
</div>
</div>
</div>
</div>
</div><header id="header" class="header-header-5 has-bottom-line" itemscope="itemscope" itemtype="https://schema.org/WPHeader">
<div class="inner-header penci-header-second">
<div class="container container-fullwidth">
<div id="logo">
<a href="https://www.thecheckeredflag.co.uk/"><img src="https://www.thecheckeredflag.co.uk/wp-content/uploads/2019/10/TCF-Header-2019.png" alt="The Checkered Flag" /></a> </div>
</div>
</div>
<nav id="navigation" class="header-layout-bottom header-5 menu-style-2 menu-item-padding" role="navigation" itemscope itemtype="https://schema.org/SiteNavigationElement">
<div class="container container-fullwidth">
<div class="button-menu-mobile header-5"><i class="penci-faicon fa fa-bars"></i></div>
<ul id="menu-2016" class="menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category penci-mega-menu menu-item-131887"><a href="https://www.thecheckeredflag.co.uk/formula-1/">F1</a>
<ul class="sub-menu">
<li class="menu-item-0"><div class="penci-megamenu">
<div class="penci-content-megamenu">
<div class="penci-mega-latest-posts col-mn-5 mega-row-1">
<div class="penci-mega-row penci-mega-3 row-active">
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.thecheckeredflag.co.uk/formula-1/">
Formula 1 </a>
</span>
<a class="penci-image-holder penci-lazy" data-src="https://i2.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/01/Sean-Bratches.jpg?resize=585%2C390&#038;ssl=1" href="https://www.thecheckeredflag.co.uk/2020/01/bratches-steps-down-as-formula-1s-head-of-commercial-operations/" title="Bratches steps down as Formula 1&#8217;s head of commercial operations">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.thecheckeredflag.co.uk/2020/01/bratches-steps-down-as-formula-1s-head-of-commercial-operations/" title="Bratches steps down as Formula 1&#8217;s head of commercial operations">Bratches steps down as Formula 1&#8217;s head of&#8230;</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2020-01-21T14:47:46+00:00">January 21, 2020</time></p>
</div>
</div>
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.thecheckeredflag.co.uk/formula-1/">
Formula 1 </a>
</span>
<a class="penci-image-holder penci-lazy" data-src="https://i1.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/01/Webp.net-resizeimage-86.jpg?resize=585%2C390&#038;ssl=1" href="https://www.thecheckeredflag.co.uk/2020/01/latifi-chooses-number-six-for-maiden-f1-season/" title="Latifi chooses number six for maiden F1 season">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.thecheckeredflag.co.uk/2020/01/latifi-chooses-number-six-for-maiden-f1-season/" title="Latifi chooses number six for maiden F1 season">Latifi chooses number six for maiden F1 season</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2020-01-21T12:44:57+00:00">January 21, 2020</time></p>
</div>
</div>
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.thecheckeredflag.co.uk/formula-1/">
Formula 1 </a>
</span>
<a class="penci-image-holder penci-lazy" data-src="https://i1.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/01/Roy-Nissany-Foto-REUTERS-Corinna-Kern.jpg?resize=585%2C390&#038;ssl=1" href="https://www.thecheckeredflag.co.uk/2020/01/roy-nissanys-test-driver-role-linked-to-2021-israeli-grand-prix-push/" title="Roy Nissany&#8217;s test driver role linked to 2021 Israeli Grand Prix push">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.thecheckeredflag.co.uk/2020/01/roy-nissanys-test-driver-role-linked-to-2021-israeli-grand-prix-push/" title="Roy Nissany&#8217;s test driver role linked to 2021 Israeli Grand Prix push">Roy Nissany&#8217;s test driver role linked to 2021&#8230;</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2020-01-20T05:20:56+00:00">January 20, 2020</time></p>
</div>
</div>
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.thecheckeredflag.co.uk/formula-1/">
Formula 1 </a>
</span>
<a class="penci-image-holder penci-lazy" data-src="https://i1.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/01/Sergio-Perez-47.jpg?resize=585%2C390&#038;ssl=1" href="https://www.thecheckeredflag.co.uk/2020/01/perez-on-racing-points-2020-chances-there-is-very-big-huge-potential-in-this-team/" title="Pérez on Racing Point’s 2020 Chances: “There is very big, huge potential in this team”">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.thecheckeredflag.co.uk/2020/01/perez-on-racing-points-2020-chances-there-is-very-big-huge-potential-in-this-team/" title="Pérez on Racing Point’s 2020 Chances: “There is very big, huge potential in this team”">Pérez on Racing Point’s 2020 Chances: “There is&#8230;</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2020-01-19T17:54:19+00:00">January 19, 2020</time></p>
</div>
</div>
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.thecheckeredflag.co.uk/formula-1/">
Formula 1 </a>
</span>
<a class="penci-image-holder penci-lazy" data-src="https://i2.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/01/Claire-Williams-01.jpg?resize=585%2C390&#038;ssl=1" href="https://www.thecheckeredflag.co.uk/2020/01/no-concerns-over-williams-2020-racing-budget-claire-williams/" title="‘No Concerns’ over Williams’ 2020 Racing Budget – Claire Williams">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.thecheckeredflag.co.uk/2020/01/no-concerns-over-williams-2020-racing-budget-claire-williams/" title="‘No Concerns’ over Williams’ 2020 Racing Budget – Claire Williams">‘No Concerns’ over Williams’ 2020 Racing Budget –&#8230;</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2020-01-19T17:15:23+00:00">January 19, 2020</time></p>
</div>
</div>
</div>
</div>
</div>
</div></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-131940"><a href="https://www.thecheckeredflag.co.uk/open-wheel/">Open Wheel</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131942"><a href="https://www.thecheckeredflag.co.uk/open-wheel/formula-e/">FIA Formula E</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131943"><a href="https://www.thecheckeredflag.co.uk/open-wheel/indycar/">IndyCar</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-218310"><a href="https://www.thecheckeredflag.co.uk/open-wheel/fia-formula-2/">FIA Formula 2</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-296601"><a href="https://www.thecheckeredflag.co.uk/open-wheel/formula-3/fia-formula-3-championship/">FIA Formula 3</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-321059"><a href="https://www.thecheckeredflag.co.uk/open-wheel/w-series/">W Series</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-180961"><a href="https://www.thecheckeredflag.co.uk/open-wheel/formula-3/british-f3-formula-3/">British F3</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131897"><a href="https://www.thecheckeredflag.co.uk/open-wheel/msa-formula/">F4 British Championship</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131946"><a href="https://www.thecheckeredflag.co.uk/open-wheel/formula-3/euroformula-open/">EuroFormula Open</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131989"><a href="https://www.thecheckeredflag.co.uk/open-wheel/renault-world-series/formula-renault-2-0-renault-world-series/">Formula Renault 2.0</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-131952"><a href="https://www.thecheckeredflag.co.uk/sportscars/">Sportscars</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131956"><a href="https://www.thecheckeredflag.co.uk/sportscars/endurance/fiawec/">FIA WEC</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131957"><a href="https://www.thecheckeredflag.co.uk/sportscars/endurance/blancpain-endurance-series/">Blancpain Endurance</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-148232"><a href="https://www.thecheckeredflag.co.uk/sportscars/endurance/blancpain-sprint/">GT World Challenge Europe</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131954"><a href="https://www.thecheckeredflag.co.uk/sportscars/gt-sportscars/british-gt/">British GT</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-290801"><a href="https://www.thecheckeredflag.co.uk/sportscars/ginetta/">Ginetta Series</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-303742"><a href="https://www.thecheckeredflag.co.uk/sportscars/porsche/">Porsche Series</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-131899"><a href="https://www.thecheckeredflag.co.uk/touring-cars/">Touring Cars</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131904"><a href="https://www.thecheckeredflag.co.uk/touring-cars/btcc/">BTCC</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-192543"><a href="https://www.thecheckeredflag.co.uk/touring-cars/dtm/">DTM</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-317944"><a href="https://www.thecheckeredflag.co.uk/touring-cars/jaguar-i-pace-etrophy/">Jaguar I-PACE eTROPHY</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-131918"><a href="https://www.thecheckeredflag.co.uk/motorcycles/">Motorcycles</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131922"><a href="https://www.thecheckeredflag.co.uk/motorcycles/motogp/">MotoGP</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131920"><a href="https://www.thecheckeredflag.co.uk/motorcycles/moto2/">Moto2</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131921"><a href="https://www.thecheckeredflag.co.uk/motorcycles/moto3/">Moto3</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor menu-item-has-children menu-item-290798"><a href="https://www.thecheckeredflag.co.uk/offroad/">Off Road</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-254211"><a href="https://www.thecheckeredflag.co.uk/offroad/rally/fiawrc/">FIA WRC</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-138301"><a href="https://www.thecheckeredflag.co.uk/offroad/rally/fia-erc/">FIA ERC</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-131910"><a href="https://www.thecheckeredflag.co.uk/offroad/rally/british-rally-championship/">British Rally Championship</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131917"><a href="https://www.thecheckeredflag.co.uk/offroad/rallycross/world-rallycross/">FIA World RX</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131913"><a href="https://www.thecheckeredflag.co.uk/offroad/rallycross/european-rallycross/">FIA European RX</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category penci-mega-menu menu-item-290800"><a href="https://www.thecheckeredflag.co.uk/nascar/">NASCAR</a>
<ul class="sub-menu">
<li class="menu-item-0"><div class="penci-megamenu"> <div class="penci-mega-child-categories">
<a class="mega-cat-child" href="https://www.thecheckeredflag.co.uk/nascar/sprint-cup/" data-id="penci-mega-2741"><span>NASCAR Cup Series</span></a>
<a class="mega-cat-child" href="https://www.thecheckeredflag.co.uk/nascar/nascar-trucks/" data-id="penci-mega-18305"><span>NASCAR Gander Trucks</span></a>
<a class="mega-cat-child" href="https://www.thecheckeredflag.co.uk/nascar/euro-racecar/" data-id="penci-mega-8304"><span>NASCAR Whelen Euro Series</span></a>
<a class="mega-cat-child" href="https://www.thecheckeredflag.co.uk/nascar/nascar-xfinity-series/" data-id="penci-mega-2742"><span>NASCAR Xfinity Series</span></a>
<a class="mega-cat-child cat-active all-style" href="https://www.thecheckeredflag.co.uk/nascar/" data-id="penci-mega-108"><span>All</span></a>
</div>
<div class="penci-content-megamenu">
<div class="penci-mega-latest-posts col-mn-4 mega-row-1">
<div class="penci-mega-row penci-mega-2741">
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.thecheckeredflag.co.uk/nascar/sprint-cup/">NASCAR Cup Series</a> </span>
<a class="penci-image-holder penci-lazy" data-src="https://i0.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/01/mcdowell_michael_600miles_2019.jpg?resize=585%2C390&#038;ssl=1" href="https://www.thecheckeredflag.co.uk/2020/01/front-row-motorsports-sign-extension-with-ford/" title="Front Row Motorsports sign extension with Ford">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.thecheckeredflag.co.uk/2020/01/front-row-motorsports-sign-extension-with-ford/" title="Front Row Motorsports sign extension with Ford">Front Row Motorsports sign extension with Ford</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2020-01-21T18:10:41+00:00">January 21, 2020</time></p>
</div>
</div>
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.thecheckeredflag.co.uk/nascar/sprint-cup/">NASCAR Cup Series</a> </span>
<a class="penci-image-holder penci-lazy" data-src="https://i2.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/01/kligerman_parker_600miles_2019.jpg?resize=585%2C390&#038;ssl=1" href="https://www.thecheckeredflag.co.uk/2020/01/parker-kligerman-not-returning-to-gaunt-brothers-racing/" title="Parker Kligerman not returning to Gaunt Brothers Racing">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.thecheckeredflag.co.uk/2020/01/parker-kligerman-not-returning-to-gaunt-brothers-racing/" title="Parker Kligerman not returning to Gaunt Brothers Racing">Parker Kligerman not returning to Gaunt Brothers Racing</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2020-01-18T01:31:10+00:00">January 18, 2020</time></p>
</div>
</div>
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.thecheckeredflag.co.uk/nascar/sprint-cup/">NASCAR Cup Series</a> </span>
<a class="penci-image-holder penci-lazy" data-src="https://i0.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/01/Erik-Jones-NextGen-Homestead-test-2020.jpg?resize=585%2C390&#038;ssl=1" href="https://www.thecheckeredflag.co.uk/2020/01/erik-jones-tests-next-gen-car-at-homestead/" title="Erik Jones tests Next Gen car at Homestead">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.thecheckeredflag.co.uk/2020/01/erik-jones-tests-next-gen-car-at-homestead/" title="Erik Jones tests Next Gen car at Homestead">Erik Jones tests Next Gen car at Homestead</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2020-01-17T03:36:08+00:00">January 17, 2020</time></p>
</div>
</div>
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.thecheckeredflag.co.uk/nascar/sprint-cup/">NASCAR Cup Series</a> </span>
<a class="penci-image-holder penci-lazy" data-src="https://i2.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/01/Chase-Elliott-Truex-Watkins-Glen-2019-MENCS.jpg?resize=585%2C390&#038;ssl=1" href="https://www.thecheckeredflag.co.uk/2020/01/nascar-cup-series-lowers-downforce-for-road-shorter-ovals/" title="NASCAR Cup Series lowers downforce for road, shorter ovals">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.thecheckeredflag.co.uk/2020/01/nascar-cup-series-lowers-downforce-for-road-shorter-ovals/" title="NASCAR Cup Series lowers downforce for road, shorter ovals">NASCAR Cup Series lowers downforce for road, shorter&#8230;</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2020-01-14T19:39:44+00:00">January 14, 2020</time></p>
</div>
</div>
</div>
<div class="penci-mega-row penci-mega-18305">
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.thecheckeredflag.co.uk/nascar/nascar-trucks/">NASCAR Gander Trucks</a> </span>
<a class="penci-image-holder penci-lazy" data-src="https://i1.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/01/Howie-DiSavino-ARCA-2019.jpg?resize=585%2C390&#038;ssl=1" href="https://www.thecheckeredflag.co.uk/2020/01/win-tron-racing-returning-to-truck-series-with-howie-disavino-iii/" title="Win-Tron Racing returning to Truck Series with Howie DiSavino III">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.thecheckeredflag.co.uk/2020/01/win-tron-racing-returning-to-truck-series-with-howie-disavino-iii/" title="Win-Tron Racing returning to Truck Series with Howie DiSavino III">Win-Tron Racing returning to Truck Series with Howie&#8230;</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2020-01-21T22:12:18+00:00">January 21, 2020</time></p>
</div>
</div>
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.thecheckeredflag.co.uk/nascar/nascar-trucks/">NASCAR Gander Trucks</a> </span>
<a class="penci-image-holder penci-lazy" data-src="https://i1.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2019/08/MIS2_NGOTS_PlayoffDrivers_081019.jpg?resize=585%2C390&#038;ssl=1" href="https://www.thecheckeredflag.co.uk/2020/01/truck-series-playoffs-expands-to-ten-drivers/" title="Truck Series playoffs expands to ten drivers">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.thecheckeredflag.co.uk/2020/01/truck-series-playoffs-expands-to-ten-drivers/" title="Truck Series playoffs expands to ten drivers">Truck Series playoffs expands to ten drivers</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2020-01-21T19:48:59+00:00">January 21, 2020</time></p>
</div>
</div>
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.thecheckeredflag.co.uk/nascar/nascar-trucks/">NASCAR Gander Trucks</a> </span>
<a class="penci-image-holder penci-lazy" data-src="https://i0.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/01/Derek-Kraus-NGOTS-2019-Martinsville-truck.jpg?resize=585%2C390&#038;ssl=1" href="https://www.thecheckeredflag.co.uk/2020/01/mcanally-hilgemann-racing-formed-to-field-gander-truck-ride-for-derek-kraus/" title="McAnally-Hilgemann Racing formed, to field Gander Truck ride for Derek Kraus">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.thecheckeredflag.co.uk/2020/01/mcanally-hilgemann-racing-formed-to-field-gander-truck-ride-for-derek-kraus/" title="McAnally-Hilgemann Racing formed, to field Gander Truck ride for Derek Kraus">McAnally-Hilgemann Racing formed, to field Gander Truck ride&#8230;</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2020-01-13T20:30:05+00:00">January 13, 2020</time></p>
</div>
</div>
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.thecheckeredflag.co.uk/nascar/nascar-trucks/">NASCAR Gander Trucks</a> </span>
<a class="penci-image-holder penci-lazy" data-src="https://i1.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/01/Todd-Gilliland-NGOTS-2019-Martinsville-VL.jpg?resize=585%2C390&#038;ssl=1" href="https://www.thecheckeredflag.co.uk/2020/01/front-row-motorsports-forms-gander-trucks-team-to-field-todd-gilliland/" title="Front Row Motorsports forms Gander Trucks team, to field Todd Gilliland">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.thecheckeredflag.co.uk/2020/01/front-row-motorsports-forms-gander-trucks-team-to-field-todd-gilliland/" title="Front Row Motorsports forms Gander Trucks team, to field Todd Gilliland">Front Row Motorsports forms Gander Trucks team, to&#8230;</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2020-01-13T18:16:10+00:00">January 13, 2020</time></p>
</div>
</div>
</div>
<div class="penci-mega-row penci-mega-8304">
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.thecheckeredflag.co.uk/nascar/euro-racecar/">NASCAR Whelen Euro Series</a> </span>
<a class="penci-image-holder penci-lazy" data-src="https://i0.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2019/10/Memphis-Racing-23-2019-NWES.jpg?resize=585%2C390&#038;ssl=1" href="https://www.thecheckeredflag.co.uk/2019/10/2020-nascar-whelen-euro-series-schedule-released/" title="2020 NASCAR Whelen Euro Series schedule released">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.thecheckeredflag.co.uk/2019/10/2020-nascar-whelen-euro-series-schedule-released/" title="2020 NASCAR Whelen Euro Series schedule released">2020 NASCAR Whelen Euro Series schedule released</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2019-10-22T17:43:44+01:00">October 22, 2019</time></p>
</div>
</div>
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.thecheckeredflag.co.uk/nascar/euro-racecar/">NASCAR Whelen Euro Series</a> </span>
<a class="penci-image-holder penci-lazy" data-src="https://i0.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2019/10/NWES-Team-FJ-2030-partnership.jpg?resize=585%2C390&#038;ssl=1" href="https://www.thecheckeredflag.co.uk/2019/10/nascar-team-fj-sign-ten-year-extension-for-whelen-euro-series-sanction/" title="NASCAR, Team FJ sign ten-year extension for Whelen Euro Series sanction">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.thecheckeredflag.co.uk/2019/10/nascar-team-fj-sign-ten-year-extension-for-whelen-euro-series-sanction/" title="NASCAR, Team FJ sign ten-year extension for Whelen Euro Series sanction">NASCAR, Team FJ sign ten-year extension for Whelen&#8230;</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2019-10-04T16:25:28+01:00">October 4, 2019</time></p>
</div>
</div>
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.thecheckeredflag.co.uk/nascar/euro-racecar/">NASCAR Whelen Euro Series</a> </span>
<a class="penci-image-holder penci-lazy" data-src="https://i0.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2019/04/Ander-Vilarino-Valencia-2019-NWES.jpg?resize=585%2C390&#038;ssl=1" href="https://www.thecheckeredflag.co.uk/2019/04/vilarino-maggi-risitano-kick-off-2019-euro-series-with-valencia-victories/" title="Vilarino, Maggi, Risitano kick off 2019 Euro Series with Valencia victories">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.thecheckeredflag.co.uk/2019/04/vilarino-maggi-risitano-kick-off-2019-euro-series-with-valencia-victories/" title="Vilarino, Maggi, Risitano kick off 2019 Euro Series with Valencia victories">Vilarino, Maggi, Risitano kick off 2019 Euro Series&#8230;</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2019-04-15T05:25:02+01:00">April 15, 2019</time></p>
</div>
</div>
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.thecheckeredflag.co.uk/nascar/euro-racecar/">NASCAR Whelen Euro Series</a> </span>
<a class="penci-image-holder penci-lazy" data-src="https://i1.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2019/04/Euro-NASCAR-18-32-paddock.jpg?resize=585%2C390&#038;ssl=1" href="https://www.thecheckeredflag.co.uk/2019/04/nascar-gp-of-spain-featuring-decorated-grid/" title="NASCAR GP of Spain featuring decorated grid">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.thecheckeredflag.co.uk/2019/04/nascar-gp-of-spain-featuring-decorated-grid/" title="NASCAR GP of Spain featuring decorated grid">NASCAR GP of Spain featuring decorated grid</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2019-04-10T18:07:18+01:00">April 10, 2019</time></p>
</div>
</div>
</div>
<div class="penci-mega-row penci-mega-2742">
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.thecheckeredflag.co.uk/nascar/nascar-xfinity-series/">NASCAR Xfinity Series</a> </span>
<a class="penci-image-holder penci-lazy" data-src="https://i2.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/01/harmon_2019nxs_carshot.jpg?resize=585%2C390&#038;ssl=1" href="https://www.thecheckeredflag.co.uk/2020/01/mike-harmon-racing-opens-second-car-for-2020-xfinity-series/" title="Mike Harmon Racing opens second car for 2020 Xfinity Series">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.thecheckeredflag.co.uk/2020/01/mike-harmon-racing-opens-second-car-for-2020-xfinity-series/" title="Mike Harmon Racing opens second car for 2020 Xfinity Series">Mike Harmon Racing opens second car for 2020&#8230;</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2020-01-19T23:19:38+00:00">January 19, 2020</time></p>
</div>
</div>
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.thecheckeredflag.co.uk/nascar/nascar-xfinity-series/">NASCAR Xfinity Series</a> </span>
<a class="penci-image-holder penci-lazy" data-src="https://i2.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/01/mencs_ks_hemric_car_101919.jpg?resize=585%2C390&#038;ssl=1" href="https://www.thecheckeredflag.co.uk/2020/01/daniel-hemric-reveals-21-race-xfinity-schedule/" title="Daniel Hemric reveals 21-race Xfinity schedule">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.thecheckeredflag.co.uk/2020/01/daniel-hemric-reveals-21-race-xfinity-schedule/" title="Daniel Hemric reveals 21-race Xfinity schedule">Daniel Hemric reveals 21-race Xfinity schedule</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2020-01-16T20:09:25+00:00">January 16, 2020</time></p>
</div>
</div>
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.thecheckeredflag.co.uk/nascar/nascar-xfinity-series/">NASCAR Xfinity Series</a> </span>
<a class="penci-image-holder penci-lazy" data-src="https://i0.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/01/Joe-Graf-Jr-NXS-Iowa-2019.jpg?resize=585%2C390&#038;ssl=1" href="https://www.thecheckeredflag.co.uk/2020/01/joe-graf-jr-joins-ss-green-light-for-2020-xfinity-season/" title="Joe Graf Jr. joins SS-Green Light for 2020 Xfinity season">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.thecheckeredflag.co.uk/2020/01/joe-graf-jr-joins-ss-green-light-for-2020-xfinity-season/" title="Joe Graf Jr. joins SS-Green Light for 2020 Xfinity season">Joe Graf Jr. joins SS-Green Light for 2020&#8230;</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2020-01-16T18:47:32+00:00">January 16, 2020</time></p>
</div>
</div>
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.thecheckeredflag.co.uk/nascar/nascar-xfinity-series/">NASCAR Xfinity Series</a> </span>
<a class="penci-image-holder penci-lazy" data-src="https://i2.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/01/Kyle-Busch-IMS-NXS-2019-checkered.jpg?resize=585%2C390&#038;ssl=1" href="https://www.thecheckeredflag.co.uk/2020/01/xfinity-series-to-run-indianapolis-road-course/" title="Xfinity Series to run Indianapolis road course">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.thecheckeredflag.co.uk/2020/01/xfinity-series-to-run-indianapolis-road-course/" title="Xfinity Series to run Indianapolis road course">Xfinity Series to run Indianapolis road course</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2020-01-16T04:15:14+00:00">January 16, 2020</time></p>
</div>
</div>
</div>
<div class="penci-mega-row penci-mega-108 row-active">
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.thecheckeredflag.co.uk/nascar/">NASCAR</a> </span>
<a class="penci-image-holder penci-lazy" data-src="https://i1.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/01/Howie-DiSavino-ARCA-2019.jpg?resize=585%2C390&#038;ssl=1" href="https://www.thecheckeredflag.co.uk/2020/01/win-tron-racing-returning-to-truck-series-with-howie-disavino-iii/" title="Win-Tron Racing returning to Truck Series with Howie DiSavino III">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.thecheckeredflag.co.uk/2020/01/win-tron-racing-returning-to-truck-series-with-howie-disavino-iii/" title="Win-Tron Racing returning to Truck Series with Howie DiSavino III">Win-Tron Racing returning to Truck Series with Howie&#8230;</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2020-01-21T22:12:18+00:00">January 21, 2020</time></p>
</div>
</div>
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.thecheckeredflag.co.uk/nascar/">NASCAR</a> </span>
<a class="penci-image-holder penci-lazy" data-src="https://i1.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2019/08/MIS2_NGOTS_PlayoffDrivers_081019.jpg?resize=585%2C390&#038;ssl=1" href="https://www.thecheckeredflag.co.uk/2020/01/truck-series-playoffs-expands-to-ten-drivers/" title="Truck Series playoffs expands to ten drivers">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.thecheckeredflag.co.uk/2020/01/truck-series-playoffs-expands-to-ten-drivers/" title="Truck Series playoffs expands to ten drivers">Truck Series playoffs expands to ten drivers</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2020-01-21T19:48:59+00:00">January 21, 2020</time></p>
</div>
</div>
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.thecheckeredflag.co.uk/nascar/">NASCAR</a> </span>
<a class="penci-image-holder penci-lazy" data-src="https://i0.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/01/mcdowell_michael_600miles_2019.jpg?resize=585%2C390&#038;ssl=1" href="https://www.thecheckeredflag.co.uk/2020/01/front-row-motorsports-sign-extension-with-ford/" title="Front Row Motorsports sign extension with Ford">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.thecheckeredflag.co.uk/2020/01/front-row-motorsports-sign-extension-with-ford/" title="Front Row Motorsports sign extension with Ford">Front Row Motorsports sign extension with Ford</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2020-01-21T18:10:41+00:00">January 21, 2020</time></p>
</div>
</div>
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.thecheckeredflag.co.uk/nascar/">NASCAR</a> </span>
<a class="penci-image-holder penci-lazy" data-src="https://i2.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/01/harmon_2019nxs_carshot.jpg?resize=585%2C390&#038;ssl=1" href="https://www.thecheckeredflag.co.uk/2020/01/mike-harmon-racing-opens-second-car-for-2020-xfinity-series/" title="Mike Harmon Racing opens second car for 2020 Xfinity Series">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.thecheckeredflag.co.uk/2020/01/mike-harmon-racing-opens-second-car-for-2020-xfinity-series/" title="Mike Harmon Racing opens second car for 2020 Xfinity Series">Mike Harmon Racing opens second car for 2020&#8230;</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2020-01-19T23:19:38+00:00">January 19, 2020</time></p>
</div>
</div>
</div>
</div>
</div>
</div></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-293110"><a href="https://www.thecheckeredflag.co.uk/features/">Features</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-293115"><a href="https://www.thecheckeredflag.co.uk/features/opinion/">Opinion</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-293113"><a href="https://www.thecheckeredflag.co.uk/features/interviews/">Interviews</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-293114"><a href="https://www.thecheckeredflag.co.uk/features/gallery/">Gallery</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-293111"><a href="https://www.thecheckeredflag.co.uk/features/product-review/">Product Review</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-293112"><a href="https://www.thecheckeredflag.co.uk/features/season-review/">Season Review</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-293118"><a href="https://www.thecheckeredflag.co.uk/other/esports/">eSports</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-293117"><a href="https://www.thecheckeredflag.co.uk/other/video-games/">Sim Racing</a></li>
</ul>
</li>
</ul>
<div id="top-search" class="dfdf">
<a class="search-click"><i class="penci-faicon fa fa-search"></i></a>
<div class="show-search">
<form role="search" method="get" id="searchform" action="https://www.thecheckeredflag.co.uk/">
<div>
<input type="text" class="search-input" placeholder="Type and hit enter..." name="s" id="s" />
</div>
</form> <a class="search-click close-search"><i class="penci-faicon fa fa-close"></i></a>
</div>
</div> </div>
</nav>
</header>
</div>
<div class="container container-single container-single-magazine penci_sidebar  penci-enable-lightbox">
<div id="main">
<div class="theiaStickySidebar">
<article id="post-329697" class="post type-post status-publish hentry">
<div class="header-standard header-classic single-header">
<div class="penci-standard-cat"><span class="cat"><a class="penci-cat-name" href="https://www.thecheckeredflag.co.uk/offroad/rally/british-rally-championship/" rel="category tag">British Rally Championship</a><a class="penci-cat-name" href="https://www.thecheckeredflag.co.uk/other/" rel="category tag">Other</a></span></div>
<h1 class="post-title single-post-title entry-title">Carmichael to enter the new Motorsport UK National Championship</h1>
<div class="penci-hide-tagupdated">
<span class="author-italic author vcard">by <a class="url fn n" href="https://www.thecheckeredflag.co.uk/author/plindroos/">Pontus Lindroos</a></span>
<time class="entry-date published" datetime="2020-01-22T07:31:48+00:00">January 22, 2020</time> </div>
<div class="post-box-meta-single">
<span class="author-post byline"><span class="author vcard">written by <a class="author-url url fn n" href="https://www.thecheckeredflag.co.uk/author/plindroos/">Pontus Lindroos</a></span></span>
<span><time class="entry-date published" datetime="2020-01-22T07:31:48+00:00">January 22, 2020</time></span>
</div>
</div>
<div class="post-image">
<a href="https://www.thecheckeredflag.co.uk/wp-content/uploads/2020/01/BRC-Fiesta.jpg" data-rel="penci-gallery-image-content"> <img width="800" height="533" src="https://i2.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/01/BRC-Fiesta.jpg?fit=800%2C533&amp;ssl=1" class="attachment-penci-full-thumb size-penci-full-thumb wp-post-image" alt="" srcset="https://i2.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/01/BRC-Fiesta.jpg?w=800&amp;ssl=1 800w, https://i2.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/01/BRC-Fiesta.jpg?resize=240%2C160&amp;ssl=1 240w, https://i2.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/01/BRC-Fiesta.jpg?resize=768%2C512&amp;ssl=1 768w, https://i2.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/01/BRC-Fiesta.jpg?resize=585%2C390&amp;ssl=1 585w, https://i2.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/01/BRC-Fiesta.jpg?resize=263%2C175&amp;ssl=1 263w" sizes="(max-width: 800px) 100vw, 800px" /> </a><div class="penci-featured-caption">Credit: British Rally Championship</div> </div>
<div class="post-entry blockquote-style-1">
<div class="inner-post-entry entry-content" id="penci-post-entry-inner">
<p><strong>Alan Carmichael</strong> from Northern Ireland is the first driver to commit to entering the newly created <strong>Motorsport UK National Championship.</strong></p>
<p>Carmichael will now step into a right-hand-drive Ford Fiesta R5 to be used in both Britain&#8217;s premier rally series and the <strong>Northern Ireland Championship.</strong></p>
<p>Last year he drove in a similar car but left-hand-drive, he showed a promising performance last year and he is keen to give it his all in the British Rally Championship this season. He is pleased to have his plans cemented early in the season.</p>
<p><em>“This really is a big box ticker for me. I wanted to do a National championship but still be involved in the BRC. The series is well run and there is a buzz and great craic around it. It’s the events and people competing and involved in it that make it</em>,&#8221; Carmichael said.</p>
<p><em>&#8220;Last year I had no luck what so ever, so from a personal point of view I want to come back and finish some rallies! From the Cambrian to Galloway Hills it just didn’t go right for me, so I am back in 2020 to give it my all and it’s great to be a part of the BRC.”</em> </p>
<p><em>“It just didn’t start on the right foot. The car kept cutting out from stage one. It was such a disappointment as we couldn’t see how we compared against everyone else. We could have won the National section on the Ulster and been on the BRC podium outright. We have to draw a line under that and now we can have a good go at the National title.”</em></p>
<p>Carmichael has no concerns about switching cars and explained why the change to right-hand-drive came about.</p>
<p><em>“I have a business to run so I am not in the car between events so the change of car wont be a massive problem. My car from last year has been turned back into a left-hand-drive model for the Motorsport Ireland programme so this right-hand-drive Fiesta R5 became available and looks a very quick option.</em></p>
<p><em>&#8220;Claire [Williams] will be back for the BRC and we got on well last year and that will help massively and I will have Ivor for the Northern Ireland Championship. I hope to see plenty of competition, and I am ready for some good battles this season.” </em>Carmichael added.</p>
<div class="penci-single-link-pages">
</div>
<div class="post-tags">
<a href="https://www.thecheckeredflag.co.uk/tag/2020-british-rally-championship/" rel="tag">2020 British Rally Championship</a><a href="https://www.thecheckeredflag.co.uk/tag/motorsport-uk-national-championship/" rel="tag">Motorsport UK National Championship</a><a href="https://www.thecheckeredflag.co.uk/tag/northern-ireland-rally-championship/" rel="tag">Northern Ireland Rally Championship</a> </div>
</div>
</div>
<div class="penci-google-adsense-2">

<ins class="adsbygoogle" style="display:inline-block;width:728px;height:90px" data-ad-client="ca-pub-9159179884377372" data-ad-slot="6495511074"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script> </div>
<div class="tags-share-box center-box tags-share-box-s1">
<span class="single-comment-o"><i class="penci-faicon fa fa-comment-o"></i><span class="dsq-postid" data-dsqidentifier="329697 https://www.thecheckeredflag.co.uk/?p=329697">0 comment</span></span>
<div class="post-share">
<span class="post-share-item post-share-plike"><span class="count-number-like">0</span><a class="penci-post-like single-like-button" data-post_id="329697" title="Like" data-like="Like" data-unlike="Unlike"><i class="penci-faicon fa fa-heart-o"></i></a></span>
<div class="list-posts-share"><a class="post-share-item post-share-facebook" target="_blank" rel="nofollow" href="https://www.facebook.com/sharer/sharer.php?u=https://www.thecheckeredflag.co.uk/2020/01/carmichael-to-enter-the-new-motorsport-uk-national-championship/"><i class="penci-faicon fa fa-facebook"></i><span class="dt-share">Facebook</span></a><a class="post-share-item post-share-twitter" target="_blank" rel="nofollow" href="https://twitter.com/intent/tweet?text=Check%20out%20this%20article:%20Carmichael%20to%20enter%20the%20new%20Motorsport%20UK%20National%20Championship%20-%20https://www.thecheckeredflag.co.uk/2020/01/carmichael-to-enter-the-new-motorsport-uk-national-championship/"><i class="penci-faicon fa fa-twitter"></i><span class="dt-share">Twitter</span></a><a class="post-share-item post-share-pinterest" data-pin-do="none" rel="nofollow noreferrer noopener" onclick="var e=document.createElement('script');e.setAttribute('type','text/javascript');e.setAttribute('charset','UTF-8');e.setAttribute('src','//assets.pinterest.com/js/pinmarklet.js?r='+Math.random()*99999999);document.body.appendChild(e);"><i class="penci-faicon fa fa-pinterest"></i><span class="dt-share">Pinterest</span></a><a class="post-share-item post-share-linkedin" target="_blank" rel="nofollow" href="https://www.linkedin.com/shareArticle?mini=true&#038;url=https%3A%2F%2Fwww.thecheckeredflag.co.uk%2F2020%2F01%2Fcarmichael-to-enter-the-new-motorsport-uk-national-championship%2F&#038;title=Carmichael%20to%20enter%20the%20new%20Motorsport%20UK%20National%20Championship"><i class="penci-faicon fa fa-linkedin"></i><span class="dt-share">Linkedin</span></a><a class="post-share-item post-share-reddit" target="_blank" rel="nofollow" href="https://reddit.com/submit?url=https%3A%2F%2Fwww.thecheckeredflag.co.uk%2F2020%2F01%2Fcarmichael-to-enter-the-new-motorsport-uk-national-championship%2F&#038;title=Carmichael%20to%20enter%20the%20new%20Motorsport%20UK%20National%20Championship"><i class="penci-faicon fa fa-reddit-alien"></i><span class="dt-share">Reddit</span></a><a class="post-share-item post-share-whatsapp" target="_blank" rel="nofollow" href="https://api.whatsapp.com/send?text=Carmichael%20to%20enter%20the%20new%20Motorsport%20UK%20National%20Championship %0A%0A https%3A%2F%2Fwww.thecheckeredflag.co.uk%2F2020%2F01%2Fcarmichael-to-enter-the-new-motorsport-uk-national-championship%2F"><i class="penci-faicon fa fa-whatsapp"></i><span class="dt-share">Whatsapp</span></a><a class="post-share-item post-share-email" target="_blank" rel="nofollow" href="/cdn-cgi/l/email-protection#89b6fafcebe3eceafdb4cae8fbe4e0eae1e8ece5acbbb9fde6acbbb9ece7fdecfbacbbb9fde1ecacbbb9e7ecfeacbbb9c4e6fde6fbfaf9e6fbfdacbbb9dcc2acbbb9c7e8fde0e6e7e8e5acbbb9cae1e8e4f9e0e6e7fae1e0f9afaab9bab1b2cbc6cdd0b4e1fdfdf9fab3a6a6fefefea7fde1eceae1eceae2ecfbecedefe5e8eea7eae6a7fce2a6bbb9bbb9a6b9b8a6eae8fbe4e0eae1e8ece5a4fde6a4ece7fdecfba4fde1eca4e7ecfea4e4e6fde6fbfaf9e6fbfda4fce2a4e7e8fde0e6e7e8e5a4eae1e8e4f9e0e6e7fae1e0f9a6"><i class="penci-faicon fa fa-envelope"></i><span class="dt-share">Email</span></a></div> </div>
</div>
<div class="post-author">
<div class="author-img">
<img alt='Pontus Lindroos' src='https://www.thecheckeredflag.co.uk/wp-content/uploads/2019/12/IMG_20190914_101654-scaled-100x100.jpg' class='avatar avatar-100 photo' height='100' width='100' /> </div>
<div class="author-content">
<h5><a href="https://www.thecheckeredflag.co.uk/author/plindroos/" title="Posts by Pontus Lindroos" rel="author">Pontus Lindroos</a></h5>
<p>RallyX Nordic, RallyX on Ice &amp; Projekt E writer. I grew up in the paddocks and have always been highly passionate about rallycross since. To bring all the latest news from different series to our wonderful readers on The Checkered Flag is always a pleasure for me.</p>
<a target="_blank" class="author-social" href="https://facebook.com/pontus.lindroos.1"><i class="penci-faicon fa fa-facebook"></i></a>
<a target="_blank" class="author-social" href="https://twitter.com/RXtheWorld"><i class="penci-faicon fa fa-twitter"></i></a>
<a target="_blank" class="author-social" href="https://instagram.com/Lindroos95"><i class="penci-faicon fa fa-instagram"></i></a>
<a class="author-social" href="/cdn-cgi/l/email-protection#f4849b9a808187da989d9a90869b9b87b4809c91979c91979f9186919092989593da979bda819f"><i class="penci-faicon fa fa-envelope"></i></a>
</div>
</div>
<div class="post-related">
<div class="post-title-box"><h4 class="post-box-title">Related articles</h4></div>
<div class="penci-owl-carousel penci-owl-carousel-slider penci-related-carousel" data-lazy="true" data-item="3" data-desktop="3" data-tablet="2" data-tabsmall="2" data-auto="false" data-speed="300" data-dots="true" data-nav="false">
<div class="item-related">
<a class="related-thumb penci-image-holder" style="background-image: url('https://i1.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/01/IMG_22012020_125210_800_x_533_pixel.jpg?resize=585%2C390&#038;ssl=1');" href="https://www.thecheckeredflag.co.uk/2020/01/creighton-aiming-for-jwrc-2021-bid-with-2020-jbrc-title-challenge/" title="Creighton aiming for JWRC 2021 bid with 2020 JBRC title challenge">
</a>
<h3><a href="https://www.thecheckeredflag.co.uk/2020/01/creighton-aiming-for-jwrc-2021-bid-with-2020-jbrc-title-challenge/">Creighton aiming for JWRC 2021 bid with 2020 JBRC title challenge</a></h3>
<span class="date"><time class="entry-date published" datetime="2020-01-22T11:35:27+00:00">January 22, 2020</time></span>
</div>
<div class="item-related">
<a class="related-thumb penci-image-holder" style="background-image: url('https://i0.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/01/Peter-Jackson-BRC.jpg?resize=585%2C390&#038;ssl=1');" href="https://www.thecheckeredflag.co.uk/2020/01/newcomer-jackson-hopes-to-secure-the-title-in-jbrc/" title="Newcomer Jackson hopes to secure the title in JBRC">
</a>
<h3><a href="https://www.thecheckeredflag.co.uk/2020/01/newcomer-jackson-hopes-to-secure-the-title-in-jbrc/">Newcomer Jackson hopes to secure the title in JBRC</a></h3>
<span class="date"><time class="entry-date published" datetime="2020-01-22T09:10:36+00:00">January 22, 2020</time></span>
</div>
<div class="item-related">
<a class="related-thumb penci-image-holder" style="background-image: url('https://i1.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/01/BRC-Academy.jpg?resize=585%2C390&#038;ssl=1');" href="https://www.thecheckeredflag.co.uk/2020/01/brc-academy-trophy-to-be-introduced-this-year-for-youngsters-to-shine/" title="BRC Academy Trophy to be introduced this year for youngsters to shine">
</a>
<h3><a href="https://www.thecheckeredflag.co.uk/2020/01/brc-academy-trophy-to-be-introduced-this-year-for-youngsters-to-shine/">BRC Academy Trophy to be introduced this year for youngsters to shine</a></h3>
<span class="date"><time class="entry-date published" datetime="2020-01-22T08:58:47+00:00">January 22, 2020</time></span>
</div>
<div class="item-related">
<a class="related-thumb penci-image-holder" style="background-image: url('https://i0.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/01/IMG_21012020_160539_800_x_533_pixel.jpg?resize=585%2C390&#038;ssl=1');" href="https://www.thecheckeredflag.co.uk/2020/01/eddie-lewis-hoping-to-make-an-impact-in-junior-brc/" title="Eddie Lewis hoping to make an impact in Junior BRC">
</a>
<h3><a href="https://www.thecheckeredflag.co.uk/2020/01/eddie-lewis-hoping-to-make-an-impact-in-junior-brc/">Eddie Lewis hoping to make an impact in Junior BRC</a></h3>
<span class="date"><time class="entry-date published" datetime="2020-01-21T16:37:17+00:00">January 21, 2020</time></span>
</div>
<div class="item-related">
<a class="related-thumb penci-image-holder" style="background-image: url('https://i1.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/01/IMG_21012020_154704_800_x_533_pixel.jpg?resize=585%2C390&#038;ssl=1');" href="https://www.thecheckeredflag.co.uk/2020/01/finlay-retson-is-ready-for-the-season-opener-at-cambrian-rally/" title="Finlay Retson is ready for the season-opener at Cambrian Rally">
</a>
<h3><a href="https://www.thecheckeredflag.co.uk/2020/01/finlay-retson-is-ready-for-the-season-opener-at-cambrian-rally/">Finlay Retson is ready for the season-opener at Cambrian Rally</a></h3>
<span class="date"><time class="entry-date published" datetime="2020-01-21T14:36:43+00:00">January 21, 2020</time></span>
</div>
<div class="item-related">
<a class="related-thumb penci-image-holder" style="background-image: url('https://i2.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/01/me.jpg?resize=585%2C390&#038;ssl=1');" href="https://www.thecheckeredflag.co.uk/2020/01/2020-british-rally-championship-news-round-up-trio-of-drivers-sign-up/" title="2020 British Rally Championship News Round Up: Trio of Drivers Sign Up">
</a>
<h3><a href="https://www.thecheckeredflag.co.uk/2020/01/2020-british-rally-championship-news-round-up-trio-of-drivers-sign-up/">2020 British Rally Championship News Round Up: Trio of Drivers Sign Up</a></h3>
<span class="date"><time class="entry-date published" datetime="2020-01-09T15:48:59+00:00">January 9, 2020</time></span>
</div>
<div class="item-related">
<a class="related-thumb penci-image-holder" style="background-image: url('https://i0.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2019/01/4d9d8e84-66a4-40b8-9d98-7ec47101f239.jpg?resize=585%2C390&#038;ssl=1');" href="https://www.thecheckeredflag.co.uk/2019/01/jwrc-prize-announced-for-leading-british-rally-championship-fiesta-driver/" title="JWRC Prize Announced for Leading British Rally Championship Fiesta Driver">
</a>
<h3><a href="https://www.thecheckeredflag.co.uk/2019/01/jwrc-prize-announced-for-leading-british-rally-championship-fiesta-driver/">JWRC Prize Announced for Leading British Rally Championship Fiesta Driver</a></h3>
<span class="date"><time class="entry-date published" datetime="2019-01-22T12:15:35+00:00">January 22, 2019</time></span>
</div>
</div></div>
<div id="disqus_thread"></div>
<div class="post-pagination">
<div class="prev-post">
<div class="prev-post-inner">
<div class="prev-post-title">
<span>previous post</span>
</div>
<a href="https://www.thecheckeredflag.co.uk/2020/01/win-tron-racing-returning-to-truck-series-with-howie-disavino-iii/">
<div class="pagi-text">
<h5 class="prev-title">Win-Tron Racing returning to Truck Series with Howie DiSavino III</h5>
</div>
</a>
</div>
</div>
<div class="next-post">
<div class="next-post-inner">
<div class="prev-post-title next-post-title">
<span>next post</span>
</div>
<a href="https://www.thecheckeredflag.co.uk/2020/01/brc-academy-trophy-to-be-introduced-this-year-for-youngsters-to-shine/">
<div class="pagi-text">
<h5 class="next-title">BRC Academy Trophy to be introduced this year for youngsters to shine</h5>
</div>
</a>
</div>
</div>
</div>
</article> </div>
</div>
<div id="sidebar" class="penci-sidebar-right penci-sidebar-content style-1 pcalign-center">
<div class="theiaStickySidebar">
<aside id="media_image-2" class="widget widget_media_image"><a href="https://www.thecheckeredflag.co.uk/tcf-blogs/jaguar-racing-blog/"><img width="1080" height="1080" src="https://i1.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2019/12/Mitch-Evans-BLOG.jpg?fit=1080%2C1080&amp;ssl=1" class="image wp-image-327097  attachment-full size-full" alt="Mitch Evans - Jaguar Racing Blog" style="max-width: 100%; height: auto;" srcset="https://i1.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2019/12/Mitch-Evans-BLOG.jpg?w=1080&amp;ssl=1 1080w, https://i1.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2019/12/Mitch-Evans-BLOG.jpg?resize=160%2C160&amp;ssl=1 160w, https://i1.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2019/12/Mitch-Evans-BLOG.jpg?resize=533%2C533&amp;ssl=1 533w, https://i1.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2019/12/Mitch-Evans-BLOG.jpg?resize=240%2C240&amp;ssl=1 240w, https://i1.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2019/12/Mitch-Evans-BLOG.jpg?resize=768%2C768&amp;ssl=1 768w, https://i1.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2019/12/Mitch-Evans-BLOG.jpg?resize=585%2C585&amp;ssl=1 585w, https://i1.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2019/12/Mitch-Evans-BLOG.jpg?resize=912%2C912&amp;ssl=1 912w, https://i1.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2019/12/Mitch-Evans-BLOG.jpg?resize=550%2C550&amp;ssl=1 550w, https://i1.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2019/12/Mitch-Evans-BLOG.jpg?resize=470%2C470&amp;ssl=1 470w" sizes="(max-width: 1080px) 100vw, 1080px" /></a></aside><aside id="custom_html-11" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget">

<ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-9159179884377372" data-ad-slot="4409003789" data-ad-format="auto" data-full-width-responsive="true"></ins>
<script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script></div></aside><aside id="penci_slider_posts_news_widget-2" class="widget penci_slider_posts_news_widget"><h4 class="widget-title penci-border-arrow"><span class="inner-arrow">Latest articles</span></h4> <div id="penci-postslidewg-6105" class="penci-owl-carousel penci-owl-carousel-slider penci-widget-slider penci-post-slider-style-1" data-lazy="true">
<div class="penci-slide-widget">
<div class="penci-slide-content">
<span class="penci-image-holder" style="background-image: url('https://i1.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/01/tanak-2.jpg?resize=585%2C390&#038;ssl=1');" title="PREVIEW: 2020 FIA World Rally Championship – Rally Monte-Carlo: All Change at the Top for 2020"></span>
<a href="https://www.thecheckeredflag.co.uk/2020/01/preview-2020-fia-world-rally-championship-rally-monte-carlo-all-change-at-the-top-for-2020/" class="penci-widget-slider-overlay" title="PREVIEW: 2020 FIA World Rally Championship – Rally Monte-Carlo: All Change at the Top for 2020"></a>
<div class="penci-widget-slide-detail">
<h4>
<a href="https://www.thecheckeredflag.co.uk/2020/01/preview-2020-fia-world-rally-championship-rally-monte-carlo-all-change-at-the-top-for-2020/" rel="bookmark" title="PREVIEW: 2020 FIA World Rally Championship – Rally Monte-Carlo: All Change at the Top for 2020">PREVIEW: 2020 FIA World Rally Championship – Rally...</a>
</h4>
<span class="slide-item-date">Jan 22, 2020</span>
</div>
</div>
</div>
<div class="penci-slide-widget">
<div class="penci-slide-content">
<span class="penci-image-holder" style="background-image: url('https://i1.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/01/IMG_22012020_125210_800_x_533_pixel.jpg?resize=585%2C390&#038;ssl=1');" title="Creighton aiming for JWRC 2021 bid with 2020 JBRC title challenge"></span>
<a href="https://www.thecheckeredflag.co.uk/2020/01/creighton-aiming-for-jwrc-2021-bid-with-2020-jbrc-title-challenge/" class="penci-widget-slider-overlay" title="Creighton aiming for JWRC 2021 bid with 2020 JBRC title challenge"></a>
<div class="penci-widget-slide-detail">
<h4>
<a href="https://www.thecheckeredflag.co.uk/2020/01/creighton-aiming-for-jwrc-2021-bid-with-2020-jbrc-title-challenge/" rel="bookmark" title="Creighton aiming for JWRC 2021 bid with 2020 JBRC title challenge">Creighton aiming for JWRC 2021 bid with 2020...</a>
</h4>
<span class="slide-item-date">Jan 22, 2020</span>
</div>
</div>
</div>
<div class="penci-slide-widget">
<div class="penci-slide-content">
<span class="penci-image-holder" style="background-image: url('https://i1.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/01/Esmee-Hawkey.jpg?resize=585%2C390&#038;ssl=1');" title="Esmee Hawkey targeting Porsche Carrera Cup GB title with Team Parker Racing"></span>
<a href="https://www.thecheckeredflag.co.uk/2020/01/esmee-hawkey-targeting-porsche-carrera-cup-gb-title-with-team-parker-racing/" class="penci-widget-slider-overlay" title="Esmee Hawkey targeting Porsche Carrera Cup GB title with Team Parker Racing"></a>
<div class="penci-widget-slide-detail">
<h4>
<a href="https://www.thecheckeredflag.co.uk/2020/01/esmee-hawkey-targeting-porsche-carrera-cup-gb-title-with-team-parker-racing/" rel="bookmark" title="Esmee Hawkey targeting Porsche Carrera Cup GB title with Team Parker Racing">Esmee Hawkey targeting Porsche Carrera Cup GB title...</a>
</h4>
<span class="slide-item-date">Jan 22, 2020</span>
</div>
</div>
</div>
<div class="penci-slide-widget">
<div class="penci-slide-content">
<span class="penci-image-holder" style="background-image: url('https://i0.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/01/Peter-Jackson-BRC.jpg?resize=585%2C390&#038;ssl=1');" title="Newcomer Jackson hopes to secure the title in JBRC"></span>
<a href="https://www.thecheckeredflag.co.uk/2020/01/newcomer-jackson-hopes-to-secure-the-title-in-jbrc/" class="penci-widget-slider-overlay" title="Newcomer Jackson hopes to secure the title in JBRC"></a>
<div class="penci-widget-slide-detail">
<h4>
<a href="https://www.thecheckeredflag.co.uk/2020/01/newcomer-jackson-hopes-to-secure-the-title-in-jbrc/" rel="bookmark" title="Newcomer Jackson hopes to secure the title in JBRC">Newcomer Jackson hopes to secure the title in...</a>
</h4>
<span class="slide-item-date">Jan 22, 2020</span>
</div>
</div>
</div>
<div class="penci-slide-widget">
<div class="penci-slide-content">
<span class="penci-image-holder" style="background-image: url('https://i1.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/01/BRC-Academy.jpg?resize=585%2C390&#038;ssl=1');" title="BRC Academy Trophy to be introduced this year for youngsters to shine"></span>
<a href="https://www.thecheckeredflag.co.uk/2020/01/brc-academy-trophy-to-be-introduced-this-year-for-youngsters-to-shine/" class="penci-widget-slider-overlay" title="BRC Academy Trophy to be introduced this year for youngsters to shine"></a>
<div class="penci-widget-slide-detail">
<h4>
<a href="https://www.thecheckeredflag.co.uk/2020/01/brc-academy-trophy-to-be-introduced-this-year-for-youngsters-to-shine/" rel="bookmark" title="BRC Academy Trophy to be introduced this year for youngsters to shine">BRC Academy Trophy to be introduced this year...</a>
</h4>
<span class="slide-item-date">Jan 22, 2020</span>
</div>
</div>
</div>
</div>
</aside><aside id="penci_popular_news_widget-5" class="widget penci_popular_news_widget"><h4 class="widget-title penci-border-arrow"><span class="inner-arrow">Popular on TCF</span></h4> <ul id="penci-popularwg-2500" class="side-newsfeed">
<li class="penci-feed featured-news">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder" rel="bookmark" style="background-image: url('https://i2.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/01/Pierre-Gasly-39.jpg?resize=585%2C390&#038;ssl=1');" href="https://www.thecheckeredflag.co.uk/2020/01/gasly-should-take-some-of-the-blame-for-red-bull-exit-marko/" title="Gasly ‘Should Take Some of the Blame’ for Red Bull Exit – Marko"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.thecheckeredflag.co.uk/2020/01/gasly-should-take-some-of-the-blame-for-red-bull-exit-marko/" rel="bookmark" title="Gasly ‘Should Take Some of the Blame’ for Red Bull Exit – Marko">
Gasly ‘Should Take Some of the Blame’ for Red Bull Exit – Marko </a>
</h4>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder small-fix-size" rel="bookmark" style="background-image: url('https://i1.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/01/Lappi-WRC.jpg?resize=263%2C175&#038;ssl=1');" href="https://www.thecheckeredflag.co.uk/2020/01/esapekka-lappi-monte-carlo-is-always-a-tricky-start-to-the-season/" title="Esapekka Lappi &#8211; &#8220;Monte-Carlo is always a tricky start to the season&#8221;"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.thecheckeredflag.co.uk/2020/01/esapekka-lappi-monte-carlo-is-always-a-tricky-start-to-the-season/" rel="bookmark" title="Esapekka Lappi &#8211; &#8220;Monte-Carlo is always a tricky start to the season&#8221;">
Esapekka Lappi &#8211; &#8220;Monte-Carlo is always a tricky start to the season&#8221; </a>
</h4>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder small-fix-size" rel="bookmark" style="background-image: url('https://i2.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/01/IMG_20012020_094801_800_x_533_pixel.jpg?resize=263%2C175&#038;ssl=1');" href="https://www.thecheckeredflag.co.uk/2020/01/reinis-nitiss-steps-out-from-rallycross-for-2020-and-aiming-for-jwrc-debut-in-2021/" title="Reinis Nitišs steps out from rallycross for 2020 and aiming for JWRC debut in 2021"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.thecheckeredflag.co.uk/2020/01/reinis-nitiss-steps-out-from-rallycross-for-2020-and-aiming-for-jwrc-debut-in-2021/" rel="bookmark" title="Reinis Nitišs steps out from rallycross for 2020 and aiming for JWRC debut in 2021">
Reinis Nitišs steps out from rallycross for 2020 and aiming for JWRC debut in 2021 </a>
</h4>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder small-fix-size" rel="bookmark" style="background-image: url('https://i1.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/01/Esmee-Hawkey.jpg?resize=263%2C175&#038;ssl=1');" href="https://www.thecheckeredflag.co.uk/2020/01/esmee-hawkey-targeting-porsche-carrera-cup-gb-title-with-team-parker-racing/" title="Esmee Hawkey targeting Porsche Carrera Cup GB title with Team Parker Racing"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.thecheckeredflag.co.uk/2020/01/esmee-hawkey-targeting-porsche-carrera-cup-gb-title-with-team-parker-racing/" rel="bookmark" title="Esmee Hawkey targeting Porsche Carrera Cup GB title with Team Parker Racing">
Esmee Hawkey targeting Porsche Carrera Cup GB title with Team Parker Racing </a>
</h4>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder small-fix-size" rel="bookmark" style="background-image: url('https://i0.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/01/Manaf-Hijawi-Douglas-Motorsport.jpg?resize=263%2C175&#038;ssl=1');" href="https://www.thecheckeredflag.co.uk/2020/01/manaf-hijawi-becomes-first-jordanian-british-f3-driver-as-he-signs-for-douglas-motorsport-for-2020/" title="Manaf Hijawi becomes first Jordanian British F3 driver as he signs for Douglas Motorsport for 2020"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.thecheckeredflag.co.uk/2020/01/manaf-hijawi-becomes-first-jordanian-british-f3-driver-as-he-signs-for-douglas-motorsport-for-2020/" rel="bookmark" title="Manaf Hijawi becomes first Jordanian British F3 driver as he signs for Douglas Motorsport for 2020">
Manaf Hijawi becomes first Jordanian British F3 driver as he signs for Douglas Motorsport for 2020 </a>
</h4>
</div>
</div>
</li>
</ul>
</aside><aside id="nav_menu-4" class="widget widget_nav_menu"><div class="menu-top-container"><ul id="menu-top" class="menu"><li id="menu-item-131978" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-131978"><a href="https://www.thecheckeredflag.co.uk/latest-news/">News</a></li>
<li id="menu-item-131965" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131965"><a href="https://www.thecheckeredflag.co.uk/features/">Features</a></li>
<li id="menu-item-173707" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-173707"><a href="https://www.thecheckeredflag.co.uk/features/gallery/">Photos</a></li>
<li id="menu-item-131884" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131884"><a href="https://www.thecheckeredflag.co.uk/tcf-blogs/">TCF Blogs</a></li>
<li id="menu-item-131986" class="menu-item menu-item-type-taxonomy menu-item-object-post_format menu-item-131986"><a href="https://www.thecheckeredflag.co.uk/type/video/">Videos</a></li>
<li id="menu-item-131967" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-131967"><a href="https://www.thecheckeredflag.co.uk/contribute/">Contribute</a></li>
<li id="menu-item-131966" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-131966"><a href="https://www.thecheckeredflag.co.uk/contact/">Contact Us</a></li>
</ul></div></aside><aside id="text-12" class="widget widget_text"> <div class="textwidget"><p><a href="https://www.facebook.com/groups/porschemotorsportcommunity/" target="_blank" rel="noopener noreferrer"><img class="aligncenter size-full wp-image-310781" src="https://i2.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2019/06/PMC-Square-1.jpg?resize=400%2C400&#038;ssl=1" alt="Porsche Motorsport Community" width="400" height="400" data-recalc-dims="1" /></a></p>
</div>
</aside><aside id="custom_html-8" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget">
<ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-9159179884377372" data-ad-slot="2468886887" data-ad-format="auto"></ins>
<script>
window.setTimeout(function(){ 
  (adsbygoogle = window.adsbygoogle || []).push({}); 
}, 200); 
</script></div></aside><aside id="penci_social_widget-2" class="widget penci_social_widget"><h4 class="widget-title penci-border-arrow"><span class="inner-arrow">Keep in touch</span></h4>
<div class="widget-social pc_aligncenter">
<a href="https://facebook.com/TheCheckeredFlag" rel="nofollow" target="_blank"><i class="penci-faicon fa fa-facebook" style="font-size: 18px"></i><span style="font-size: 13px">Facebook</span></a>
<a href="https://twitter.com/TheCheckerFlag" rel="nofollow" target="_blank"><i class="penci-faicon fa fa-twitter" style="font-size: 18px"></i><span style="font-size: 13px">Twitter</span></a>
<a href="https://instagram.com/thecheckeredflag/" rel="nofollow" target="_blank"><i class="penci-faicon fa fa-instagram" style="font-size: 18px"></i><span style="font-size: 13px">Instagram</span></a>
<a href="https://www.linkedin.com/company/thecheckeredflag/" rel="nofollow" target="_blank"><i class="penci-faicon fa fa-linkedin" style="font-size: 18px"></i><span style="font-size: 13px">Linkedin</span></a>
<a href="https://www.youtube.com/channel/UCueRVoGbSE4GF2RszehXIgw" rel="nofollow" target="_blank"><i class="penci-faicon fa fa-youtube-play" style="font-size: 18px"></i><span style="font-size: 13px">Youtube</span></a>
<a href="https://www.thecheckeredflag.co.uk/feed" rel="nofollow" target="_blank"><i class="penci-faicon fa fa-rss" style="font-size: 18px"></i><span style="font-size: 13px">RSS</span></a>
</div>
</aside><aside id="penci_latest_news_widget-2" class="widget penci_latest_news_widget"><h4 class="widget-title penci-border-arrow"><span class="inner-arrow">Recent Features</span></h4> <ul id="penci-latestwg-5218" class="side-newsfeed penci-feed-2columns penci-2columns-feed">
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder small-fix-size" rel="bookmark" style="background-image: url('https://i1.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/01/tanak-2.jpg?resize=263%2C175&#038;ssl=1');" href="https://www.thecheckeredflag.co.uk/2020/01/preview-2020-fia-world-rally-championship-rally-monte-carlo-all-change-at-the-top-for-2020/" title="PREVIEW: 2020 FIA World Rally Championship – Rally Monte-Carlo: All Change at the Top for 2020"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.thecheckeredflag.co.uk/2020/01/preview-2020-fia-world-rally-championship-rally-monte-carlo-all-change-at-the-top-for-2020/" rel="bookmark" title="PREVIEW: 2020 FIA World Rally Championship – Rally Monte-Carlo: All Change at the Top for 2020">
PREVIEW: 2020 FIA World Rally Championship – Rally Monte-Carlo: All Change at the Top for 2020 </a>
</h4>
<span class="side-item-meta"><time class="entry-date published" datetime="2020-01-22T11:55:00+00:00">January 22, 2020</time></span>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder small-fix-size" rel="bookmark" style="background-image: url('https://i1.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2019/06/maloney-start-resize.jpg?resize=263%2C175&#038;ssl=1');" href="https://www.thecheckeredflag.co.uk/2020/01/season-review-2019-f4-british-championship-maloney-seals-one-of-the-closest-title-fights-yet/" title="SEASON REVIEW: 2019 F4 BRITISH CHAMPIONSHIP – MALONEY SEALS ONE OF THE CLOSEST TITLE FIGHTS YET"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.thecheckeredflag.co.uk/2020/01/season-review-2019-f4-british-championship-maloney-seals-one-of-the-closest-title-fights-yet/" rel="bookmark" title="SEASON REVIEW: 2019 F4 BRITISH CHAMPIONSHIP – MALONEY SEALS ONE OF THE CLOSEST TITLE FIGHTS YET">
SEASON REVIEW: 2019 F4 BRITISH CHAMPIONSHIP – MALONEY SEALS ONE OF THE CLOSEST TITLE FIGHTS YET </a>
</h4>
<span class="side-item-meta"><time class="entry-date published" datetime="2020-01-21T19:57:00+00:00">January 21, 2020</time></span>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder small-fix-size" rel="bookmark" style="background-image: url('https://i0.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/01/1017411226-20190330-_L5R0557-scaled.jpg?resize=263%2C175&#038;ssl=1');" href="https://www.thecheckeredflag.co.uk/2020/01/f2-chasing-the-dream-documentary-revie/" title="REVIEW &#8211; Formula 2: Chasing The Dream Documentary"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.thecheckeredflag.co.uk/2020/01/f2-chasing-the-dream-documentary-revie/" rel="bookmark" title="REVIEW &#8211; Formula 2: Chasing The Dream Documentary">
REVIEW &#8211; Formula 2: Chasing The Dream Documentary </a>
</h4>
<span class="side-item-meta"><time class="entry-date published" datetime="2020-01-21T13:33:24+00:00">January 21, 2020</time></span>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder small-fix-size" rel="bookmark" style="background-image: url('https://i2.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/01/Robert-Shwartzman-Champion-.jpg?resize=263%2C175&#038;ssl=1');" href="https://www.thecheckeredflag.co.uk/2020/01/review-2019-fia-formula-3-championship-supreme-shwartzman/" title="SEASON REVIEW: 2019 FIA Formula 3 Championship &#8211; Supreme Shwartzman"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.thecheckeredflag.co.uk/2020/01/review-2019-fia-formula-3-championship-supreme-shwartzman/" rel="bookmark" title="SEASON REVIEW: 2019 FIA Formula 3 Championship &#8211; Supreme Shwartzman">
SEASON REVIEW: 2019 FIA Formula 3 Championship &#8211; Supreme Shwartzman </a>
</h4>
<span class="side-item-meta"><time class="entry-date published" datetime="2020-01-19T19:25:24+00:00">January 19, 2020</time></span>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder small-fix-size" rel="bookmark" style="background-image: url('https://i2.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/01/ASI-2020-10.jpg?resize=263%2C175&#038;ssl=1');" href="https://www.thecheckeredflag.co.uk/2020/01/gallery-2020-autosport-international-show/" title="Gallery: 2020 Autosport International Show"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.thecheckeredflag.co.uk/2020/01/gallery-2020-autosport-international-show/" rel="bookmark" title="Gallery: 2020 Autosport International Show">
Gallery: 2020 Autosport International Show </a>
</h4>
<span class="side-item-meta"><time class="entry-date published" datetime="2020-01-17T15:52:17+00:00">January 17, 2020</time></span>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder small-fix-size" rel="bookmark" style="background-image: url('https://i2.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/01/Bennett-3.jpg?resize=263%2C175&#038;ssl=1');" href="https://www.thecheckeredflag.co.uk/2020/01/oliver-bennett-on-2020-world-rx-it-could-be-the-best-year-of-rallycross-yet/" title="Oliver Bennett on 2020 World RX: “It Could Be the Best Year of Rallycross Yet”"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.thecheckeredflag.co.uk/2020/01/oliver-bennett-on-2020-world-rx-it-could-be-the-best-year-of-rallycross-yet/" rel="bookmark" title="Oliver Bennett on 2020 World RX: “It Could Be the Best Year of Rallycross Yet”">
Oliver Bennett on 2020 World RX: “It Could Be the Best Year of Rallycross Yet” </a>
</h4>
<span class="side-item-meta"><time class="entry-date published" datetime="2020-01-16T20:16:41+00:00">January 16, 2020</time></span>
</div>
</div>
</li>
</ul>
</aside> </div>
</div>
</div>
<div class="clear-footer"></div>
<div class="footer-subscribe">
<aside id="mc4wp_form_widget-2" class="widget widget_mc4wp_form_widget"><script>(function() {
	if ( ! window.mc4wp) {
		window.mc4wp = {
			listeners: [],
			forms    : {
				on: function (event, callback) {
					window.mc4wp.listeners.push(
						{
							event   : event,
							callback: callback
						}
					);
				}
			}
		}
	}
})();
</script><form id="mc4wp-form-1" class="mc4wp-form mc4wp-form-293151" method="post" data-id="293151" data-name="TCF Daily Headlines to your Inbox"><div class="mc4wp-form-fields"><p class="mdes">Get the latest headlines from TCF in a daily roundup, straight to your inbox</p>
<p class="memail"><input type="email" id="mc4wp_email" name="EMAIL" placeholder="Email..." required /></p>
<p class="msubmit"><input type="submit" value="Subscribe" /></p></div><label style="display: none !important;">Leave this field empty if you're human: <input type="text" name="_mc4wp_honeypot" value="" tabindex="-1" autocomplete="off" /></label><input type="hidden" name="_mc4wp_timestamp" value="1579696509" /><input type="hidden" name="_mc4wp_form_id" value="293151" /><input type="hidden" name="_mc4wp_form_element_id" value="mc4wp-form-1" /><div class="mc4wp-response"></div></form></aside> </div>
<footer id="footer-section" class="penci-footer-social-media penci-lazy" itemscope itemtype="https://schema.org/WPFooter">
<div class="container">
<div class="footer-socials-section">
<ul class="footer-socials">
<li><a href="https://facebook.com/TheCheckeredFlag" rel="nofollow" target="_blank"><i class="penci-faicon fa fa-facebook"></i><span>Facebook</span></a></li>
<li><a href="https://twitter.com/TheCheckerFlag" rel="nofollow" target="_blank"><i class="penci-faicon fa fa-twitter"></i><span>Twitter</span></a></li>
<li><a href="https://instagram.com/thecheckeredflag/" rel="nofollow" target="_blank"><i class="penci-faicon fa fa-instagram"></i><span>Instagram</span></a></li>
<li><a href="https://www.linkedin.com/company/thecheckeredflag/" rel="nofollow" target="_blank"><i class="penci-faicon fa fa-linkedin"></i><span>Linkedin</span></a></li>
<li><a href="https://www.youtube.com/channel/UCueRVoGbSE4GF2RszehXIgw" rel="nofollow" target="_blank"><i class="penci-faicon fa fa-youtube-play"></i><span>Youtube</span></a></li>
<li><a href="https://www.thecheckeredflag.co.uk/feed" rel="nofollow" target="_blank"><i class="penci-faicon fa fa-rss"></i><span>RSS</span></a></li>
</ul>
</div>
<div class="footer-logo-copyright footer-not-logo">
<div id="footer-copyright">
<p><a href="https://www.thecheckeredflag.co.uk/contact/">Contact Us</a> | <a href="https://www.thecheckeredflag.co.uk/contribute/">Contribute</a> | <a href="https://www.thecheckeredflag.co.uk/about-us">About Us</a><br />
<a href="https://www.thecheckeredflag.co.uk/tcf-partners/">TCF Friends & Partners</a> | <a href="https://www.thecheckeredflag.co.uk/submitting-news/">Submitting News</a> | <a href="https://www.thecheckeredflag.co.uk/terms-and-conditions/">T & C</a> | <a href="https://www.thecheckeredflag.co.uk/privacy-policy/">Privacy Policy</a> | <a href="https://www.thecheckeredflag.co.uk/cookies-in-use-on-this-site/">Cookie Policy</a><br />
©Copyright MMXIX - The Checkered Flag - All Rights Reserved</p>
</div>
<div class="go-to-top-parent"><a href="#" class="go-to-top"><span><i class="penci-faicon fa fa-angle-up"></i> <br>Back To Top</span></a></div>
</div>
</div>
</footer>
</div>
<div id="fb-root"></div>
<div class="penci-wrap-gprd-law penci-wrap-gprd-law-close penci-close-all">
<div class="penci-gprd-law">
<p>
This website uses cookies to improve your experience. We&#039;ll assume you&#039;re ok with this, but you can opt-out if you wish. <a class="penci-gprd-accept" href="#">Accept</a> <a class="penci-gprd-more" href="#">Read More</a> </p>
</div>
</div>

<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-MG875N"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<script>(function() {function addEventListener(element,event,handler) {
	if (element.addEventListener) {
		element.addEventListener( event,handler, false );
	} else if (element.attachEvent) {
		element.attachEvent( 'on' + event,handler );
	}
}
function maybePrefixUrlField() {
	if (this.value.trim() !== '' && this.value.indexOf( 'http' ) !== 0) {
		this.value = "http://" + this.value;
	}
}

var urlFields = document.querySelectorAll( '.mc4wp-form input[type="url"]' );
if ( urlFields && urlFields.length > 0 ) {
	for ( var j = 0; j < urlFields.length; j++ ) {
		addEventListener( urlFields[j],'blur',maybePrefixUrlField );
	}
}
/* test if browser supports date fields */
var testInput = document.createElement( 'input' );
testInput.setAttribute( 'type', 'date' );
if ( testInput.type !== 'date') {

	/* add placeholder & pattern to all date fields */
	var dateFields = document.querySelectorAll( '.mc4wp-form input[type="date"]' );
	for (var i = 0; i < dateFields.length; i++) {
		if ( ! dateFields[i].placeholder) {
			dateFields[i].placeholder = 'YYYY-MM-DD';
		}
		if ( ! dateFields[i].pattern) {
			dateFields[i].pattern = '[0-9]{4}-(0[1-9]|1[012])-(0[1-9]|1[0-9]|2[0-9]|3[01])';
		}
	}
}
})();</script>
<script type='text/javascript'>
/* <![CDATA[ */
var countVars = {"disqusShortname":"thecheckerdflag"};
/* ]]> */
</script>
<script type='text/javascript'>
/* <![CDATA[ */
var embedVars = {"disqusConfig":{"integration":"wordpress 3.0.17"},"disqusIdentifier":"329697 https:\/\/www.thecheckeredflag.co.uk\/?p=329697","disqusShortname":"thecheckerdflag","disqusTitle":"Carmichael to enter the new Motorsport UK National Championship","disqusUrl":"https:\/\/www.thecheckeredflag.co.uk\/2020\/01\/carmichael-to-enter-the-new-motorsport-uk-national-championship\/","postId":"329697"};
/* ]]> */
</script>
<script type='text/javascript'>
/* <![CDATA[ */
var ajax_var_more = {"url":"https:\/\/www.thecheckeredflag.co.uk\/wp-admin\/admin-ajax.php","nonce":"fef9d87152","errorPass":"<p class=\"message message-error\">Password does not match the confirm password<\/p>","login":"Email Address","password":"Password"};
/* ]]> */
</script>
<script type='text/javascript'>
/* <![CDATA[ */
var ajax_var = {"url":"https:\/\/www.thecheckeredflag.co.uk\/wp-admin\/admin-ajax.php","nonce":"fef9d87152","errorPass":"<p class=\"message message-error\">Password does not match the confirm password<\/p>","login":"Email Address","password":"Password"};
/* ]]> */
</script>
<script type='text/javascript'>
/* <![CDATA[ */
var SOLEDADLOCALIZE = {"url":"https:\/\/www.thecheckeredflag.co.uk\/wp-admin\/admin-ajax.php","nonce":"fef9d87152","errorPass":"<p class=\"message message-error\">Password does not match the confirm password<\/p>","login":"Email Address","password":"Password"};
/* ]]> */
</script>
<script type='text/javascript'>
/* <![CDATA[ */
var mc4wp_forms_config = [];
/* ]]> */
</script>
<!--[if lte IE 9]>
<script type='text/javascript' src='https://www.thecheckeredflag.co.uk/wp-content/plugins/mailchimp-for-wp/assets/js/third-party/placeholders.min.js?ver=4.7.4'></script>
<![endif]-->
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:8.1',blog:'9437658',post:'329697',tz:'0',srv:'www.thecheckeredflag.co.uk'} ]);
	_stq.push([ 'clickTrackerInit', '9437658', '329697' ]);
</script>
<script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><script type='text/javascript' src='https://c0.wp.com/p/jetpack/8.1/_inc/build/photon/photon.min.js'></script><script type='text/javascript' src='https://c0.wp.com/c/5.3.2/wp-includes/js/wp-embed.min.js'></script><script type='text/javascript' src='https://stats.wp.com/e-202004.js' async='async' defer='defer'></script><script data-optimized='1' src='https://www.thecheckeredflag.co.uk/min/8c2e9.js'></script></body>
</html>
