<!DOCTYPE html>
<html lang="en-GB">
<head>
<meta charset="UTF-8"><link rel='stylesheet' id='wp-block-library-css' href='https://c0.wp.com/c/5.3.2/wp-includes/css/dist/block-library/style.min.css' type='text/css' media='all' /><link rel='stylesheet' id='wp-block-library-theme-css' href='https://c0.wp.com/c/5.3.2/wp-includes/css/dist/block-library/theme.min.css' type='text/css' media='all' /><link rel='stylesheet' id='penci-fonts-css' href='//fonts.googleapis.com/css?family=Playfair+Display+SC%3A300%2C300italic%2C400%2C400italic%2C500%2C500italic%2C700%2C700italic%2C800%2C800italic%7CMontserrat%3A300%2C300italic%2C400%2C400italic%2C500%2C500italic%2C700%2C700italic%2C800%2C800italic%7CRoboto%3A300%2C300italic%2C400%2C400italic%2C500%2C500italic%2C700%2C700italic%2C800%2C800italic%7CArial%3A300%2C300italic%2C400%2C400italic%2C500%2C500italic%2C700%2C700italic%2C800%2C800italic%26subset%3Dlatin%2Ccyrillic%2Ccyrillic-ext%2Cgreek%2Cgreek-ext%2Clatin-ext&#038;ver=1.0' type='text/css' media='all' /><link rel='stylesheet' id='jetpack_css-css' href='https://c0.wp.com/p/jetpack/8.3/css/jetpack.css' type='text/css' media='all' /><link data-optimized='2' rel='stylesheet' href='https://www.thecheckeredflag.co.uk/min/d2f3c.css' /><script type='text/javascript' src='https://c0.wp.com/c/5.3.2/wp-includes/js/jquery/jquery.js'></script><script type='text/javascript' src='https://c0.wp.com/c/5.3.2/wp-includes/js/jquery/jquery-migrate.min.js'></script><script data-optimized='1' src='https://www.thecheckeredflag.co.uk/min/afdb9.js'></script>
<meta http-equiv="X-UA-Compatible" content="IE=edge">
<meta name="viewport" content="width=device-width, initial-scale=1">
<link rel="profile" href="https://gmpg.org/xfn/11" />
<link rel="shortcut icon" href="https://www.thecheckeredflag.co.uk/wp-content/uploads/2018/11/TCF-black.jpg" type="image/x-icon" />
<link rel="apple-touch-icon" sizes="180x180" href="https://www.thecheckeredflag.co.uk/wp-content/uploads/2018/11/TCF-black.jpg">
<link rel="alternate" type="application/rss+xml" title="The Checkered Flag RSS Feed" href="https://www.thecheckeredflag.co.uk/feed/" />
<link rel="alternate" type="application/atom+xml" title="The Checkered Flag Atom Feed" href="https://www.thecheckeredflag.co.uk/feed/atom/" />
<link rel="pingback" href="https://www.thecheckeredflag.co.uk/xmlrpc.php" />
<!--[if lt IE 9]>
	<script src="https://www.thecheckeredflag.co.uk/wp-content/themes/soledad/js/html5.js"></script>
	<![endif]-->
<title>Kaylen Frederick fastest at Snetterton Formula 3 media day - The Checkered Flag</title>

<script data-cfasync="false" data-pagespeed-no-defer type="text/javascript">//<![CDATA[
	var gtm4wp_datalayer_name = "dataLayer";
	var dataLayer = dataLayer || [];
//]]>
</script>


<meta name="description" content="After three sessions of the track, Carlin Racing driver Kaylen Frederick was fastest at Snetterton Media Day" />
<meta name="robots" content="max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
<link rel="canonical" href="https://www.thecheckeredflag.co.uk/2020/03/kaylen-frederick-fastest-at-snetterton-formula-3-media-day/" />
<meta property="og:locale" content="en_GB" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Kaylen Frederick fastest at Snetterton Formula 3 media day - The Checkered Flag" />
<meta property="og:description" content="After three sessions of the track, Carlin Racing driver Kaylen Frederick was fastest at Snetterton Media Day" />
<meta property="og:url" content="https://www.thecheckeredflag.co.uk/2020/03/kaylen-frederick-fastest-at-snetterton-formula-3-media-day/" />
<meta property="og:site_name" content="The Checkered Flag" />
<meta property="article:publisher" content="http://www.facebook.com/TheCheckeredFlag" />
<meta property="article:author" content="sportsblogbylauren" />
<meta property="article:tag" content="2020 BRDC British Formula 3 Championship" />
<meta property="article:tag" content="Kaylen Frederick" />
<meta property="article:tag" content="Nazim Azman" />
<meta property="article:tag" content="Ulysse De Pauw" />
<meta property="article:section" content="British F3" />
<meta property="article:published_time" content="2020-03-08T12:46:48+00:00" />
<meta property="article:modified_time" content="2020-03-08T13:45:54+00:00" />
<meta property="og:updated_time" content="2020-03-08T13:45:54+00:00" />
<meta property="fb:app_id" content="135274436510698" />
<meta property="og:image" content="https://i2.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/03/7077061E-B026-49F2-8273-BB46200F3056.jpeg?fit=800%2C533&#038;ssl=1" />
<meta property="og:image:secure_url" content="https://i2.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/03/7077061E-B026-49F2-8273-BB46200F3056.jpeg?fit=800%2C533&#038;ssl=1" />
<meta property="og:image:width" content="800" />
<meta property="og:image:height" content="533" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:description" content="After three sessions of the track, Carlin Racing driver Kaylen Frederick was fastest at Snetterton Media Day" />
<meta name="twitter:title" content="Kaylen Frederick fastest at Snetterton Formula 3 media day - The Checkered Flag" />
<meta name="twitter:site" content="@thecheckerflag" />
<meta name="twitter:image" content="https://i2.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/03/7077061E-B026-49F2-8273-BB46200F3056.jpeg?fit=800%2C533&#038;ssl=1" />
<meta name="twitter:creator" content="@sportsbylauren" />
<script type='application/ld+json' class='yoast-schema-graph yoast-schema-graph--main'>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</script>

<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="The Checkered Flag &raquo; Feed" href="https://www.thecheckeredflag.co.uk/feed/" />
<link rel="alternate" type="application/rss+xml" title="The Checkered Flag &raquo; Comments Feed" href="https://www.thecheckeredflag.co.uk/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="The Checkered Flag &raquo; Kaylen Frederick fastest at Snetterton Formula 3 media day Comments Feed" href="https://www.thecheckeredflag.co.uk/2020/03/kaylen-frederick-fastest-at-snetterton-formula-3-media-day/feed/" />
<style id='wp-block-library-inline-css' type='text/css'>
.has-text-align-justify{text-align:justify;}
</style>
<!--[if !IE]><!-->
<!--<![endif]-->
<link rel='https://api.w.org/' href='https://www.thecheckeredflag.co.uk/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.thecheckeredflag.co.uk/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.thecheckeredflag.co.uk/wp-includes/wlwmanifest.xml" />
<link rel='shortlink' href='https://www.thecheckeredflag.co.uk/?p=333750' />
<link rel="alternate" type="application/json+oembed" href="https://www.thecheckeredflag.co.uk/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.thecheckeredflag.co.uk%2F2020%2F03%2Fkaylen-frederick-fastest-at-snetterton-formula-3-media-day%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.thecheckeredflag.co.uk/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.thecheckeredflag.co.uk%2F2020%2F03%2Fkaylen-frederick-fastest-at-snetterton-formula-3-media-day%2F&#038;format=xml" />

<script data-cfasync="false" data-pagespeed-no-defer type="text/javascript">//<![CDATA[
	var dataLayer_content = {"pageTitle":"Kaylen Frederick fastest at Snetterton Formula 3 media day - The Checkered Flag","pageCategory":["british-f3-formula-3"],"pageAttributes":["2020-brdc-british-formula-3-championship","kaylen-frederick","nazim-azman","ulysse-de-pauw"],"pagePostAuthor":"Lauren Taylor"};
	dataLayer.push( dataLayer_content );//]]>
</script>
<script data-cfasync="false">//<![CDATA[
(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'//www.googletagmanager.com/gtm.'+'js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-MG875N');//]]>
</script>


<link rel='dns-prefetch' href='//c0.wp.com' />
<link rel='dns-prefetch' href='//i0.wp.com' />
<link rel='dns-prefetch' href='//i1.wp.com' />
<link rel='dns-prefetch' href='//i2.wp.com' />
<style type='text/css'>img#wpstats{display:none}</style><style type="text/css">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</style><script>
var penciBlocksArray=[];
var portfolioDataJs = portfolioDataJs || [];var PENCILOCALCACHE = {};
		(function () {
				"use strict";
		
				PENCILOCALCACHE = {
					data: {},
					remove: function ( ajaxFilterItem ) {
						delete PENCILOCALCACHE.data[ajaxFilterItem];
					},
					exist: function ( ajaxFilterItem ) {
						return PENCILOCALCACHE.data.hasOwnProperty( ajaxFilterItem ) && PENCILOCALCACHE.data[ajaxFilterItem] !== null;
					},
					get: function ( ajaxFilterItem ) {
						return PENCILOCALCACHE.data[ajaxFilterItem];
					},
					set: function ( ajaxFilterItem, cachedData ) {
						PENCILOCALCACHE.remove( ajaxFilterItem );
						PENCILOCALCACHE.data[ajaxFilterItem] = cachedData;
					}
				};
			}
		)();function penciBlock() {
		    this.atts_json = '';
		    this.content = '';
		}</script>
<script type="application/ld+json">{
    "@context": "https:\/\/schema.org\/",
    "@type": "organization",
    "@id": "#organization",
    "logo": {
        "@type": "ImageObject",
        "url": "https:\/\/www.thecheckeredflag.co.uk\/wp-content\/uploads\/2019\/08\/TCF-Square.jpg"
    },
    "url": "https:\/\/www.thecheckeredflag.co.uk\/",
    "name": "The Checkered Flag",
    "description": "Independent motor sport news since 2009"
}</script><script type="application/ld+json">{
    "@context": "https:\/\/schema.org\/",
    "@type": "WebSite",
    "name": "The Checkered Flag",
    "alternateName": "Independent motor sport news since 2009",
    "url": "https:\/\/www.thecheckeredflag.co.uk\/"
}</script><script type="application/ld+json">{
    "@context": "https:\/\/schema.org\/",
    "@type": "BlogPosting",
    "headline": "Kaylen Frederick fastest at Snetterton Formula 3 media day",
    "description": "After three sessions of the track, Carlin Racing driver Kaylen Frederick was fastest at Snetterton Media Day",
    "datePublished": "2020-03-08",
    "datemodified": "2020-03-08",
    "mainEntityOfPage": "https:\/\/www.thecheckeredflag.co.uk\/2020\/03\/kaylen-frederick-fastest-at-snetterton-formula-3-media-day\/",
    "image": {
        "@type": "ImageObject",
        "url": "https:\/\/i2.wp.com\/www.thecheckeredflag.co.uk\/wp-content\/uploads\/2020\/03\/7077061E-B026-49F2-8273-BB46200F3056.jpeg?fit=800%2C533&ssl=1",
        "width": 800,
        "height": 533
    },
    "publisher": {
        "@type": "Organization",
        "name": "The Checkered Flag",
        "logo": {
            "@type": "ImageObject",
            "url": "https:\/\/www.thecheckeredflag.co.uk\/wp-content\/uploads\/2019\/08\/TCF-Square.jpg"
        }
    },
    "author": {
        "@type": "Person",
        "@id": "#person-LaurenTaylor",
        "name": "Lauren Taylor"
    }
}</script><script type="application/ld+json">{
    "@context": "https:\/\/schema.org",
    "@type": "NewsArticle",
    "headline": "Kaylen Frederick fastest at Snetterton Formula 3 media day",
    "image": "https:\/\/i2.wp.com\/www.thecheckeredflag.co.uk\/wp-content\/uploads\/2020\/03\/7077061E-B026-49F2-8273-BB46200F3056.jpeg?fit=800%2C533&ssl=1",
    "datePublished": "2020-03-08",
    "datemodified": "2020-03-08",
    "description": "After three sessions of the track, Carlin Racing driver Kaylen Frederick was fastest at Snetterton Media Day",
    "mainEntityOfPage": "https:\/\/www.thecheckeredflag.co.uk\/2020\/03\/kaylen-frederick-fastest-at-snetterton-formula-3-media-day\/",
    "publisher": {
        "@type": "Organization",
        "name": "The Checkered Flag",
        "logo": {
            "@type": "ImageObject",
            "url": "https:\/\/www.thecheckeredflag.co.uk\/wp-content\/uploads\/2019\/08\/TCF-Square.jpg"
        }
    },
    "author": {
        "@type": "Person",
        "name": "Lauren Taylor"
    }
}</script><link rel="amphtml" href="https://www.thecheckeredflag.co.uk/amp/2020/03/kaylen-frederick-fastest-at-snetterton-formula-3-media-day/" /><link rel="icon" href="https://i0.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2016/02/cropped-TCF.png?fit=32%2C32&#038;ssl=1" sizes="32x32" />
<link rel="icon" href="https://i0.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2016/02/cropped-TCF.png?fit=192%2C192&#038;ssl=1" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="https://i0.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2016/02/cropped-TCF.png?fit=180%2C180&#038;ssl=1" />
<meta name="msapplication-TileImage" content="https://i0.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2016/02/cropped-TCF.png?fit=270%2C270&#038;ssl=1" />
</head>
<body data-rsssl=1 class="post-template-default single single-post postid-333750 single-format-standard">
<a id="close-sidebar-nav" class="header-5"><i class="penci-faicon fa fa-close"></i></a>
<nav id="sidebar-nav" class="header-5" role="navigation" itemscope itemtype="https://schema.org/SiteNavigationElement">
<div id="sidebar-nav-logo">
<a href="https://www.thecheckeredflag.co.uk/"><img class="penci-lazy" src="https://www.thecheckeredflag.co.uk/wp-content/themes/soledad/images/penci-holder.png" data-src="https://www.thecheckeredflag.co.uk/wp-content/uploads/2018/11/TCF-black.jpg" alt="The Checkered Flag" /></a>
</div>
<div class="header-social sidebar-nav-social">
<div class="inner-header-social">
<a href="https://facebook.com/TheCheckeredFlag" rel="nofollow" target="_blank"><i class="penci-faicon fa fa-facebook"></i></a>
<a href="https://twitter.com/TheCheckerFlag" rel="nofollow" target="_blank"><i class="penci-faicon fa fa-twitter"></i></a>
<a href="https://instagram.com/thecheckeredflag/" rel="nofollow" target="_blank"><i class="penci-faicon fa fa-instagram"></i></a>
<a href="https://www.linkedin.com/company/thecheckeredflag/" rel="nofollow" target="_blank"><i class="penci-faicon fa fa-linkedin"></i></a>
<a href="https://www.youtube.com/channel/UCueRVoGbSE4GF2RszehXIgw" rel="nofollow" target="_blank"><i class="penci-faicon fa fa-youtube-play"></i></a>
<a href="https://www.thecheckeredflag.co.uk/feed" rel="nofollow" target="_blank"><i class="penci-faicon fa fa-rss"></i></a>
</div> </div>
<ul id="menu-2015" class="menu"><li id="menu-item-131887" class="menu-item menu-item-type-taxonomy menu-item-object-category penci-mega-menu menu-item-131887"><a href="https://www.thecheckeredflag.co.uk/formula-1/">F1</a>
<ul class="sub-menu">
<li id="menu-item-0" class="menu-item-0"><div class="penci-megamenu">
<div class="penci-content-megamenu">
<div class="penci-mega-latest-posts col-mn-5 mega-row-1">
<div class="penci-mega-row penci-mega-3 row-active">
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.thecheckeredflag.co.uk/formula-1/">
Formula 1 </a>
</span>
<a class="penci-image-holder penci-lazy" data-src="https://i0.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/03/Gene-Haas-01.jpg?resize=585%2C390&#038;ssl=1" href="https://www.thecheckeredflag.co.uk/2020/03/gene-haas-not-ruling-out-pulling-haas-f1-team-out-of-formula-1-after-2020/" title="Gene Haas Not Ruling Out Pulling Haas F1 Team Out of Formula 1 after 2020">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.thecheckeredflag.co.uk/2020/03/gene-haas-not-ruling-out-pulling-haas-f1-team-out-of-formula-1-after-2020/" title="Gene Haas Not Ruling Out Pulling Haas F1 Team Out of Formula 1 after 2020">Gene Haas Not Ruling Out Pulling Haas F1&#8230;</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2020-03-08T16:01:07+00:00">March 8, 2020</time></p>
</div>
</div>
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.thecheckeredflag.co.uk/formula-1/">
Formula 1 </a>
</span>
<a class="penci-image-holder penci-lazy" data-src="https://i2.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/03/Lance-Stroll-08.jpg?resize=585%2C390&#038;ssl=1" href="https://www.thecheckeredflag.co.uk/2020/03/no-point-in-complaining-about-racing-points-rp20-design-process-andreas-seidl/" title="‘No Point’ in Complaining about Racing Point’s RP20 Design Process – Andreas Seidl">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.thecheckeredflag.co.uk/2020/03/no-point-in-complaining-about-racing-points-rp20-design-process-andreas-seidl/" title="‘No Point’ in Complaining about Racing Point’s RP20 Design Process – Andreas Seidl">‘No Point’ in Complaining about Racing Point’s RP20&#8230;</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2020-03-08T15:23:47+00:00">March 8, 2020</time></p>
</div>
</div>
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.thecheckeredflag.co.uk/formula-1/">
Formula 1 </a>
</span>
<a class="penci-image-holder penci-lazy" data-src="https://i2.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/03/Lance-Stroll-07.jpg?resize=585%2C390&#038;ssl=1" href="https://www.thecheckeredflag.co.uk/2020/03/lack-of-financial-resources-prevented-racing-point-reset-prior-to-2020-andrew-green/" title="Lack of Financial Resources Prevented Racing Point ‘Reset’ Prior to 2020 – Andrew Green">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.thecheckeredflag.co.uk/2020/03/lack-of-financial-resources-prevented-racing-point-reset-prior-to-2020-andrew-green/" title="Lack of Financial Resources Prevented Racing Point ‘Reset’ Prior to 2020 – Andrew Green">Lack of Financial Resources Prevented Racing Point ‘Reset’&#8230;</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2020-03-08T14:59:33+00:00">March 8, 2020</time></p>
</div>
</div>
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.thecheckeredflag.co.uk/formula-1/">
Formula 1 </a>
</span>
<a class="penci-image-holder penci-lazy" data-src="https://i0.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/03/Sergio-Perez-04.jpg?resize=585%2C390&#038;ssl=1" href="https://www.thecheckeredflag.co.uk/2020/03/mclarens-james-key-the-last-thing-you-want-to-do-is-copying-your-neighbour/" title="McLaren’s James Key: “The last thing you want to do is copying your neighbour”">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.thecheckeredflag.co.uk/2020/03/mclarens-james-key-the-last-thing-you-want-to-do-is-copying-your-neighbour/" title="McLaren’s James Key: “The last thing you want to do is copying your neighbour”">McLaren’s James Key: “The last thing you want&#8230;</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2020-03-08T13:52:43+00:00">March 8, 2020</time></p>
</div>
</div>
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.thecheckeredflag.co.uk/formula-1/">
Formula 1 </a>
</span>
<a class="penci-image-holder penci-lazy" data-src="https://i0.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/03/Lando-Norris-02.jpg?resize=585%2C390&#038;ssl=1" href="https://www.thecheckeredflag.co.uk/2020/03/mcl35-more-consistent-and-nicer-to-drive-than-mcl34-lando-norris/" title="MCL35 ‘More Consistent and Nicer to Drive’ than MCL34 – Lando Norris">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.thecheckeredflag.co.uk/2020/03/mcl35-more-consistent-and-nicer-to-drive-than-mcl34-lando-norris/" title="MCL35 ‘More Consistent and Nicer to Drive’ than MCL34 – Lando Norris">MCL35 ‘More Consistent and Nicer to Drive’ than&#8230;</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2020-03-08T13:06:59+00:00">March 8, 2020</time></p>
</div>
</div>
</div>
</div>
</div>
</div></li>
</ul>
</li>
<li id="menu-item-131940" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor menu-item-has-children menu-item-131940"><a href="https://www.thecheckeredflag.co.uk/open-wheel/">Open Wheel</a>
<ul class="sub-menu">
<li id="menu-item-131942" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131942"><a href="https://www.thecheckeredflag.co.uk/open-wheel/formula-e/">FIA Formula E</a></li>
<li id="menu-item-131943" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131943"><a href="https://www.thecheckeredflag.co.uk/open-wheel/indycar/">IndyCar</a></li>
<li id="menu-item-333871" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-333871"><a href="https://www.thecheckeredflag.co.uk/open-wheel/fia-formula-2-championship/">FIA Formula 2</a></li>
<li id="menu-item-296601" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-296601"><a href="https://www.thecheckeredflag.co.uk/open-wheel/formula-3/fia-formula-3-championship/">FIA Formula 3</a></li>
<li id="menu-item-321059" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-321059"><a href="https://www.thecheckeredflag.co.uk/open-wheel/w-series/">W Series</a></li>
<li id="menu-item-180961" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-180961"><a href="https://www.thecheckeredflag.co.uk/open-wheel/formula-3/british-f3-formula-3/">British F3</a></li>
<li id="menu-item-131897" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131897"><a href="https://www.thecheckeredflag.co.uk/open-wheel/msa-formula/">F4 British Championship</a></li>
<li id="menu-item-131946" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131946"><a href="https://www.thecheckeredflag.co.uk/open-wheel/formula-3/euroformula-open/">EuroFormula Open</a></li>
<li id="menu-item-330918" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-330918"><a href="https://www.thecheckeredflag.co.uk/open-wheel/formula-renault-eurocup/">Formula Renault Eurocup</a></li>
<li id="menu-item-330987" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-330987"><a href="https://www.thecheckeredflag.co.uk/open-wheel/formula-3/formula-regional-european-championship/">Formula Regional European Championship</a></li>
</ul>
</li>
<li id="menu-item-131952" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-131952"><a href="https://www.thecheckeredflag.co.uk/sportscars/">Sportscars</a>
<ul class="sub-menu">
<li id="menu-item-131956" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131956"><a href="https://www.thecheckeredflag.co.uk/sportscars/endurance/fiawec/">FIA WEC</a></li>
<li id="menu-item-131957" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131957"><a href="https://www.thecheckeredflag.co.uk/sportscars/endurance/blancpain-endurance-series/">GT World Challenge Europe Endurance Cup</a></li>
<li id="menu-item-148232" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-148232"><a href="https://www.thecheckeredflag.co.uk/sportscars/endurance/blancpain-sprint/">GT World Challenge Europe</a></li>
<li id="menu-item-131954" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131954"><a href="https://www.thecheckeredflag.co.uk/sportscars/gt-sportscars/british-gt/">British GT</a></li>
<li id="menu-item-290801" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-290801"><a href="https://www.thecheckeredflag.co.uk/sportscars/ginetta/">Ginetta Series</a></li>
<li id="menu-item-303742" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-303742"><a href="https://www.thecheckeredflag.co.uk/sportscars/porsche/">Porsche Series</a></li>
</ul>
</li>
<li id="menu-item-131899" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-131899"><a href="https://www.thecheckeredflag.co.uk/touring-cars/">Touring Cars</a>
<ul class="sub-menu">
<li id="menu-item-131904" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131904"><a href="https://www.thecheckeredflag.co.uk/touring-cars/btcc/">BTCC</a></li>
<li id="menu-item-192543" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-192543"><a href="https://www.thecheckeredflag.co.uk/touring-cars/dtm/">DTM</a></li>
<li id="menu-item-317944" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-317944"><a href="https://www.thecheckeredflag.co.uk/touring-cars/jaguar-i-pace-etrophy/">Jaguar I-PACE eTROPHY</a></li>
</ul>
</li>
<li id="menu-item-131918" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-131918"><a href="https://www.thecheckeredflag.co.uk/motorcycles/">Motorcycles</a>
<ul class="sub-menu">
<li id="menu-item-131922" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131922"><a href="https://www.thecheckeredflag.co.uk/motorcycles/motogp/">MotoGP</a></li>
<li id="menu-item-131920" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131920"><a href="https://www.thecheckeredflag.co.uk/motorcycles/moto2/">Moto2</a></li>
<li id="menu-item-131921" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131921"><a href="https://www.thecheckeredflag.co.uk/motorcycles/moto3/">Moto3</a></li>
</ul>
</li>
<li id="menu-item-290798" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-290798"><a href="https://www.thecheckeredflag.co.uk/offroad/">Off Road</a>
<ul class="sub-menu">
<li id="menu-item-254211" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-254211"><a href="https://www.thecheckeredflag.co.uk/offroad/rally/fiawrc/">FIA WRC</a></li>
<li id="menu-item-138301" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-138301"><a href="https://www.thecheckeredflag.co.uk/offroad/rally/fia-erc/">FIA ERC</a></li>
<li id="menu-item-131910" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131910"><a href="https://www.thecheckeredflag.co.uk/offroad/rally/british-rally-championship/">British Rally Championship</a></li>
<li id="menu-item-131917" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131917"><a href="https://www.thecheckeredflag.co.uk/offroad/rallycross/world-rallycross/">FIA World RX</a></li>
<li id="menu-item-131913" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131913"><a href="https://www.thecheckeredflag.co.uk/offroad/rallycross/european-rallycross/">FIA European RX</a></li>
<li id="menu-item-330919" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-330919"><a href="https://www.thecheckeredflag.co.uk/offroad/rallycross/british-rallycross/">British Rallycross</a></li>
<li id="menu-item-332829" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-332829"><a href="https://www.thecheckeredflag.co.uk/offroad/rallycross/rallyx-nordic/">RallyX Nordic</a></li>
</ul>
</li>
<li id="menu-item-290800" class="menu-item menu-item-type-taxonomy menu-item-object-category penci-mega-menu menu-item-290800"><a href="https://www.thecheckeredflag.co.uk/nascar/">NASCAR</a>
<ul class="sub-menu">
<li class="menu-item-0"><div class="penci-megamenu"> <div class="penci-mega-child-categories">
<a class="mega-cat-child" href="https://www.thecheckeredflag.co.uk/nascar/sprint-cup/" data-id="penci-mega-2741"><span>NASCAR Cup Series</span></a>
<a class="mega-cat-child" href="https://www.thecheckeredflag.co.uk/nascar/nascar-trucks/" data-id="penci-mega-18305"><span>NASCAR Gander Trucks</span></a>
<a class="mega-cat-child" href="https://www.thecheckeredflag.co.uk/nascar/euro-racecar/" data-id="penci-mega-8304"><span>NASCAR Whelen Euro Series</span></a>
<a class="mega-cat-child" href="https://www.thecheckeredflag.co.uk/nascar/nascar-xfinity-series/" data-id="penci-mega-2742"><span>NASCAR Xfinity Series</span></a>
<a class="mega-cat-child cat-active all-style" href="https://www.thecheckeredflag.co.uk/nascar/" data-id="penci-mega-108"><span>All</span></a>
</div>
<div class="penci-content-megamenu">
<div class="penci-mega-latest-posts col-mn-4 mega-row-1">
<div class="penci-mega-row penci-mega-2741">
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.thecheckeredflag.co.uk/nascar/sprint-cup/">NASCAR Cup Series</a> </span>
<a class="penci-image-holder penci-lazy" data-src="https://i2.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/03/Ryan-Blaney-NCS-Auto-Club-2020.jpg?resize=585%2C390&#038;ssl=1" href="https://www.thecheckeredflag.co.uk/2020/03/ryan-blaney-signs-contract-extension-with-penske/" title="Ryan Blaney signs contract extension with Penske">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.thecheckeredflag.co.uk/2020/03/ryan-blaney-signs-contract-extension-with-penske/" title="Ryan Blaney signs contract extension with Penske">Ryan Blaney signs contract extension with Penske</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2020-03-06T16:24:34+00:00">March 6, 2020</time></p>
</div>
</div>
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.thecheckeredflag.co.uk/nascar/sprint-cup/">NASCAR Cup Series</a> </span>
<a class="penci-image-holder penci-lazy" data-src="https://i1.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/03/Erik-Jones-2020-Busch-Clash-VL.jpg?resize=585%2C390&#038;ssl=1" href="https://www.thecheckeredflag.co.uk/2020/03/busch-clash-moves-to-daytona-road-course-for-2021/" title="Busch Clash moves to Daytona road course for 2021">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.thecheckeredflag.co.uk/2020/03/busch-clash-moves-to-daytona-road-course-for-2021/" title="Busch Clash moves to Daytona road course for 2021">Busch Clash moves to Daytona road course for&#8230;</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2020-03-05T01:19:05+00:00">March 5, 2020</time></p>
</div>
</div>
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.thecheckeredflag.co.uk/nascar/sprint-cup/">NASCAR Cup Series</a> </span>
<a class="penci-image-holder penci-lazy" data-src="https://i2.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/03/Goodyear-tires-NASCAR-NSCS-2015.jpg?resize=585%2C390&#038;ssl=1" href="https://www.thecheckeredflag.co.uk/2020/03/nascar-next-gen-to-feature-single-lug-wheel/" title="NASCAR Next Gen to feature single-lug wheel">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.thecheckeredflag.co.uk/2020/03/nascar-next-gen-to-feature-single-lug-wheel/" title="NASCAR Next Gen to feature single-lug wheel">NASCAR Next Gen to feature single-lug wheel</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2020-03-03T03:37:04+00:00">March 3, 2020</time></p>
</div>
</div>
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.thecheckeredflag.co.uk/nascar/sprint-cup/">NASCAR Cup Series</a> </span>
<a class="penci-image-holder penci-lazy" data-src="https://i0.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/03/Alex-Bowman-2020-NCS-Fontana-Auto-Club-400-celebration.jpg?resize=585%2C390&#038;ssl=1" href="https://www.thecheckeredflag.co.uk/2020/03/alex-bowman-dominates-final-stage-to-auto-club-400-win/" title="Alex Bowman dominates final stage to Auto Club 400 win">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.thecheckeredflag.co.uk/2020/03/alex-bowman-dominates-final-stage-to-auto-club-400-win/" title="Alex Bowman dominates final stage to Auto Club 400 win">Alex Bowman dominates final stage to Auto Club&#8230;</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2020-03-01T23:33:39+00:00">March 1, 2020</time></p>
</div>
</div>
</div>
<div class="penci-mega-row penci-mega-18305">
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.thecheckeredflag.co.uk/nascar/nascar-trucks/">NASCAR Gander Trucks</a> </span>
<a class="penci-image-holder penci-lazy" data-src="https://i0.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/02/lvms1_ngrots_buschcelebration_022120.jpg?resize=585%2C390&#038;ssl=1" href="https://www.thecheckeredflag.co.uk/2020/02/kyle-busch-bounty-hunt-picks-up-chase-elliott-kyle-larson/" title="Kyle Busch bounty hunt picks up Chase Elliott, Kyle Larson">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.thecheckeredflag.co.uk/2020/02/kyle-busch-bounty-hunt-picks-up-chase-elliott-kyle-larson/" title="Kyle Busch bounty hunt picks up Chase Elliott, Kyle Larson">Kyle Busch bounty hunt picks up Chase Elliott,&#8230;</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2020-02-28T01:47:13+00:00">February 28, 2020</time></p>
</div>
</div>
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.thecheckeredflag.co.uk/nascar/nascar-trucks/">NASCAR Gander Trucks</a> </span>
<a class="penci-image-holder penci-lazy" data-src="https://i1.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/02/dean_2019ngots_truckshot.jpg?resize=585%2C390&#038;ssl=1" href="https://www.thecheckeredflag.co.uk/2020/02/gus-dean-ryan-truex-recruited-by-hill-niece-for-truck-runs/" title="Gus Dean, Ryan Truex recruited by Hill, Niece for Truck runs">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.thecheckeredflag.co.uk/2020/02/gus-dean-ryan-truex-recruited-by-hill-niece-for-truck-runs/" title="Gus Dean, Ryan Truex recruited by Hill, Niece for Truck runs">Gus Dean, Ryan Truex recruited by Hill, Niece&#8230;</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2020-02-04T22:29:56+00:00">February 4, 2020</time></p>
</div>
</div>
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.thecheckeredflag.co.uk/nascar/nascar-trucks/">NASCAR Gander Trucks</a> </span>
<a class="penci-image-holder penci-lazy" data-src="https://i1.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/01/Spencer-Boyd-Talladega-NGOTS-VL-2019.jpg?resize=585%2C390&#038;ssl=1" href="https://www.thecheckeredflag.co.uk/2020/01/spencer-boyd-returns-to-youngs-for-full-truck-season/" title="Spencer Boyd returns to Young&#8217;s for full Truck season">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.thecheckeredflag.co.uk/2020/01/spencer-boyd-returns-to-youngs-for-full-truck-season/" title="Spencer Boyd returns to Young&#8217;s for full Truck season">Spencer Boyd returns to Young&#8217;s for full Truck&#8230;</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2020-01-31T16:40:07+00:00">January 31, 2020</time></p>
</div>
</div>
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.thecheckeredflag.co.uk/nascar/nascar-trucks/">NASCAR Gander Trucks</a> </span>
<a class="penci-image-holder penci-lazy" data-src="https://i2.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/01/ruch_2019ngots_truckshot.jpg?resize=585%2C390&#038;ssl=1" href="https://www.thecheckeredflag.co.uk/2020/01/angela-ruch-joins-reaume-brothers-for-full-truck-season/" title="Angela Ruch joins Reaume Brothers for full Truck season">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.thecheckeredflag.co.uk/2020/01/angela-ruch-joins-reaume-brothers-for-full-truck-season/" title="Angela Ruch joins Reaume Brothers for full Truck season">Angela Ruch joins Reaume Brothers for full Truck&#8230;</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2020-01-29T21:51:44+00:00">January 29, 2020</time></p>
</div>
</div>
</div>
<div class="penci-mega-row penci-mega-8304">
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.thecheckeredflag.co.uk/nascar/euro-racecar/">NASCAR Whelen Euro Series</a> </span>
<a class="penci-image-holder penci-lazy" data-src="https://i0.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2019/10/Memphis-Racing-23-2019-NWES.jpg?resize=585%2C390&#038;ssl=1" href="https://www.thecheckeredflag.co.uk/2019/10/2020-nascar-whelen-euro-series-schedule-released/" title="2020 NASCAR Whelen Euro Series schedule released">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.thecheckeredflag.co.uk/2019/10/2020-nascar-whelen-euro-series-schedule-released/" title="2020 NASCAR Whelen Euro Series schedule released">2020 NASCAR Whelen Euro Series schedule released</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2019-10-22T17:43:44+01:00">October 22, 2019</time></p>
</div>
</div>
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.thecheckeredflag.co.uk/nascar/euro-racecar/">NASCAR Whelen Euro Series</a> </span>
<a class="penci-image-holder penci-lazy" data-src="https://i0.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2019/10/NWES-Team-FJ-2030-partnership.jpg?resize=585%2C390&#038;ssl=1" href="https://www.thecheckeredflag.co.uk/2019/10/nascar-team-fj-sign-ten-year-extension-for-whelen-euro-series-sanction/" title="NASCAR, Team FJ sign ten-year extension for Whelen Euro Series sanction">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.thecheckeredflag.co.uk/2019/10/nascar-team-fj-sign-ten-year-extension-for-whelen-euro-series-sanction/" title="NASCAR, Team FJ sign ten-year extension for Whelen Euro Series sanction">NASCAR, Team FJ sign ten-year extension for Whelen&#8230;</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2019-10-04T16:25:28+01:00">October 4, 2019</time></p>
</div>
</div>
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.thecheckeredflag.co.uk/nascar/euro-racecar/">NASCAR Whelen Euro Series</a> </span>
<a class="penci-image-holder penci-lazy" data-src="https://i0.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2019/04/Ander-Vilarino-Valencia-2019-NWES.jpg?resize=585%2C390&#038;ssl=1" href="https://www.thecheckeredflag.co.uk/2019/04/vilarino-maggi-risitano-kick-off-2019-euro-series-with-valencia-victories/" title="Vilarino, Maggi, Risitano kick off 2019 Euro Series with Valencia victories">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.thecheckeredflag.co.uk/2019/04/vilarino-maggi-risitano-kick-off-2019-euro-series-with-valencia-victories/" title="Vilarino, Maggi, Risitano kick off 2019 Euro Series with Valencia victories">Vilarino, Maggi, Risitano kick off 2019 Euro Series&#8230;</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2019-04-15T05:25:02+01:00">April 15, 2019</time></p>
</div>
</div>
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.thecheckeredflag.co.uk/nascar/euro-racecar/">NASCAR Whelen Euro Series</a> </span>
<a class="penci-image-holder penci-lazy" data-src="https://i1.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2019/04/Euro-NASCAR-18-32-paddock.jpg?resize=585%2C390&#038;ssl=1" href="https://www.thecheckeredflag.co.uk/2019/04/nascar-gp-of-spain-featuring-decorated-grid/" title="NASCAR GP of Spain featuring decorated grid">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.thecheckeredflag.co.uk/2019/04/nascar-gp-of-spain-featuring-decorated-grid/" title="NASCAR GP of Spain featuring decorated grid">NASCAR GP of Spain featuring decorated grid</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2019-04-10T18:07:18+01:00">April 10, 2019</time></p>
</div>
</div>
</div>
<div class="penci-mega-row penci-mega-2742">
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.thecheckeredflag.co.uk/nascar/nascar-xfinity-series/">NASCAR Xfinity Series</a> </span>
<a class="penci-image-holder penci-lazy" data-src="https://i0.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/03/Tony-Stewart-NASCAR-Hall-of-Fame-2020.jpg?resize=585%2C390&#038;ssl=1" href="https://www.thecheckeredflag.co.uk/2020/03/tony-stewart-making-nascar-return-at-indy-road-course/" title="Tony Stewart making NASCAR return at Indy road course">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.thecheckeredflag.co.uk/2020/03/tony-stewart-making-nascar-return-at-indy-road-course/" title="Tony Stewart making NASCAR return at Indy road course">Tony Stewart making NASCAR return at Indy road&#8230;</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2020-03-05T00:55:41+00:00">March 5, 2020</time></p>
</div>
</div>
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.thecheckeredflag.co.uk/nascar/nascar-xfinity-series/">NASCAR Xfinity Series</a> </span>
<a class="penci-image-holder penci-lazy" data-src="https://i1.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/02/Kody_Vanderwal_Matt_Levin_2017_Carneros_200.jpg?resize=585%2C390&#038;ssl=1" href="https://www.thecheckeredflag.co.uk/2020/02/means-racing-to-field-jj-yeley-kody-vanderwal/" title="Means Racing to field JJ Yeley, Kody Vanderwal">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.thecheckeredflag.co.uk/2020/02/means-racing-to-field-jj-yeley-kody-vanderwal/" title="Means Racing to field JJ Yeley, Kody Vanderwal">Means Racing to field JJ Yeley, Kody Vanderwal</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2020-02-14T01:25:14+00:00">February 14, 2020</time></p>
</div>
</div>
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.thecheckeredflag.co.uk/nascar/nascar-xfinity-series/">NASCAR Xfinity Series</a> </span>
<a class="penci-image-holder penci-lazy" data-src="https://i1.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/02/mcleod_2019nxs_carshot.jpg?resize=585%2C390&#038;ssl=1" href="https://www.thecheckeredflag.co.uk/2020/02/jd-motorsports-finalise-2020-lineup/" title="JD Motorsports finalise 2020 lineup">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.thecheckeredflag.co.uk/2020/02/jd-motorsports-finalise-2020-lineup/" title="JD Motorsports finalise 2020 lineup">JD Motorsports finalise 2020 lineup</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2020-02-10T20:59:36+00:00">February 10, 2020</time></p>
</div>
</div>
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.thecheckeredflag.co.uk/nascar/nascar-xfinity-series/">NASCAR Xfinity Series</a> </span>
<a class="penci-image-holder penci-lazy" data-src="https://i0.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/02/Matt-DiBenedetto-IMS-road-course-test-2020-markers.jpg?resize=585%2C390&#038;ssl=1" href="https://www.thecheckeredflag.co.uk/2020/02/pennzoil-150-race-details-outlined/" title="Pennzoil 150 race details outlined">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.thecheckeredflag.co.uk/2020/02/pennzoil-150-race-details-outlined/" title="Pennzoil 150 race details outlined">Pennzoil 150 race details outlined</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2020-02-04T23:51:40+00:00">February 4, 2020</time></p>
</div>
</div>
</div>
<div class="penci-mega-row penci-mega-108 row-active">
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.thecheckeredflag.co.uk/nascar/">NASCAR</a> </span>
<a class="penci-image-holder penci-lazy" data-src="https://i2.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/03/Ryan-Blaney-NCS-Auto-Club-2020.jpg?resize=585%2C390&#038;ssl=1" href="https://www.thecheckeredflag.co.uk/2020/03/ryan-blaney-signs-contract-extension-with-penske/" title="Ryan Blaney signs contract extension with Penske">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.thecheckeredflag.co.uk/2020/03/ryan-blaney-signs-contract-extension-with-penske/" title="Ryan Blaney signs contract extension with Penske">Ryan Blaney signs contract extension with Penske</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2020-03-06T16:24:34+00:00">March 6, 2020</time></p>
</div>
</div>
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.thecheckeredflag.co.uk/nascar/">NASCAR</a> </span>
<a class="penci-image-holder penci-lazy" data-src="https://i1.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/03/Erik-Jones-2020-Busch-Clash-VL.jpg?resize=585%2C390&#038;ssl=1" href="https://www.thecheckeredflag.co.uk/2020/03/busch-clash-moves-to-daytona-road-course-for-2021/" title="Busch Clash moves to Daytona road course for 2021">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.thecheckeredflag.co.uk/2020/03/busch-clash-moves-to-daytona-road-course-for-2021/" title="Busch Clash moves to Daytona road course for 2021">Busch Clash moves to Daytona road course for&#8230;</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2020-03-05T01:19:05+00:00">March 5, 2020</time></p>
</div>
</div>
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.thecheckeredflag.co.uk/nascar/">NASCAR</a> </span>
<a class="penci-image-holder penci-lazy" data-src="https://i0.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/03/Tony-Stewart-NASCAR-Hall-of-Fame-2020.jpg?resize=585%2C390&#038;ssl=1" href="https://www.thecheckeredflag.co.uk/2020/03/tony-stewart-making-nascar-return-at-indy-road-course/" title="Tony Stewart making NASCAR return at Indy road course">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.thecheckeredflag.co.uk/2020/03/tony-stewart-making-nascar-return-at-indy-road-course/" title="Tony Stewart making NASCAR return at Indy road course">Tony Stewart making NASCAR return at Indy road&#8230;</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2020-03-05T00:55:41+00:00">March 5, 2020</time></p>
</div>
</div>
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.thecheckeredflag.co.uk/nascar/">NASCAR</a> </span>
<a class="penci-image-holder penci-lazy" data-src="https://i0.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/03/TCF-IndyCar-2019-Johnson-IMS.jpg?resize=585%2C390&#038;ssl=1" href="https://www.thecheckeredflag.co.uk/2020/03/jimmie-johnson-to-test-mclaren-indycar-at-barber/" title="Jimmie Johnson to test McLaren IndyCar at Barber">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.thecheckeredflag.co.uk/2020/03/jimmie-johnson-to-test-mclaren-indycar-at-barber/" title="Jimmie Johnson to test McLaren IndyCar at Barber">Jimmie Johnson to test McLaren IndyCar at Barber</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2020-03-04T21:11:21+00:00">March 4, 2020</time></p>
</div>
</div>
</div>
</div>
</div>
</div></li>
</ul>
</li>
<li id="menu-item-293110" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-293110"><a href="https://www.thecheckeredflag.co.uk/features/">Features</a>
<ul class="sub-menu">
<li id="menu-item-330921" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-330921"><a href="https://www.thecheckeredflag.co.uk/tcf-blogs/">TCF Blogs</a></li>
<li id="menu-item-293115" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-293115"><a href="https://www.thecheckeredflag.co.uk/features/opinion/">Opinion</a></li>
<li id="menu-item-293113" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-293113"><a href="https://www.thecheckeredflag.co.uk/features/interviews/">Interviews</a></li>
<li id="menu-item-293114" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-293114"><a href="https://www.thecheckeredflag.co.uk/features/gallery/">Gallery</a></li>
<li id="menu-item-293111" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-293111"><a href="https://www.thecheckeredflag.co.uk/features/product-review/">Product Review</a></li>
<li id="menu-item-293112" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-293112"><a href="https://www.thecheckeredflag.co.uk/features/season-review/">Season Review</a></li>
<li id="menu-item-293118" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-293118"><a href="https://www.thecheckeredflag.co.uk/other/esports/">eSports</a></li>
<li id="menu-item-293117" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-293117"><a href="https://www.thecheckeredflag.co.uk/other/video-games/">Sim Racing</a></li>
</ul>
</li>
</ul> </nav>
<div class="wrapper-boxed header-style-header-5 penci-hlogo-center">
<div class="penci-header-wrap"><div class="penci-top-bar">
<div class="container">
<div class="penci-headline" role="navigation" itemscope itemtype="https://schema.org/SiteNavigationElement">
<span class="headline-title">Latest</span>
<div class="penci-topbar-social">
<div class="inner-header-social">
<a href="https://facebook.com/TheCheckeredFlag" rel="nofollow" target="_blank"><i class="penci-faicon fa fa-facebook"></i></a>
<a href="https://twitter.com/TheCheckerFlag" rel="nofollow" target="_blank"><i class="penci-faicon fa fa-twitter"></i></a>
<a href="https://instagram.com/thecheckeredflag/" rel="nofollow" target="_blank"><i class="penci-faicon fa fa-instagram"></i></a>
<a href="https://www.linkedin.com/company/thecheckeredflag/" rel="nofollow" target="_blank"><i class="penci-faicon fa fa-linkedin"></i></a>
<a href="https://www.youtube.com/channel/UCueRVoGbSE4GF2RszehXIgw" rel="nofollow" target="_blank"><i class="penci-faicon fa fa-youtube-play"></i></a>
<a href="https://www.thecheckeredflag.co.uk/feed" rel="nofollow" target="_blank"><i class="penci-faicon fa fa-rss"></i></a>
</div> </div>
<div class="penci-owl-carousel penci-owl-carousel-slider penci-headline-posts" data-auto="true" data-autotime="3000" data-speed="200">
<div>
<a class="penci-topbar-post-title" href="https://www.thecheckeredflag.co.uk/2020/03/gene-haas-not-ruling-out-pulling-haas-f1-team-out-of-formula-1-after-2020/">Gene Haas Not Ruling Out Pulling Haas F1 Team Out of Formula 1 after 2020</a>
</div>
<div>
<a class="penci-topbar-post-title" href="https://www.thecheckeredflag.co.uk/2020/03/makinen-is-feeling-confident-for-the-rally-mexico/">Mäkinen is feeling confident for the Rally Mexico</a>
</div>
<div>
<a class="penci-topbar-post-title" href="https://www.thecheckeredflag.co.uk/2020/03/no-point-in-complaining-about-racing-points-rp20-design-process-andreas-seidl/">‘No Point’ in Complaining about Racing Point’s RP20 Design Process – Andreas Seidl</a>
</div>
<div>
<a class="penci-topbar-post-title" href="https://www.thecheckeredflag.co.uk/2020/03/ogier-hoping-to-take-his-sixth-rally-mexico-win/">Ogier hoping to take his sixth Rally Mexico win</a>
</div>
<div>
<a class="penci-topbar-post-title" href="https://www.thecheckeredflag.co.uk/2020/03/lack-of-financial-resources-prevented-racing-point-reset-prior-to-2020-andrew-green/">Lack of Financial Resources Prevented Racing Point ‘Reset’ Prior to 2020 – Andrew Green</a>
</div>
<div>
<a class="penci-topbar-post-title" href="https://www.thecheckeredflag.co.uk/2020/03/hugo-de-sadeleer-announces-2020-plans-with-r-motorsport/">Hugo de Sadeleer announces 2020 plans with R-Motorsport</a>
</div>
<div>
<a class="penci-topbar-post-title" href="https://www.thecheckeredflag.co.uk/2020/03/black-falcon-to-field-two-cars-for-the-gt-world-challenge-europe/">Black Falcon to field two cars for the GT World Challenge Europe</a>
</div>
<div>
<a class="penci-topbar-post-title" href="https://www.thecheckeredflag.co.uk/2020/03/uni-virtuosi-begin-sophomore-f2-year-with-solid-test/">UNI-Virtuosi begin sophomore F2 year with solid test</a>
</div>
<div>
<a class="penci-topbar-post-title" href="https://www.thecheckeredflag.co.uk/2020/03/mclarens-james-key-the-last-thing-you-want-to-do-is-copying-your-neighbour/">McLaren’s James Key: “The last thing you want to do is copying your neighbour”</a>
</div>
<div>
<a class="penci-topbar-post-title" href="https://www.thecheckeredflag.co.uk/2020/03/mikkel-grundtvig-completes-jhr-developments-lineup-for-2020/">Mikkel Grundtvig completes JHR Developments&#8217; lineup for 2020</a>
</div>
</div>
</div>
</div>
</div><header id="header" class="header-header-5 has-bottom-line" itemscope="itemscope" itemtype="https://schema.org/WPHeader">
<div class="inner-header penci-header-second">
<div class="container container-fullwidth">
<div id="logo">
<a href="https://www.thecheckeredflag.co.uk/"><img src="https://www.thecheckeredflag.co.uk/wp-content/uploads/2019/10/TCF-Header-2019.png" alt="The Checkered Flag" /></a> </div>
</div>
</div>
<nav id="navigation" class="header-layout-bottom header-5 menu-style-2 menu-item-padding" role="navigation" itemscope itemtype="https://schema.org/SiteNavigationElement">
<div class="container container-fullwidth">
<div class="button-menu-mobile header-5"><i class="penci-faicon fa fa-bars"></i></div>
<ul id="menu-2016" class="menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category penci-mega-menu menu-item-131887"><a href="https://www.thecheckeredflag.co.uk/formula-1/">F1</a>
<ul class="sub-menu">
<li class="menu-item-0"><div class="penci-megamenu">
<div class="penci-content-megamenu">
<div class="penci-mega-latest-posts col-mn-5 mega-row-1">
<div class="penci-mega-row penci-mega-3 row-active">
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.thecheckeredflag.co.uk/formula-1/">
Formula 1 </a>
</span>
<a class="penci-image-holder penci-lazy" data-src="https://i0.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/03/Gene-Haas-01.jpg?resize=585%2C390&#038;ssl=1" href="https://www.thecheckeredflag.co.uk/2020/03/gene-haas-not-ruling-out-pulling-haas-f1-team-out-of-formula-1-after-2020/" title="Gene Haas Not Ruling Out Pulling Haas F1 Team Out of Formula 1 after 2020">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.thecheckeredflag.co.uk/2020/03/gene-haas-not-ruling-out-pulling-haas-f1-team-out-of-formula-1-after-2020/" title="Gene Haas Not Ruling Out Pulling Haas F1 Team Out of Formula 1 after 2020">Gene Haas Not Ruling Out Pulling Haas F1&#8230;</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2020-03-08T16:01:07+00:00">March 8, 2020</time></p>
</div>
</div>
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.thecheckeredflag.co.uk/formula-1/">
Formula 1 </a>
</span>
<a class="penci-image-holder penci-lazy" data-src="https://i2.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/03/Lance-Stroll-08.jpg?resize=585%2C390&#038;ssl=1" href="https://www.thecheckeredflag.co.uk/2020/03/no-point-in-complaining-about-racing-points-rp20-design-process-andreas-seidl/" title="‘No Point’ in Complaining about Racing Point’s RP20 Design Process – Andreas Seidl">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.thecheckeredflag.co.uk/2020/03/no-point-in-complaining-about-racing-points-rp20-design-process-andreas-seidl/" title="‘No Point’ in Complaining about Racing Point’s RP20 Design Process – Andreas Seidl">‘No Point’ in Complaining about Racing Point’s RP20&#8230;</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2020-03-08T15:23:47+00:00">March 8, 2020</time></p>
</div>
</div>
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.thecheckeredflag.co.uk/formula-1/">
Formula 1 </a>
</span>
<a class="penci-image-holder penci-lazy" data-src="https://i2.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/03/Lance-Stroll-07.jpg?resize=585%2C390&#038;ssl=1" href="https://www.thecheckeredflag.co.uk/2020/03/lack-of-financial-resources-prevented-racing-point-reset-prior-to-2020-andrew-green/" title="Lack of Financial Resources Prevented Racing Point ‘Reset’ Prior to 2020 – Andrew Green">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.thecheckeredflag.co.uk/2020/03/lack-of-financial-resources-prevented-racing-point-reset-prior-to-2020-andrew-green/" title="Lack of Financial Resources Prevented Racing Point ‘Reset’ Prior to 2020 – Andrew Green">Lack of Financial Resources Prevented Racing Point ‘Reset’&#8230;</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2020-03-08T14:59:33+00:00">March 8, 2020</time></p>
</div>
</div>
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.thecheckeredflag.co.uk/formula-1/">
Formula 1 </a>
</span>
<a class="penci-image-holder penci-lazy" data-src="https://i0.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/03/Sergio-Perez-04.jpg?resize=585%2C390&#038;ssl=1" href="https://www.thecheckeredflag.co.uk/2020/03/mclarens-james-key-the-last-thing-you-want-to-do-is-copying-your-neighbour/" title="McLaren’s James Key: “The last thing you want to do is copying your neighbour”">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.thecheckeredflag.co.uk/2020/03/mclarens-james-key-the-last-thing-you-want-to-do-is-copying-your-neighbour/" title="McLaren’s James Key: “The last thing you want to do is copying your neighbour”">McLaren’s James Key: “The last thing you want&#8230;</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2020-03-08T13:52:43+00:00">March 8, 2020</time></p>
</div>
</div>
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.thecheckeredflag.co.uk/formula-1/">
Formula 1 </a>
</span>
<a class="penci-image-holder penci-lazy" data-src="https://i0.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/03/Lando-Norris-02.jpg?resize=585%2C390&#038;ssl=1" href="https://www.thecheckeredflag.co.uk/2020/03/mcl35-more-consistent-and-nicer-to-drive-than-mcl34-lando-norris/" title="MCL35 ‘More Consistent and Nicer to Drive’ than MCL34 – Lando Norris">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.thecheckeredflag.co.uk/2020/03/mcl35-more-consistent-and-nicer-to-drive-than-mcl34-lando-norris/" title="MCL35 ‘More Consistent and Nicer to Drive’ than MCL34 – Lando Norris">MCL35 ‘More Consistent and Nicer to Drive’ than&#8230;</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2020-03-08T13:06:59+00:00">March 8, 2020</time></p>
</div>
</div>
</div>
</div>
</div>
</div></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor menu-item-has-children menu-item-131940"><a href="https://www.thecheckeredflag.co.uk/open-wheel/">Open Wheel</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131942"><a href="https://www.thecheckeredflag.co.uk/open-wheel/formula-e/">FIA Formula E</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131943"><a href="https://www.thecheckeredflag.co.uk/open-wheel/indycar/">IndyCar</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-333871"><a href="https://www.thecheckeredflag.co.uk/open-wheel/fia-formula-2-championship/">FIA Formula 2</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-296601"><a href="https://www.thecheckeredflag.co.uk/open-wheel/formula-3/fia-formula-3-championship/">FIA Formula 3</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-321059"><a href="https://www.thecheckeredflag.co.uk/open-wheel/w-series/">W Series</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-180961"><a href="https://www.thecheckeredflag.co.uk/open-wheel/formula-3/british-f3-formula-3/">British F3</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131897"><a href="https://www.thecheckeredflag.co.uk/open-wheel/msa-formula/">F4 British Championship</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131946"><a href="https://www.thecheckeredflag.co.uk/open-wheel/formula-3/euroformula-open/">EuroFormula Open</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-330918"><a href="https://www.thecheckeredflag.co.uk/open-wheel/formula-renault-eurocup/">Formula Renault Eurocup</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-330987"><a href="https://www.thecheckeredflag.co.uk/open-wheel/formula-3/formula-regional-european-championship/">Formula Regional European Championship</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-131952"><a href="https://www.thecheckeredflag.co.uk/sportscars/">Sportscars</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131956"><a href="https://www.thecheckeredflag.co.uk/sportscars/endurance/fiawec/">FIA WEC</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131957"><a href="https://www.thecheckeredflag.co.uk/sportscars/endurance/blancpain-endurance-series/">GT World Challenge Europe Endurance Cup</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-148232"><a href="https://www.thecheckeredflag.co.uk/sportscars/endurance/blancpain-sprint/">GT World Challenge Europe</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131954"><a href="https://www.thecheckeredflag.co.uk/sportscars/gt-sportscars/british-gt/">British GT</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-290801"><a href="https://www.thecheckeredflag.co.uk/sportscars/ginetta/">Ginetta Series</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-303742"><a href="https://www.thecheckeredflag.co.uk/sportscars/porsche/">Porsche Series</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-131899"><a href="https://www.thecheckeredflag.co.uk/touring-cars/">Touring Cars</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131904"><a href="https://www.thecheckeredflag.co.uk/touring-cars/btcc/">BTCC</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-192543"><a href="https://www.thecheckeredflag.co.uk/touring-cars/dtm/">DTM</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-317944"><a href="https://www.thecheckeredflag.co.uk/touring-cars/jaguar-i-pace-etrophy/">Jaguar I-PACE eTROPHY</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-131918"><a href="https://www.thecheckeredflag.co.uk/motorcycles/">Motorcycles</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131922"><a href="https://www.thecheckeredflag.co.uk/motorcycles/motogp/">MotoGP</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131920"><a href="https://www.thecheckeredflag.co.uk/motorcycles/moto2/">Moto2</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131921"><a href="https://www.thecheckeredflag.co.uk/motorcycles/moto3/">Moto3</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-290798"><a href="https://www.thecheckeredflag.co.uk/offroad/">Off Road</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-254211"><a href="https://www.thecheckeredflag.co.uk/offroad/rally/fiawrc/">FIA WRC</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-138301"><a href="https://www.thecheckeredflag.co.uk/offroad/rally/fia-erc/">FIA ERC</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131910"><a href="https://www.thecheckeredflag.co.uk/offroad/rally/british-rally-championship/">British Rally Championship</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131917"><a href="https://www.thecheckeredflag.co.uk/offroad/rallycross/world-rallycross/">FIA World RX</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131913"><a href="https://www.thecheckeredflag.co.uk/offroad/rallycross/european-rallycross/">FIA European RX</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-330919"><a href="https://www.thecheckeredflag.co.uk/offroad/rallycross/british-rallycross/">British Rallycross</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-332829"><a href="https://www.thecheckeredflag.co.uk/offroad/rallycross/rallyx-nordic/">RallyX Nordic</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category penci-mega-menu menu-item-290800"><a href="https://www.thecheckeredflag.co.uk/nascar/">NASCAR</a>
<ul class="sub-menu">
<li class="menu-item-0"><div class="penci-megamenu"> <div class="penci-mega-child-categories">
<a class="mega-cat-child" href="https://www.thecheckeredflag.co.uk/nascar/sprint-cup/" data-id="penci-mega-2741"><span>NASCAR Cup Series</span></a>
<a class="mega-cat-child" href="https://www.thecheckeredflag.co.uk/nascar/nascar-trucks/" data-id="penci-mega-18305"><span>NASCAR Gander Trucks</span></a>
<a class="mega-cat-child" href="https://www.thecheckeredflag.co.uk/nascar/euro-racecar/" data-id="penci-mega-8304"><span>NASCAR Whelen Euro Series</span></a>
<a class="mega-cat-child" href="https://www.thecheckeredflag.co.uk/nascar/nascar-xfinity-series/" data-id="penci-mega-2742"><span>NASCAR Xfinity Series</span></a>
<a class="mega-cat-child cat-active all-style" href="https://www.thecheckeredflag.co.uk/nascar/" data-id="penci-mega-108"><span>All</span></a>
</div>
<div class="penci-content-megamenu">
<div class="penci-mega-latest-posts col-mn-4 mega-row-1">
<div class="penci-mega-row penci-mega-2741">
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.thecheckeredflag.co.uk/nascar/sprint-cup/">NASCAR Cup Series</a> </span>
<a class="penci-image-holder penci-lazy" data-src="https://i2.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/03/Ryan-Blaney-NCS-Auto-Club-2020.jpg?resize=585%2C390&#038;ssl=1" href="https://www.thecheckeredflag.co.uk/2020/03/ryan-blaney-signs-contract-extension-with-penske/" title="Ryan Blaney signs contract extension with Penske">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.thecheckeredflag.co.uk/2020/03/ryan-blaney-signs-contract-extension-with-penske/" title="Ryan Blaney signs contract extension with Penske">Ryan Blaney signs contract extension with Penske</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2020-03-06T16:24:34+00:00">March 6, 2020</time></p>
</div>
</div>
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.thecheckeredflag.co.uk/nascar/sprint-cup/">NASCAR Cup Series</a> </span>
<a class="penci-image-holder penci-lazy" data-src="https://i1.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/03/Erik-Jones-2020-Busch-Clash-VL.jpg?resize=585%2C390&#038;ssl=1" href="https://www.thecheckeredflag.co.uk/2020/03/busch-clash-moves-to-daytona-road-course-for-2021/" title="Busch Clash moves to Daytona road course for 2021">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.thecheckeredflag.co.uk/2020/03/busch-clash-moves-to-daytona-road-course-for-2021/" title="Busch Clash moves to Daytona road course for 2021">Busch Clash moves to Daytona road course for&#8230;</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2020-03-05T01:19:05+00:00">March 5, 2020</time></p>
</div>
</div>
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.thecheckeredflag.co.uk/nascar/sprint-cup/">NASCAR Cup Series</a> </span>
<a class="penci-image-holder penci-lazy" data-src="https://i2.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/03/Goodyear-tires-NASCAR-NSCS-2015.jpg?resize=585%2C390&#038;ssl=1" href="https://www.thecheckeredflag.co.uk/2020/03/nascar-next-gen-to-feature-single-lug-wheel/" title="NASCAR Next Gen to feature single-lug wheel">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.thecheckeredflag.co.uk/2020/03/nascar-next-gen-to-feature-single-lug-wheel/" title="NASCAR Next Gen to feature single-lug wheel">NASCAR Next Gen to feature single-lug wheel</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2020-03-03T03:37:04+00:00">March 3, 2020</time></p>
</div>
</div>
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.thecheckeredflag.co.uk/nascar/sprint-cup/">NASCAR Cup Series</a> </span>
<a class="penci-image-holder penci-lazy" data-src="https://i0.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/03/Alex-Bowman-2020-NCS-Fontana-Auto-Club-400-celebration.jpg?resize=585%2C390&#038;ssl=1" href="https://www.thecheckeredflag.co.uk/2020/03/alex-bowman-dominates-final-stage-to-auto-club-400-win/" title="Alex Bowman dominates final stage to Auto Club 400 win">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.thecheckeredflag.co.uk/2020/03/alex-bowman-dominates-final-stage-to-auto-club-400-win/" title="Alex Bowman dominates final stage to Auto Club 400 win">Alex Bowman dominates final stage to Auto Club&#8230;</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2020-03-01T23:33:39+00:00">March 1, 2020</time></p>
</div>
</div>
</div>
<div class="penci-mega-row penci-mega-18305">
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.thecheckeredflag.co.uk/nascar/nascar-trucks/">NASCAR Gander Trucks</a> </span>
<a class="penci-image-holder penci-lazy" data-src="https://i0.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/02/lvms1_ngrots_buschcelebration_022120.jpg?resize=585%2C390&#038;ssl=1" href="https://www.thecheckeredflag.co.uk/2020/02/kyle-busch-bounty-hunt-picks-up-chase-elliott-kyle-larson/" title="Kyle Busch bounty hunt picks up Chase Elliott, Kyle Larson">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.thecheckeredflag.co.uk/2020/02/kyle-busch-bounty-hunt-picks-up-chase-elliott-kyle-larson/" title="Kyle Busch bounty hunt picks up Chase Elliott, Kyle Larson">Kyle Busch bounty hunt picks up Chase Elliott,&#8230;</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2020-02-28T01:47:13+00:00">February 28, 2020</time></p>
</div>
</div>
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.thecheckeredflag.co.uk/nascar/nascar-trucks/">NASCAR Gander Trucks</a> </span>
<a class="penci-image-holder penci-lazy" data-src="https://i1.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/02/dean_2019ngots_truckshot.jpg?resize=585%2C390&#038;ssl=1" href="https://www.thecheckeredflag.co.uk/2020/02/gus-dean-ryan-truex-recruited-by-hill-niece-for-truck-runs/" title="Gus Dean, Ryan Truex recruited by Hill, Niece for Truck runs">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.thecheckeredflag.co.uk/2020/02/gus-dean-ryan-truex-recruited-by-hill-niece-for-truck-runs/" title="Gus Dean, Ryan Truex recruited by Hill, Niece for Truck runs">Gus Dean, Ryan Truex recruited by Hill, Niece&#8230;</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2020-02-04T22:29:56+00:00">February 4, 2020</time></p>
</div>
</div>
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.thecheckeredflag.co.uk/nascar/nascar-trucks/">NASCAR Gander Trucks</a> </span>
<a class="penci-image-holder penci-lazy" data-src="https://i1.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/01/Spencer-Boyd-Talladega-NGOTS-VL-2019.jpg?resize=585%2C390&#038;ssl=1" href="https://www.thecheckeredflag.co.uk/2020/01/spencer-boyd-returns-to-youngs-for-full-truck-season/" title="Spencer Boyd returns to Young&#8217;s for full Truck season">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.thecheckeredflag.co.uk/2020/01/spencer-boyd-returns-to-youngs-for-full-truck-season/" title="Spencer Boyd returns to Young&#8217;s for full Truck season">Spencer Boyd returns to Young&#8217;s for full Truck&#8230;</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2020-01-31T16:40:07+00:00">January 31, 2020</time></p>
</div>
</div>
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.thecheckeredflag.co.uk/nascar/nascar-trucks/">NASCAR Gander Trucks</a> </span>
<a class="penci-image-holder penci-lazy" data-src="https://i2.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/01/ruch_2019ngots_truckshot.jpg?resize=585%2C390&#038;ssl=1" href="https://www.thecheckeredflag.co.uk/2020/01/angela-ruch-joins-reaume-brothers-for-full-truck-season/" title="Angela Ruch joins Reaume Brothers for full Truck season">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.thecheckeredflag.co.uk/2020/01/angela-ruch-joins-reaume-brothers-for-full-truck-season/" title="Angela Ruch joins Reaume Brothers for full Truck season">Angela Ruch joins Reaume Brothers for full Truck&#8230;</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2020-01-29T21:51:44+00:00">January 29, 2020</time></p>
</div>
</div>
</div>
<div class="penci-mega-row penci-mega-8304">
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.thecheckeredflag.co.uk/nascar/euro-racecar/">NASCAR Whelen Euro Series</a> </span>
<a class="penci-image-holder penci-lazy" data-src="https://i0.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2019/10/Memphis-Racing-23-2019-NWES.jpg?resize=585%2C390&#038;ssl=1" href="https://www.thecheckeredflag.co.uk/2019/10/2020-nascar-whelen-euro-series-schedule-released/" title="2020 NASCAR Whelen Euro Series schedule released">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.thecheckeredflag.co.uk/2019/10/2020-nascar-whelen-euro-series-schedule-released/" title="2020 NASCAR Whelen Euro Series schedule released">2020 NASCAR Whelen Euro Series schedule released</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2019-10-22T17:43:44+01:00">October 22, 2019</time></p>
</div>
</div>
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.thecheckeredflag.co.uk/nascar/euro-racecar/">NASCAR Whelen Euro Series</a> </span>
<a class="penci-image-holder penci-lazy" data-src="https://i0.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2019/10/NWES-Team-FJ-2030-partnership.jpg?resize=585%2C390&#038;ssl=1" href="https://www.thecheckeredflag.co.uk/2019/10/nascar-team-fj-sign-ten-year-extension-for-whelen-euro-series-sanction/" title="NASCAR, Team FJ sign ten-year extension for Whelen Euro Series sanction">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.thecheckeredflag.co.uk/2019/10/nascar-team-fj-sign-ten-year-extension-for-whelen-euro-series-sanction/" title="NASCAR, Team FJ sign ten-year extension for Whelen Euro Series sanction">NASCAR, Team FJ sign ten-year extension for Whelen&#8230;</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2019-10-04T16:25:28+01:00">October 4, 2019</time></p>
</div>
</div>
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.thecheckeredflag.co.uk/nascar/euro-racecar/">NASCAR Whelen Euro Series</a> </span>
<a class="penci-image-holder penci-lazy" data-src="https://i0.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2019/04/Ander-Vilarino-Valencia-2019-NWES.jpg?resize=585%2C390&#038;ssl=1" href="https://www.thecheckeredflag.co.uk/2019/04/vilarino-maggi-risitano-kick-off-2019-euro-series-with-valencia-victories/" title="Vilarino, Maggi, Risitano kick off 2019 Euro Series with Valencia victories">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.thecheckeredflag.co.uk/2019/04/vilarino-maggi-risitano-kick-off-2019-euro-series-with-valencia-victories/" title="Vilarino, Maggi, Risitano kick off 2019 Euro Series with Valencia victories">Vilarino, Maggi, Risitano kick off 2019 Euro Series&#8230;</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2019-04-15T05:25:02+01:00">April 15, 2019</time></p>
</div>
</div>
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.thecheckeredflag.co.uk/nascar/euro-racecar/">NASCAR Whelen Euro Series</a> </span>
<a class="penci-image-holder penci-lazy" data-src="https://i1.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2019/04/Euro-NASCAR-18-32-paddock.jpg?resize=585%2C390&#038;ssl=1" href="https://www.thecheckeredflag.co.uk/2019/04/nascar-gp-of-spain-featuring-decorated-grid/" title="NASCAR GP of Spain featuring decorated grid">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.thecheckeredflag.co.uk/2019/04/nascar-gp-of-spain-featuring-decorated-grid/" title="NASCAR GP of Spain featuring decorated grid">NASCAR GP of Spain featuring decorated grid</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2019-04-10T18:07:18+01:00">April 10, 2019</time></p>
</div>
</div>
</div>
<div class="penci-mega-row penci-mega-2742">
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.thecheckeredflag.co.uk/nascar/nascar-xfinity-series/">NASCAR Xfinity Series</a> </span>
<a class="penci-image-holder penci-lazy" data-src="https://i0.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/03/Tony-Stewart-NASCAR-Hall-of-Fame-2020.jpg?resize=585%2C390&#038;ssl=1" href="https://www.thecheckeredflag.co.uk/2020/03/tony-stewart-making-nascar-return-at-indy-road-course/" title="Tony Stewart making NASCAR return at Indy road course">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.thecheckeredflag.co.uk/2020/03/tony-stewart-making-nascar-return-at-indy-road-course/" title="Tony Stewart making NASCAR return at Indy road course">Tony Stewart making NASCAR return at Indy road&#8230;</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2020-03-05T00:55:41+00:00">March 5, 2020</time></p>
</div>
</div>
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.thecheckeredflag.co.uk/nascar/nascar-xfinity-series/">NASCAR Xfinity Series</a> </span>
<a class="penci-image-holder penci-lazy" data-src="https://i1.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/02/Kody_Vanderwal_Matt_Levin_2017_Carneros_200.jpg?resize=585%2C390&#038;ssl=1" href="https://www.thecheckeredflag.co.uk/2020/02/means-racing-to-field-jj-yeley-kody-vanderwal/" title="Means Racing to field JJ Yeley, Kody Vanderwal">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.thecheckeredflag.co.uk/2020/02/means-racing-to-field-jj-yeley-kody-vanderwal/" title="Means Racing to field JJ Yeley, Kody Vanderwal">Means Racing to field JJ Yeley, Kody Vanderwal</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2020-02-14T01:25:14+00:00">February 14, 2020</time></p>
</div>
</div>
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.thecheckeredflag.co.uk/nascar/nascar-xfinity-series/">NASCAR Xfinity Series</a> </span>
<a class="penci-image-holder penci-lazy" data-src="https://i1.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/02/mcleod_2019nxs_carshot.jpg?resize=585%2C390&#038;ssl=1" href="https://www.thecheckeredflag.co.uk/2020/02/jd-motorsports-finalise-2020-lineup/" title="JD Motorsports finalise 2020 lineup">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.thecheckeredflag.co.uk/2020/02/jd-motorsports-finalise-2020-lineup/" title="JD Motorsports finalise 2020 lineup">JD Motorsports finalise 2020 lineup</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2020-02-10T20:59:36+00:00">February 10, 2020</time></p>
</div>
</div>
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.thecheckeredflag.co.uk/nascar/nascar-xfinity-series/">NASCAR Xfinity Series</a> </span>
<a class="penci-image-holder penci-lazy" data-src="https://i0.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/02/Matt-DiBenedetto-IMS-road-course-test-2020-markers.jpg?resize=585%2C390&#038;ssl=1" href="https://www.thecheckeredflag.co.uk/2020/02/pennzoil-150-race-details-outlined/" title="Pennzoil 150 race details outlined">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.thecheckeredflag.co.uk/2020/02/pennzoil-150-race-details-outlined/" title="Pennzoil 150 race details outlined">Pennzoil 150 race details outlined</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2020-02-04T23:51:40+00:00">February 4, 2020</time></p>
</div>
</div>
</div>
<div class="penci-mega-row penci-mega-108 row-active">
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.thecheckeredflag.co.uk/nascar/">NASCAR</a> </span>
<a class="penci-image-holder penci-lazy" data-src="https://i2.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/03/Ryan-Blaney-NCS-Auto-Club-2020.jpg?resize=585%2C390&#038;ssl=1" href="https://www.thecheckeredflag.co.uk/2020/03/ryan-blaney-signs-contract-extension-with-penske/" title="Ryan Blaney signs contract extension with Penske">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.thecheckeredflag.co.uk/2020/03/ryan-blaney-signs-contract-extension-with-penske/" title="Ryan Blaney signs contract extension with Penske">Ryan Blaney signs contract extension with Penske</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2020-03-06T16:24:34+00:00">March 6, 2020</time></p>
</div>
</div>
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.thecheckeredflag.co.uk/nascar/">NASCAR</a> </span>
<a class="penci-image-holder penci-lazy" data-src="https://i1.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/03/Erik-Jones-2020-Busch-Clash-VL.jpg?resize=585%2C390&#038;ssl=1" href="https://www.thecheckeredflag.co.uk/2020/03/busch-clash-moves-to-daytona-road-course-for-2021/" title="Busch Clash moves to Daytona road course for 2021">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.thecheckeredflag.co.uk/2020/03/busch-clash-moves-to-daytona-road-course-for-2021/" title="Busch Clash moves to Daytona road course for 2021">Busch Clash moves to Daytona road course for&#8230;</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2020-03-05T01:19:05+00:00">March 5, 2020</time></p>
</div>
</div>
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.thecheckeredflag.co.uk/nascar/">NASCAR</a> </span>
<a class="penci-image-holder penci-lazy" data-src="https://i0.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/03/Tony-Stewart-NASCAR-Hall-of-Fame-2020.jpg?resize=585%2C390&#038;ssl=1" href="https://www.thecheckeredflag.co.uk/2020/03/tony-stewart-making-nascar-return-at-indy-road-course/" title="Tony Stewart making NASCAR return at Indy road course">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.thecheckeredflag.co.uk/2020/03/tony-stewart-making-nascar-return-at-indy-road-course/" title="Tony Stewart making NASCAR return at Indy road course">Tony Stewart making NASCAR return at Indy road&#8230;</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2020-03-05T00:55:41+00:00">March 5, 2020</time></p>
</div>
</div>
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.thecheckeredflag.co.uk/nascar/">NASCAR</a> </span>
<a class="penci-image-holder penci-lazy" data-src="https://i0.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/03/TCF-IndyCar-2019-Johnson-IMS.jpg?resize=585%2C390&#038;ssl=1" href="https://www.thecheckeredflag.co.uk/2020/03/jimmie-johnson-to-test-mclaren-indycar-at-barber/" title="Jimmie Johnson to test McLaren IndyCar at Barber">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.thecheckeredflag.co.uk/2020/03/jimmie-johnson-to-test-mclaren-indycar-at-barber/" title="Jimmie Johnson to test McLaren IndyCar at Barber">Jimmie Johnson to test McLaren IndyCar at Barber</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2020-03-04T21:11:21+00:00">March 4, 2020</time></p>
</div>
</div>
</div>
</div>
</div>
</div></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-293110"><a href="https://www.thecheckeredflag.co.uk/features/">Features</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-330921"><a href="https://www.thecheckeredflag.co.uk/tcf-blogs/">TCF Blogs</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-293115"><a href="https://www.thecheckeredflag.co.uk/features/opinion/">Opinion</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-293113"><a href="https://www.thecheckeredflag.co.uk/features/interviews/">Interviews</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-293114"><a href="https://www.thecheckeredflag.co.uk/features/gallery/">Gallery</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-293111"><a href="https://www.thecheckeredflag.co.uk/features/product-review/">Product Review</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-293112"><a href="https://www.thecheckeredflag.co.uk/features/season-review/">Season Review</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-293118"><a href="https://www.thecheckeredflag.co.uk/other/esports/">eSports</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-293117"><a href="https://www.thecheckeredflag.co.uk/other/video-games/">Sim Racing</a></li>
</ul>
</li>
</ul>
<div id="top-search" class="dfdf">
<a class="search-click"><i class="penci-faicon fa fa-search"></i></a>
<div class="show-search">
<form role="search" method="get" id="searchform" action="https://www.thecheckeredflag.co.uk/">
<div>
<input type="text" class="search-input" placeholder="Type and hit enter..." name="s" id="s" />
</div>
</form> <a class="search-click close-search"><i class="penci-faicon fa fa-close"></i></a>
</div>
</div> </div>
</nav>
</header>
</div>
<div class="container container-single container-single-magazine penci_sidebar  penci-enable-lightbox">
<div id="main">
<div class="theiaStickySidebar">
<article id="post-333750" class="post type-post status-publish hentry">
<div class="header-standard header-classic single-header">
<div class="penci-standard-cat"><span class="cat"><a class="penci-cat-name" href="https://www.thecheckeredflag.co.uk/open-wheel/formula-3/british-f3-formula-3/" rel="category tag">British F3</a></span></div>
<h1 class="post-title single-post-title entry-title">Kaylen Frederick fastest at Snetterton Formula 3 media day</h1>
<div class="penci-hide-tagupdated">
<span class="author-italic author vcard">by <a class="url fn n" href="https://www.thecheckeredflag.co.uk/author/ltaylor/">Lauren Taylor</a></span>
<time class="entry-date published" datetime="2020-03-08T12:46:48+00:00">March 8, 2020</time>
</div>
<div class="post-box-meta-single">
<span class="author-post byline"><span class="author vcard">written by <a class="author-url url fn n" href="https://www.thecheckeredflag.co.uk/author/ltaylor/">Lauren Taylor</a></span></span>
<span><time class="entry-date published" datetime="2020-03-08T12:46:48+00:00">March 8, 2020</time></span>
</div>
</div>
<div class="post-image">
<a href="https://www.thecheckeredflag.co.uk/wp-content/uploads/2020/03/7077061E-B026-49F2-8273-BB46200F3056.jpeg" data-rel="penci-gallery-image-content"> <img width="800" height="533" src="https://i2.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/03/7077061E-B026-49F2-8273-BB46200F3056.jpeg?fit=800%2C533&amp;ssl=1" class="attachment-penci-full-thumb size-penci-full-thumb wp-post-image" alt="" srcset="https://i2.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/03/7077061E-B026-49F2-8273-BB46200F3056.jpeg?w=800&amp;ssl=1 800w, https://i2.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/03/7077061E-B026-49F2-8273-BB46200F3056.jpeg?resize=240%2C160&amp;ssl=1 240w, https://i2.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/03/7077061E-B026-49F2-8273-BB46200F3056.jpeg?resize=768%2C512&amp;ssl=1 768w, https://i2.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/03/7077061E-B026-49F2-8273-BB46200F3056.jpeg?resize=585%2C390&amp;ssl=1 585w, https://i2.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/03/7077061E-B026-49F2-8273-BB46200F3056.jpeg?resize=263%2C175&amp;ssl=1 263w" sizes="(max-width: 800px) 100vw, 800px" /> </a> </div>
<div class="post-entry blockquote-style-1">
<div class="inner-post-entry entry-content" id="penci-post-entry-inner">
<p>Kaylen Frederick, the Carlin Racing driver, topped the times at Snetterton with a time of 1:43.705 in the final session of the 2020 BRDC British F3 Championship.</p>
<p>The day consisted of almost 3 hours of running time, throughout three session in which 16 drivers participated. It was also the public’s first chance to see the new BRDC British F3 car.</p>
<p> A familiar face to the series returned as Ulysse De Pauw topped the morning opening session. Nazim Azman who is also returning back to F3, gathered speed in the second session. Frederick came out on top with a late effort in the third session.</p>
<p>After returning to the championship for a second season, American driver Frederick was 0.016 seconds ahead of Fortec’s Christian Olsen, who was also just over a tenth of a second ahead of Frederick’s teammate Guilherme Peixoto. </p>
<p>With only five minutes of the session left, Olsen went fastest but before long, Frederick picked up pace and set the fastest lap just as a light rain shower prevented the field from improving. </p>
<p>Louis Foster was also familiar to the top of the table throughout the day. He finished fourth, two tenths away from the top time. Next in the line was Kiern Jewiss in fifth, 0.075 seconds away from Foster and slightly ahead of his teammate De Pauw. </p>
<p>Nazim Azman was seventh fastest and was closely followed by Bart Horsten, with Benjamin Pedersen in ninth and Piers Prior in tenth to complete the top 10. </p>
<p>Jordanian Manaf Hijjawi, the Douglas Motorsport driver, was next in eleventh place with Sebastian Alvarez just behind him in twelfth. </p>
<p>Josh Skelton was close behind in thirteenth and was just a tenth clear of Hillspeed’s local driver Oliver Clarke who was in fourteenth. The Chris Dittmann Racing driver Jordan Dempsey was following behind in fifteenth with the Lanan driver Josh Mason completing the 16 car line up. </p>
<p>Fastest driver Frederick commented, “<em>We’ve been working quite hard in the off-season and getting things how we want them. Even though a lot of people in that last session put on new tyres, we still put in quite a good time. We’re still looking for places to improve but it’s a good way to start the season knowing that we’re quite quick</em>”.</p>
<p>“<em>I had a disadvantage last year, everyone who came for their second year had quite a bit more experience, and a lot of people had done British F4 beforehand too, so they had a lot of experience on the tracks and with the teams. </em></p>
<p><em>So having a year under my belt now is really useful and I’m feeling really comfortable. I’m in a great position with this team, I like working with everyone, so I feel confident heading into this year” </em></p>
<p>Finally he added. “<em>I got some decent results last year with a couple of wins and a bunch of podiums but we’re aiming for those consistent results this year as I had way too many mistakes last year.”</em></p>
<div class="penci-single-link-pages">
</div>
<div class="post-tags">
<a href="https://www.thecheckeredflag.co.uk/tag/2020-brdc-british-formula-3-championship/" rel="tag">2020 BRDC British Formula 3 Championship</a><a href="https://www.thecheckeredflag.co.uk/tag/kaylen-frederick/" rel="tag">Kaylen Frederick</a><a href="https://www.thecheckeredflag.co.uk/tag/nazim-azman/" rel="tag">Nazim Azman</a><a href="https://www.thecheckeredflag.co.uk/tag/ulysse-de-pauw/" rel="tag">Ulysse De Pauw</a> </div>
</div>
</div>
<div class="penci-google-adsense-2">

<ins class="adsbygoogle" style="display:inline-block;width:728px;height:90px" data-ad-client="ca-pub-9159179884377372" data-ad-slot="6495511074"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script> </div>
<div class="tags-share-box center-box tags-share-box-s1">
<span class="single-comment-o"><i class="penci-faicon fa fa-comment-o"></i><span class="dsq-postid" data-dsqidentifier="333750 https://www.thecheckeredflag.co.uk/?p=333750">0 comment</span></span>
<div class="post-share">
<span class="post-share-item post-share-plike">
<span class="count-number-like">0</span><a class="penci-post-like single-like-button" data-post_id="333750" title="Like" data-like="Like" data-unlike="Unlike"><i class="penci-faicon fa fa-heart-o"></i></a> </span>
<div class="list-posts-share"><a class="post-share-item post-share-facebook" target="_blank" rel="nofollow" href="https://www.facebook.com/sharer/sharer.php?u=https://www.thecheckeredflag.co.uk/2020/03/kaylen-frederick-fastest-at-snetterton-formula-3-media-day/"><i class="penci-faicon fa fa-facebook"></i><span class="dt-share">Facebook</span></a><a class="post-share-item post-share-twitter" target="_blank" rel="nofollow" href="https://twitter.com/intent/tweet?text=Check%20out%20this%20article:%20Kaylen%20Frederick%20fastest%20at%20Snetterton%20Formula%203%20media%20day%20-%20https://www.thecheckeredflag.co.uk/2020/03/kaylen-frederick-fastest-at-snetterton-formula-3-media-day/"><i class="penci-faicon fa fa-twitter"></i><span class="dt-share">Twitter</span></a><a class="post-share-item post-share-pinterest" data-pin-do="none" rel="nofollow noreferrer noopener" onclick="var e=document.createElement('script');e.setAttribute('type','text/javascript');e.setAttribute('charset','UTF-8');e.setAttribute('src','//assets.pinterest.com/js/pinmarklet.js?r='+Math.random()*99999999);document.body.appendChild(e);"><i class="penci-faicon fa fa-pinterest"></i><span class="dt-share">Pinterest</span></a><a class="post-share-item post-share-linkedin" target="_blank" rel="nofollow" href="https://www.linkedin.com/shareArticle?mini=true&#038;url=https%3A%2F%2Fwww.thecheckeredflag.co.uk%2F2020%2F03%2Fkaylen-frederick-fastest-at-snetterton-formula-3-media-day%2F&#038;title=Kaylen%20Frederick%20fastest%20at%20Snetterton%20Formula%203%20media%20day"><i class="penci-faicon fa fa-linkedin"></i><span class="dt-share">Linkedin</span></a><a class="post-share-item post-share-reddit" target="_blank" rel="nofollow" href="https://reddit.com/submit?url=https%3A%2F%2Fwww.thecheckeredflag.co.uk%2F2020%2F03%2Fkaylen-frederick-fastest-at-snetterton-formula-3-media-day%2F&#038;title=Kaylen%20Frederick%20fastest%20at%20Snetterton%20Formula%203%20media%20day"><i class="penci-faicon fa fa-reddit-alien"></i><span class="dt-share">Reddit</span></a><a class="post-share-item post-share-whatsapp" target="_blank" rel="nofollow" href="https://api.whatsapp.com/send?text=Kaylen%20Frederick%20fastest%20at%20Snetterton%20Formula%203%20media%20day %0A%0A https%3A%2F%2Fwww.thecheckeredflag.co.uk%2F2020%2F03%2Fkaylen-frederick-fastest-at-snetterton-formula-3-media-day%2F"><i class="penci-faicon fa fa-whatsapp"></i><span class="dt-share">Whatsapp</span></a><a class="post-share-item post-share-email" target="_blank" rel="nofollow" href="/cdn-cgi/l/email-protection#330c404651595650470e78524a5f565d1601037541565756415a5058160103555240475640471601035247160103605d5647475641475c5d160103755c415e465f52160103001601035e56575a5216010357524a151003000b08717c776a0e5b47474340091c1c4444441d475b56505b56505856415657555f52541d505c1d46581c010301031c03001c58524a5f565d1e5541565756415a50581e555240475640471e52471e405d5647475641475c5d1e555c415e465f521e001e5e56575a521e57524a1c"><i class="penci-faicon fa fa-envelope"></i><span class="dt-share">Email</span></a></div> </div>
</div>
<div class="post-author">
<div class="author-img">
<img alt='Lauren Taylor' src='https://www.thecheckeredflag.co.uk/wp-content/uploads/2020/02/received_615420169293612-scaled-100x100.jpeg' class='avatar avatar-100 photo' height='100' width='100' /> </div>
<div class="author-content">
<h5><a href="https://www.thecheckeredflag.co.uk/author/ltaylor/" title="Posts by Lauren Taylor" rel="author">Lauren Taylor</a></h5>
<p>I am currently studying A level English Language &amp; Literature at QE college, aiming to become a Sports Journalist. I cover a wide range of areas for TCF with my main interests being F1, WRC and GT series.</p>
<a rel="nofollow" target="_blank" class="author-social" href="https://sportsblogbylauren.home.blog/"><i class="penci-faicon fa fa-globe"></i></a>
<a rel="nofollow" target="_blank" class="author-social" href="https://facebook.com/sportsblogbylauren"><i class="penci-faicon fa fa-facebook"></i></a>
<a rel="nofollow" target="_blank" class="author-social" href="https://twitter.com/sportsbylauren"><i class="penci-faicon fa fa-twitter"></i></a>
<a rel="nofollow" target="_blank" class="author-social" href="https://instagram.com/lauren.02x"><i class="penci-faicon fa fa-instagram"></i></a>
<a rel="nofollow" class="author-social" href="/cdn-cgi/l/email-protection#7e121f0b0c1b10500a1f0712110c3e0a161b1d161b1d151b0c1b1a18121f19501d11500b15"><i class="penci-faicon fa fa-envelope"></i></a>
</div>
</div>
<div class="post-related">
<div class="post-title-box"><h4 class="post-box-title">Related articles</h4></div>
<div class="penci-owl-carousel penci-owl-carousel-slider penci-related-carousel" data-lazy="true" data-item="3" data-desktop="3" data-tablet="2" data-tabsmall="2" data-auto="false" data-speed="300" data-dots="true" data-nav="false">
<div class="item-related">
<a class="related-thumb penci-image-holder" style="background-image: url('https://i1.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/02/095761E6-E274-45AC-82EC-6D2EBC3992C2.jpeg?resize=585%2C390&#038;ssl=1');" href="https://www.thecheckeredflag.co.uk/2020/03/kaylen-frederick-remains-with-carlin-racing-for-2020-brdc-british-f3-campaign/" title="Kaylen Frederick remains with Carlin Racing for 2020 BRDC British F3 Campaign">
</a>
<h3><a href="https://www.thecheckeredflag.co.uk/2020/03/kaylen-frederick-remains-with-carlin-racing-for-2020-brdc-british-f3-campaign/">Kaylen Frederick remains with Carlin Racing for 2020 BRDC British F3 Campaign</a></h3>
<span class="date"><time class="entry-date published" datetime="2020-03-06T22:21:47+00:00">March 6, 2020</time></span>
</div>
<div class="item-related">
<a class="related-thumb penci-image-holder" style="background-image: url('https://i0.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/02/60916969-77CC-4F65-9717-FED858299360.jpeg?resize=585%2C390&#038;ssl=1');" href="https://www.thecheckeredflag.co.uk/2020/02/christian-olsen-signs-fortec-motorsport-for-2020-brdc-british-f3-campaign/" title="Christian Olsen signs Fortec Motorsport for 2020 BRDC British F3 Campaign">
</a>
<h3><a href="https://www.thecheckeredflag.co.uk/2020/02/christian-olsen-signs-fortec-motorsport-for-2020-brdc-british-f3-campaign/">Christian Olsen signs Fortec Motorsport for 2020 BRDC British F3 Campaign</a></h3>
<span class="date"><time class="entry-date published" datetime="2020-02-28T16:19:43+00:00">February 28, 2020</time></span>
</div>
<div class="item-related">
<a class="related-thumb penci-image-holder" style="background-image: url('https://i1.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/02/E0E4F15B-FB12-467E-9AAE-576FEA9FF30C.jpeg?resize=585%2C390&#038;ssl=1');" href="https://www.thecheckeredflag.co.uk/2020/02/josh-skelton-joins-chris-dittmann-racing-for-2020-brdc-british-f3-championship/" title="Josh Skelton joins Chris Dittmann Racing for 2020 BRDC British F3 Championship">
</a>
<h3><a href="https://www.thecheckeredflag.co.uk/2020/02/josh-skelton-joins-chris-dittmann-racing-for-2020-brdc-british-f3-championship/">Josh Skelton joins Chris Dittmann Racing for 2020 BRDC British F3 Championship</a></h3>
<span class="date"><time class="entry-date published" datetime="2020-02-28T09:00:10+00:00">February 28, 2020</time></span>
</div>
<div class="item-related">
<a class="related-thumb penci-image-holder" style="background-image: url('https://i0.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/02/Piers-Prior-F3-2.jpg?resize=585%2C390&#038;ssl=1');" href="https://www.thecheckeredflag.co.uk/2020/02/piers-prior-joins-lanan-racing-for-2020-british-f3/" title="Piers Prior joins Lanan Racing for 2020 British F3 campaign">
</a>
<h3><a href="https://www.thecheckeredflag.co.uk/2020/02/piers-prior-joins-lanan-racing-for-2020-british-f3/">Piers Prior joins Lanan Racing for 2020 British F3 campaign</a></h3>
<span class="date"><time class="entry-date published" datetime="2020-02-26T14:02:49+00:00">February 26, 2020</time></span>
</div>
<div class="item-related">
<a class="related-thumb penci-image-holder" style="background-image: url('https://i0.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/01/Manaf-Hijawi-Douglas-Motorsport.jpg?resize=585%2C390&#038;ssl=1');" href="https://www.thecheckeredflag.co.uk/2020/01/manaf-hijawi-becomes-first-jordanian-british-f3-driver-as-he-signs-for-douglas-motorsport-for-2020/" title="Manaf Hijawi becomes first Jordanian British F3 driver as he signs for Douglas Motorsport for 2020">
</a>
<h3><a href="https://www.thecheckeredflag.co.uk/2020/01/manaf-hijawi-becomes-first-jordanian-british-f3-driver-as-he-signs-for-douglas-motorsport-for-2020/">Manaf Hijawi becomes first Jordanian British F3 driver as he signs for...</a></h3>
<span class="date"><time class="entry-date published" datetime="2020-01-17T18:30:17+00:00">January 17, 2020</time></span>
</div>
<div class="item-related">
<a class="related-thumb penci-image-holder" style="background-image: url('https://i2.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/01/Benjamin-Pedersen-2020-Fortec-Motorsports-driver.jpg?resize=585%2C390&#038;ssl=1');" href="https://www.thecheckeredflag.co.uk/2020/01/double-r-racing-sign-benjamin-pedersen-for-2020-british-f3-campaign/" title="Double R Racing sign Benjamin Pedersen for 2020 British F3 campaign">
</a>
<h3><a href="https://www.thecheckeredflag.co.uk/2020/01/double-r-racing-sign-benjamin-pedersen-for-2020-british-f3-campaign/">Double R Racing sign Benjamin Pedersen for 2020 British F3 campaign</a></h3>
<span class="date"><time class="entry-date published" datetime="2020-01-15T22:02:18+00:00">January 15, 2020</time></span>
</div>
<div class="item-related">
<a class="related-thumb penci-image-holder" style="background-image: url('https://i0.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/01/Jewiss_17-1-1100x733-1.jpg?resize=585%2C390&#038;ssl=1');" href="https://www.thecheckeredflag.co.uk/2020/01/kiern-jewiss-retained-by-douglas-motorsport-for-2020-british-f3-season/" title="Kiern Jewiss retained by Douglas Motorsport for 2020 British F3 season">
</a>
<h3><a href="https://www.thecheckeredflag.co.uk/2020/01/kiern-jewiss-retained-by-douglas-motorsport-for-2020-british-f3-season/">Kiern Jewiss retained by Douglas Motorsport for 2020 British F3 season</a></h3>
<span class="date"><time class="entry-date published" datetime="2020-01-10T21:25:55+00:00">January 10, 2020</time></span>
</div>
<div class="item-related">
<a class="related-thumb penci-image-holder" style="background-image: url('https://i0.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2019/10/Oliver-Clarke-Hillspeed.jpg?resize=585%2C390&#038;ssl=1');" href="https://www.thecheckeredflag.co.uk/2019/10/hillspeed-sign-oliver-clarke-for-their-2020-brdc-british-f3-driver-line-up/" title="Hillspeed sign Oliver Clarke for their 2020 BRDC British F3 driver line-up">
</a>
<h3><a href="https://www.thecheckeredflag.co.uk/2019/10/hillspeed-sign-oliver-clarke-for-their-2020-brdc-british-f3-driver-line-up/">Hillspeed sign Oliver Clarke for their 2020 BRDC British F3 driver line-up</a></h3>
<span class="date"><time class="entry-date published" datetime="2019-10-25T08:47:52+01:00">October 25, 2019</time></span>
</div>
<div class="item-related">
<a class="related-thumb penci-image-holder" style="background-image: url('https://i0.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2019/09/Clement-Novalak-BRDC-British-F3-Champions-Podium.jpg?resize=585%2C390&#038;ssl=1');" href="https://www.thecheckeredflag.co.uk/2019/09/review-2019-brdc-british-formula-3-round-eight-donington-park-consistent-clement-novalak-clinches-title-after-clash-with-hoggard/" title="REVIEW: 2019 BRDC British Formula 3 Round eight Donington Park &#8211; consistent Clement Novalak clinches title after clash with Hoggard">
</a>
<h3><a href="https://www.thecheckeredflag.co.uk/2019/09/review-2019-brdc-british-formula-3-round-eight-donington-park-consistent-clement-novalak-clinches-title-after-clash-with-hoggard/">REVIEW: 2019 BRDC British Formula 3 Round eight Donington Park &#8211; consistent...</a></h3>
<span class="date"><time class="entry-date published" datetime="2019-09-18T13:29:37+01:00">September 18, 2019</time></span>
</div>
</div></div>
<div id="disqus_thread"></div>
<div class="post-pagination">
<div class="prev-post">
<div class="prev-post-inner">
<div class="prev-post-title">
<span>previous post</span>
</div>
<a href="https://www.thecheckeredflag.co.uk/2020/03/ferrari-could-enforce-team-orders-in-2020-if-to-the-benefit-of-the-entire-team-binotto/">
<div class="pagi-text">
<h5 class="prev-title">Ferrari Could Enforce Team Orders in 2020 if ‘to the Benefit of the Entire Team’ – Binotto</h5>
</div>
</a>
</div>
</div>
<div class="next-post">
<div class="next-post-inner">
<div class="prev-post-title next-post-title">
<span>next post</span>
</div>
<a href="https://www.thecheckeredflag.co.uk/2020/03/hwa-racelab-upbeat-as-season-draws-near/">
<div class="pagi-text">
<h5 class="next-title">HWA Racelab upbeat as season draws near</h5>
</div>
</a>
</div>
</div>
</div>
</article> </div>
</div>
<div id="sidebar" class="penci-sidebar-right penci-sidebar-content style-1 pcalign-center">
<div class="theiaStickySidebar">
<aside id="media_image-2" class="widget widget_media_image"><a href="https://www.thecheckeredflag.co.uk/tcf-blogs/jaguar-racing-blog/"><img width="1080" height="1080" src="https://i2.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/01/CALADO-BLOG.jpg?fit=1080%2C1080&amp;ssl=1" class="image wp-image-330391  attachment-full size-full" alt="" style="max-width: 100%; height: auto;" srcset="https://i2.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/01/CALADO-BLOG.jpg?w=1080&amp;ssl=1 1080w, https://i2.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/01/CALADO-BLOG.jpg?resize=160%2C160&amp;ssl=1 160w, https://i2.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/01/CALADO-BLOG.jpg?resize=533%2C533&amp;ssl=1 533w, https://i2.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/01/CALADO-BLOG.jpg?resize=240%2C240&amp;ssl=1 240w, https://i2.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/01/CALADO-BLOG.jpg?resize=768%2C768&amp;ssl=1 768w, https://i2.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/01/CALADO-BLOG.jpg?resize=585%2C585&amp;ssl=1 585w, https://i2.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/01/CALADO-BLOG.jpg?resize=912%2C912&amp;ssl=1 912w, https://i2.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/01/CALADO-BLOG.jpg?resize=550%2C550&amp;ssl=1 550w, https://i2.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/01/CALADO-BLOG.jpg?resize=470%2C470&amp;ssl=1 470w" sizes="(max-width: 1080px) 100vw, 1080px" /></a></aside><aside id="custom_html-11" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget">

<ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-9159179884377372" data-ad-slot="4409003789" data-ad-format="auto" data-full-width-responsive="true"></ins>
<script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script></div></aside><aside id="penci_slider_posts_news_widget-2" class="widget penci_slider_posts_news_widget"><h4 class="widget-title penci-border-arrow"><span class="inner-arrow">Latest articles</span></h4> <div id="penci-postslidewg-5643" class="penci-owl-carousel penci-owl-carousel-slider penci-widget-slider penci-post-slider-style-1" data-lazy="true">
<div class="penci-slide-widget">
<div class="penci-slide-content">
<span class="penci-image-holder" style="background-image: url('https://i0.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/03/Gene-Haas-01.jpg?resize=585%2C390&#038;ssl=1');" title="Gene Haas Not Ruling Out Pulling Haas F1 Team Out of Formula 1 after 2020"></span>
<a href="https://www.thecheckeredflag.co.uk/2020/03/gene-haas-not-ruling-out-pulling-haas-f1-team-out-of-formula-1-after-2020/" class="penci-widget-slider-overlay" title="Gene Haas Not Ruling Out Pulling Haas F1 Team Out of Formula 1 after 2020"></a>
<div class="penci-widget-slide-detail">
<h4>
<a href="https://www.thecheckeredflag.co.uk/2020/03/gene-haas-not-ruling-out-pulling-haas-f1-team-out-of-formula-1-after-2020/" rel="bookmark" title="Gene Haas Not Ruling Out Pulling Haas F1 Team Out of Formula 1 after 2020">Gene Haas Not Ruling Out Pulling Haas F1...</a>
</h4>
<span class="slide-item-date">Mar 8, 2020</span>
</div>
</div>
</div>
<div class="penci-slide-widget">
<div class="penci-slide-content">
<span class="penci-image-holder" style="background-image: url('https://i0.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/03/IMG_08032020_150847_800_x_533_pixel.jpg?resize=585%2C390&#038;ssl=1');" title="Mäkinen is feeling confident for the Rally Mexico"></span>
<a href="https://www.thecheckeredflag.co.uk/2020/03/makinen-is-feeling-confident-for-the-rally-mexico/" class="penci-widget-slider-overlay" title="Mäkinen is feeling confident for the Rally Mexico"></a>
<div class="penci-widget-slide-detail">
<h4>
<a href="https://www.thecheckeredflag.co.uk/2020/03/makinen-is-feeling-confident-for-the-rally-mexico/" rel="bookmark" title="Mäkinen is feeling confident for the Rally Mexico">Mäkinen is feeling confident for the Rally Mexico</a>
</h4>
<span class="slide-item-date">Mar 8, 2020</span>
</div>
</div>
</div>
<div class="penci-slide-widget">
<div class="penci-slide-content">
<span class="penci-image-holder" style="background-image: url('https://i2.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/03/Lance-Stroll-08.jpg?resize=585%2C390&#038;ssl=1');" title="‘No Point’ in Complaining about Racing Point’s RP20 Design Process – Andreas Seidl"></span>
<a href="https://www.thecheckeredflag.co.uk/2020/03/no-point-in-complaining-about-racing-points-rp20-design-process-andreas-seidl/" class="penci-widget-slider-overlay" title="‘No Point’ in Complaining about Racing Point’s RP20 Design Process – Andreas Seidl"></a>
<div class="penci-widget-slide-detail">
<h4>
<a href="https://www.thecheckeredflag.co.uk/2020/03/no-point-in-complaining-about-racing-points-rp20-design-process-andreas-seidl/" rel="bookmark" title="‘No Point’ in Complaining about Racing Point’s RP20 Design Process – Andreas Seidl">‘No Point’ in Complaining about Racing Point’s RP20...</a>
</h4>
<span class="slide-item-date">Mar 8, 2020</span>
</div>
</div>
</div>
<div class="penci-slide-widget">
<div class="penci-slide-content">
<span class="penci-image-holder" style="background-image: url('https://i0.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/03/IMG_08032020_152804_800_x_533_pixel.jpg?resize=585%2C390&#038;ssl=1');" title="Ogier hoping to take his sixth Rally Mexico win"></span>
<a href="https://www.thecheckeredflag.co.uk/2020/03/ogier-hoping-to-take-his-sixth-rally-mexico-win/" class="penci-widget-slider-overlay" title="Ogier hoping to take his sixth Rally Mexico win"></a>
<div class="penci-widget-slide-detail">
<h4>
<a href="https://www.thecheckeredflag.co.uk/2020/03/ogier-hoping-to-take-his-sixth-rally-mexico-win/" rel="bookmark" title="Ogier hoping to take his sixth Rally Mexico win">Ogier hoping to take his sixth Rally Mexico...</a>
</h4>
<span class="slide-item-date">Mar 8, 2020</span>
</div>
</div>
</div>
<div class="penci-slide-widget">
<div class="penci-slide-content">
<span class="penci-image-holder" style="background-image: url('https://i2.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/03/Lance-Stroll-07.jpg?resize=585%2C390&#038;ssl=1');" title="Lack of Financial Resources Prevented Racing Point ‘Reset’ Prior to 2020 – Andrew Green"></span>
<a href="https://www.thecheckeredflag.co.uk/2020/03/lack-of-financial-resources-prevented-racing-point-reset-prior-to-2020-andrew-green/" class="penci-widget-slider-overlay" title="Lack of Financial Resources Prevented Racing Point ‘Reset’ Prior to 2020 – Andrew Green"></a>
<div class="penci-widget-slide-detail">
<h4>
<a href="https://www.thecheckeredflag.co.uk/2020/03/lack-of-financial-resources-prevented-racing-point-reset-prior-to-2020-andrew-green/" rel="bookmark" title="Lack of Financial Resources Prevented Racing Point ‘Reset’ Prior to 2020 – Andrew Green">Lack of Financial Resources Prevented Racing Point ‘Reset’...</a>
</h4>
<span class="slide-item-date">Mar 8, 2020</span>
</div>
</div>
</div>
</div>
</aside><aside id="penci_popular_news_widget-5" class="widget penci_popular_news_widget"><h4 class="widget-title penci-border-arrow"><span class="inner-arrow">Popular on TCF</span></h4> <ul id="penci-popularwg-8102" class="side-newsfeed">
<li class="penci-feed featured-news">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder" rel="bookmark" style="background-image: url('https://i1.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/03/Sebastian-Vettel-01.jpg?resize=585%2C390&#038;ssl=1');" href="https://www.thecheckeredflag.co.uk/2020/03/world-motor-sport-council-supports-fia-decision-over-ferrari-power-unit-settlement/" title="World Motor Sport Council Supports FIA Decision over Ferrari Power Unit Settlement"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.thecheckeredflag.co.uk/2020/03/world-motor-sport-council-supports-fia-decision-over-ferrari-power-unit-settlement/" rel="bookmark" title="World Motor Sport Council Supports FIA Decision over Ferrari Power Unit Settlement">
World Motor Sport Council Supports FIA Decision over Ferrari Power Unit Settlement </a>
</h4>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder small-fix-size" rel="bookmark" style="background-image: url('https://i1.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/03/MotoGP-Facebook-Announce-New-Partnership.jpg.jpg?resize=263%2C175&#038;ssl=1');" href="https://www.thecheckeredflag.co.uk/2020/03/motogp-and-facebook-join-forces-for-2020/" title="MotoGP and Facebook join forces for 2020"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.thecheckeredflag.co.uk/2020/03/motogp-and-facebook-join-forces-for-2020/" rel="bookmark" title="MotoGP and Facebook join forces for 2020">
MotoGP and Facebook join forces for 2020 </a>
</h4>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder small-fix-size" rel="bookmark" style="background-image: url('https://i1.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/03/IMG_03032020_192910_800_x_533_pixel.jpg?resize=263%2C175&#038;ssl=1');" href="https://www.thecheckeredflag.co.uk/2020/03/meeke-making-rally-comeback-with-a-mazda-2-ap4-in-the-nzrc/" title="Meeke making rally comeback, with a Mazda 2 AP4 in the NZRC"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.thecheckeredflag.co.uk/2020/03/meeke-making-rally-comeback-with-a-mazda-2-ap4-in-the-nzrc/" rel="bookmark" title="Meeke making rally comeback, with a Mazda 2 AP4 in the NZRC">
Meeke making rally comeback, with a Mazda 2 AP4 in the NZRC </a>
</h4>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder small-fix-size" rel="bookmark" style="background-image: url('https://i1.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/03/tanak.jpg?resize=263%2C175&#038;ssl=1');" href="https://www.thecheckeredflag.co.uk/2020/03/tanak-rally-mexico-a-very-specific-event/" title="Tänak: Rally Mexico “A Very Specific Event”"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.thecheckeredflag.co.uk/2020/03/tanak-rally-mexico-a-very-specific-event/" rel="bookmark" title="Tänak: Rally Mexico “A Very Specific Event”">
Tänak: Rally Mexico “A Very Specific Event” </a>
</h4>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder small-fix-size" rel="bookmark" style="background-image: url('https://i0.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/03/SORDO.jpg?resize=263%2C175&#038;ssl=1');" href="https://www.thecheckeredflag.co.uk/2020/03/sordos-favourable-road-position-not-enough-in-mexico/" title="Sordo’s Favourable Road Position “Not Enough” in Mexico"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.thecheckeredflag.co.uk/2020/03/sordos-favourable-road-position-not-enough-in-mexico/" rel="bookmark" title="Sordo’s Favourable Road Position “Not Enough” in Mexico">
Sordo’s Favourable Road Position “Not Enough” in Mexico </a>
</h4>
</div>
</div>
</li>
</ul>
</aside><aside id="nav_menu-4" class="widget widget_nav_menu"><div class="menu-top-container"><ul id="menu-top" class="menu"><li id="menu-item-131978" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-131978"><a href="https://www.thecheckeredflag.co.uk/latest-news/">News</a></li>
<li id="menu-item-131965" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131965"><a href="https://www.thecheckeredflag.co.uk/features/">Features</a></li>
<li id="menu-item-173707" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-173707"><a href="https://www.thecheckeredflag.co.uk/features/gallery/">Photos</a></li>
<li id="menu-item-131884" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131884"><a href="https://www.thecheckeredflag.co.uk/tcf-blogs/">TCF Blogs</a></li>
<li id="menu-item-131986" class="menu-item menu-item-type-taxonomy menu-item-object-post_format menu-item-131986"><a href="https://www.thecheckeredflag.co.uk/type/video/">Videos</a></li>
<li id="menu-item-131967" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-131967"><a href="https://www.thecheckeredflag.co.uk/contribute/">Contribute</a></li>
<li id="menu-item-131966" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-131966"><a href="https://www.thecheckeredflag.co.uk/contact/">Contact Us</a></li>
</ul></div></aside><aside id="text-12" class="widget widget_text"> <div class="textwidget"><p><a href="https://www.facebook.com/groups/porschemotorsportcommunity/" target="_blank" rel="noopener noreferrer"><img class="aligncenter size-full wp-image-310781" src="https://i2.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2019/06/PMC-Square-1.jpg?resize=400%2C400&#038;ssl=1" alt="Porsche Motorsport Community" width="400" height="400" data-recalc-dims="1" /></a></p>
</div>
</aside><aside id="custom_html-8" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget">
<ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-9159179884377372" data-ad-slot="2468886887" data-ad-format="auto"></ins>
<script>
window.setTimeout(function(){ 
  (adsbygoogle = window.adsbygoogle || []).push({}); 
}, 200); 
</script></div></aside><aside id="penci_social_widget-2" class="widget penci_social_widget"><h4 class="widget-title penci-border-arrow"><span class="inner-arrow">Keep in touch</span></h4>
<div class="widget-social pc_aligncenter">
<a href="https://facebook.com/TheCheckeredFlag" rel="nofollow" target="_blank"><i class="penci-faicon fa fa-facebook" style="font-size: 18px"></i><span style="font-size: 13px">Facebook</span></a>
<a href="https://twitter.com/TheCheckerFlag" rel="nofollow" target="_blank"><i class="penci-faicon fa fa-twitter" style="font-size: 18px"></i><span style="font-size: 13px">Twitter</span></a>
<a href="https://instagram.com/thecheckeredflag/" rel="nofollow" target="_blank"><i class="penci-faicon fa fa-instagram" style="font-size: 18px"></i><span style="font-size: 13px">Instagram</span></a>
<a href="https://www.linkedin.com/company/thecheckeredflag/" rel="nofollow" target="_blank"><i class="penci-faicon fa fa-linkedin" style="font-size: 18px"></i><span style="font-size: 13px">Linkedin</span></a>
<a href="https://www.youtube.com/channel/UCueRVoGbSE4GF2RszehXIgw" rel="nofollow" target="_blank"><i class="penci-faicon fa fa-youtube-play" style="font-size: 18px"></i><span style="font-size: 13px">Youtube</span></a>
<a href="https://www.thecheckeredflag.co.uk/feed" rel="nofollow" target="_blank"><i class="penci-faicon fa fa-rss" style="font-size: 18px"></i><span style="font-size: 13px">RSS</span></a>
</div>
</aside><aside id="penci_latest_news_widget-2" class="widget penci_latest_news_widget"><h4 class="widget-title penci-border-arrow"><span class="inner-arrow">Recent Features</span></h4> <ul id="penci-latestwg-7711" class="side-newsfeed penci-feed-2columns penci-2columns-feed">
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder small-fix-size" rel="bookmark" style="background-image: url('https://i0.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/02/James-Calado-Jaguar-Formula-E-6-scaled.jpg?resize=263%2C175&#038;ssl=1');" href="https://www.thecheckeredflag.co.uk/2020/02/james-calado-blog-viva-mexico/" title="James Calado Blog: ¡Viva México!"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.thecheckeredflag.co.uk/2020/02/james-calado-blog-viva-mexico/" rel="bookmark" title="James Calado Blog: ¡Viva México!">
James Calado Blog: ¡Viva México! </a>
</h4>
<span class="side-item-meta"><time class="entry-date published" datetime="2020-02-26T12:58:24+00:00">February 26, 2020</time></span>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder small-fix-size" rel="bookmark" style="background-image: url('https://i0.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/02/Cook-podium.jpg?resize=263%2C175&#038;ssl=1');" href="https://www.thecheckeredflag.co.uk/2020/02/prepared-cook-confident-of-strong-season-with-btc-racing/" title="Prepared Cook confident of strong season with BTC Racing"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.thecheckeredflag.co.uk/2020/02/prepared-cook-confident-of-strong-season-with-btc-racing/" rel="bookmark" title="Prepared Cook confident of strong season with BTC Racing">
Prepared Cook confident of strong season with BTC Racing </a>
</h4>
<span class="side-item-meta"><time class="entry-date published" datetime="2020-02-21T00:18:29+00:00">February 21, 2020</time></span>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder small-fix-size" rel="bookmark" style="background-image: url('https://i2.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/02/Jag-3.jpg?resize=263%2C175&#038;ssl=1');" href="https://www.thecheckeredflag.co.uk/2020/02/jaguar-racing-blog-mark-turner-talks-jaguar-i-pace-etrophy/" title="Jaguar Racing Blog: Mark Turner talks Jaguar I-PACE eTROPHY"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.thecheckeredflag.co.uk/2020/02/jaguar-racing-blog-mark-turner-talks-jaguar-i-pace-etrophy/" rel="bookmark" title="Jaguar Racing Blog: Mark Turner talks Jaguar I-PACE eTROPHY">
Jaguar Racing Blog: Mark Turner talks Jaguar I-PACE eTROPHY </a>
</h4>
<span class="side-item-meta"><time class="entry-date published" datetime="2020-02-11T10:12:41+00:00">February 11, 2020</time></span>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder small-fix-size" rel="bookmark" style="background-image: url('https://i2.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/01/Pack-at-Knockhill.jpg?resize=263%2C175&#038;ssl=1');" href="https://www.thecheckeredflag.co.uk/2020/02/the-btccs-golden-era-is-a-must-watch/" title="The BTCC&#8217;s golden era is a must watch"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.thecheckeredflag.co.uk/2020/02/the-btccs-golden-era-is-a-must-watch/" rel="bookmark" title="The BTCC&#8217;s golden era is a must watch">
The BTCC&#8217;s golden era is a must watch </a>
</h4>
<span class="side-item-meta"><time class="entry-date published" datetime="2020-02-03T09:44:24+00:00">February 3, 2020</time></span>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder small-fix-size" rel="bookmark" style="background-image: url('https://i0.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/01/James-Calado-2.jpg?resize=263%2C175&#038;ssl=1');" href="https://www.thecheckeredflag.co.uk/2020/01/james-calado-blog-preparation-never-stops/" title="James Calado Blog: Preparation never stops"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.thecheckeredflag.co.uk/2020/01/james-calado-blog-preparation-never-stops/" rel="bookmark" title="James Calado Blog: Preparation never stops">
James Calado Blog: Preparation never stops </a>
</h4>
<span class="side-item-meta"><time class="entry-date published" datetime="2020-01-29T15:54:14+00:00">January 29, 2020</time></span>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder small-fix-size" rel="bookmark" style="background-image: url('https://i0.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/01/f4-feat-res.jpg?resize=263%2C175&#038;ssl=1');" href="https://www.thecheckeredflag.co.uk/2020/01/motorsports-next-generation/" title="Motorsport&#8217;s Next Generation"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.thecheckeredflag.co.uk/2020/01/motorsports-next-generation/" rel="bookmark" title="Motorsport&#8217;s Next Generation">
Motorsport&#8217;s Next Generation </a>
</h4>
<span class="side-item-meta"><time class="entry-date published" datetime="2020-01-26T14:57:00+00:00">January 26, 2020</time></span>
</div>
</div>
</li>
</ul>
</aside> </div>
</div>
</div>
<div class="clear-footer"></div>
<div class="footer-subscribe">
<aside id="mc4wp_form_widget-2" class="widget widget_mc4wp_form_widget"><script>(function() {
	window.mc4wp = window.mc4wp || {
		listeners: [],
		forms: {
			on: function(evt, cb) {
				window.mc4wp.listeners.push(
					{
						event   : evt,
						callback: cb
					}
				);
			}
		}
	}
})();
</script><form id="mc4wp-form-1" class="mc4wp-form mc4wp-form-293151" method="post" data-id="293151" data-name="TCF Daily Headlines to your Inbox"><div class="mc4wp-form-fields"><p class="mdes">Get the latest headlines from TCF in a daily roundup, straight to your inbox</p>
<p class="memail"><input type="email" id="mc4wp_email" name="EMAIL" placeholder="Email..." required /></p>
<p class="msubmit"><input type="submit" value="Subscribe" /></p></div><label style="display: none !important;">Leave this field empty if you're human: <input type="text" name="_mc4wp_honeypot" value="" tabindex="-1" autocomplete="off" /></label><input type="hidden" name="_mc4wp_timestamp" value="1583683308" /><input type="hidden" name="_mc4wp_form_id" value="293151" /><input type="hidden" name="_mc4wp_form_element_id" value="mc4wp-form-1" /><div class="mc4wp-response"></div></form></aside> </div>
<footer id="footer-section" class="penci-footer-social-media penci-lazy" itemscope itemtype="https://schema.org/WPFooter">
<div class="container">
<div class="footer-socials-section">
<ul class="footer-socials">
<li><a href="https://facebook.com/TheCheckeredFlag" rel="nofollow" target="_blank"><i class="penci-faicon fa fa-facebook"></i><span>Facebook</span></a></li>
<li><a href="https://twitter.com/TheCheckerFlag" rel="nofollow" target="_blank"><i class="penci-faicon fa fa-twitter"></i><span>Twitter</span></a></li>
<li><a href="https://instagram.com/thecheckeredflag/" rel="nofollow" target="_blank"><i class="penci-faicon fa fa-instagram"></i><span>Instagram</span></a></li>
<li><a href="https://www.linkedin.com/company/thecheckeredflag/" rel="nofollow" target="_blank"><i class="penci-faicon fa fa-linkedin"></i><span>Linkedin</span></a></li>
<li><a href="https://www.youtube.com/channel/UCueRVoGbSE4GF2RszehXIgw" rel="nofollow" target="_blank"><i class="penci-faicon fa fa-youtube-play"></i><span>Youtube</span></a></li>
<li><a href="https://www.thecheckeredflag.co.uk/feed" rel="nofollow" target="_blank"><i class="penci-faicon fa fa-rss"></i><span>RSS</span></a></li>
</ul>
</div>
<div class="footer-logo-copyright footer-not-logo">
<div id="footer-copyright">
<p><a href="https://www.thecheckeredflag.co.uk/contact/">Contact Us</a> | <a href="https://www.thecheckeredflag.co.uk/contribute/">Contribute</a> | <a href="https://www.thecheckeredflag.co.uk/about-us">About Us</a><br />
<a href="https://www.thecheckeredflag.co.uk/tcf-partners/">TCF Friends & Partners</a> | <a href="https://www.thecheckeredflag.co.uk/submitting-news/">Submitting News</a> | <a href="https://www.thecheckeredflag.co.uk/terms-and-conditions/">T & C</a> | <a href="https://www.thecheckeredflag.co.uk/privacy-policy/">Privacy Policy</a> | <a href="https://www.thecheckeredflag.co.uk/cookies-in-use-on-this-site/">Cookie Policy</a><br />
©Copyright MMXIX - The Checkered Flag - All Rights Reserved</p>
</div>
<div class="go-to-top-parent"><a href="#" class="go-to-top"><span><i class="penci-faicon fa fa-angle-up"></i> <br>Back To Top</span></a></div>
</div>
</div>
</footer>
</div>
<div id="fb-root"></div>
<div class="penci-wrap-gprd-law penci-wrap-gprd-law-close penci-close-all">
<div class="penci-gprd-law">
<p>
This website uses cookies to improve your experience. We&#039;ll assume you&#039;re ok with this, but you can opt-out if you wish. <a class="penci-gprd-accept" href="#">Accept</a> <a class="penci-gprd-more" href="#">Read More</a> </p>
</div>
</div>
<script>(function() {function maybePrefixUrlField() {
	if (this.value.trim() !== '' && this.value.indexOf('http') !== 0) {
		this.value = "http://" + this.value;
	}
}

var urlFields = document.querySelectorAll('.mc4wp-form input[type="url"]');
if (urlFields) {
	for (var j=0; j < urlFields.length; j++) {
		urlFields[j].addEventListener('blur', maybePrefixUrlField);
	}
}
})();</script>

<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-MG875N"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>

<script type='text/javascript'>
/* <![CDATA[ */
var countVars = {"disqusShortname":"thecheckerdflag"};
/* ]]> */
</script>
<script type='text/javascript'>
/* <![CDATA[ */
var embedVars = {"disqusConfig":{"integration":"wordpress 3.0.17"},"disqusIdentifier":"333750 https:\/\/www.thecheckeredflag.co.uk\/?p=333750","disqusShortname":"thecheckerdflag","disqusTitle":"Kaylen Frederick fastest at Snetterton Formula 3 media day","disqusUrl":"https:\/\/www.thecheckeredflag.co.uk\/2020\/03\/kaylen-frederick-fastest-at-snetterton-formula-3-media-day\/","postId":"333750"};
/* ]]> */
</script>
<script type='text/javascript'>
/* <![CDATA[ */
var ajax_var_more = {"url":"https:\/\/www.thecheckeredflag.co.uk\/wp-admin\/admin-ajax.php","nonce":"e9842cc626","errorPass":"<p class=\"message message-error\">Password does not match the confirm password<\/p>","login":"Email Address","password":"Password"};
/* ]]> */
</script>
<script type='text/javascript'>
/* <![CDATA[ */
var ajax_var = {"url":"https:\/\/www.thecheckeredflag.co.uk\/wp-admin\/admin-ajax.php","nonce":"e9842cc626","errorPass":"<p class=\"message message-error\">Password does not match the confirm password<\/p>","login":"Email Address","password":"Password"};
/* ]]> */
</script>
<script type='text/javascript'>
/* <![CDATA[ */
var SOLEDADLOCALIZE = {"url":"https:\/\/www.thecheckeredflag.co.uk\/wp-admin\/admin-ajax.php","nonce":"e9842cc626","errorPass":"<p class=\"message message-error\">Password does not match the confirm password<\/p>","login":"Email Address","password":"Password"};
/* ]]> */
</script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:8.3',blog:'9437658',post:'333750',tz:'0',srv:'www.thecheckeredflag.co.uk'} ]);
	_stq.push([ 'clickTrackerInit', '9437658', '333750' ]);
</script>
<script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><script type='text/javascript' src='https://c0.wp.com/p/jetpack/8.3/_inc/build/photon/photon.min.js'></script><script type='text/javascript' src='https://c0.wp.com/c/5.3.2/wp-includes/js/wp-embed.min.js'></script><script type='text/javascript' src='https://stats.wp.com/e-202010.js' async='async' defer='defer'></script><script data-optimized='1' src='https://www.thecheckeredflag.co.uk/min/bf809.js'></script></body>
</html>
