<!DOCTYPE html>
<html lang="en-GB">
<head>
<meta charset="UTF-8"><link rel='stylesheet' id='wp-block-library-css' href='https://c0.wp.com/c/5.4/wp-includes/css/dist/block-library/style.min.css' type='text/css' media='all' /><link rel='stylesheet' id='wp-block-library-theme-css' href='https://c0.wp.com/c/5.4/wp-includes/css/dist/block-library/theme.min.css' type='text/css' media='all' /><link rel='stylesheet' id='penci-fonts-css' href='//fonts.googleapis.com/css?family=Playfair+Display+SC%3A300%2C300italic%2C400%2C400italic%2C500%2C500italic%2C700%2C700italic%2C800%2C800italic%7CMontserrat%3A300%2C300italic%2C400%2C400italic%2C500%2C500italic%2C700%2C700italic%2C800%2C800italic%7CRoboto%3A300%2C300italic%2C400%2C400italic%2C500%2C500italic%2C700%2C700italic%2C800%2C800italic%7CArial%3A300%2C300italic%2C400%2C400italic%2C500%2C500italic%2C700%2C700italic%2C800%2C800italic%26subset%3Dlatin%2Ccyrillic%2Ccyrillic-ext%2Cgreek%2Cgreek-ext%2Clatin-ext&#038;ver=1.0' type='text/css' media='all' /><link rel='stylesheet' id='jetpack_css-css' href='https://c0.wp.com/p/jetpack/8.3/css/jetpack.css' type='text/css' media='all' /><link data-optimized='2' rel='stylesheet' href='https://www.thecheckeredflag.co.uk/min/a1ae8.css' /><script type='text/javascript' src='https://c0.wp.com/c/5.4/wp-includes/js/jquery/jquery.js'></script><script type='text/javascript' src='https://c0.wp.com/c/5.4/wp-includes/js/jquery/jquery-migrate.min.js'></script><script data-optimized='1' src='https://www.thecheckeredflag.co.uk/min/72efe.js'></script>
<meta http-equiv="X-UA-Compatible" content="IE=edge">
<meta name="viewport" content="width=device-width, initial-scale=1">
<link rel="profile" href="https://gmpg.org/xfn/11" />
<link rel="shortcut icon" href="https://www.thecheckeredflag.co.uk/wp-content/uploads/2018/11/TCF-black.jpg" type="image/x-icon" />
<link rel="apple-touch-icon" sizes="180x180" href="https://www.thecheckeredflag.co.uk/wp-content/uploads/2018/11/TCF-black.jpg">
<link rel="alternate" type="application/rss+xml" title="The Checkered Flag RSS Feed" href="https://www.thecheckeredflag.co.uk/feed/" />
<link rel="alternate" type="application/atom+xml" title="The Checkered Flag Atom Feed" href="https://www.thecheckeredflag.co.uk/feed/atom/" />
<link rel="pingback" href="https://www.thecheckeredflag.co.uk/xmlrpc.php" />
<!--[if lt IE 9]>
	<script src="https://www.thecheckeredflag.co.uk/wp-content/themes/soledad/js/html5.js"></script>
	<![endif]-->
<title>Tributes Pour In from the Motorsport World for Sir Stirling Moss - The Checkered Flag</title>

<script data-cfasync="false" data-pagespeed-no-defer>//<![CDATA[
	var gtm4wp_datalayer_name = "dataLayer";
	var dataLayer = dataLayer || [];
//]]>
</script>


<meta name="description" content="Tributes continue to pour in for Sir Stirling Moss, who has died aged ninety." />
<meta name="robots" content="max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
<link rel="canonical" href="https://www.thecheckeredflag.co.uk/2020/04/tributes-pour-in-from-the-motorsport-world-for-sir-stirling-moss/" />
<meta property="og:locale" content="en_GB" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Tributes Pour In from the Motorsport World for Sir Stirling Moss - The Checkered Flag" />
<meta property="og:description" content="Tributes continue to pour in for Sir Stirling Moss, who has died aged ninety." />
<meta property="og:url" content="https://www.thecheckeredflag.co.uk/2020/04/tributes-pour-in-from-the-motorsport-world-for-sir-stirling-moss/" />
<meta property="og:site_name" content="The Checkered Flag" />
<meta property="article:publisher" content="http://www.facebook.com/TheCheckeredFlag" />
<meta property="article:author" content="https://www.facebook.com/paul.hensby" />
<meta property="article:tag" content="Sir Stirling Moss" />
<meta property="article:section" content="Formula 1" />
<meta property="article:published_time" content="2020-04-12T14:25:46+00:00" />
<meta property="article:modified_time" content="2020-04-12T14:48:11+00:00" />
<meta property="og:updated_time" content="2020-04-12T14:48:11+00:00" />
<meta property="fb:app_id" content="135274436510698" />
<meta property="og:image" content="https://i2.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/04/Sir-Stirling-Moss-03.jpg?fit=800%2C533&#038;ssl=1" />
<meta property="og:image:secure_url" content="https://i2.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/04/Sir-Stirling-Moss-03.jpg?fit=800%2C533&#038;ssl=1" />
<meta property="og:image:width" content="800" />
<meta property="og:image:height" content="533" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:description" content="Tributes continue to pour in for Sir Stirling Moss, who has died aged ninety." />
<meta name="twitter:title" content="Tributes Pour In from the Motorsport World for Sir Stirling Moss - The Checkered Flag" />
<meta name="twitter:site" content="@thecheckerflag" />
<meta name="twitter:image" content="https://i2.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/04/Sir-Stirling-Moss-03.jpg?fit=800%2C533&#038;ssl=1" />
<meta name="twitter:creator" content="@Paul11MSport" />
<script type='application/ld+json' class='yoast-schema-graph yoast-schema-graph--main'>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</script>

<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="The Checkered Flag &raquo; Feed" href="https://www.thecheckeredflag.co.uk/feed/" />
<link rel="alternate" type="application/rss+xml" title="The Checkered Flag &raquo; Comments Feed" href="https://www.thecheckeredflag.co.uk/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="The Checkered Flag &raquo; Tributes Pour In from the Motorsport World for Sir Stirling Moss Comments Feed" href="https://www.thecheckeredflag.co.uk/2020/04/tributes-pour-in-from-the-motorsport-world-for-sir-stirling-moss/feed/" />
<style id='wp-block-library-inline-css' type='text/css'>
.has-text-align-justify{text-align:justify;}
</style>
<!--[if !IE]><!-->
<!--<![endif]-->
<link rel='https://api.w.org/' href='https://www.thecheckeredflag.co.uk/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.thecheckeredflag.co.uk/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.thecheckeredflag.co.uk/wp-includes/wlwmanifest.xml" />
<link rel='shortlink' href='https://www.thecheckeredflag.co.uk/?p=335837' />
<link rel="alternate" type="application/json+oembed" href="https://www.thecheckeredflag.co.uk/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.thecheckeredflag.co.uk%2F2020%2F04%2Ftributes-pour-in-from-the-motorsport-world-for-sir-stirling-moss%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.thecheckeredflag.co.uk/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.thecheckeredflag.co.uk%2F2020%2F04%2Ftributes-pour-in-from-the-motorsport-world-for-sir-stirling-moss%2F&#038;format=xml" />

<script data-cfasync="false" data-pagespeed-no-defer>//<![CDATA[
	var dataLayer_content = {"pageTitle":"Tributes Pour In from the Motorsport World for Sir Stirling Moss - The Checkered Flag","pageCategory":["formula-1","sportscars"],"pageAttributes":["sir-stirling-moss"],"pagePostAuthor":"Paul Hensby"};
	dataLayer.push( dataLayer_content );//]]>
</script>
<script data-cfasync="false">//<![CDATA[
(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'//www.googletagmanager.com/gtm.'+'js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-MG875N');//]]>
</script>


<link rel='dns-prefetch' href='//c0.wp.com' />
<link rel='dns-prefetch' href='//i0.wp.com' />
<link rel='dns-prefetch' href='//i1.wp.com' />
<link rel='dns-prefetch' href='//i2.wp.com' />
<style type='text/css'>img#wpstats{display:none}</style><style type="text/css">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</style><script>
var penciBlocksArray=[];
var portfolioDataJs = portfolioDataJs || [];var PENCILOCALCACHE = {};
		(function () {
				"use strict";
		
				PENCILOCALCACHE = {
					data: {},
					remove: function ( ajaxFilterItem ) {
						delete PENCILOCALCACHE.data[ajaxFilterItem];
					},
					exist: function ( ajaxFilterItem ) {
						return PENCILOCALCACHE.data.hasOwnProperty( ajaxFilterItem ) && PENCILOCALCACHE.data[ajaxFilterItem] !== null;
					},
					get: function ( ajaxFilterItem ) {
						return PENCILOCALCACHE.data[ajaxFilterItem];
					},
					set: function ( ajaxFilterItem, cachedData ) {
						PENCILOCALCACHE.remove( ajaxFilterItem );
						PENCILOCALCACHE.data[ajaxFilterItem] = cachedData;
					}
				};
			}
		)();function penciBlock() {
		    this.atts_json = '';
		    this.content = '';
		}</script>
<script type="application/ld+json">{
    "@context": "https:\/\/schema.org\/",
    "@type": "organization",
    "@id": "#organization",
    "logo": {
        "@type": "ImageObject",
        "url": "https:\/\/www.thecheckeredflag.co.uk\/wp-content\/uploads\/2019\/08\/TCF-Square.jpg"
    },
    "url": "https:\/\/www.thecheckeredflag.co.uk\/",
    "name": "The Checkered Flag",
    "description": "Independent motor sport news since 2009"
}</script><script type="application/ld+json">{
    "@context": "https:\/\/schema.org\/",
    "@type": "WebSite",
    "name": "The Checkered Flag",
    "alternateName": "Independent motor sport news since 2009",
    "url": "https:\/\/www.thecheckeredflag.co.uk\/"
}</script><script type="application/ld+json">{
    "@context": "https:\/\/schema.org\/",
    "@type": "BlogPosting",
    "headline": "Tributes Pour In from the Motorsport World for Sir Stirling Moss",
    "description": "Tributes continue to pour in for Sir Stirling Moss, who has died aged ninety.",
    "datePublished": "2020-04-12",
    "datemodified": "2020-04-12",
    "mainEntityOfPage": "https:\/\/www.thecheckeredflag.co.uk\/2020\/04\/tributes-pour-in-from-the-motorsport-world-for-sir-stirling-moss\/",
    "image": {
        "@type": "ImageObject",
        "url": "https:\/\/i2.wp.com\/www.thecheckeredflag.co.uk\/wp-content\/uploads\/2020\/04\/Sir-Stirling-Moss-03.jpg?fit=800%2C533&ssl=1",
        "width": 800,
        "height": 533
    },
    "publisher": {
        "@type": "Organization",
        "name": "The Checkered Flag",
        "logo": {
            "@type": "ImageObject",
            "url": "https:\/\/www.thecheckeredflag.co.uk\/wp-content\/uploads\/2019\/08\/TCF-Square.jpg"
        }
    },
    "author": {
        "@type": "Person",
        "@id": "#person-PaulHensby",
        "name": "Paul Hensby"
    }
}</script><script type="application/ld+json">{
    "@context": "https:\/\/schema.org",
    "@type": "NewsArticle",
    "headline": "Tributes Pour In from the Motorsport World for Sir Stirling Moss",
    "image": "https:\/\/i2.wp.com\/www.thecheckeredflag.co.uk\/wp-content\/uploads\/2020\/04\/Sir-Stirling-Moss-03.jpg?fit=800%2C533&ssl=1",
    "datePublished": "2020-04-12",
    "datemodified": "2020-04-12",
    "description": "Tributes continue to pour in for Sir Stirling Moss, who has died aged ninety.",
    "mainEntityOfPage": "https:\/\/www.thecheckeredflag.co.uk\/2020\/04\/tributes-pour-in-from-the-motorsport-world-for-sir-stirling-moss\/",
    "publisher": {
        "@type": "Organization",
        "name": "The Checkered Flag",
        "logo": {
            "@type": "ImageObject",
            "url": "https:\/\/www.thecheckeredflag.co.uk\/wp-content\/uploads\/2019\/08\/TCF-Square.jpg"
        }
    },
    "author": {
        "@type": "Person",
        "name": "Paul Hensby"
    }
}</script><link rel="amphtml" href="https://www.thecheckeredflag.co.uk/amp/2020/04/tributes-pour-in-from-the-motorsport-world-for-sir-stirling-moss/" /><link rel="icon" href="https://i0.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2016/02/cropped-TCF.png?fit=32%2C32&#038;ssl=1" sizes="32x32" />
<link rel="icon" href="https://i0.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2016/02/cropped-TCF.png?fit=192%2C192&#038;ssl=1" sizes="192x192" />
<link rel="apple-touch-icon" href="https://i0.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2016/02/cropped-TCF.png?fit=180%2C180&#038;ssl=1" />
<meta name="msapplication-TileImage" content="https://i0.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2016/02/cropped-TCF.png?fit=270%2C270&#038;ssl=1" />
</head>
<body data-rsssl=1 class="post-template-default single single-post postid-335837 single-format-standard">
<a id="close-sidebar-nav" class="header-5"><i class="penci-faicon fa fa-close"></i></a>
<nav id="sidebar-nav" class="header-5" role="navigation" itemscope itemtype="https://schema.org/SiteNavigationElement">
<div id="sidebar-nav-logo">
<a href="https://www.thecheckeredflag.co.uk/"><img class="penci-lazy" src="https://www.thecheckeredflag.co.uk/wp-content/themes/soledad/images/penci-holder.png" data-src="https://www.thecheckeredflag.co.uk/wp-content/uploads/2018/11/TCF-black.jpg" alt="The Checkered Flag" /></a>
</div>
<div class="header-social sidebar-nav-social">
<div class="inner-header-social">
<a href="https://facebook.com/TheCheckeredFlag" rel="nofollow" target="_blank"><i class="penci-faicon fa fa-facebook"></i></a>
<a href="https://twitter.com/TheCheckerFlag" rel="nofollow" target="_blank"><i class="penci-faicon fa fa-twitter"></i></a>
<a href="https://instagram.com/thecheckeredflag/" rel="nofollow" target="_blank"><i class="penci-faicon fa fa-instagram"></i></a>
<a href="https://www.linkedin.com/company/thecheckeredflag/" rel="nofollow" target="_blank"><i class="penci-faicon fa fa-linkedin"></i></a>
<a href="https://www.youtube.com/channel/UCueRVoGbSE4GF2RszehXIgw" rel="nofollow" target="_blank"><i class="penci-faicon fa fa-youtube-play"></i></a>
<a href="https://www.thecheckeredflag.co.uk/feed" rel="nofollow" target="_blank"><i class="penci-faicon fa fa-rss"></i></a>
</div> </div>
<ul id="menu-2015" class="menu"><li id="menu-item-131887" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent penci-mega-menu menu-item-131887"><a href="https://www.thecheckeredflag.co.uk/formula-1/">F1</a>
<ul class="sub-menu">
<li id="menu-item-0" class="menu-item-0"><div class="penci-megamenu">
<div class="penci-content-megamenu">
<div class="penci-mega-latest-posts col-mn-5 mega-row-1">
<div class="penci-mega-row penci-mega-3 row-active">
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.thecheckeredflag.co.uk/formula-1/">
Formula 1 </a>
</span>
<a class="penci-image-holder penci-lazy" data-src="https://i2.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/04/Sir-Stirling-Moss-03.jpg?resize=585%2C390&#038;ssl=1" href="https://www.thecheckeredflag.co.uk/2020/04/tributes-pour-in-from-the-motorsport-world-for-sir-stirling-moss/" title="Tributes Pour In from the Motorsport World for Sir Stirling Moss">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.thecheckeredflag.co.uk/2020/04/tributes-pour-in-from-the-motorsport-world-for-sir-stirling-moss/" title="Tributes Pour In from the Motorsport World for Sir Stirling Moss">Tributes Pour In from the Motorsport World for&#8230;</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2020-04-12T15:25:46+01:00">April 12, 2020</time></p>
</div>
</div>
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.thecheckeredflag.co.uk/formula-1/">
Formula 1 </a>
</span>
<a class="penci-image-holder penci-lazy" data-src="https://i2.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/04/Sir-Stirling-Moss-01.jpg?resize=585%2C390&#038;ssl=1" href="https://www.thecheckeredflag.co.uk/2020/04/motor-sport-legend-sir-stirling-moss-passes-away-aged-90/" title="Motor Sport Legend Sir Stirling Moss Passes Away aged 90">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.thecheckeredflag.co.uk/2020/04/motor-sport-legend-sir-stirling-moss-passes-away-aged-90/" title="Motor Sport Legend Sir Stirling Moss Passes Away aged 90">Motor Sport Legend Sir Stirling Moss Passes Away&#8230;</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2020-04-12T14:46:59+01:00">April 12, 2020</time></p>
</div>
</div>
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.thecheckeredflag.co.uk/formula-1/">
Formula 1 </a>
</span>
<a class="penci-image-holder penci-lazy" data-src="https://i1.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/04/Canadian-GP-Start-01.jpg?resize=585%2C390&#038;ssl=1" href="https://www.thecheckeredflag.co.uk/2020/04/canadian-grand-prix-becomes-race-number-eight-to-be-postponed-in-2020/" title="Canadian Grand Prix becomes Race Number Nine to be Postponed in 2020">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.thecheckeredflag.co.uk/2020/04/canadian-grand-prix-becomes-race-number-eight-to-be-postponed-in-2020/" title="Canadian Grand Prix becomes Race Number Nine to be Postponed in 2020">Canadian Grand Prix becomes Race Number Nine to&#8230;</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2020-04-07T21:41:14+01:00">April 7, 2020</time></p>
</div>
</div>
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.thecheckeredflag.co.uk/formula-1/">
Formula 1 </a>
</span>
<a class="penci-image-holder penci-lazy" data-src="https://i1.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/04/Patient-with-CPAP-device.jpg?resize=585%2C390&#038;ssl=1" href="https://www.thecheckeredflag.co.uk/2020/04/uk-based-formula-1-teams-show-collective-strength-to-combat-coronavirus-pandemic/" title="UK-based Formula 1 Teams show collective strength to combat Coronavirus pandemic">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.thecheckeredflag.co.uk/2020/04/uk-based-formula-1-teams-show-collective-strength-to-combat-coronavirus-pandemic/" title="UK-based Formula 1 Teams show collective strength to combat Coronavirus pandemic">UK-based Formula 1 Teams show collective strength to&#8230;</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2020-04-02T11:59:27+01:00">April 2, 2020</time></p>
</div>
</div>
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.thecheckeredflag.co.uk/formula-1/">
Formula 1 </a>
</span>
<a class="penci-image-holder penci-lazy" data-src="https://i1.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2019/10/2019-Mexico-Charles-Leclerc-Pre-Race.jpg?resize=585%2C390&#038;ssl=1" href="https://www.thecheckeredflag.co.uk/2020/04/five-current-f1-drivers-confirm-participation-in-second-esports-gp/" title="Five current F1 drivers confirm participation in second eSports GP">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.thecheckeredflag.co.uk/2020/04/five-current-f1-drivers-confirm-participation-in-second-esports-gp/" title="Five current F1 drivers confirm participation in second eSports GP">Five current F1 drivers confirm participation in second&#8230;</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2020-04-02T10:57:26+01:00">April 2, 2020</time></p>
</div>
</div>
</div>
</div>
</div>
</div></li>
</ul>
</li>
<li id="menu-item-131940" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-131940"><a href="https://www.thecheckeredflag.co.uk/open-wheel/">Open Wheel</a>
<ul class="sub-menu">
<li id="menu-item-131942" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131942"><a href="https://www.thecheckeredflag.co.uk/open-wheel/formula-e/">FIA Formula E</a></li>
<li id="menu-item-131943" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131943"><a href="https://www.thecheckeredflag.co.uk/open-wheel/indycar/">IndyCar</a></li>
<li id="menu-item-333871" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-333871"><a href="https://www.thecheckeredflag.co.uk/open-wheel/fia-formula-2-championship/">FIA Formula 2</a></li>
<li id="menu-item-296601" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-296601"><a href="https://www.thecheckeredflag.co.uk/open-wheel/formula-3/fia-formula-3-championship/">FIA Formula 3</a></li>
<li id="menu-item-335473" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-335473"><a href="https://www.thecheckeredflag.co.uk/open-wheel/super-formula/">Super Formula</a></li>
<li id="menu-item-321059" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-321059"><a href="https://www.thecheckeredflag.co.uk/open-wheel/w-series/">W Series</a></li>
<li id="menu-item-180961" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-180961"><a href="https://www.thecheckeredflag.co.uk/open-wheel/formula-3/british-f3-formula-3/">British F3</a></li>
<li id="menu-item-131897" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131897"><a href="https://www.thecheckeredflag.co.uk/open-wheel/msa-formula/">F4 British Championship</a></li>
<li id="menu-item-131946" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131946"><a href="https://www.thecheckeredflag.co.uk/open-wheel/formula-3/euroformula-open/">EuroFormula Open</a></li>
<li id="menu-item-330918" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-330918"><a href="https://www.thecheckeredflag.co.uk/open-wheel/formula-renault-eurocup/">Formula Renault Eurocup</a></li>
<li id="menu-item-330987" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-330987"><a href="https://www.thecheckeredflag.co.uk/open-wheel/formula-3/formula-regional-european-championship/">Formula Regional European Championship</a></li>
</ul>
</li>
<li id="menu-item-131952" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-131952"><a href="https://www.thecheckeredflag.co.uk/sportscars/">Sportscars</a>
<ul class="sub-menu">
<li id="menu-item-131956" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131956"><a href="https://www.thecheckeredflag.co.uk/sportscars/endurance/fiawec/">FIA WEC</a></li>
<li id="menu-item-131957" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131957"><a href="https://www.thecheckeredflag.co.uk/sportscars/endurance/blancpain-endurance-series/">GT World Challenge Europe Endurance Cup</a></li>
<li id="menu-item-148232" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-148232"><a href="https://www.thecheckeredflag.co.uk/sportscars/endurance/blancpain-sprint/">GT World Challenge Europe</a></li>
<li id="menu-item-131954" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131954"><a href="https://www.thecheckeredflag.co.uk/sportscars/gt-sportscars/british-gt/">British GT</a></li>
<li id="menu-item-290801" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-290801"><a href="https://www.thecheckeredflag.co.uk/sportscars/ginetta/">Ginetta Series</a></li>
<li id="menu-item-303742" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-303742"><a href="https://www.thecheckeredflag.co.uk/sportscars/porsche/">Porsche Series</a></li>
</ul>
</li>
<li id="menu-item-131899" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-131899"><a href="https://www.thecheckeredflag.co.uk/touring-cars/">Touring Cars</a>
<ul class="sub-menu">
<li id="menu-item-131904" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131904"><a href="https://www.thecheckeredflag.co.uk/touring-cars/btcc/">BTCC</a></li>
<li id="menu-item-192543" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-192543"><a href="https://www.thecheckeredflag.co.uk/touring-cars/dtm/">DTM</a></li>
<li id="menu-item-317944" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-317944"><a href="https://www.thecheckeredflag.co.uk/touring-cars/jaguar-i-pace-etrophy/">Jaguar I-PACE eTROPHY</a></li>
</ul>
</li>
<li id="menu-item-131918" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-131918"><a href="https://www.thecheckeredflag.co.uk/motorcycles/">Motorcycles</a>
<ul class="sub-menu">
<li id="menu-item-131922" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131922"><a href="https://www.thecheckeredflag.co.uk/motorcycles/motogp/">MotoGP</a></li>
<li id="menu-item-131920" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131920"><a href="https://www.thecheckeredflag.co.uk/motorcycles/moto2/">Moto2</a></li>
<li id="menu-item-131921" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131921"><a href="https://www.thecheckeredflag.co.uk/motorcycles/moto3/">Moto3</a></li>
</ul>
</li>
<li id="menu-item-290798" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-290798"><a href="https://www.thecheckeredflag.co.uk/offroad/">Off Road</a>
<ul class="sub-menu">
<li id="menu-item-254211" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-254211"><a href="https://www.thecheckeredflag.co.uk/offroad/rally/fiawrc/">FIA WRC</a></li>
<li id="menu-item-138301" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-138301"><a href="https://www.thecheckeredflag.co.uk/offroad/rally/fia-erc/">FIA ERC</a></li>
<li id="menu-item-131910" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131910"><a href="https://www.thecheckeredflag.co.uk/offroad/rally/british-rally-championship/">British Rally Championship</a></li>
<li id="menu-item-131917" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131917"><a href="https://www.thecheckeredflag.co.uk/offroad/rallycross/world-rallycross/">FIA World RX</a></li>
<li id="menu-item-131913" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131913"><a href="https://www.thecheckeredflag.co.uk/offroad/rallycross/european-rallycross/">FIA European RX</a></li>
<li id="menu-item-330919" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-330919"><a href="https://www.thecheckeredflag.co.uk/offroad/rallycross/british-rallycross/">British Rallycross</a></li>
<li id="menu-item-332829" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-332829"><a href="https://www.thecheckeredflag.co.uk/offroad/rallycross/rallyx-nordic/">RallyX Nordic</a></li>
</ul>
</li>
<li id="menu-item-290800" class="menu-item menu-item-type-taxonomy menu-item-object-category penci-mega-menu menu-item-290800"><a href="https://www.thecheckeredflag.co.uk/nascar/">NASCAR</a>
<ul class="sub-menu">
<li class="menu-item-0"><div class="penci-megamenu"> <div class="penci-mega-child-categories">
<a class="mega-cat-child" href="https://www.thecheckeredflag.co.uk/nascar/sprint-cup/" data-id="penci-mega-2741"><span>NASCAR Cup Series</span></a>
<a class="mega-cat-child" href="https://www.thecheckeredflag.co.uk/nascar/nascar-trucks/" data-id="penci-mega-18305"><span>NASCAR Gander Trucks</span></a>
<a class="mega-cat-child" href="https://www.thecheckeredflag.co.uk/nascar/euro-racecar/" data-id="penci-mega-8304"><span>NASCAR Whelen Euro Series</span></a>
<a class="mega-cat-child" href="https://www.thecheckeredflag.co.uk/nascar/nascar-xfinity-series/" data-id="penci-mega-2742"><span>NASCAR Xfinity Series</span></a>
<a class="mega-cat-child cat-active all-style" href="https://www.thecheckeredflag.co.uk/nascar/" data-id="penci-mega-108"><span>All</span></a>
</div>
<div class="penci-content-megamenu">
<div class="penci-mega-latest-posts col-mn-4 mega-row-1">
<div class="penci-mega-row penci-mega-2741">
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.thecheckeredflag.co.uk/other/esports/">eSports</a> </span>
<a class="penci-image-holder penci-lazy" data-src="https://i1.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/04/William-Byron-eNASCAR-Pro-Invitational-2020-Bristol.jpg?resize=585%2C390&#038;ssl=1" href="https://www.thecheckeredflag.co.uk/2020/04/william-byron-wins-wreck-filled-food-city-showdown/" title="William Byron wins wreck-filled Food City Showdown">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.thecheckeredflag.co.uk/2020/04/william-byron-wins-wreck-filled-food-city-showdown/" title="William Byron wins wreck-filled Food City Showdown">William Byron wins wreck-filled Food City Showdown</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2020-04-05T20:27:01+01:00">April 5, 2020</time></p>
</div>
</div>
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.thecheckeredflag.co.uk/nascar/sprint-cup/">NASCAR Cup Series</a> </span>
<a class="penci-image-holder penci-lazy" data-src="https://i2.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/04/NASCAR-Next-Gen-car-test-2020-Homestead.jpg?resize=585%2C390&#038;ssl=1" href="https://www.thecheckeredflag.co.uk/2020/04/nascar-next-gen-car-delayed-to-2022/" title="NASCAR Next Gen car delayed to 2022">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.thecheckeredflag.co.uk/2020/04/nascar-next-gen-car-delayed-to-2022/" title="NASCAR Next Gen car delayed to 2022">NASCAR Next Gen car delayed to 2022</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2020-04-02T22:19:53+01:00">April 2, 2020</time></p>
</div>
</div>
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.thecheckeredflag.co.uk/nascar/sprint-cup/">NASCAR Cup Series</a> </span>
<a class="penci-image-holder penci-lazy" data-src="https://i0.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/04/Joey-Gase-2020-Southern-500-Darlington-throwback.jpg?resize=585%2C390&#038;ssl=1" href="https://www.thecheckeredflag.co.uk/2020/04/joey-gase-reveals-bobby-allison-throwback-for-darlington/" title="Joey Gase reveals Bobby Allison throwback for Darlington">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.thecheckeredflag.co.uk/2020/04/joey-gase-reveals-bobby-allison-throwback-for-darlington/" title="Joey Gase reveals Bobby Allison throwback for Darlington">Joey Gase reveals Bobby Allison throwback for Darlington</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2020-04-01T21:31:45+01:00">April 1, 2020</time></p>
</div>
</div>
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.thecheckeredflag.co.uk/other/esports/">eSports</a> </span>
<a class="penci-image-holder penci-lazy" data-src="https://i1.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/04/eNASCAR-PIS-Blaney-Busch-wreck-Texas-2020.jpg?resize=585%2C390&#038;ssl=1" href="https://www.thecheckeredflag.co.uk/2020/04/enascar-pro-invitational-introduces-heats-for-bristol/" title="eNASCAR Pro Invitational introduces heats for Bristol">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.thecheckeredflag.co.uk/2020/04/enascar-pro-invitational-introduces-heats-for-bristol/" title="eNASCAR Pro Invitational introduces heats for Bristol">eNASCAR Pro Invitational introduces heats for Bristol</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2020-04-01T18:47:08+01:00">April 1, 2020</time></p>
</div>
</div>
</div>
<div class="penci-mega-row penci-mega-18305">
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.thecheckeredflag.co.uk/nascar/nascar-trucks/">NASCAR Gander Trucks</a> </span>
<a class="penci-image-holder penci-lazy" data-src="https://i1.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/04/Logan-Seavey-eNASCAR-Saturday-Night-Thunder-2020-Bristol.jpg?resize=585%2C390&#038;ssl=1" href="https://www.thecheckeredflag.co.uk/2020/04/logan-seavey-wins-saturday-night-thunder/" title="Logan Seavey wins Saturday Night Thunder">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.thecheckeredflag.co.uk/2020/04/logan-seavey-wins-saturday-night-thunder/" title="Logan Seavey wins Saturday Night Thunder">Logan Seavey wins Saturday Night Thunder</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2020-04-05T03:04:26+01:00">April 5, 2020</time></p>
</div>
</div>
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.thecheckeredflag.co.uk/nascar/nascar-trucks/">NASCAR Gander Trucks</a> </span>
<a class="penci-image-holder penci-lazy" data-src="https://i2.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/03/Brett-Moffitt-2019-NGOTS-ISM.jpg?resize=585%2C390&#038;ssl=1" href="https://www.thecheckeredflag.co.uk/2020/03/brett-moffitt-injured-in-motocross-accident/" title="Brett Moffitt injured in motocross accident">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.thecheckeredflag.co.uk/2020/03/brett-moffitt-injured-in-motocross-accident/" title="Brett Moffitt injured in motocross accident">Brett Moffitt injured in motocross accident</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2020-03-16T18:36:32+00:00">March 16, 2020</time></p>
</div>
</div>
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.thecheckeredflag.co.uk/nascar/nascar-trucks/">NASCAR Gander Trucks</a> </span>
<a class="penci-image-holder penci-lazy" data-src="https://i0.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/03/nhms_mencs_ragan_053017.jpg?resize=585%2C390&#038;ssl=1" href="https://www.thecheckeredflag.co.uk/2020/03/david-ragan-joins-dgr-crosley-for-truck-series-at-richmond/" title="David Ragan joins DGR-Crosley for Truck Series at Richmond">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.thecheckeredflag.co.uk/2020/03/david-ragan-joins-dgr-crosley-for-truck-series-at-richmond/" title="David Ragan joins DGR-Crosley for Truck Series at Richmond">David Ragan joins DGR-Crosley for Truck Series at&#8230;</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2020-03-11T18:25:25+00:00">March 11, 2020</time></p>
</div>
</div>
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.thecheckeredflag.co.uk/nascar/nascar-trucks/">NASCAR Gander Trucks</a> </span>
<a class="penci-image-holder penci-lazy" data-src="https://i0.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/02/lvms1_ngrots_buschcelebration_022120.jpg?resize=585%2C390&#038;ssl=1" href="https://www.thecheckeredflag.co.uk/2020/02/kyle-busch-bounty-hunt-picks-up-chase-elliott-kyle-larson/" title="Kyle Busch bounty hunt picks up Chase Elliott, Kyle Larson">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.thecheckeredflag.co.uk/2020/02/kyle-busch-bounty-hunt-picks-up-chase-elliott-kyle-larson/" title="Kyle Busch bounty hunt picks up Chase Elliott, Kyle Larson">Kyle Busch bounty hunt picks up Chase Elliott,&#8230;</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2020-02-28T01:47:13+00:00">February 28, 2020</time></p>
</div>
</div>
</div>
<div class="penci-mega-row penci-mega-8304">
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.thecheckeredflag.co.uk/nascar/euro-racecar/">NASCAR Whelen Euro Series</a> </span>
<a class="penci-image-holder penci-lazy" data-src="https://i0.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/04/Whelen-Euro-Series-iRacing-Watkins-Glen.jpg?resize=585%2C390&#038;ssl=1" href="https://www.thecheckeredflag.co.uk/2020/04/euronascar-esports-series-formed-with-real-life-points-in-play/" title="EuroNASCAR Esports Series formed with real-life points in play">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.thecheckeredflag.co.uk/2020/04/euronascar-esports-series-formed-with-real-life-points-in-play/" title="EuroNASCAR Esports Series formed with real-life points in play">EuroNASCAR Esports Series formed with real-life points in&#8230;</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2020-04-06T21:51:29+01:00">April 6, 2020</time></p>
</div>
</div>
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.thecheckeredflag.co.uk/nascar/euro-racecar/">NASCAR Whelen Euro Series</a> </span>
<a class="penci-image-holder penci-lazy" data-src="https://i1.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/04/Logan-Seavey-eNASCAR-Saturday-Night-Thunder-2020-Bristol.jpg?resize=585%2C390&#038;ssl=1" href="https://www.thecheckeredflag.co.uk/2020/04/logan-seavey-wins-saturday-night-thunder/" title="Logan Seavey wins Saturday Night Thunder">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.thecheckeredflag.co.uk/2020/04/logan-seavey-wins-saturday-night-thunder/" title="Logan Seavey wins Saturday Night Thunder">Logan Seavey wins Saturday Night Thunder</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2020-04-05T03:04:26+01:00">April 5, 2020</time></p>
</div>
</div>
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.thecheckeredflag.co.uk/nascar/euro-racecar/">NASCAR Whelen Euro Series</a> </span>
<a class="penci-image-holder penci-lazy" data-src="https://i0.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/03/2019-NWES-GP-Belgium-Zolder-start.jpeg?resize=585%2C390&#038;ssl=1" href="https://www.thecheckeredflag.co.uk/2020/03/2020-euro-series-sees-largest-full-time-grid-ever-at-33-cars/" title="2020 Euro Series sees largest full-time grid ever at 33 cars">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.thecheckeredflag.co.uk/2020/03/2020-euro-series-sees-largest-full-time-grid-ever-at-33-cars/" title="2020 Euro Series sees largest full-time grid ever at 33 cars">2020 Euro Series sees largest full-time grid ever&#8230;</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2020-03-31T19:51:27+01:00">March 31, 2020</time></p>
</div>
</div>
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.thecheckeredflag.co.uk/nascar/euro-racecar/">NASCAR Whelen Euro Series</a> </span>
<a class="penci-image-holder penci-lazy" data-src="https://i0.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/03/BritishGT-TrackingSafetyCar-009.jpg?resize=585%2C390&#038;ssl=1" href="https://www.thecheckeredflag.co.uk/2020/03/motorsport-uk-prolonging-covid-suspension-to-end-of-june/" title="Motorsport UK prolonging COVID suspension to end of June">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.thecheckeredflag.co.uk/2020/03/motorsport-uk-prolonging-covid-suspension-to-end-of-june/" title="Motorsport UK prolonging COVID suspension to end of June">Motorsport UK prolonging COVID suspension to end of&#8230;</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2020-03-24T17:55:29+00:00">March 24, 2020</time></p>
</div>
</div>
</div>
<div class="penci-mega-row penci-mega-2742">
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.thecheckeredflag.co.uk/nascar/nascar-xfinity-series/">NASCAR Xfinity Series</a> </span>
<a class="penci-image-holder penci-lazy" data-src="https://i1.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/04/Logan-Seavey-eNASCAR-Saturday-Night-Thunder-2020-Bristol.jpg?resize=585%2C390&#038;ssl=1" href="https://www.thecheckeredflag.co.uk/2020/04/logan-seavey-wins-saturday-night-thunder/" title="Logan Seavey wins Saturday Night Thunder">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.thecheckeredflag.co.uk/2020/04/logan-seavey-wins-saturday-night-thunder/" title="Logan Seavey wins Saturday Night Thunder">Logan Seavey wins Saturday Night Thunder</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2020-04-05T03:04:26+01:00">April 5, 2020</time></p>
</div>
</div>
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.thecheckeredflag.co.uk/nascar/nascar-xfinity-series/">NASCAR Xfinity Series</a> </span>
<a class="penci-image-holder penci-lazy" data-src="https://i0.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/03/Tony-Stewart-NASCAR-Hall-of-Fame-2020.jpg?resize=585%2C390&#038;ssl=1" href="https://www.thecheckeredflag.co.uk/2020/03/tony-stewart-making-nascar-return-at-indy-road-course/" title="Tony Stewart making NASCAR return at Indy road course">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.thecheckeredflag.co.uk/2020/03/tony-stewart-making-nascar-return-at-indy-road-course/" title="Tony Stewart making NASCAR return at Indy road course">Tony Stewart making NASCAR return at Indy road&#8230;</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2020-03-05T00:55:41+00:00">March 5, 2020</time></p>
</div>
</div>
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.thecheckeredflag.co.uk/nascar/nascar-xfinity-series/">NASCAR Xfinity Series</a> </span>
<a class="penci-image-holder penci-lazy" data-src="https://i1.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/02/Kody_Vanderwal_Matt_Levin_2017_Carneros_200.jpg?resize=585%2C390&#038;ssl=1" href="https://www.thecheckeredflag.co.uk/2020/02/means-racing-to-field-jj-yeley-kody-vanderwal/" title="Means Racing to field JJ Yeley, Kody Vanderwal">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.thecheckeredflag.co.uk/2020/02/means-racing-to-field-jj-yeley-kody-vanderwal/" title="Means Racing to field JJ Yeley, Kody Vanderwal">Means Racing to field JJ Yeley, Kody Vanderwal</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2020-02-14T01:25:14+00:00">February 14, 2020</time></p>
</div>
</div>
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.thecheckeredflag.co.uk/nascar/nascar-xfinity-series/">NASCAR Xfinity Series</a> </span>
<a class="penci-image-holder penci-lazy" data-src="https://i1.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/02/mcleod_2019nxs_carshot.jpg?resize=585%2C390&#038;ssl=1" href="https://www.thecheckeredflag.co.uk/2020/02/jd-motorsports-finalise-2020-lineup/" title="JD Motorsports finalise 2020 lineup">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.thecheckeredflag.co.uk/2020/02/jd-motorsports-finalise-2020-lineup/" title="JD Motorsports finalise 2020 lineup">JD Motorsports finalise 2020 lineup</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2020-02-10T20:59:36+00:00">February 10, 2020</time></p>
</div>
</div>
</div>
<div class="penci-mega-row penci-mega-108 row-active">
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.thecheckeredflag.co.uk/nascar/">NASCAR</a> </span>
<a class="penci-image-holder penci-lazy" data-src="https://i0.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/04/Whelen-Euro-Series-iRacing-Watkins-Glen.jpg?resize=585%2C390&#038;ssl=1" href="https://www.thecheckeredflag.co.uk/2020/04/euronascar-esports-series-formed-with-real-life-points-in-play/" title="EuroNASCAR Esports Series formed with real-life points in play">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.thecheckeredflag.co.uk/2020/04/euronascar-esports-series-formed-with-real-life-points-in-play/" title="EuroNASCAR Esports Series formed with real-life points in play">EuroNASCAR Esports Series formed with real-life points in&#8230;</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2020-04-06T21:51:29+01:00">April 6, 2020</time></p>
</div>
</div>
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.thecheckeredflag.co.uk/nascar/">NASCAR</a> </span>
<a class="penci-image-holder penci-lazy" data-src="https://i1.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/04/William-Byron-eNASCAR-Pro-Invitational-2020-Bristol.jpg?resize=585%2C390&#038;ssl=1" href="https://www.thecheckeredflag.co.uk/2020/04/william-byron-wins-wreck-filled-food-city-showdown/" title="William Byron wins wreck-filled Food City Showdown">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.thecheckeredflag.co.uk/2020/04/william-byron-wins-wreck-filled-food-city-showdown/" title="William Byron wins wreck-filled Food City Showdown">William Byron wins wreck-filled Food City Showdown</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2020-04-05T20:27:01+01:00">April 5, 2020</time></p>
</div>
</div>
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.thecheckeredflag.co.uk/nascar/">NASCAR</a> </span>
<a class="penci-image-holder penci-lazy" data-src="https://i1.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/04/Logan-Seavey-eNASCAR-Saturday-Night-Thunder-2020-Bristol.jpg?resize=585%2C390&#038;ssl=1" href="https://www.thecheckeredflag.co.uk/2020/04/logan-seavey-wins-saturday-night-thunder/" title="Logan Seavey wins Saturday Night Thunder">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.thecheckeredflag.co.uk/2020/04/logan-seavey-wins-saturday-night-thunder/" title="Logan Seavey wins Saturday Night Thunder">Logan Seavey wins Saturday Night Thunder</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2020-04-05T03:04:26+01:00">April 5, 2020</time></p>
</div>
</div>
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.thecheckeredflag.co.uk/nascar/">NASCAR</a> </span>
<a class="penci-image-holder penci-lazy" data-src="https://i2.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/04/NASCAR-Next-Gen-car-test-2020-Homestead.jpg?resize=585%2C390&#038;ssl=1" href="https://www.thecheckeredflag.co.uk/2020/04/nascar-next-gen-car-delayed-to-2022/" title="NASCAR Next Gen car delayed to 2022">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.thecheckeredflag.co.uk/2020/04/nascar-next-gen-car-delayed-to-2022/" title="NASCAR Next Gen car delayed to 2022">NASCAR Next Gen car delayed to 2022</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2020-04-02T22:19:53+01:00">April 2, 2020</time></p>
</div>
</div>
</div>
</div>
</div>
</div></li>
</ul>
</li>
<li id="menu-item-293110" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-293110"><a href="https://www.thecheckeredflag.co.uk/features/">Features</a>
<ul class="sub-menu">
<li id="menu-item-330921" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-330921"><a href="https://www.thecheckeredflag.co.uk/tcf-blogs/">TCF Blogs</a></li>
<li id="menu-item-293115" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-293115"><a href="https://www.thecheckeredflag.co.uk/features/opinion/">Opinion</a></li>
<li id="menu-item-293113" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-293113"><a href="https://www.thecheckeredflag.co.uk/features/interviews/">Interviews</a></li>
<li id="menu-item-293114" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-293114"><a href="https://www.thecheckeredflag.co.uk/features/gallery/">Gallery</a></li>
<li id="menu-item-293111" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-293111"><a href="https://www.thecheckeredflag.co.uk/features/product-review/">Product Review</a></li>
<li id="menu-item-293112" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-293112"><a href="https://www.thecheckeredflag.co.uk/features/season-review/">Season Review</a></li>
<li id="menu-item-293118" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-293118"><a href="https://www.thecheckeredflag.co.uk/other/esports/">eSports</a></li>
<li id="menu-item-293117" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-293117"><a href="https://www.thecheckeredflag.co.uk/other/video-games/">Sim Racing</a></li>
</ul>
</li>
</ul> </nav>
<div class="wrapper-boxed header-style-header-5 penci-hlogo-center">
<div class="penci-header-wrap"><div class="penci-top-bar">
<div class="container">
<div class="penci-headline" role="navigation" itemscope itemtype="https://schema.org/SiteNavigationElement">
<span class="headline-title">Latest</span>
<div class="penci-topbar-social">
<div class="inner-header-social">
<a href="https://facebook.com/TheCheckeredFlag" rel="nofollow" target="_blank"><i class="penci-faicon fa fa-facebook"></i></a>
<a href="https://twitter.com/TheCheckerFlag" rel="nofollow" target="_blank"><i class="penci-faicon fa fa-twitter"></i></a>
<a href="https://instagram.com/thecheckeredflag/" rel="nofollow" target="_blank"><i class="penci-faicon fa fa-instagram"></i></a>
<a href="https://www.linkedin.com/company/thecheckeredflag/" rel="nofollow" target="_blank"><i class="penci-faicon fa fa-linkedin"></i></a>
<a href="https://www.youtube.com/channel/UCueRVoGbSE4GF2RszehXIgw" rel="nofollow" target="_blank"><i class="penci-faicon fa fa-youtube-play"></i></a>
<a href="https://www.thecheckeredflag.co.uk/feed" rel="nofollow" target="_blank"><i class="penci-faicon fa fa-rss"></i></a>
</div> </div>
<div class="penci-owl-carousel penci-owl-carousel-slider penci-headline-posts" data-auto="true" data-autotime="3000" data-speed="200">
<div>
<a class="penci-topbar-post-title" href="https://www.thecheckeredflag.co.uk/2020/04/covid-19-forces-euroformula-open-to-reschedule-spa-barcelona-rounds/">COVID-19 Forces EuroFormula Open to Reschedule Spa &#038; Barcelona Rounds</a>
</div>
<div>
<a class="penci-topbar-post-title" href="https://www.thecheckeredflag.co.uk/2020/04/tributes-pour-in-from-the-motorsport-world-for-sir-stirling-moss/">Tributes Pour In from the Motorsport World for Sir Stirling Moss</a>
</div>
<div>
<a class="penci-topbar-post-title" href="https://www.thecheckeredflag.co.uk/2020/04/motor-sport-legend-sir-stirling-moss-passes-away-aged-90/">Motor Sport Legend Sir Stirling Moss Passes Away aged 90</a>
</div>
<div>
<a class="penci-topbar-post-title" href="https://www.thecheckeredflag.co.uk/2020/04/pagenaud-takes-fuel-mileage-michigan-win-in-indycar-iracing-challenge/">Pagenaud takes fuel mileage Michigan win in IndyCar iRacing Challenge</a>
</div>
<div>
<a class="penci-topbar-post-title" href="https://www.thecheckeredflag.co.uk/2020/04/formula-e-teams-unanimously-agree-to-cost-cutting-measures/">Formula E teams unanimously agree to cost-cutting measures</a>
</div>
<div>
<a class="penci-topbar-post-title" href="https://www.thecheckeredflag.co.uk/2020/04/wrc-testing-suspended-during-covid-19-pandemic/">WRC Testing Suspended During COVID-19 Pandemic</a>
</div>
<div>
<a class="penci-topbar-post-title" href="https://www.thecheckeredflag.co.uk/2020/04/a-look-at-the-greats-that-have-dominated-motogp-history/">A look at the greats that have dominated MotoGP history</a>
</div>
<div>
<a class="penci-topbar-post-title" href="https://www.thecheckeredflag.co.uk/2020/04/italian-and-catalan-grand-prix-postponed/">Italian and Catalan Grand Prix postponed</a>
</div>
<div>
<a class="penci-topbar-post-title" href="https://www.thecheckeredflag.co.uk/2020/04/canadian-grand-prix-becomes-race-number-eight-to-be-postponed-in-2020/">Canadian Grand Prix becomes Race Number Nine to be Postponed in 2020</a>
</div>
<div>
<a class="penci-topbar-post-title" href="https://www.thecheckeredflag.co.uk/2020/04/tatiana-calderon-we-definitely-did-a-step-forward-during-the-test/">Tatiana Calderón: “We definitely did a step forward during the test”</a>
</div>
</div>
</div>
</div>
</div><header id="header" class="header-header-5 has-bottom-line" itemscope="itemscope" itemtype="https://schema.org/WPHeader">
<div class="inner-header penci-header-second">
<div class="container container-fullwidth">
<div id="logo">
<a href="https://www.thecheckeredflag.co.uk/"><img src="https://www.thecheckeredflag.co.uk/wp-content/uploads/2019/10/TCF-Header-2019.png" alt="The Checkered Flag" /></a> </div>
</div>
</div>
<nav id="navigation" class="header-layout-bottom header-5 menu-style-2 menu-item-padding" role="navigation" itemscope itemtype="https://schema.org/SiteNavigationElement">
<div class="container container-fullwidth">
<div class="button-menu-mobile header-5"><i class="penci-faicon fa fa-bars"></i></div>
<ul id="menu-2016" class="menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent penci-mega-menu menu-item-131887"><a href="https://www.thecheckeredflag.co.uk/formula-1/">F1</a>
<ul class="sub-menu">
<li class="menu-item-0"><div class="penci-megamenu">
<div class="penci-content-megamenu">
<div class="penci-mega-latest-posts col-mn-5 mega-row-1">
<div class="penci-mega-row penci-mega-3 row-active">
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.thecheckeredflag.co.uk/formula-1/">
Formula 1 </a>
</span>
<a class="penci-image-holder penci-lazy" data-src="https://i2.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/04/Sir-Stirling-Moss-03.jpg?resize=585%2C390&#038;ssl=1" href="https://www.thecheckeredflag.co.uk/2020/04/tributes-pour-in-from-the-motorsport-world-for-sir-stirling-moss/" title="Tributes Pour In from the Motorsport World for Sir Stirling Moss">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.thecheckeredflag.co.uk/2020/04/tributes-pour-in-from-the-motorsport-world-for-sir-stirling-moss/" title="Tributes Pour In from the Motorsport World for Sir Stirling Moss">Tributes Pour In from the Motorsport World for&#8230;</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2020-04-12T15:25:46+01:00">April 12, 2020</time></p>
</div>
</div>
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.thecheckeredflag.co.uk/formula-1/">
Formula 1 </a>
</span>
<a class="penci-image-holder penci-lazy" data-src="https://i2.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/04/Sir-Stirling-Moss-01.jpg?resize=585%2C390&#038;ssl=1" href="https://www.thecheckeredflag.co.uk/2020/04/motor-sport-legend-sir-stirling-moss-passes-away-aged-90/" title="Motor Sport Legend Sir Stirling Moss Passes Away aged 90">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.thecheckeredflag.co.uk/2020/04/motor-sport-legend-sir-stirling-moss-passes-away-aged-90/" title="Motor Sport Legend Sir Stirling Moss Passes Away aged 90">Motor Sport Legend Sir Stirling Moss Passes Away&#8230;</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2020-04-12T14:46:59+01:00">April 12, 2020</time></p>
</div>
</div>
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.thecheckeredflag.co.uk/formula-1/">
Formula 1 </a>
</span>
<a class="penci-image-holder penci-lazy" data-src="https://i1.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/04/Canadian-GP-Start-01.jpg?resize=585%2C390&#038;ssl=1" href="https://www.thecheckeredflag.co.uk/2020/04/canadian-grand-prix-becomes-race-number-eight-to-be-postponed-in-2020/" title="Canadian Grand Prix becomes Race Number Nine to be Postponed in 2020">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.thecheckeredflag.co.uk/2020/04/canadian-grand-prix-becomes-race-number-eight-to-be-postponed-in-2020/" title="Canadian Grand Prix becomes Race Number Nine to be Postponed in 2020">Canadian Grand Prix becomes Race Number Nine to&#8230;</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2020-04-07T21:41:14+01:00">April 7, 2020</time></p>
</div>
</div>
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.thecheckeredflag.co.uk/formula-1/">
Formula 1 </a>
</span>
<a class="penci-image-holder penci-lazy" data-src="https://i1.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/04/Patient-with-CPAP-device.jpg?resize=585%2C390&#038;ssl=1" href="https://www.thecheckeredflag.co.uk/2020/04/uk-based-formula-1-teams-show-collective-strength-to-combat-coronavirus-pandemic/" title="UK-based Formula 1 Teams show collective strength to combat Coronavirus pandemic">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.thecheckeredflag.co.uk/2020/04/uk-based-formula-1-teams-show-collective-strength-to-combat-coronavirus-pandemic/" title="UK-based Formula 1 Teams show collective strength to combat Coronavirus pandemic">UK-based Formula 1 Teams show collective strength to&#8230;</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2020-04-02T11:59:27+01:00">April 2, 2020</time></p>
</div>
</div>
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.thecheckeredflag.co.uk/formula-1/">
Formula 1 </a>
</span>
<a class="penci-image-holder penci-lazy" data-src="https://i1.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2019/10/2019-Mexico-Charles-Leclerc-Pre-Race.jpg?resize=585%2C390&#038;ssl=1" href="https://www.thecheckeredflag.co.uk/2020/04/five-current-f1-drivers-confirm-participation-in-second-esports-gp/" title="Five current F1 drivers confirm participation in second eSports GP">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.thecheckeredflag.co.uk/2020/04/five-current-f1-drivers-confirm-participation-in-second-esports-gp/" title="Five current F1 drivers confirm participation in second eSports GP">Five current F1 drivers confirm participation in second&#8230;</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2020-04-02T10:57:26+01:00">April 2, 2020</time></p>
</div>
</div>
</div>
</div>
</div>
</div></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-131940"><a href="https://www.thecheckeredflag.co.uk/open-wheel/">Open Wheel</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131942"><a href="https://www.thecheckeredflag.co.uk/open-wheel/formula-e/">FIA Formula E</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131943"><a href="https://www.thecheckeredflag.co.uk/open-wheel/indycar/">IndyCar</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-333871"><a href="https://www.thecheckeredflag.co.uk/open-wheel/fia-formula-2-championship/">FIA Formula 2</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-296601"><a href="https://www.thecheckeredflag.co.uk/open-wheel/formula-3/fia-formula-3-championship/">FIA Formula 3</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-335473"><a href="https://www.thecheckeredflag.co.uk/open-wheel/super-formula/">Super Formula</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-321059"><a href="https://www.thecheckeredflag.co.uk/open-wheel/w-series/">W Series</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-180961"><a href="https://www.thecheckeredflag.co.uk/open-wheel/formula-3/british-f3-formula-3/">British F3</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131897"><a href="https://www.thecheckeredflag.co.uk/open-wheel/msa-formula/">F4 British Championship</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131946"><a href="https://www.thecheckeredflag.co.uk/open-wheel/formula-3/euroformula-open/">EuroFormula Open</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-330918"><a href="https://www.thecheckeredflag.co.uk/open-wheel/formula-renault-eurocup/">Formula Renault Eurocup</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-330987"><a href="https://www.thecheckeredflag.co.uk/open-wheel/formula-3/formula-regional-european-championship/">Formula Regional European Championship</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-131952"><a href="https://www.thecheckeredflag.co.uk/sportscars/">Sportscars</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131956"><a href="https://www.thecheckeredflag.co.uk/sportscars/endurance/fiawec/">FIA WEC</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131957"><a href="https://www.thecheckeredflag.co.uk/sportscars/endurance/blancpain-endurance-series/">GT World Challenge Europe Endurance Cup</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-148232"><a href="https://www.thecheckeredflag.co.uk/sportscars/endurance/blancpain-sprint/">GT World Challenge Europe</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131954"><a href="https://www.thecheckeredflag.co.uk/sportscars/gt-sportscars/british-gt/">British GT</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-290801"><a href="https://www.thecheckeredflag.co.uk/sportscars/ginetta/">Ginetta Series</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-303742"><a href="https://www.thecheckeredflag.co.uk/sportscars/porsche/">Porsche Series</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-131899"><a href="https://www.thecheckeredflag.co.uk/touring-cars/">Touring Cars</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131904"><a href="https://www.thecheckeredflag.co.uk/touring-cars/btcc/">BTCC</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-192543"><a href="https://www.thecheckeredflag.co.uk/touring-cars/dtm/">DTM</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-317944"><a href="https://www.thecheckeredflag.co.uk/touring-cars/jaguar-i-pace-etrophy/">Jaguar I-PACE eTROPHY</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-131918"><a href="https://www.thecheckeredflag.co.uk/motorcycles/">Motorcycles</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131922"><a href="https://www.thecheckeredflag.co.uk/motorcycles/motogp/">MotoGP</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131920"><a href="https://www.thecheckeredflag.co.uk/motorcycles/moto2/">Moto2</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131921"><a href="https://www.thecheckeredflag.co.uk/motorcycles/moto3/">Moto3</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-290798"><a href="https://www.thecheckeredflag.co.uk/offroad/">Off Road</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-254211"><a href="https://www.thecheckeredflag.co.uk/offroad/rally/fiawrc/">FIA WRC</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-138301"><a href="https://www.thecheckeredflag.co.uk/offroad/rally/fia-erc/">FIA ERC</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131910"><a href="https://www.thecheckeredflag.co.uk/offroad/rally/british-rally-championship/">British Rally Championship</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131917"><a href="https://www.thecheckeredflag.co.uk/offroad/rallycross/world-rallycross/">FIA World RX</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131913"><a href="https://www.thecheckeredflag.co.uk/offroad/rallycross/european-rallycross/">FIA European RX</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-330919"><a href="https://www.thecheckeredflag.co.uk/offroad/rallycross/british-rallycross/">British Rallycross</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-332829"><a href="https://www.thecheckeredflag.co.uk/offroad/rallycross/rallyx-nordic/">RallyX Nordic</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category penci-mega-menu menu-item-290800"><a href="https://www.thecheckeredflag.co.uk/nascar/">NASCAR</a>
<ul class="sub-menu">
<li class="menu-item-0"><div class="penci-megamenu"> <div class="penci-mega-child-categories">
<a class="mega-cat-child" href="https://www.thecheckeredflag.co.uk/nascar/sprint-cup/" data-id="penci-mega-2741"><span>NASCAR Cup Series</span></a>
<a class="mega-cat-child" href="https://www.thecheckeredflag.co.uk/nascar/nascar-trucks/" data-id="penci-mega-18305"><span>NASCAR Gander Trucks</span></a>
<a class="mega-cat-child" href="https://www.thecheckeredflag.co.uk/nascar/euro-racecar/" data-id="penci-mega-8304"><span>NASCAR Whelen Euro Series</span></a>
<a class="mega-cat-child" href="https://www.thecheckeredflag.co.uk/nascar/nascar-xfinity-series/" data-id="penci-mega-2742"><span>NASCAR Xfinity Series</span></a>
<a class="mega-cat-child cat-active all-style" href="https://www.thecheckeredflag.co.uk/nascar/" data-id="penci-mega-108"><span>All</span></a>
</div>
<div class="penci-content-megamenu">
<div class="penci-mega-latest-posts col-mn-4 mega-row-1">
<div class="penci-mega-row penci-mega-2741">
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.thecheckeredflag.co.uk/other/esports/">eSports</a> </span>
<a class="penci-image-holder penci-lazy" data-src="https://i1.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/04/William-Byron-eNASCAR-Pro-Invitational-2020-Bristol.jpg?resize=585%2C390&#038;ssl=1" href="https://www.thecheckeredflag.co.uk/2020/04/william-byron-wins-wreck-filled-food-city-showdown/" title="William Byron wins wreck-filled Food City Showdown">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.thecheckeredflag.co.uk/2020/04/william-byron-wins-wreck-filled-food-city-showdown/" title="William Byron wins wreck-filled Food City Showdown">William Byron wins wreck-filled Food City Showdown</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2020-04-05T20:27:01+01:00">April 5, 2020</time></p>
</div>
</div>
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.thecheckeredflag.co.uk/nascar/sprint-cup/">NASCAR Cup Series</a> </span>
<a class="penci-image-holder penci-lazy" data-src="https://i2.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/04/NASCAR-Next-Gen-car-test-2020-Homestead.jpg?resize=585%2C390&#038;ssl=1" href="https://www.thecheckeredflag.co.uk/2020/04/nascar-next-gen-car-delayed-to-2022/" title="NASCAR Next Gen car delayed to 2022">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.thecheckeredflag.co.uk/2020/04/nascar-next-gen-car-delayed-to-2022/" title="NASCAR Next Gen car delayed to 2022">NASCAR Next Gen car delayed to 2022</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2020-04-02T22:19:53+01:00">April 2, 2020</time></p>
</div>
</div>
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.thecheckeredflag.co.uk/nascar/sprint-cup/">NASCAR Cup Series</a> </span>
<a class="penci-image-holder penci-lazy" data-src="https://i0.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/04/Joey-Gase-2020-Southern-500-Darlington-throwback.jpg?resize=585%2C390&#038;ssl=1" href="https://www.thecheckeredflag.co.uk/2020/04/joey-gase-reveals-bobby-allison-throwback-for-darlington/" title="Joey Gase reveals Bobby Allison throwback for Darlington">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.thecheckeredflag.co.uk/2020/04/joey-gase-reveals-bobby-allison-throwback-for-darlington/" title="Joey Gase reveals Bobby Allison throwback for Darlington">Joey Gase reveals Bobby Allison throwback for Darlington</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2020-04-01T21:31:45+01:00">April 1, 2020</time></p>
</div>
</div>
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.thecheckeredflag.co.uk/other/esports/">eSports</a> </span>
<a class="penci-image-holder penci-lazy" data-src="https://i1.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/04/eNASCAR-PIS-Blaney-Busch-wreck-Texas-2020.jpg?resize=585%2C390&#038;ssl=1" href="https://www.thecheckeredflag.co.uk/2020/04/enascar-pro-invitational-introduces-heats-for-bristol/" title="eNASCAR Pro Invitational introduces heats for Bristol">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.thecheckeredflag.co.uk/2020/04/enascar-pro-invitational-introduces-heats-for-bristol/" title="eNASCAR Pro Invitational introduces heats for Bristol">eNASCAR Pro Invitational introduces heats for Bristol</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2020-04-01T18:47:08+01:00">April 1, 2020</time></p>
</div>
</div>
</div>
<div class="penci-mega-row penci-mega-18305">
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.thecheckeredflag.co.uk/nascar/nascar-trucks/">NASCAR Gander Trucks</a> </span>
<a class="penci-image-holder penci-lazy" data-src="https://i1.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/04/Logan-Seavey-eNASCAR-Saturday-Night-Thunder-2020-Bristol.jpg?resize=585%2C390&#038;ssl=1" href="https://www.thecheckeredflag.co.uk/2020/04/logan-seavey-wins-saturday-night-thunder/" title="Logan Seavey wins Saturday Night Thunder">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.thecheckeredflag.co.uk/2020/04/logan-seavey-wins-saturday-night-thunder/" title="Logan Seavey wins Saturday Night Thunder">Logan Seavey wins Saturday Night Thunder</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2020-04-05T03:04:26+01:00">April 5, 2020</time></p>
</div>
</div>
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.thecheckeredflag.co.uk/nascar/nascar-trucks/">NASCAR Gander Trucks</a> </span>
<a class="penci-image-holder penci-lazy" data-src="https://i2.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/03/Brett-Moffitt-2019-NGOTS-ISM.jpg?resize=585%2C390&#038;ssl=1" href="https://www.thecheckeredflag.co.uk/2020/03/brett-moffitt-injured-in-motocross-accident/" title="Brett Moffitt injured in motocross accident">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.thecheckeredflag.co.uk/2020/03/brett-moffitt-injured-in-motocross-accident/" title="Brett Moffitt injured in motocross accident">Brett Moffitt injured in motocross accident</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2020-03-16T18:36:32+00:00">March 16, 2020</time></p>
</div>
</div>
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.thecheckeredflag.co.uk/nascar/nascar-trucks/">NASCAR Gander Trucks</a> </span>
<a class="penci-image-holder penci-lazy" data-src="https://i0.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/03/nhms_mencs_ragan_053017.jpg?resize=585%2C390&#038;ssl=1" href="https://www.thecheckeredflag.co.uk/2020/03/david-ragan-joins-dgr-crosley-for-truck-series-at-richmond/" title="David Ragan joins DGR-Crosley for Truck Series at Richmond">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.thecheckeredflag.co.uk/2020/03/david-ragan-joins-dgr-crosley-for-truck-series-at-richmond/" title="David Ragan joins DGR-Crosley for Truck Series at Richmond">David Ragan joins DGR-Crosley for Truck Series at&#8230;</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2020-03-11T18:25:25+00:00">March 11, 2020</time></p>
</div>
</div>
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.thecheckeredflag.co.uk/nascar/nascar-trucks/">NASCAR Gander Trucks</a> </span>
<a class="penci-image-holder penci-lazy" data-src="https://i0.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/02/lvms1_ngrots_buschcelebration_022120.jpg?resize=585%2C390&#038;ssl=1" href="https://www.thecheckeredflag.co.uk/2020/02/kyle-busch-bounty-hunt-picks-up-chase-elliott-kyle-larson/" title="Kyle Busch bounty hunt picks up Chase Elliott, Kyle Larson">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.thecheckeredflag.co.uk/2020/02/kyle-busch-bounty-hunt-picks-up-chase-elliott-kyle-larson/" title="Kyle Busch bounty hunt picks up Chase Elliott, Kyle Larson">Kyle Busch bounty hunt picks up Chase Elliott,&#8230;</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2020-02-28T01:47:13+00:00">February 28, 2020</time></p>
</div>
</div>
</div>
<div class="penci-mega-row penci-mega-8304">
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.thecheckeredflag.co.uk/nascar/euro-racecar/">NASCAR Whelen Euro Series</a> </span>
<a class="penci-image-holder penci-lazy" data-src="https://i0.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/04/Whelen-Euro-Series-iRacing-Watkins-Glen.jpg?resize=585%2C390&#038;ssl=1" href="https://www.thecheckeredflag.co.uk/2020/04/euronascar-esports-series-formed-with-real-life-points-in-play/" title="EuroNASCAR Esports Series formed with real-life points in play">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.thecheckeredflag.co.uk/2020/04/euronascar-esports-series-formed-with-real-life-points-in-play/" title="EuroNASCAR Esports Series formed with real-life points in play">EuroNASCAR Esports Series formed with real-life points in&#8230;</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2020-04-06T21:51:29+01:00">April 6, 2020</time></p>
</div>
</div>
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.thecheckeredflag.co.uk/nascar/euro-racecar/">NASCAR Whelen Euro Series</a> </span>
<a class="penci-image-holder penci-lazy" data-src="https://i1.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/04/Logan-Seavey-eNASCAR-Saturday-Night-Thunder-2020-Bristol.jpg?resize=585%2C390&#038;ssl=1" href="https://www.thecheckeredflag.co.uk/2020/04/logan-seavey-wins-saturday-night-thunder/" title="Logan Seavey wins Saturday Night Thunder">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.thecheckeredflag.co.uk/2020/04/logan-seavey-wins-saturday-night-thunder/" title="Logan Seavey wins Saturday Night Thunder">Logan Seavey wins Saturday Night Thunder</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2020-04-05T03:04:26+01:00">April 5, 2020</time></p>
</div>
</div>
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.thecheckeredflag.co.uk/nascar/euro-racecar/">NASCAR Whelen Euro Series</a> </span>
<a class="penci-image-holder penci-lazy" data-src="https://i0.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/03/2019-NWES-GP-Belgium-Zolder-start.jpeg?resize=585%2C390&#038;ssl=1" href="https://www.thecheckeredflag.co.uk/2020/03/2020-euro-series-sees-largest-full-time-grid-ever-at-33-cars/" title="2020 Euro Series sees largest full-time grid ever at 33 cars">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.thecheckeredflag.co.uk/2020/03/2020-euro-series-sees-largest-full-time-grid-ever-at-33-cars/" title="2020 Euro Series sees largest full-time grid ever at 33 cars">2020 Euro Series sees largest full-time grid ever&#8230;</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2020-03-31T19:51:27+01:00">March 31, 2020</time></p>
</div>
</div>
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.thecheckeredflag.co.uk/nascar/euro-racecar/">NASCAR Whelen Euro Series</a> </span>
<a class="penci-image-holder penci-lazy" data-src="https://i0.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/03/BritishGT-TrackingSafetyCar-009.jpg?resize=585%2C390&#038;ssl=1" href="https://www.thecheckeredflag.co.uk/2020/03/motorsport-uk-prolonging-covid-suspension-to-end-of-june/" title="Motorsport UK prolonging COVID suspension to end of June">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.thecheckeredflag.co.uk/2020/03/motorsport-uk-prolonging-covid-suspension-to-end-of-june/" title="Motorsport UK prolonging COVID suspension to end of June">Motorsport UK prolonging COVID suspension to end of&#8230;</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2020-03-24T17:55:29+00:00">March 24, 2020</time></p>
</div>
</div>
</div>
<div class="penci-mega-row penci-mega-2742">
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.thecheckeredflag.co.uk/nascar/nascar-xfinity-series/">NASCAR Xfinity Series</a> </span>
<a class="penci-image-holder penci-lazy" data-src="https://i1.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/04/Logan-Seavey-eNASCAR-Saturday-Night-Thunder-2020-Bristol.jpg?resize=585%2C390&#038;ssl=1" href="https://www.thecheckeredflag.co.uk/2020/04/logan-seavey-wins-saturday-night-thunder/" title="Logan Seavey wins Saturday Night Thunder">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.thecheckeredflag.co.uk/2020/04/logan-seavey-wins-saturday-night-thunder/" title="Logan Seavey wins Saturday Night Thunder">Logan Seavey wins Saturday Night Thunder</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2020-04-05T03:04:26+01:00">April 5, 2020</time></p>
</div>
</div>
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.thecheckeredflag.co.uk/nascar/nascar-xfinity-series/">NASCAR Xfinity Series</a> </span>
<a class="penci-image-holder penci-lazy" data-src="https://i0.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/03/Tony-Stewart-NASCAR-Hall-of-Fame-2020.jpg?resize=585%2C390&#038;ssl=1" href="https://www.thecheckeredflag.co.uk/2020/03/tony-stewart-making-nascar-return-at-indy-road-course/" title="Tony Stewart making NASCAR return at Indy road course">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.thecheckeredflag.co.uk/2020/03/tony-stewart-making-nascar-return-at-indy-road-course/" title="Tony Stewart making NASCAR return at Indy road course">Tony Stewart making NASCAR return at Indy road&#8230;</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2020-03-05T00:55:41+00:00">March 5, 2020</time></p>
</div>
</div>
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.thecheckeredflag.co.uk/nascar/nascar-xfinity-series/">NASCAR Xfinity Series</a> </span>
<a class="penci-image-holder penci-lazy" data-src="https://i1.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/02/Kody_Vanderwal_Matt_Levin_2017_Carneros_200.jpg?resize=585%2C390&#038;ssl=1" href="https://www.thecheckeredflag.co.uk/2020/02/means-racing-to-field-jj-yeley-kody-vanderwal/" title="Means Racing to field JJ Yeley, Kody Vanderwal">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.thecheckeredflag.co.uk/2020/02/means-racing-to-field-jj-yeley-kody-vanderwal/" title="Means Racing to field JJ Yeley, Kody Vanderwal">Means Racing to field JJ Yeley, Kody Vanderwal</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2020-02-14T01:25:14+00:00">February 14, 2020</time></p>
</div>
</div>
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.thecheckeredflag.co.uk/nascar/nascar-xfinity-series/">NASCAR Xfinity Series</a> </span>
<a class="penci-image-holder penci-lazy" data-src="https://i1.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/02/mcleod_2019nxs_carshot.jpg?resize=585%2C390&#038;ssl=1" href="https://www.thecheckeredflag.co.uk/2020/02/jd-motorsports-finalise-2020-lineup/" title="JD Motorsports finalise 2020 lineup">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.thecheckeredflag.co.uk/2020/02/jd-motorsports-finalise-2020-lineup/" title="JD Motorsports finalise 2020 lineup">JD Motorsports finalise 2020 lineup</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2020-02-10T20:59:36+00:00">February 10, 2020</time></p>
</div>
</div>
</div>
<div class="penci-mega-row penci-mega-108 row-active">
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.thecheckeredflag.co.uk/nascar/">NASCAR</a> </span>
<a class="penci-image-holder penci-lazy" data-src="https://i0.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/04/Whelen-Euro-Series-iRacing-Watkins-Glen.jpg?resize=585%2C390&#038;ssl=1" href="https://www.thecheckeredflag.co.uk/2020/04/euronascar-esports-series-formed-with-real-life-points-in-play/" title="EuroNASCAR Esports Series formed with real-life points in play">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.thecheckeredflag.co.uk/2020/04/euronascar-esports-series-formed-with-real-life-points-in-play/" title="EuroNASCAR Esports Series formed with real-life points in play">EuroNASCAR Esports Series formed with real-life points in&#8230;</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2020-04-06T21:51:29+01:00">April 6, 2020</time></p>
</div>
</div>
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.thecheckeredflag.co.uk/nascar/">NASCAR</a> </span>
<a class="penci-image-holder penci-lazy" data-src="https://i1.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/04/William-Byron-eNASCAR-Pro-Invitational-2020-Bristol.jpg?resize=585%2C390&#038;ssl=1" href="https://www.thecheckeredflag.co.uk/2020/04/william-byron-wins-wreck-filled-food-city-showdown/" title="William Byron wins wreck-filled Food City Showdown">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.thecheckeredflag.co.uk/2020/04/william-byron-wins-wreck-filled-food-city-showdown/" title="William Byron wins wreck-filled Food City Showdown">William Byron wins wreck-filled Food City Showdown</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2020-04-05T20:27:01+01:00">April 5, 2020</time></p>
</div>
</div>
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.thecheckeredflag.co.uk/nascar/">NASCAR</a> </span>
<a class="penci-image-holder penci-lazy" data-src="https://i1.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/04/Logan-Seavey-eNASCAR-Saturday-Night-Thunder-2020-Bristol.jpg?resize=585%2C390&#038;ssl=1" href="https://www.thecheckeredflag.co.uk/2020/04/logan-seavey-wins-saturday-night-thunder/" title="Logan Seavey wins Saturday Night Thunder">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.thecheckeredflag.co.uk/2020/04/logan-seavey-wins-saturday-night-thunder/" title="Logan Seavey wins Saturday Night Thunder">Logan Seavey wins Saturday Night Thunder</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2020-04-05T03:04:26+01:00">April 5, 2020</time></p>
</div>
</div>
<div class="penci-mega-post">
<div class="penci-mega-thumbnail">
<span class="mega-cat-name">
<a href="https://www.thecheckeredflag.co.uk/nascar/">NASCAR</a> </span>
<a class="penci-image-holder penci-lazy" data-src="https://i2.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/04/NASCAR-Next-Gen-car-test-2020-Homestead.jpg?resize=585%2C390&#038;ssl=1" href="https://www.thecheckeredflag.co.uk/2020/04/nascar-next-gen-car-delayed-to-2022/" title="NASCAR Next Gen car delayed to 2022">
</a>
</div>
<div class="penci-mega-meta">
<h3 class="post-mega-title">
<a href="https://www.thecheckeredflag.co.uk/2020/04/nascar-next-gen-car-delayed-to-2022/" title="NASCAR Next Gen car delayed to 2022">NASCAR Next Gen car delayed to 2022</a>
</h3>
<p class="penci-mega-date"><time class="entry-date published" datetime="2020-04-02T22:19:53+01:00">April 2, 2020</time></p>
</div>
</div>
</div>
</div>
</div>
</div></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-293110"><a href="https://www.thecheckeredflag.co.uk/features/">Features</a>
<ul class="sub-menu">
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-330921"><a href="https://www.thecheckeredflag.co.uk/tcf-blogs/">TCF Blogs</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-293115"><a href="https://www.thecheckeredflag.co.uk/features/opinion/">Opinion</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-293113"><a href="https://www.thecheckeredflag.co.uk/features/interviews/">Interviews</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-293114"><a href="https://www.thecheckeredflag.co.uk/features/gallery/">Gallery</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-293111"><a href="https://www.thecheckeredflag.co.uk/features/product-review/">Product Review</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-293112"><a href="https://www.thecheckeredflag.co.uk/features/season-review/">Season Review</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-293118"><a href="https://www.thecheckeredflag.co.uk/other/esports/">eSports</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-293117"><a href="https://www.thecheckeredflag.co.uk/other/video-games/">Sim Racing</a></li>
</ul>
</li>
</ul>
<div id="top-search" class="dfdf">
<a class="search-click"><i class="penci-faicon fa fa-search"></i></a>
<div class="show-search">
<form role="search" method="get" id="searchform" action="https://www.thecheckeredflag.co.uk/">
<div>
<input type="text" class="search-input" placeholder="Type and hit enter..." name="s" id="s" />
</div>
</form> <a class="search-click close-search"><i class="penci-faicon fa fa-close"></i></a>
</div>
</div> </div>
</nav>
</header>
</div>
<div class="container container-single container-single-magazine penci_sidebar  penci-enable-lightbox">
<div id="main">
<div class="theiaStickySidebar">
<article id="post-335837" class="post type-post status-publish hentry">
<div class="header-standard header-classic single-header">
<div class="penci-standard-cat"><span class="cat"><a class="penci-cat-name" href="https://www.thecheckeredflag.co.uk/formula-1/" rel="category tag">Formula 1</a><a class="penci-cat-name" href="https://www.thecheckeredflag.co.uk/sportscars/" rel="category tag">Sportscars</a></span></div>
<h1 class="post-title single-post-title entry-title">Tributes Pour In from the Motorsport World for Sir Stirling Moss</h1>
<div class="penci-hide-tagupdated">
<span class="author-italic author vcard">by <a class="url fn n" href="https://www.thecheckeredflag.co.uk/author/phensby/">Paul Hensby</a></span>
<time class="entry-date published" datetime="2020-04-12T15:25:46+01:00">April 12, 2020</time>
</div>
<div class="post-box-meta-single">
<span class="author-post byline"><span class="author vcard">written by <a class="author-url url fn n" href="https://www.thecheckeredflag.co.uk/author/phensby/">Paul Hensby</a></span></span>
<span><time class="entry-date published" datetime="2020-04-12T15:25:46+01:00">April 12, 2020</time></span>
</div>
</div>
<div class="post-image">
<a href="https://www.thecheckeredflag.co.uk/wp-content/uploads/2020/04/Sir-Stirling-Moss-03.jpg" data-rel="penci-gallery-image-content"> <img width="800" height="533" src="https://i2.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/04/Sir-Stirling-Moss-03.jpg?fit=800%2C533&amp;ssl=1" class="attachment-penci-full-thumb size-penci-full-thumb wp-post-image" alt="" srcset="https://i2.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/04/Sir-Stirling-Moss-03.jpg?w=800&amp;ssl=1 800w, https://i2.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/04/Sir-Stirling-Moss-03.jpg?resize=240%2C160&amp;ssl=1 240w, https://i2.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/04/Sir-Stirling-Moss-03.jpg?resize=768%2C512&amp;ssl=1 768w, https://i2.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/04/Sir-Stirling-Moss-03.jpg?resize=585%2C390&amp;ssl=1 585w, https://i2.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/04/Sir-Stirling-Moss-03.jpg?resize=263%2C175&amp;ssl=1 263w" sizes="(max-width: 800px) 100vw, 800px" /> </a><div class="penci-featured-caption">Credit: Octane Photographic Ltd</div> </div>
<div class="post-entry blockquote-style-1">
<div class="inner-post-entry entry-content" id="penci-post-entry-inner">
<p>Tributes have poured in for <strong>Sir Stirling Moss</strong>, who has passed away at the age of ninety, with the motorsport world coming together to remember a legend that was a superstar in anything he drove.</p>
<p>Moss, who finished second in the World Championship in four consecutive seasons between 1955 and 1958 before adding a trio of third places between 1959 and 1961 before a heavy crash at <strong>Goodwood </strong>on Easter Monday in 1962 ended his <strong>Formula 1 </strong>career.</p>
<p>He was also competitive at the <strong>24 Hours of Le Mans</strong>, twice finishing as runner-up, while he twice was a victor in the <strong>12 Hours of Sebring</strong> and once at the <strong>12 Hours of Reims</strong>.  He also took a super victory in the 1955 <strong>Mille Miglia</strong> in a record time, a time that remains etched in history after the race was discontinued just two years later.</p>
<p>Many tributes have been paid to the Briton on social media, including from reigning Formula 1 World Champion <strong>Lewis Hamilton</strong>.</p>
<p><strong>Lewis Hamilton</strong></p>
<figure class="wp-block-embed-twitter wp-block-embed is-type-rich is-provider-twitter"><div class="wp-block-embed__wrapper">
<blockquote class="twitter-tweet" data-width="550" data-dnt="true"><p lang="en" dir="ltr">Today we say goodbye to Sir Stirling Moss, the racing legend. I certainly will miss our conversations. I am truly grateful to have had these special moments with him. Sending my prayers and thoughts to his family. May he rest in peace🙏🏾 <a href="https://t.co/SDUAqxENHk">pic.twitter.com/SDUAqxENHk</a></p>&mdash; Lewis Hamilton (@LewisHamilton) <a href="https://twitter.com/LewisHamilton/status/1249326917569961985?ref_src=twsrc%5Etfw">April 12, 2020</a></blockquote>
</div></figure>
<p><strong>Martin Brundle</strong></p>
<figure class="wp-block-embed-twitter wp-block-embed is-type-rich is-provider-twitter"><div class="wp-block-embed__wrapper">
<blockquote class="twitter-tweet" data-width="550" data-dnt="true"><p lang="en" dir="ltr">RIP Sir Stirling Moss. A mighty racer and gentleman. He had a press on style on the track and in life. Remarkable man. Survived the most dangerous era of motorsport and died today aged 90. He had such great stories to tell, and it was a privilege to know him. 😢</p>&mdash; Martin Brundle (@MBrundleF1) <a href="https://twitter.com/MBrundleF1/status/1249278344274870272?ref_src=twsrc%5Etfw">April 12, 2020</a></blockquote>
</div></figure>
<p><strong>British Racing Drivers&#8217; Club</strong></p>
<figure class="wp-block-embed-twitter wp-block-embed is-type-rich is-provider-twitter"><div class="wp-block-embed__wrapper">
<blockquote class="twitter-tweet" data-width="550" data-dnt="true"><p lang="en" dir="ltr">We are deeply saddened to hear about the passing of BRDC Member, motorsport legend &amp; friend to many Sir Stirling Moss OBE. Our thoughts are with Lady Moss &amp; their family at this difficult time. A proud BRDC Member from the day he received his badge &amp; we will all miss him dearly. <a href="https://t.co/1qca9mvuRD">pic.twitter.com/1qca9mvuRD</a></p>&mdash; BRDC (@BRDCSilverstone) <a href="https://twitter.com/BRDCSilverstone/status/1249278132449837056?ref_src=twsrc%5Etfw">April 12, 2020</a></blockquote>
</div></figure>
<p><strong>George Russell</strong></p>
<figure class="wp-block-embed-twitter wp-block-embed is-type-rich is-provider-twitter"><div class="wp-block-embed__wrapper">
<blockquote class="twitter-tweet" data-width="550" data-dnt="true"><p lang="en" dir="ltr">RIP Sir Stirling Moss.<br><br>Only had the pleasure of meeting him briefly a couple of times but even that was enough to understand why he was so highly respected.<br><br>My thoughts are with his family.</p>&mdash; George Russell (@GeorgeRussell63) <a href="https://twitter.com/GeorgeRussell63/status/1249282877168238592?ref_src=twsrc%5Etfw">April 12, 2020</a></blockquote>
</div></figure>
<p><strong>Zak Brown</strong></p>
<figure class="wp-block-embed-twitter wp-block-embed is-type-rich is-provider-twitter"><div class="wp-block-embed__wrapper">
<blockquote class="twitter-tweet" data-width="550" data-dnt="true"><p lang="en" dir="ltr">Saddened to read of the passing of Sir Stirling Moss. A Formula 1 great, versatile racer and incredible ambassador for British and international motorsport. My respects and sympathies to his loved ones.</p>&mdash; Zak Brown (@ZBrownCEO) <a href="https://twitter.com/ZBrownCEO/status/1249282707512844290?ref_src=twsrc%5Etfw">April 12, 2020</a></blockquote>
</div></figure>
<p><strong>Aston Martin Racing</strong></p>
<figure class="wp-block-embed-twitter wp-block-embed is-type-rich is-provider-twitter"><div class="wp-block-embed__wrapper">
<blockquote class="twitter-tweet" data-width="550" data-dnt="true"><p lang="en" dir="ltr">Aston Martin is sad to record the passing of one of Britain’s greatest racing drivers, Sir Stirling Moss.<br><br>A legendary sportsman and gentleman, our thoughts go to Lady Moss, his family and his many fans worldwide. <a href="https://t.co/HnypW4E7Wc">pic.twitter.com/HnypW4E7Wc</a></p>&mdash; Aston Martin Racing (@AMR_Official) <a href="https://twitter.com/AMR_Official/status/1249286606013554688?ref_src=twsrc%5Etfw">April 12, 2020</a></blockquote>
</div></figure>
<p><strong>Aston Martin Red Bull Racing</strong></p>
<figure class="wp-block-embed-twitter wp-block-embed is-type-rich is-provider-twitter"><div class="wp-block-embed__wrapper">
<blockquote class="twitter-tweet" data-width="550" data-dnt="true"><p lang="en" dir="ltr">A pure racer and an inspiration to the entire motorsport community. Rest in peace Sir Stirling Moss. Your legacy will live on. ❤️ <a href="https://t.co/GAhMV9cjiW">pic.twitter.com/GAhMV9cjiW</a></p>&mdash; Aston Martin Red Bull Racing (@redbullracing) <a href="https://twitter.com/redbullracing/status/1249308992125440002?ref_src=twsrc%5Etfw">April 12, 2020</a></blockquote>
</div></figure>
<p><strong>FIA Formula E</strong></p>
<figure class="wp-block-embed-twitter wp-block-embed is-type-rich is-provider-twitter"><div class="wp-block-embed__wrapper">
<blockquote class="twitter-tweet" data-width="550" data-dnt="true"><p lang="en" dir="ltr">Today we send our kindest thoughts and condolences to the loved ones of Sir Stirling Moss, a gentleman whose talent and resolve inspired millions across generations. Rest in peace.</p>&mdash; ABB Formula E (@FIAFormulaE) <a href="https://twitter.com/FIAFormulaE/status/1249295553575505920?ref_src=twsrc%5Etfw">April 12, 2020</a></blockquote>
</div></figure>
<p><strong>Alfa Romeo Racing ORLEN</strong></p>
<figure class="wp-block-embed-twitter wp-block-embed is-type-rich is-provider-twitter"><div class="wp-block-embed__wrapper">
<blockquote class="twitter-tweet" data-width="550" data-dnt="true"><p lang="en" dir="ltr">RIP, Sir Stirling Moss. ❤️<br><br>A true sporting legend. <br><br>Our condolences to his family and loved ones. <a href="https://t.co/SsU2mTUpde">pic.twitter.com/SsU2mTUpde</a></p>&mdash; Alfa Romeo Racing ORLEN (@alfaromeoracing) <a href="https://twitter.com/alfaromeoracing/status/1249288126301954048?ref_src=twsrc%5Etfw">April 12, 2020</a></blockquote>
</div></figure>
<p><strong>ROKiT Williams Racing</strong></p>
<figure class="wp-block-embed-twitter wp-block-embed is-type-rich is-provider-twitter"><div class="wp-block-embed__wrapper">
<blockquote class="twitter-tweet" data-width="550" data-dnt="true"><p lang="en" dir="ltr">A true icon of our sport.<br><br>Our thoughts and condolences go out to his family &amp; friends.<br><br>Rest in peace, Sir Stirling Moss ❤️ <a href="https://t.co/kaqA2zXbAW">pic.twitter.com/kaqA2zXbAW</a></p>&mdash; ROKiT WILLIAMS RACING (@WilliamsRacing) <a href="https://twitter.com/WilliamsRacing/status/1249291349951762434?ref_src=twsrc%5Etfw">April 12, 2020</a></blockquote>
</div></figure>
<p><strong>Billy Monger</strong></p>
<figure class="wp-block-embed-twitter wp-block-embed is-type-rich is-provider-twitter"><div class="wp-block-embed__wrapper">
<blockquote class="twitter-tweet" data-width="550" data-dnt="true"><p lang="en" dir="ltr">A legend of motorsport. RIP Sir Stirling Moss 🙏🏼💙 <a href="https://t.co/JkhlEmhs9p">pic.twitter.com/JkhlEmhs9p</a></p>&mdash; billywhizz (@BillyMonger) <a href="https://twitter.com/BillyMonger/status/1249286357400371200?ref_src=twsrc%5Etfw">April 12, 2020</a></blockquote>
</div><figcaption><br /></figcaption></figure>
<p><strong>McLaren F1 Team</strong></p>
<figure class="wp-block-embed-twitter wp-block-embed is-type-rich is-provider-twitter"><div class="wp-block-embed__wrapper">
<blockquote class="twitter-tweet" data-width="550" data-dnt="true"><p lang="en" dir="ltr">All at McLaren mourn the passing of a legend of our sport, Sir Stirling Moss. A prodigious competitor, supremely talented racer, and consummate gentleman, he leaves an indelible mark of greatness on the history of international motorsport. Our condolences to his family. <a href="https://t.co/c3vdzTuFgN">pic.twitter.com/c3vdzTuFgN</a></p>&mdash; McLaren (@McLarenF1) <a href="https://twitter.com/McLarenF1/status/1249281871554531328?ref_src=twsrc%5Etfw">April 12, 2020</a></blockquote>
</div></figure>
<p><strong>Scuderia AlphaTauri</strong></p>
<figure class="wp-block-embed-twitter wp-block-embed is-type-rich is-provider-twitter"><div class="wp-block-embed__wrapper">
<blockquote class="twitter-tweet" data-width="550" data-dnt="true"><p lang="en" dir="ltr">Today the motorsport world lost one of its legends. <br><br>RIP Sir Stirling Moss. Our deepest condolences go out to his family and loved ones. <a href="https://t.co/g10nOMsJpC">pic.twitter.com/g10nOMsJpC</a></p>&mdash; Scuderia AlphaTauri (@AlphaTauriF1) <a href="https://twitter.com/AlphaTauriF1/status/1249306034440552448?ref_src=twsrc%5Etfw">April 12, 2020</a></blockquote>
</div></figure>
<p><strong>Haas F1 Team</strong></p>
<figure class="wp-block-embed-twitter wp-block-embed is-type-rich is-provider-twitter"><div class="wp-block-embed__wrapper">
<blockquote class="twitter-tweet" data-width="550" data-dnt="true"><p lang="en" dir="ltr">Today we have lost a true legend of motorsport. A formidable racer and a real gentleman. <br><br>Rest in Peace Sir Stirling Moss.<br><br>Our thoughts are with his family. <a href="https://t.co/WUuNvergkF">pic.twitter.com/WUuNvergkF</a></p>&mdash; Haas F1 Team (@HaasF1Team) <a href="https://twitter.com/HaasF1Team/status/1249289031797653504?ref_src=twsrc%5Etfw">April 12, 2020</a></blockquote>
</div></figure>
<p><strong>Silverstone</strong></p>
<figure class="wp-block-embed-twitter wp-block-embed is-type-rich is-provider-twitter"><div class="wp-block-embed__wrapper">
<blockquote class="twitter-tweet" data-width="550" data-dnt="true"><p lang="en" dir="ltr">It is with great sadness that we have to report the death of one of Great Britain’s finest racing drivers, Sir Stirling Moss OBE, who passed away in the early hours of this morning at the age of 90. <a href="https://t.co/ZpzyGiPAXw">https://t.co/ZpzyGiPAXw</a> <a href="https://t.co/HGRbZ3lnPV">pic.twitter.com/HGRbZ3lnPV</a></p>&mdash; Silverstone (@SilverstoneUK) <a href="https://twitter.com/SilverstoneUK/status/1249290408896745472?ref_src=twsrc%5Etfw">April 12, 2020</a></blockquote>
</div></figure>
<p><strong>Paul di Resta</strong></p>
<figure class="wp-block-embed-twitter wp-block-embed is-type-rich is-provider-twitter"><div class="wp-block-embed__wrapper">
<blockquote class="twitter-tweet" data-width="550" data-dnt="true"><p lang="en" dir="ltr">RIP Sir Stirling Moss, what a legend. Has to be one of the kindest men I have ever met. A true ambassador of our sport, I was lucky enough to be working at some great events with the man over the years. I will always be a big fan. <a href="https://twitter.com/hashtag/legend?src=hash&amp;ref_src=twsrc%5Etfw">#legend</a></p>&mdash; Paul Di Resta (@PaulDiResta) <a href="https://twitter.com/PaulDiResta/status/1249283324981510145?ref_src=twsrc%5Etfw">April 12, 2020</a></blockquote>
</div></figure>
<div class="penci-single-link-pages">
</div>
<div class="post-tags">
<a href="https://www.thecheckeredflag.co.uk/tag/sir-stirling-moss/" rel="tag">Sir Stirling Moss</a> </div>
</div>
</div>
<div class="penci-google-adsense-2">

<ins class="adsbygoogle" style="display:inline-block;width:728px;height:90px" data-ad-client="ca-pub-9159179884377372" data-ad-slot="6495511074"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script> </div>
<div class="tags-share-box center-box tags-share-box-s1">
<span class="single-comment-o"><i class="penci-faicon fa fa-comment-o"></i><span class="dsq-postid" data-dsqidentifier="335837 https://www.thecheckeredflag.co.uk/?p=335837">0 comment</span></span>
<div class="post-share">
<span class="post-share-item post-share-plike">
<span class="count-number-like">0</span><a class="penci-post-like single-like-button" data-post_id="335837" title="Like" data-like="Like" data-unlike="Unlike"><i class="penci-faicon fa fa-heart-o"></i></a> </span>
<div class="list-posts-share"><a class="post-share-item post-share-facebook" target="_blank" rel="nofollow" href="https://www.facebook.com/sharer/sharer.php?u=https://www.thecheckeredflag.co.uk/2020/04/tributes-pour-in-from-the-motorsport-world-for-sir-stirling-moss/"><i class="penci-faicon fa fa-facebook"></i><span class="dt-share">Facebook</span></a><a class="post-share-item post-share-twitter" target="_blank" rel="nofollow" href="https://twitter.com/intent/tweet?text=Check%20out%20this%20article:%20Tributes%20Pour%20In%20from%20the%20Motorsport%20World%20for%20Sir%20Stirling%20Moss%20-%20https://www.thecheckeredflag.co.uk/2020/04/tributes-pour-in-from-the-motorsport-world-for-sir-stirling-moss/"><i class="penci-faicon fa fa-twitter"></i><span class="dt-share">Twitter</span></a><a class="post-share-item post-share-pinterest" data-pin-do="none" rel="nofollow noreferrer noopener" onclick="var e=document.createElement('script');e.setAttribute('type','text/javascript');e.setAttribute('charset','UTF-8');e.setAttribute('src','//assets.pinterest.com/js/pinmarklet.js?r='+Math.random()*99999999);document.body.appendChild(e);"><i class="penci-faicon fa fa-pinterest"></i><span class="dt-share">Pinterest</span></a><a class="post-share-item post-share-linkedin" target="_blank" rel="nofollow" href="https://www.linkedin.com/shareArticle?mini=true&#038;url=https%3A%2F%2Fwww.thecheckeredflag.co.uk%2F2020%2F04%2Ftributes-pour-in-from-the-motorsport-world-for-sir-stirling-moss%2F&#038;title=Tributes%20Pour%20In%20from%20the%20Motorsport%20World%20for%20Sir%20Stirling%20Moss"><i class="penci-faicon fa fa-linkedin"></i><span class="dt-share">Linkedin</span></a><a class="post-share-item post-share-reddit" target="_blank" rel="nofollow" href="https://reddit.com/submit?url=https%3A%2F%2Fwww.thecheckeredflag.co.uk%2F2020%2F04%2Ftributes-pour-in-from-the-motorsport-world-for-sir-stirling-moss%2F&#038;title=Tributes%20Pour%20In%20from%20the%20Motorsport%20World%20for%20Sir%20Stirling%20Moss"><i class="penci-faicon fa fa-reddit-alien"></i><span class="dt-share">Reddit</span></a><a class="post-share-item post-share-whatsapp" target="_blank" rel="nofollow" href="https://api.whatsapp.com/send?text=Tributes%20Pour%20In%20from%20the%20Motorsport%20World%20for%20Sir%20Stirling%20Moss %0A%0A https%3A%2F%2Fwww.thecheckeredflag.co.uk%2F2020%2F04%2Ftributes-pour-in-from-the-motorsport-world-for-sir-stirling-moss%2F"><i class="penci-faicon fa fa-whatsapp"></i><span class="dt-share">Whatsapp</span></a><a class="post-share-item post-share-email" target="_blank" rel="nofollow" href="/cdn-cgi/l/email-protection#76490503141c1315024b22041f1403021305534446261903045344463f185344461004191b534446021e135344463b1902190405061904025344462119041a12534446101904534446251f0453444625021f041a1f18115344463b190505505546454e4d3439322f4b1e020206054c595901010158021e13151e13151d13041312101a171158151958031d59444644465946425902041f14030213055b061903045b1f185b1004191b5b021e135b1b1902190405061904025b0119041a125b1019045b051f045b05021f041a1f18115b1b19050559"><i class="penci-faicon fa fa-envelope"></i><span class="dt-share">Email</span></a></div> </div>
</div>
<div class="post-author">
<div class="author-img">
<img alt='' src='https://secure.gravatar.com/avatar/69769702984b39119ce03515eadc47ce?s=100&#038;d=https%3A%2F%2Fwww.thecheckeredflag.co.uk%2Fwp-content%2Fuploads%2F2018%2F11%2FTCF-black.jpg&#038;r=g' srcset='https://secure.gravatar.com/avatar/69769702984b39119ce03515eadc47ce?s=200&#038;d=https%3A%2F%2Fwww.thecheckeredflag.co.uk%2Fwp-content%2Fuploads%2F2018%2F11%2FTCF-black.jpg&#038;r=g 2x' class='avatar avatar-100 photo' height='100' width='100' /> </div>
<div class="author-content">
<h5><a href="https://www.thecheckeredflag.co.uk/author/phensby/" title="Posts by Paul Hensby" rel="author">Paul Hensby</a></h5>
<p>Thirty-something motorsport fanatic, covering Formula 1, Formula Renault 2.0 and Formula 3. Feel free to give him a follow on Twitter at @Paul11MSport.</p>
<a rel="nofollow" target="_blank" class="author-social" href="https://facebook.com/https://www.facebook.com/paul.hensby"><i class="penci-faicon fa fa-facebook"></i></a>
<a rel="nofollow" target="_blank" class="author-social" href="https://twitter.com/Paul11MSport"><i class="penci-faicon fa fa-twitter"></i></a>
<a rel="nofollow" class="author-social" href="/cdn-cgi/l/email-protection#6c1c0d1900420409021f0e152c1804090f04090f07091e09080a000d0b420f03421907"><i class="penci-faicon fa fa-envelope"></i></a>
</div>
</div>
<div class="post-related">
<div class="post-title-box"><h4 class="post-box-title">Related articles</h4></div>
<div class="penci-owl-carousel penci-owl-carousel-slider penci-related-carousel" data-lazy="true" data-item="3" data-desktop="3" data-tablet="2" data-tabsmall="2" data-auto="false" data-speed="300" data-dots="true" data-nav="false">
<div class="item-related">
<a class="related-thumb penci-image-holder" style="background-image: url('https://i2.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/04/Sir-Stirling-Moss-01.jpg?resize=585%2C390&#038;ssl=1');" href="https://www.thecheckeredflag.co.uk/2020/04/motor-sport-legend-sir-stirling-moss-passes-away-aged-90/" title="Motor Sport Legend Sir Stirling Moss Passes Away aged 90">
</a>
<h3><a href="https://www.thecheckeredflag.co.uk/2020/04/motor-sport-legend-sir-stirling-moss-passes-away-aged-90/">Motor Sport Legend Sir Stirling Moss Passes Away aged 90</a></h3>
<span class="date"><time class="entry-date published" datetime="2020-04-12T14:46:59+01:00">April 12, 2020</time></span>
</div>
<div class="item-related">
<a class="related-thumb penci-image-holder" style="background-image: url('https://i1.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2018/01/Stirling-Moss-01.jpg?resize=585%2C390&#038;ssl=1');" href="https://www.thecheckeredflag.co.uk/2018/01/sir-stirling-moss-retires-public-life-aged-eighty-eight/" title="Sir Stirling Moss Retires from Public Life, Aged Eighty-Eight!">
</a>
<h3><a href="https://www.thecheckeredflag.co.uk/2018/01/sir-stirling-moss-retires-public-life-aged-eighty-eight/">Sir Stirling Moss Retires from Public Life, Aged Eighty-Eight!</a></h3>
<span class="date"><time class="entry-date published" datetime="2018-01-20T07:30:28+00:00">January 20, 2018</time></span>
</div>
<div class="item-related">
<a class="related-thumb penci-image-holder" style="background-image: url('https://i0.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2017/11/TCF-Piquet-to-be-honoured-at-Autosport-Awards-2017.jpg?resize=585%2C390&#038;ssl=1');" href="https://www.thecheckeredflag.co.uk/2017/11/nelson-piquet-to-receive-honour-at-autosport-awards-2017/" title="Nelson Piquet to receive honour at Autosport Awards 2017">
</a>
<h3><a href="https://www.thecheckeredflag.co.uk/2017/11/nelson-piquet-to-receive-honour-at-autosport-awards-2017/">Nelson Piquet to receive honour at Autosport Awards 2017</a></h3>
<span class="date"><time class="entry-date published" datetime="2017-11-30T13:15:46+00:00">November 30, 2017</time></span>
</div>
<div class="item-related">
<a class="related-thumb penci-image-holder" style="background-image: url('https://i1.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2016/10/Sterlings-Restuarant.jpg?resize=585%2C390&#038;ssl=1');" href="https://www.thecheckeredflag.co.uk/2016/10/sir-stirling-moss-honoured-stirlings-restaurant/" title="Sir Stirling Moss honoured with &#8216;Stirling&#8217;s&#8217; restaurant">
</a>
<h3><a href="https://www.thecheckeredflag.co.uk/2016/10/sir-stirling-moss-honoured-stirlings-restaurant/">Sir Stirling Moss honoured with &#8216;Stirling&#8217;s&#8217; restaurant</a></h3>
<span class="date"><time class="entry-date published" datetime="2016-10-22T16:22:04+01:00">October 22, 2016</time></span>
</div>
<div class="item-related">
<a class="related-thumb penci-image-holder" style="background-image: url('https://i0.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2016/05/A-Salute-to-Women-in-Motor-Sport-2016.jpg?resize=585%2C390&#038;ssl=1');" href="https://www.thecheckeredflag.co.uk/2016/05/royal-automobile-club-celebrates-women-motor-sport/" title="Royal Automobile Club celebrates women in motor sport">
</a>
<h3><a href="https://www.thecheckeredflag.co.uk/2016/05/royal-automobile-club-celebrates-women-motor-sport/">Royal Automobile Club celebrates women in motor sport</a></h3>
<span class="date"><time class="entry-date published" datetime="2016-05-23T19:49:45+01:00">May 23, 2016</time></span>
</div>
<div class="item-related">
<a class="related-thumb penci-image-holder" style="background-image: url('https://i1.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2016/04/TCF-legends-e1460534791111.jpg?resize=585%2C390&#038;ssl=1');" href="https://www.thecheckeredflag.co.uk/2016/04/motor-sport-hall-fame-awards-2016-open-public/" title="Motor Sport Hall of Fame Awards 2016 open to public">
</a>
<h3><a href="https://www.thecheckeredflag.co.uk/2016/04/motor-sport-hall-fame-awards-2016-open-public/">Motor Sport Hall of Fame Awards 2016 open to public</a></h3>
<span class="date"><time class="entry-date published" datetime="2016-04-13T09:26:26+01:00">April 13, 2016</time></span>
</div>
<div class="item-related">
<a class="related-thumb penci-image-holder" style="background-image: url('https://i0.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2015/04/F1BAH2015_JK1683257.jpg?resize=585%2C390&#038;ssl=1');" href="https://www.thecheckeredflag.co.uk/2015/04/lewis-hamilton-sir-stirling-moss-and-two-classic-silver-arrows-at-monza-pure-magic/" title="Lewis Hamilton, Sir Stirling Moss and two Classic Silver Arrows at Monza! Pure Magic!">
</a>
<h3><a href="https://www.thecheckeredflag.co.uk/2015/04/lewis-hamilton-sir-stirling-moss-and-two-classic-silver-arrows-at-monza-pure-magic/">Lewis Hamilton, Sir Stirling Moss and two Classic Silver Arrows at Monza!...</a></h3>
<span class="date"><time class="entry-date published" datetime="2015-04-25T07:55:36+01:00">April 25, 2015</time></span>
</div>
<div class="item-related">
<a class="related-thumb penci-image-holder" style="background-image: url('https://i2.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2015/03/NMM_Chequered-History_Opening-24.jpg?resize=585%2C390&#038;ssl=1');" href="https://www.thecheckeredflag.co.uk/2015/03/beaulieu-motor-museum-unveil-new-motorsport-gallery/" title="Beaulieu Motor Museum Unveil New Motorsport Gallery">
</a>
<h3><a href="https://www.thecheckeredflag.co.uk/2015/03/beaulieu-motor-museum-unveil-new-motorsport-gallery/">Beaulieu Motor Museum Unveil New Motorsport Gallery</a></h3>
<span class="date"><time class="entry-date published" datetime="2015-03-08T13:11:42+00:00">March 8, 2015</time></span>
</div>
<div class="item-related">
<a class="related-thumb penci-image-holder" style="background-image: url('https://i0.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2014/06/LHGoodwood.jpg?resize=585%2C390&#038;ssl=1');" href="https://www.thecheckeredflag.co.uk/2014/06/mercedes-benz-celebrated-festival-speed/" title="Mercedes-Benz To Be Celebrated At Festival of Speed">
</a>
<h3><a href="https://www.thecheckeredflag.co.uk/2014/06/mercedes-benz-celebrated-festival-speed/">Mercedes-Benz To Be Celebrated At Festival of Speed</a></h3>
<span class="date"><time class="entry-date published" datetime="2014-06-17T17:07:29+01:00">June 17, 2014</time></span>
</div>
</div></div>
<div id="disqus_thread"></div>
<div class="post-pagination">
<div class="prev-post">
<div class="prev-post-inner">
<div class="prev-post-title">
<span>previous post</span>
</div>
<a href="https://www.thecheckeredflag.co.uk/2020/04/motor-sport-legend-sir-stirling-moss-passes-away-aged-90/">
<div class="pagi-text">
<h5 class="prev-title">Motor Sport Legend Sir Stirling Moss Passes Away aged 90</h5>
</div>
</a>
</div>
</div>
<div class="next-post">
<div class="next-post-inner">
<div class="prev-post-title next-post-title">
<span>next post</span>
</div>
<a href="https://www.thecheckeredflag.co.uk/2020/04/covid-19-forces-euroformula-open-to-reschedule-spa-barcelona-rounds/">
<div class="pagi-text">
<h5 class="next-title">COVID-19 Forces EuroFormula Open to Reschedule Spa &#038; Barcelona Rounds</h5>
</div>
</a>
</div>
</div>
</div>
</article> </div>
</div>
<div id="sidebar" class="penci-sidebar-right penci-sidebar-content style-1 pcalign-center">
<div class="theiaStickySidebar">
<aside id="media_image-2" class="widget widget_media_image"><a href="https://www.thecheckeredflag.co.uk/tcf-blogs/jaguar-racing-blog/"><img width="1080" height="1080" src="https://i2.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/01/CALADO-BLOG.jpg?fit=1080%2C1080&amp;ssl=1" class="image wp-image-330391  attachment-full size-full" alt="" style="max-width: 100%; height: auto;" srcset="https://i2.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/01/CALADO-BLOG.jpg?w=1080&amp;ssl=1 1080w, https://i2.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/01/CALADO-BLOG.jpg?resize=160%2C160&amp;ssl=1 160w, https://i2.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/01/CALADO-BLOG.jpg?resize=533%2C533&amp;ssl=1 533w, https://i2.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/01/CALADO-BLOG.jpg?resize=240%2C240&amp;ssl=1 240w, https://i2.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/01/CALADO-BLOG.jpg?resize=768%2C768&amp;ssl=1 768w, https://i2.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/01/CALADO-BLOG.jpg?resize=585%2C585&amp;ssl=1 585w, https://i2.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/01/CALADO-BLOG.jpg?resize=912%2C912&amp;ssl=1 912w, https://i2.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/01/CALADO-BLOG.jpg?resize=550%2C550&amp;ssl=1 550w, https://i2.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/01/CALADO-BLOG.jpg?resize=470%2C470&amp;ssl=1 470w" sizes="(max-width: 1080px) 100vw, 1080px" /></a></aside><aside id="custom_html-11" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget">

<ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-9159179884377372" data-ad-slot="4409003789" data-ad-format="auto" data-full-width-responsive="true"></ins>
<script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script></div></aside><aside id="penci_slider_posts_news_widget-2" class="widget penci_slider_posts_news_widget"><h4 class="widget-title penci-border-arrow"><span class="inner-arrow">Latest articles</span></h4> <div id="penci-postslidewg-6628" class="penci-owl-carousel penci-owl-carousel-slider penci-widget-slider penci-post-slider-style-1" data-lazy="true">
<div class="penci-slide-widget">
<div class="penci-slide-content">
<span class="penci-image-holder" style="background-image: url('https://i0.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/04/Christian-Hahn-01.jpg?resize=585%2C390&#038;ssl=1');" title="COVID-19 Forces EuroFormula Open to Reschedule Spa &#038; Barcelona Rounds"></span>
<a href="https://www.thecheckeredflag.co.uk/2020/04/covid-19-forces-euroformula-open-to-reschedule-spa-barcelona-rounds/" class="penci-widget-slider-overlay" title="COVID-19 Forces EuroFormula Open to Reschedule Spa &#038; Barcelona Rounds"></a>
<div class="penci-widget-slide-detail">
<h4>
<a href="https://www.thecheckeredflag.co.uk/2020/04/covid-19-forces-euroformula-open-to-reschedule-spa-barcelona-rounds/" rel="bookmark" title="COVID-19 Forces EuroFormula Open to Reschedule Spa &#038; Barcelona Rounds">COVID-19 Forces EuroFormula Open to Reschedule Spa &#038;...</a>
</h4>
<span class="slide-item-date">Apr 12, 2020</span>
</div>
</div>
</div>
<div class="penci-slide-widget">
<div class="penci-slide-content">
<span class="penci-image-holder" style="background-image: url('https://i2.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/04/Sir-Stirling-Moss-03.jpg?resize=585%2C390&#038;ssl=1');" title="Tributes Pour In from the Motorsport World for Sir Stirling Moss"></span>
<a href="https://www.thecheckeredflag.co.uk/2020/04/tributes-pour-in-from-the-motorsport-world-for-sir-stirling-moss/" class="penci-widget-slider-overlay" title="Tributes Pour In from the Motorsport World for Sir Stirling Moss"></a>
<div class="penci-widget-slide-detail">
<h4>
<a href="https://www.thecheckeredflag.co.uk/2020/04/tributes-pour-in-from-the-motorsport-world-for-sir-stirling-moss/" rel="bookmark" title="Tributes Pour In from the Motorsport World for Sir Stirling Moss">Tributes Pour In from the Motorsport World for...</a>
</h4>
<span class="slide-item-date">Apr 12, 2020</span>
</div>
</div>
</div>
<div class="penci-slide-widget">
<div class="penci-slide-content">
<span class="penci-image-holder" style="background-image: url('https://i2.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/04/Sir-Stirling-Moss-01.jpg?resize=585%2C390&#038;ssl=1');" title="Motor Sport Legend Sir Stirling Moss Passes Away aged 90"></span>
<a href="https://www.thecheckeredflag.co.uk/2020/04/motor-sport-legend-sir-stirling-moss-passes-away-aged-90/" class="penci-widget-slider-overlay" title="Motor Sport Legend Sir Stirling Moss Passes Away aged 90"></a>
<div class="penci-widget-slide-detail">
<h4>
<a href="https://www.thecheckeredflag.co.uk/2020/04/motor-sport-legend-sir-stirling-moss-passes-away-aged-90/" rel="bookmark" title="Motor Sport Legend Sir Stirling Moss Passes Away aged 90">Motor Sport Legend Sir Stirling Moss Passes Away...</a>
</h4>
<span class="slide-item-date">Apr 12, 2020</span>
</div>
</div>
</div>
<div class="penci-slide-widget">
<div class="penci-slide-content">
<span class="penci-image-holder" style="background-image: url('https://i2.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/04/TCF-IndyCar-iRacing-Pagenaud-Michigan.jpg?resize=585%2C390&#038;ssl=1');" title="Pagenaud takes fuel mileage Michigan win in IndyCar iRacing Challenge"></span>
<a href="https://www.thecheckeredflag.co.uk/2020/04/pagenaud-takes-fuel-mileage-michigan-win-in-indycar-iracing-challenge/" class="penci-widget-slider-overlay" title="Pagenaud takes fuel mileage Michigan win in IndyCar iRacing Challenge"></a>
<div class="penci-widget-slide-detail">
<h4>
<a href="https://www.thecheckeredflag.co.uk/2020/04/pagenaud-takes-fuel-mileage-michigan-win-in-indycar-iracing-challenge/" rel="bookmark" title="Pagenaud takes fuel mileage Michigan win in IndyCar iRacing Challenge">Pagenaud takes fuel mileage Michigan win in IndyCar...</a>
</h4>
<span class="slide-item-date">Apr 11, 2020</span>
</div>
</div>
</div>
<div class="penci-slide-widget">
<div class="penci-slide-content">
<span class="penci-image-holder" style="background-image: url('https://i2.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/04/ABB.jpg?resize=585%2C390&#038;ssl=1');" title="Formula E teams unanimously agree to cost-cutting measures"></span>
<a href="https://www.thecheckeredflag.co.uk/2020/04/formula-e-teams-unanimously-agree-to-cost-cutting-measures/" class="penci-widget-slider-overlay" title="Formula E teams unanimously agree to cost-cutting measures"></a>
<div class="penci-widget-slide-detail">
<h4>
<a href="https://www.thecheckeredflag.co.uk/2020/04/formula-e-teams-unanimously-agree-to-cost-cutting-measures/" rel="bookmark" title="Formula E teams unanimously agree to cost-cutting measures">Formula E teams unanimously agree to cost-cutting measures</a>
</h4>
<span class="slide-item-date">Apr 10, 2020</span>
</div>
</div>
</div>
</div>
</aside><aside id="penci_popular_news_widget-5" class="widget penci_popular_news_widget"><h4 class="widget-title penci-border-arrow"><span class="inner-arrow">Popular on TCF</span></h4> <ul id="penci-popularwg-4207" class="side-newsfeed">
<li class="penci-feed featured-news">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder" rel="bookmark" style="background-image: url('https://i2.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/04/ABB.jpg?resize=585%2C390&#038;ssl=1');" href="https://www.thecheckeredflag.co.uk/2020/04/formula-e-teams-unanimously-agree-to-cost-cutting-measures/" title="Formula E teams unanimously agree to cost-cutting measures"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.thecheckeredflag.co.uk/2020/04/formula-e-teams-unanimously-agree-to-cost-cutting-measures/" rel="bookmark" title="Formula E teams unanimously agree to cost-cutting measures">
Formula E teams unanimously agree to cost-cutting measures </a>
</h4>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder small-fix-size" rel="bookmark" style="background-image: url('https://i2.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/04/TCF-IndyCar-iRacing-Pagenaud-Michigan.jpg?resize=263%2C175&#038;ssl=1');" href="https://www.thecheckeredflag.co.uk/2020/04/pagenaud-takes-fuel-mileage-michigan-win-in-indycar-iracing-challenge/" title="Pagenaud takes fuel mileage Michigan win in IndyCar iRacing Challenge"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.thecheckeredflag.co.uk/2020/04/pagenaud-takes-fuel-mileage-michigan-win-in-indycar-iracing-challenge/" rel="bookmark" title="Pagenaud takes fuel mileage Michigan win in IndyCar iRacing Challenge">
Pagenaud takes fuel mileage Michigan win in IndyCar iRacing Challenge </a>
</h4>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder small-fix-size" rel="bookmark" style="background-image: url('https://i1.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/04/AP-23D65UMJW1W11_news-1.jpg?resize=263%2C175&#038;ssl=1');" href="https://www.thecheckeredflag.co.uk/2020/04/wrc-testing-suspended-during-covid-19-pandemic/" title="WRC Testing Suspended During COVID-19 Pandemic"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.thecheckeredflag.co.uk/2020/04/wrc-testing-suspended-during-covid-19-pandemic/" rel="bookmark" title="WRC Testing Suspended During COVID-19 Pandemic">
WRC Testing Suspended During COVID-19 Pandemic </a>
</h4>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder small-fix-size" rel="bookmark" style="background-image: url('https://i2.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/04/Sir-Stirling-Moss-01.jpg?resize=263%2C175&#038;ssl=1');" href="https://www.thecheckeredflag.co.uk/2020/04/motor-sport-legend-sir-stirling-moss-passes-away-aged-90/" title="Motor Sport Legend Sir Stirling Moss Passes Away aged 90"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.thecheckeredflag.co.uk/2020/04/motor-sport-legend-sir-stirling-moss-passes-away-aged-90/" rel="bookmark" title="Motor Sport Legend Sir Stirling Moss Passes Away aged 90">
Motor Sport Legend Sir Stirling Moss Passes Away aged 90 </a>
</h4>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder small-fix-size" rel="bookmark" style="background-image: url('https://i2.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/04/Sir-Stirling-Moss-03.jpg?resize=263%2C175&#038;ssl=1');" href="https://www.thecheckeredflag.co.uk/2020/04/tributes-pour-in-from-the-motorsport-world-for-sir-stirling-moss/" title="Tributes Pour In from the Motorsport World for Sir Stirling Moss"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.thecheckeredflag.co.uk/2020/04/tributes-pour-in-from-the-motorsport-world-for-sir-stirling-moss/" rel="bookmark" title="Tributes Pour In from the Motorsport World for Sir Stirling Moss">
Tributes Pour In from the Motorsport World for Sir Stirling Moss </a>
</h4>
</div>
</div>
</li>
</ul>
</aside><aside id="nav_menu-4" class="widget widget_nav_menu"><div class="menu-top-container"><ul id="menu-top" class="menu"><li id="menu-item-131978" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-131978"><a href="https://www.thecheckeredflag.co.uk/latest-news/">News</a></li>
<li id="menu-item-131965" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131965"><a href="https://www.thecheckeredflag.co.uk/features/">Features</a></li>
<li id="menu-item-173707" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-173707"><a href="https://www.thecheckeredflag.co.uk/features/gallery/">Photos</a></li>
<li id="menu-item-131884" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-131884"><a href="https://www.thecheckeredflag.co.uk/tcf-blogs/">TCF Blogs</a></li>
<li id="menu-item-131986" class="menu-item menu-item-type-taxonomy menu-item-object-post_format menu-item-131986"><a href="https://www.thecheckeredflag.co.uk/type/video/">Videos</a></li>
<li id="menu-item-131967" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-131967"><a href="https://www.thecheckeredflag.co.uk/contribute/">Contribute</a></li>
<li id="menu-item-131966" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-131966"><a href="https://www.thecheckeredflag.co.uk/contact/">Contact Us</a></li>
</ul></div></aside><aside id="text-12" class="widget widget_text"> <div class="textwidget"><p><a href="https://www.facebook.com/groups/porschemotorsportcommunity/" target="_blank" rel="noopener noreferrer"><img class="aligncenter size-full wp-image-310781" src="https://i2.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2019/06/PMC-Square-1.jpg?resize=400%2C400&#038;ssl=1" alt="Porsche Motorsport Community" width="400" height="400" data-recalc-dims="1" /></a></p>
</div>
</aside><aside id="custom_html-8" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget">
<ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-9159179884377372" data-ad-slot="2468886887" data-ad-format="auto"></ins>
<script>
window.setTimeout(function(){ 
  (adsbygoogle = window.adsbygoogle || []).push({}); 
}, 200); 
</script></div></aside><aside id="penci_social_widget-2" class="widget penci_social_widget"><h4 class="widget-title penci-border-arrow"><span class="inner-arrow">Keep in touch</span></h4>
<div class="widget-social pc_aligncenter">
<a href="https://facebook.com/TheCheckeredFlag" rel="nofollow" target="_blank"><i class="penci-faicon fa fa-facebook" style="font-size: 18px"></i><span style="font-size: 13px">Facebook</span></a>
<a href="https://twitter.com/TheCheckerFlag" rel="nofollow" target="_blank"><i class="penci-faicon fa fa-twitter" style="font-size: 18px"></i><span style="font-size: 13px">Twitter</span></a>
<a href="https://instagram.com/thecheckeredflag/" rel="nofollow" target="_blank"><i class="penci-faicon fa fa-instagram" style="font-size: 18px"></i><span style="font-size: 13px">Instagram</span></a>
<a href="https://www.linkedin.com/company/thecheckeredflag/" rel="nofollow" target="_blank"><i class="penci-faicon fa fa-linkedin" style="font-size: 18px"></i><span style="font-size: 13px">Linkedin</span></a>
<a href="https://www.youtube.com/channel/UCueRVoGbSE4GF2RszehXIgw" rel="nofollow" target="_blank"><i class="penci-faicon fa fa-youtube-play" style="font-size: 18px"></i><span style="font-size: 13px">Youtube</span></a>
<a href="https://www.thecheckeredflag.co.uk/feed" rel="nofollow" target="_blank"><i class="penci-faicon fa fa-rss" style="font-size: 18px"></i><span style="font-size: 13px">RSS</span></a>
</div>
</aside><aside id="penci_latest_news_widget-2" class="widget penci_latest_news_widget"><h4 class="widget-title penci-border-arrow"><span class="inner-arrow">Recent Features</span></h4> <ul id="penci-latestwg-6301" class="side-newsfeed penci-feed-2columns penci-2columns-feed">
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder small-fix-size" rel="bookmark" style="background-image: url('https://i2.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/03/Andrew-Coley.jpg?resize=263%2C175&#038;ssl=1');" href="https://www.thecheckeredflag.co.uk/2020/03/interview-world-rx-commentator-andrew-coley-id-love-it-to-be-as-incredible-as-last-year/" title="INTERVIEW: World RX Commentator Andrew Coley &#8211; &#8220;I&#8217;d love it to be as incredible as last year&#8221;"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.thecheckeredflag.co.uk/2020/03/interview-world-rx-commentator-andrew-coley-id-love-it-to-be-as-incredible-as-last-year/" rel="bookmark" title="INTERVIEW: World RX Commentator Andrew Coley &#8211; &#8220;I&#8217;d love it to be as incredible as last year&#8221;">
INTERVIEW: World RX Commentator Andrew Coley &#8211; &#8220;I&#8217;d love it to be as incredible as last year&#8221; </a>
</h4>
<span class="side-item-meta"><time class="entry-date published" datetime="2020-03-23T15:08:47+00:00">March 23, 2020</time></span>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder small-fix-size" rel="bookmark" style="background-image: url('https://i0.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/03/2020-Aus-GP.jpg?resize=263%2C175&#038;ssl=1');" href="https://www.thecheckeredflag.co.uk/2020/03/opinion-why-f1-cannot-be-allowed-to-forget-its-melbourne-humiliation/" title="Opinion: Why F1 cannot be allowed to forget its Melbourne humiliation"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.thecheckeredflag.co.uk/2020/03/opinion-why-f1-cannot-be-allowed-to-forget-its-melbourne-humiliation/" rel="bookmark" title="Opinion: Why F1 cannot be allowed to forget its Melbourne humiliation">
Opinion: Why F1 cannot be allowed to forget its Melbourne humiliation </a>
</h4>
<span class="side-item-meta"><time class="entry-date published" datetime="2020-03-22T10:49:18+00:00">March 22, 2020</time></span>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder small-fix-size" rel="bookmark" style="background-image: url('https://i2.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/03/Webp.net-resizeimage-59.jpg?resize=263%2C175&#038;ssl=1');" href="https://www.thecheckeredflag.co.uk/2020/03/andrew-coley-esports-is-a-gateway-to-real-world-motorsport/" title="Andrew Coley: &#8220;esports is a gateway to real-world motorsport&#8221;"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.thecheckeredflag.co.uk/2020/03/andrew-coley-esports-is-a-gateway-to-real-world-motorsport/" rel="bookmark" title="Andrew Coley: &#8220;esports is a gateway to real-world motorsport&#8221;">
Andrew Coley: &#8220;esports is a gateway to real-world motorsport&#8221; </a>
</h4>
<span class="side-item-meta"><time class="entry-date published" datetime="2020-03-18T11:21:08+00:00">March 18, 2020</time></span>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder small-fix-size" rel="bookmark" style="background-image: url('https://i1.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/03/Mitch-Evans-2.jpg?resize=263%2C175&#038;ssl=1');" href="https://www.thecheckeredflag.co.uk/2020/03/jaguar-racing-blog-mitch-evans-talks-balloon-rides-and-winning/" title="Jaguar Racing Blog: Mitch Evans talks balloon rides and winning"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.thecheckeredflag.co.uk/2020/03/jaguar-racing-blog-mitch-evans-talks-balloon-rides-and-winning/" rel="bookmark" title="Jaguar Racing Blog: Mitch Evans talks balloon rides and winning">
Jaguar Racing Blog: Mitch Evans talks balloon rides and winning </a>
</h4>
<span class="side-item-meta"><time class="entry-date published" datetime="2020-03-11T21:24:51+00:00">March 11, 2020</time></span>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder small-fix-size" rel="bookmark" style="background-image: url('https://i0.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/02/James-Calado-Jaguar-Formula-E-6-scaled.jpg?resize=263%2C175&#038;ssl=1');" href="https://www.thecheckeredflag.co.uk/2020/02/james-calado-blog-viva-mexico/" title="James Calado Blog: ¡Viva México!"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.thecheckeredflag.co.uk/2020/02/james-calado-blog-viva-mexico/" rel="bookmark" title="James Calado Blog: ¡Viva México!">
James Calado Blog: ¡Viva México! </a>
</h4>
<span class="side-item-meta"><time class="entry-date published" datetime="2020-02-26T12:58:24+00:00">February 26, 2020</time></span>
</div>
</div>
</li>
<li class="penci-feed">
<div class="side-item">
<div class="side-image">
<a class="penci-image-holder small-fix-size" rel="bookmark" style="background-image: url('https://i0.wp.com/www.thecheckeredflag.co.uk/wp-content/uploads/2020/02/Cook-podium.jpg?resize=263%2C175&#038;ssl=1');" href="https://www.thecheckeredflag.co.uk/2020/02/prepared-cook-confident-of-strong-season-with-btc-racing/" title="Prepared Cook confident of strong season with BTC Racing"></a>
</div>
<div class="side-item-text">
<h4 class="side-title-post">
<a href="https://www.thecheckeredflag.co.uk/2020/02/prepared-cook-confident-of-strong-season-with-btc-racing/" rel="bookmark" title="Prepared Cook confident of strong season with BTC Racing">
Prepared Cook confident of strong season with BTC Racing </a>
</h4>
<span class="side-item-meta"><time class="entry-date published" datetime="2020-02-21T00:18:29+00:00">February 21, 2020</time></span>
</div>
</div>
</li>
</ul>
</aside> </div>
</div>
</div>
<div class="clear-footer"></div>
<div class="footer-subscribe">
<aside id="mc4wp_form_widget-2" class="widget widget_mc4wp_form_widget"><script>(function() {
	window.mc4wp = window.mc4wp || {
		listeners: [],
		forms: {
			on: function(evt, cb) {
				window.mc4wp.listeners.push(
					{
						event   : evt,
						callback: cb
					}
				);
			}
		}
	}
})();
</script><form id="mc4wp-form-1" class="mc4wp-form mc4wp-form-293151" method="post" data-id="293151" data-name="TCF Daily Headlines to your Inbox"><div class="mc4wp-form-fields"><p class="mdes">Get the latest headlines from TCF in a daily roundup, straight to your inbox</p>
<p class="memail"><input type="email" id="mc4wp_email" name="EMAIL" placeholder="Email..." required /></p>
<p class="msubmit"><input type="submit" value="Subscribe" /></p></div><label style="display: none !important;">Leave this field empty if you're human: <input type="text" name="_mc4wp_honeypot" value="" tabindex="-1" autocomplete="off" /></label><input type="hidden" name="_mc4wp_timestamp" value="1586705282" /><input type="hidden" name="_mc4wp_form_id" value="293151" /><input type="hidden" name="_mc4wp_form_element_id" value="mc4wp-form-1" /><div class="mc4wp-response"></div></form></aside> </div>
<footer id="footer-section" class="penci-footer-social-media penci-lazy" itemscope itemtype="https://schema.org/WPFooter">
<div class="container">
<div class="footer-socials-section">
<ul class="footer-socials">
<li><a href="https://facebook.com/TheCheckeredFlag" rel="nofollow" target="_blank"><i class="penci-faicon fa fa-facebook"></i><span>Facebook</span></a></li>
<li><a href="https://twitter.com/TheCheckerFlag" rel="nofollow" target="_blank"><i class="penci-faicon fa fa-twitter"></i><span>Twitter</span></a></li>
<li><a href="https://instagram.com/thecheckeredflag/" rel="nofollow" target="_blank"><i class="penci-faicon fa fa-instagram"></i><span>Instagram</span></a></li>
<li><a href="https://www.linkedin.com/company/thecheckeredflag/" rel="nofollow" target="_blank"><i class="penci-faicon fa fa-linkedin"></i><span>Linkedin</span></a></li>
<li><a href="https://www.youtube.com/channel/UCueRVoGbSE4GF2RszehXIgw" rel="nofollow" target="_blank"><i class="penci-faicon fa fa-youtube-play"></i><span>Youtube</span></a></li>
<li><a href="https://www.thecheckeredflag.co.uk/feed" rel="nofollow" target="_blank"><i class="penci-faicon fa fa-rss"></i><span>RSS</span></a></li>
</ul>
</div>
<div class="footer-logo-copyright footer-not-logo">
<div id="footer-copyright">
<p><a href="https://www.thecheckeredflag.co.uk/contact/">Contact Us</a> | <a href="https://www.thecheckeredflag.co.uk/contribute/">Contribute</a> | <a href="https://www.thecheckeredflag.co.uk/about-us">About Us</a><br />
<a href="https://www.thecheckeredflag.co.uk/tcf-partners/">TCF Friends & Partners</a> | <a href="https://www.thecheckeredflag.co.uk/submitting-news/">Submitting News</a> | <a href="https://www.thecheckeredflag.co.uk/terms-and-conditions/">T & C</a> | <a href="https://www.thecheckeredflag.co.uk/privacy-policy/">Privacy Policy</a> | <a href="https://www.thecheckeredflag.co.uk/cookies-in-use-on-this-site/">Cookie Policy</a><br />
©Copyright MMXIX - The Checkered Flag - All Rights Reserved</p>
</div>
<div class="go-to-top-parent"><a href="#" class="go-to-top"><span><i class="penci-faicon fa fa-angle-up"></i> <br>Back To Top</span></a></div>
</div>
</div>
</footer>
</div>
<div id="fb-root"></div>
<div class="penci-wrap-gprd-law penci-wrap-gprd-law-close penci-close-all">
<div class="penci-gprd-law">
<p>
This website uses cookies to improve your experience. We&#039;ll assume you&#039;re ok with this, but you can opt-out if you wish. <a class="penci-gprd-accept" href="#">Accept</a> <a class="penci-gprd-more" href="#">Read More</a> </p>
</div>
</div>
<script>(function() {function maybePrefixUrlField() {
	if (this.value.trim() !== '' && this.value.indexOf('http') !== 0) {
		this.value = "http://" + this.value;
	}
}

var urlFields = document.querySelectorAll('.mc4wp-form input[type="url"]');
if (urlFields) {
	for (var j=0; j < urlFields.length; j++) {
		urlFields[j].addEventListener('blur', maybePrefixUrlField);
	}
}
})();</script>

<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-MG875N"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>

<script type='text/javascript'>
/* <![CDATA[ */
var countVars = {"disqusShortname":"thecheckerdflag"};
/* ]]> */
</script>
<script type='text/javascript'>
/* <![CDATA[ */
var embedVars = {"disqusConfig":{"integration":"wordpress 3.0.17"},"disqusIdentifier":"335837 https:\/\/www.thecheckeredflag.co.uk\/?p=335837","disqusShortname":"thecheckerdflag","disqusTitle":"Tributes Pour In from the Motorsport World for Sir Stirling Moss","disqusUrl":"https:\/\/www.thecheckeredflag.co.uk\/2020\/04\/tributes-pour-in-from-the-motorsport-world-for-sir-stirling-moss\/","postId":"335837"};
/* ]]> */
</script>
<script type='text/javascript'>
/* <![CDATA[ */
var ajax_var_more = {"url":"https:\/\/www.thecheckeredflag.co.uk\/wp-admin\/admin-ajax.php","nonce":"bc6f421622","errorPass":"<p class=\"message message-error\">Password does not match the confirm password<\/p>","login":"Email Address","password":"Password"};
/* ]]> */
</script>
<script type='text/javascript'>
/* <![CDATA[ */
var ajax_var = {"url":"https:\/\/www.thecheckeredflag.co.uk\/wp-admin\/admin-ajax.php","nonce":"bc6f421622","errorPass":"<p class=\"message message-error\">Password does not match the confirm password<\/p>","login":"Email Address","password":"Password"};
/* ]]> */
</script>
<script type='text/javascript'>
/* <![CDATA[ */
var SOLEDADLOCALIZE = {"url":"https:\/\/www.thecheckeredflag.co.uk\/wp-admin\/admin-ajax.php","nonce":"bc6f421622","errorPass":"<p class=\"message message-error\">Password does not match the confirm password<\/p>","login":"Email Address","password":"Password"};
/* ]]> */
</script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:8.3',blog:'9437658',post:'335837',tz:'1',srv:'www.thecheckeredflag.co.uk'} ]);
	_stq.push([ 'clickTrackerInit', '9437658', '335837' ]);
</script>
<script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script><script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><script type='text/javascript' src='https://c0.wp.com/p/jetpack/8.3/_inc/build/photon/photon.min.js'></script><script type='text/javascript' src='https://c0.wp.com/c/5.4/wp-includes/js/wp-embed.min.js'></script><script type='text/javascript' src='https://stats.wp.com/e-202015.js' async='async' defer='defer'></script><script data-optimized='1' src='https://www.thecheckeredflag.co.uk/min/60cfa.js'></script></body>
</html>
