<!DOCTYPE html>
<html lang="en-GB">
<head>
<meta name="viewport" content="width=device-width, initial-scale=1.0" />
<meta charset="UTF-8" /><link data-optimized="2" rel="stylesheet" href="https://www.thecheckeredflag.co.uk/wp-content/litespeed/cssjs/1f223.css?1e814" />
<link rel="profile" href="https://gmpg.org/xfn/11" />
<link rel="pingback" href="https://www.thecheckeredflag.co.uk/xmlrpc.php" />

<script data-cfasync="false" data-pagespeed-no-defer>//<![CDATA[
	var gtm4wp_datalayer_name = "dataLayer";
	var dataLayer = dataLayer || [];
//]]>
</script>


<title>Ben Rhodes wins bargain-bin Daytona endurance race with BrakeBest Select 159 victory - The Checkered Flag</title>
<meta name="description" content="Entering Friday night&#039;s NASCAR Truck Series race on the Daytona road course, much excitement was built over racing at night in the rain. That hype faded as long cautions and three overtimes took their toll, and by the end, Ben Rhodes won for the second week in a row." />
<meta name="robots" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
<link rel="canonical" href="https://www.thecheckeredflag.co.uk/2021/02/ben-rhodes-wins-bargain-bin-daytona-endurance-race-with-brakebest-select-159-victory/" />
<meta property="og:locale" content="en_GB" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Ben Rhodes wins bargain-bin Daytona endurance race with BrakeBest Select 159 victory - The Checkered Flag" />
<meta property="og:description" content="Entering Friday night&#039;s NASCAR Truck Series race on the Daytona road course, much excitement was built over racing at night in the rain. That hype faded as long cautions and three overtimes took their toll, and by the end, Ben Rhodes won for the second week in a row." />
<meta property="og:url" content="https://www.thecheckeredflag.co.uk/2021/02/ben-rhodes-wins-bargain-bin-daytona-endurance-race-with-brakebest-select-159-victory/" />
<meta property="og:site_name" content="The Checkered Flag" />
<meta property="article:publisher" content="http://www.facebook.com/TheCheckeredFlag" />
<meta property="article:published_time" content="2021-02-20T03:57:28+00:00" />
<meta property="article:modified_time" content="2021-02-20T04:32:30+00:00" />
<meta property="og:image" content="https://www.thecheckeredflag.co.uk/wp-content/uploads/2021/02/Ben-Rhodes-John-Hunter-Nemechek-2021-BrakeBest-Select-159-Daytona-RC-CWTS.jpg" />
<meta property="og:image:width" content="800" />
<meta property="og:image:height" content="533" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:creator" content="@ZappaOMatic" />
<meta name="twitter:site" content="@thecheckerflag" />
<meta name="twitter:label1" content="Written by">
<meta name="twitter:data1" content="Justin Nguyen">
<meta name="twitter:label2" content="Estimated reading time">
<meta name="twitter:data2" content="10 minutes">
<script type="application/ld+json" class="yoast-schema-graph">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</script>

<link rel='dns-prefetch' href='//s.w.org' />
<link href='https://fonts.gstatic.com' crossorigin rel='preconnect' />
<link rel="alternate" type="application/rss+xml" title="The Checkered Flag &raquo; Feed" href="https://www.thecheckeredflag.co.uk/feed/" />
<link rel="alternate" type="application/rss+xml" title="The Checkered Flag &raquo; Comments Feed" href="https://www.thecheckeredflag.co.uk/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="The Checkered Flag &raquo; Ben Rhodes wins bargain-bin Daytona endurance race with BrakeBest Select 159 victory Comments Feed" href="https://www.thecheckeredflag.co.uk/2021/02/ben-rhodes-wins-bargain-bin-daytona-endurance-race-with-brakebest-select-159-victory/feed/" />
<style id="" media="all">@font-face {
  font-family: 'Noto Serif';
  font-style: italic;
  font-weight: 400;
  src: url(/fonts.gstatic.com/s/notoserif/v9/ga6Kaw1J5X9T9RW6j9bNfFImajC-.ttf) format('truetype');
}
@font-face {
  font-family: 'Noto Serif';
  font-style: italic;
  font-weight: 700;
  src: url(/fonts.gstatic.com/s/notoserif/v9/ga6Vaw1J5X9T9RW6j9bNfFIu0RWuc-VJ.ttf) format('truetype');
}
@font-face {
  font-family: 'Noto Serif';
  font-style: normal;
  font-weight: 400;
  src: url(/fonts.gstatic.com/s/notoserif/v9/ga6Iaw1J5X9T9RW6j9bNfFcWbQ.ttf) format('truetype');
}
@font-face {
  font-family: 'Noto Serif';
  font-style: normal;
  font-weight: 700;
  src: url(/fonts.gstatic.com/s/notoserif/v9/ga6Law1J5X9T9RW6j9bNdOwzfReedA.ttf) format('truetype');
}
</style>
<script src="https://www.thecheckeredflag.co.uk/wp-includes/js/jquery/jquery.min.js" id="jquery-core-js"></script>
<script src="https://www.thecheckeredflag.co.uk/wp-includes/js/jquery/jquery-migrate.min.js" id="jquery-migrate-js"></script>
<script src="https://www.thecheckeredflag.co.uk/wp-content/plugins/duracelltomi-google-tag-manager/js/gtm4wp-youtube.js" id="gtm4wp-youtube-js"></script>
<script src="https://www.thecheckeredflag.co.uk/wp-content/uploads/js-cache-inhype.js" id="js-cache-inhype-js"></script>
<script type='text/javascript' id='wp-disable-css-lazy-load-js-extra'>
/* <![CDATA[ */
var WpDisableAsyncLinks = {"wp-disable-font-awesome":"https:\/\/www.thecheckeredflag.co.uk\/wp-content\/themes\/inhype\/css\/font-awesome.css"};
/* ]]> */
</script>
<script src="https://www.thecheckeredflag.co.uk/wp-content/plugins/wp-disable/js/css-lazy-load.min.js" id="wp-disable-css-lazy-load-js"></script>
<link rel="alternate" type="application/json+oembed" href="https://www.thecheckeredflag.co.uk/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.thecheckeredflag.co.uk%2F2021%2F02%2Fben-rhodes-wins-bargain-bin-daytona-endurance-race-with-brakebest-select-159-victory%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.thecheckeredflag.co.uk/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.thecheckeredflag.co.uk%2F2021%2F02%2Fben-rhodes-wins-bargain-bin-daytona-endurance-race-with-brakebest-select-159-victory%2F&#038;format=xml" />

<script data-cfasync="false" data-pagespeed-no-defer>//<![CDATA[
	var dataLayer_content = {"pageTitle":"Ben Rhodes wins bargain-bin Daytona endurance race with BrakeBest Select 159 victory - The Checkered Flag","pageCategory":["nascar-trucks"],"pagePostAuthor":"Justin Nguyen"};
	dataLayer.push( dataLayer_content );//]]>
</script>
<script data-cfasync="false">//<![CDATA[
(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'//www.googletagmanager.com/gtm.'+'js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-MG875N');//]]>
</script>

<link rel="icon" href="https://www.thecheckeredflag.co.uk/wp-content/uploads/2016/02/cropped-TCF-32x32.png" sizes="32x32" />
<link rel="icon" href="https://www.thecheckeredflag.co.uk/wp-content/uploads/2016/02/cropped-TCF-200x200.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://www.thecheckeredflag.co.uk/wp-content/uploads/2016/02/cropped-TCF-200x200.png" />
<meta name="msapplication-TileImage" content="https://www.thecheckeredflag.co.uk/wp-content/uploads/2016/02/cropped-TCF-500x500.png" />
<style type="text/css" id="wp-custom-css">
			.cat-title {text-transform: uppercase;}

.widgettitle {text-transform:uppercase; text-align:center; }

.page-item-title-archive .category-posts-count { display:none; }

.page-description {
display: none;
}

.iframe-container {
  overflow: hidden;
  padding-top: 56.25%;
  position: relative;
}
 
.iframe-container iframe {
   border: 0;
   height: 100%;
   left: 0;
   position: absolute;
   top: 0;
   width: 100%;
}
.post-entry th {
    font-weight: bold;
    font-size: 14px;
    background: #ff7200;
    color: #fff;
}

h1.post-title.entry-title {
    max-width: 100% !important;
}		</style>
<style id="kirki-inline-styles">/* cyrillic-ext */
@font-face {
  font-family: 'Cormorant Garamond';
  font-style: normal;
  font-weight: 400;
  font-display: swap;
  src: url(https://www.thecheckeredflag.co.uk/wp-content/fonts/cormorant-garamond/co3bmX5slCNuHLi8bLeY9MK7whWMhyjYpHtMky2F7i6C.woff) format('woff');
  unicode-range: U+0460-052F, U+1C80-1C88, U+20B4, U+2DE0-2DFF, U+A640-A69F, U+FE2E-FE2F;
}
/* cyrillic */
@font-face {
  font-family: 'Cormorant Garamond';
  font-style: normal;
  font-weight: 400;
  font-display: swap;
  src: url(https://www.thecheckeredflag.co.uk/wp-content/fonts/cormorant-garamond/co3bmX5slCNuHLi8bLeY9MK7whWMhyjYrXtMky2F7i6C.woff) format('woff');
  unicode-range: U+0400-045F, U+0490-0491, U+04B0-04B1, U+2116;
}
/* vietnamese */
@font-face {
  font-family: 'Cormorant Garamond';
  font-style: normal;
  font-weight: 400;
  font-display: swap;
  src: url(https://www.thecheckeredflag.co.uk/wp-content/fonts/cormorant-garamond/co3bmX5slCNuHLi8bLeY9MK7whWMhyjYpntMky2F7i6C.woff) format('woff');
  unicode-range: U+0102-0103, U+0110-0111, U+0128-0129, U+0168-0169, U+01A0-01A1, U+01AF-01B0, U+1EA0-1EF9, U+20AB;
}
/* latin-ext */
@font-face {
  font-family: 'Cormorant Garamond';
  font-style: normal;
  font-weight: 400;
  font-display: swap;
  src: url(https://www.thecheckeredflag.co.uk/wp-content/fonts/cormorant-garamond/co3bmX5slCNuHLi8bLeY9MK7whWMhyjYp3tMky2F7i6C.woff) format('woff');
  unicode-range: U+0100-024F, U+0259, U+1E00-1EFF, U+2020, U+20A0-20AB, U+20AD-20CF, U+2113, U+2C60-2C7F, U+A720-A7FF;
}
/* latin */
@font-face {
  font-family: 'Cormorant Garamond';
  font-style: normal;
  font-weight: 400;
  font-display: swap;
  src: url(https://www.thecheckeredflag.co.uk/wp-content/fonts/cormorant-garamond/co3bmX5slCNuHLi8bLeY9MK7whWMhyjYqXtMky2F7g.woff) format('woff');
  unicode-range: U+0000-00FF, U+0131, U+0152-0153, U+02BB-02BC, U+02C6, U+02DA, U+02DC, U+2000-206F, U+2074, U+20AC, U+2122, U+2191, U+2193, U+2212, U+2215, U+FEFF, U+FFFD;
}/* cyrillic-ext */
@font-face {
  font-family: 'Roboto';
  font-style: normal;
  font-weight: 400;
  font-display: swap;
  src: url(https://www.thecheckeredflag.co.uk/wp-content/fonts/roboto/KFOmCnqEu92Fr1Mu72xMKTU1Kvnz.woff) format('woff');
  unicode-range: U+0460-052F, U+1C80-1C88, U+20B4, U+2DE0-2DFF, U+A640-A69F, U+FE2E-FE2F;
}
/* cyrillic */
@font-face {
  font-family: 'Roboto';
  font-style: normal;
  font-weight: 400;
  font-display: swap;
  src: url(https://www.thecheckeredflag.co.uk/wp-content/fonts/roboto/KFOmCnqEu92Fr1Mu5mxMKTU1Kvnz.woff) format('woff');
  unicode-range: U+0400-045F, U+0490-0491, U+04B0-04B1, U+2116;
}
/* greek-ext */
@font-face {
  font-family: 'Roboto';
  font-style: normal;
  font-weight: 400;
  font-display: swap;
  src: url(https://www.thecheckeredflag.co.uk/wp-content/fonts/roboto/KFOmCnqEu92Fr1Mu7mxMKTU1Kvnz.woff) format('woff');
  unicode-range: U+1F00-1FFF;
}
/* greek */
@font-face {
  font-family: 'Roboto';
  font-style: normal;
  font-weight: 400;
  font-display: swap;
  src: url(https://www.thecheckeredflag.co.uk/wp-content/fonts/roboto/KFOmCnqEu92Fr1Mu4WxMKTU1Kvnz.woff) format('woff');
  unicode-range: U+0370-03FF;
}
/* vietnamese */
@font-face {
  font-family: 'Roboto';
  font-style: normal;
  font-weight: 400;
  font-display: swap;
  src: url(https://www.thecheckeredflag.co.uk/wp-content/fonts/roboto/KFOmCnqEu92Fr1Mu7WxMKTU1Kvnz.woff) format('woff');
  unicode-range: U+0102-0103, U+0110-0111, U+0128-0129, U+0168-0169, U+01A0-01A1, U+01AF-01B0, U+1EA0-1EF9, U+20AB;
}
/* latin-ext */
@font-face {
  font-family: 'Roboto';
  font-style: normal;
  font-weight: 400;
  font-display: swap;
  src: url(https://www.thecheckeredflag.co.uk/wp-content/fonts/roboto/KFOmCnqEu92Fr1Mu7GxMKTU1Kvnz.woff) format('woff');
  unicode-range: U+0100-024F, U+0259, U+1E00-1EFF, U+2020, U+20A0-20AB, U+20AD-20CF, U+2113, U+2C60-2C7F, U+A720-A7FF;
}
/* latin */
@font-face {
  font-family: 'Roboto';
  font-style: normal;
  font-weight: 400;
  font-display: swap;
  src: url(https://www.thecheckeredflag.co.uk/wp-content/fonts/roboto/KFOmCnqEu92Fr1Mu4mxMKTU1Kg.woff) format('woff');
  unicode-range: U+0000-00FF, U+0131, U+0152-0153, U+02BB-02BC, U+02C6, U+02DA, U+02DC, U+2000-206F, U+2074, U+20AC, U+2122, U+2191, U+2193, U+2212, U+2215, U+FEFF, U+FFFD;
}</style></head>
<body class="post-template-default single single-post postid-352736 single-format-standard blog-post-transparent-header-disable blog-slider-enable blog-enable-images-animations blog-style-corners-rounded blog-home-block-title-left blog-home-block-title-style-regular blog-home-block-subtitle-style-uppercase">
<div class="header-menu-bg menu_white menu_border_fullwidth header-menu-uppercase header-menu-social-icons-right" role="navigation">
<div class="header-menu">
<div class="container">
<div class="row">
<div class="col-md-12">
<div class="social-icons-wrapper no-description"><a href="https://facebook.com/TheCheckeredFlag" target="_blank" class="a-facebook no-description"><i class="fa fa-facebook"></i></a><a href="https://twitter.com/TheCheckerFlag" target="_blank" class="a-twitter no-description"><i class="fa fa-twitter"></i></a><a href="https://instagram.com/thecheckeredflag/" target="_blank" class="a-instagram no-description"><i class="fa fa-instagram"></i></a><a href="https://www.linkedin.com/company/thecheckeredflag/" target="_blank" class="a-linkedin no-description"><i class="fa fa-linkedin"></i></a><a href="https://www.youtube.com/channel/UCueRVoGbSE4GF2RszehXIgw" target="_blank" class="a-youtube no-description"><i class="fa fa-youtube"></i></a></div> <div class="menu-top-menu-container-toggle">
<i class="fa fa-bars" aria-hidden="true"></i>
</div>
<div class="menu-top-container"><ul id="menu-top-1" class="links"><li class="menu-item menu-item-type-post_type menu-item-object-page current_page_parent menu-item-131978"><a href="https://www.thecheckeredflag.co.uk/latest-news/">Latest News</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-131967"><a href="https://www.thecheckeredflag.co.uk/contribute/">Contribute</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-131966"><a href="https://www.thecheckeredflag.co.uk/contact/">Contact Us</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-351613"><a href="https://shop.spreadshirt.co.uk/the-checkered-flag/tcf+original+range?collection=YpolblhjNm">TCF Merchandise</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-346099"><a href="https://discord.gg/7w9DuY6">Join our Discord Channel</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-347631"><a href="https://www.facebook.com/TheCheckeredFlag/live/">Live Motorsport</a></li>
</ul></div> </div>
</div>
</div>
</div>
</div>
<header class="main-header clearfix header-layout-menu-below-header-center-border mainmenu-light">
<div class="blog-post-reading-progress"></div>
<div class="container">
<div class="row">
<div class="col-md-12">
<div class="header-left">
</div>
<div class="header-center">
<div class="mainmenu-mobile-toggle"><i class="fa fa-bars" aria-hidden="true"></i></div>
<div class="logo">
<a class="logo-link" href="https://www.thecheckeredflag.co.uk/"><img src="https://www.thecheckeredflag.co.uk/wp-content/uploads/2020/04/cropped-TCF-Logo-1.jpg" alt="The Checkered Flag" class="regular-logo"><img src="https://www.thecheckeredflag.co.uk/wp-content/uploads/2020/04/cropped-TCF-Logo-1.jpg" alt="The Checkered Flag" class="light-logo"></a>
</div>
</div>
<div class="header-right">
<div class="search-toggle-wrapper search-fullscreen">
<a class="search-toggle-btn" aria-label="Search toggle"><i class="fa fa-search" aria-hidden="true"></i></a>
<div class="header-center-search-form">
<form method="get" role="search" class="searchform" action="https://www.thecheckeredflag.co.uk/">
<input type="search" aria-label="Search" class="field" name="s" value="" placeholder="Type keyword(s) here&hellip;" /><input type="submit" class="submit btn" value="Search" />
</form>
</div>
</div>
</div>
</div>
</div>
<div class="mainmenu mainmenu-light mainmenu-center mainmenu-uppercase mainmenu-regularfont mainmenu-noarrow clearfix" role="navigation">
<div id="navbar" class="navbar navbar-default clearfix mgt-mega-menu">
<div class="navbar-inner">
<div class="container">
<div class="navbar-toggle btn" data-toggle="collapse" data-target=".collapse">
Menu </div>
<div class="navbar-center-wrapper">
<div class="navbar-collapse collapse"><ul id="menu-2017" class="nav"><li id="mgt-menu-item-131940" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children"><a href="https://www.thecheckeredflag.co.uk/open-wheel/">Open Wheel</a>
<ul class="sub-menu  megamenu-column-1 level-0">
<li id="mgt-menu-item-131887" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="https://www.thecheckeredflag.co.uk/open-wheel/formula-1/">FIA Formula 1</a></li> <li id="mgt-menu-item-131942" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="https://www.thecheckeredflag.co.uk/open-wheel/formula-e/">FIA Formula E</a></li> <li id="mgt-menu-item-131943" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="https://www.thecheckeredflag.co.uk/open-wheel/indycar/">IndyCar</a></li> <li id="mgt-menu-item-333871" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="https://www.thecheckeredflag.co.uk/open-wheel/fia-formula-2-championship/">FIA Formula 2</a></li> <li id="mgt-menu-item-296601" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="https://www.thecheckeredflag.co.uk/open-wheel/fia-formula-3-championship/">FIA Formula 3</a></li> <li id="mgt-menu-item-335473" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="https://www.thecheckeredflag.co.uk/open-wheel/super-formula/">Super Formula</a></li> <li id="mgt-menu-item-321059" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="https://www.thecheckeredflag.co.uk/open-wheel/w-series/">W Series</a></li> <li id="mgt-menu-item-180961" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="https://www.thecheckeredflag.co.uk/open-wheel/formula-3/british-f3-formula-3/">British F3</a></li> <li id="mgt-menu-item-131897" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="https://www.thecheckeredflag.co.uk/open-wheel/msa-formula/">F4 British Championship</a></li> <li id="mgt-menu-item-131946" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="https://www.thecheckeredflag.co.uk/open-wheel/formula-3/euroformula-open/">EuroFormula Open</a></li> <li id="mgt-menu-item-330918" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="https://www.thecheckeredflag.co.uk/open-wheel/formula-renault-eurocup/">Formula Renault Eurocup</a></li> <li id="mgt-menu-item-330987" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="https://www.thecheckeredflag.co.uk/open-wheel/formula-3/formula-regional-european-championship/">Formula Regional European Championship</a></li></ul>
</li><li id="mgt-menu-item-290798" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children"><a href="https://www.thecheckeredflag.co.uk/offroad/">Off Road</a>
<ul class="sub-menu  megamenu-column-1 level-0">
<li id="mgt-menu-item-349729" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="https://www.thecheckeredflag.co.uk/offroad/extreme-e/">Extreme E</a></li> <li id="mgt-menu-item-254211" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="https://www.thecheckeredflag.co.uk/offroad/rally/fiawrc/">FIA WRC</a></li> <li id="mgt-menu-item-138301" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="https://www.thecheckeredflag.co.uk/offroad/rally/fia-erc/">FIA ERC</a></li> <li id="mgt-menu-item-131910" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="https://www.thecheckeredflag.co.uk/offroad/rally/british-rally-championship/">British Rally Championship</a></li> <li id="mgt-menu-item-131917" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="https://www.thecheckeredflag.co.uk/offroad/rallycross/world-rallycross/">FIA World RX</a></li> <li id="mgt-menu-item-131913" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="https://www.thecheckeredflag.co.uk/offroad/rallycross/european-rallycross/">FIA European RX</a></li> <li id="mgt-menu-item-346211" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="https://www.thecheckeredflag.co.uk/offroad/rallycross/world-rallycross/projekt-e/">Projekt E</a></li> <li id="mgt-menu-item-330919" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="https://www.thecheckeredflag.co.uk/offroad/rallycross/british-rallycross/">British Rallycross</a></li> <li id="mgt-menu-item-332829" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="https://www.thecheckeredflag.co.uk/offroad/rallycross/rallyx-nordic/">RallyX Nordic</a></li></ul>
</li><li id="mgt-menu-item-131952" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children"><a href="https://www.thecheckeredflag.co.uk/sportscars/">Sportscars</a>
<ul class="sub-menu  megamenu-column-1 level-0">
<li id="mgt-menu-item-131956" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="https://www.thecheckeredflag.co.uk/sportscars/endurance/fiawec/">FIA WEC</a></li> <li id="mgt-menu-item-131957" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="https://www.thecheckeredflag.co.uk/sportscars/endurance/blancpain-endurance-series/">GT World Challenge Europe Endurance Cup</a></li> <li id="mgt-menu-item-148232" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="https://www.thecheckeredflag.co.uk/sportscars/endurance/blancpain-sprint/">GT World Challenge Europe</a></li> <li id="mgt-menu-item-131954" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="https://www.thecheckeredflag.co.uk/sportscars/gt-sportscars/british-gt/">British GT</a></li> <li id="mgt-menu-item-290801" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="https://www.thecheckeredflag.co.uk/sportscars/ginetta/">Ginetta Series</a></li> <li id="mgt-menu-item-303742" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="https://www.thecheckeredflag.co.uk/sportscars/porsche/">Porsche Series</a></li></ul>
</li><li id="mgt-menu-item-131899" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children"><a href="https://www.thecheckeredflag.co.uk/touring-cars/">Touring Cars</a>
<ul class="sub-menu  megamenu-column-1 level-0">
<li id="mgt-menu-item-131904" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="https://www.thecheckeredflag.co.uk/touring-cars/btcc/">BTCC</a></li> <li id="mgt-menu-item-192543" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="https://www.thecheckeredflag.co.uk/touring-cars/dtm/">DTM</a></li> <li id="mgt-menu-item-317944" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="https://www.thecheckeredflag.co.uk/touring-cars/jaguar-i-pace-etrophy/">Jaguar I-PACE eTROPHY</a></li></ul>
</li><li id="mgt-menu-item-290800" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor"><a href="https://www.thecheckeredflag.co.uk/nascar/">NASCAR</a></li><li id="mgt-menu-item-293110" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children"><a href="https://www.thecheckeredflag.co.uk/features/">Features</a>
<ul class="sub-menu  megamenu-column-1 level-0">
<li id="mgt-menu-item-330921" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="https://www.thecheckeredflag.co.uk/tcf-blogs/">TCF Blogs</a></li> <li id="mgt-menu-item-293115" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="https://www.thecheckeredflag.co.uk/features/opinion/">Opinion</a></li> <li id="mgt-menu-item-293113" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="https://www.thecheckeredflag.co.uk/features/interviews/">Interviews</a></li> <li id="mgt-menu-item-293114" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="https://www.thecheckeredflag.co.uk/features/gallery/">Gallery</a></li> <li id="mgt-menu-item-293111" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="https://www.thecheckeredflag.co.uk/features/product-review/">Product Review</a></li> <li id="mgt-menu-item-293112" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="https://www.thecheckeredflag.co.uk/features/season-review/">Season Review</a></li> <li id="mgt-menu-item-293118" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="https://www.thecheckeredflag.co.uk/other/esports/">eSports</a></li> <li id="mgt-menu-item-293117" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="https://www.thecheckeredflag.co.uk/other/video-games/">Sim Racing</a></li></ul>
</li></ul></div> </div>
</div>
</div>
</div>
</div>
</div>
</header>
<div class="content-block post-header-incontent2 post-sidebar-right">
<div class="post-container container span-col-md-8">
<div class="row">
<div class="col-md-8">
<div class="blog-post blog-post-single hentry clearfix">
<div class="container-page-item-title container-page-item-title-inside without-bg">
<div class="page-item-title-single page-item-title-single-inside">
<div class="inhype-post-single inhype-post">
<div class="post-categories"><a href="https://www.thecheckeredflag.co.uk/nascar/nascar-trucks/"><span class="cat-dot"></span><span class="cat-title">NASCAR Truck Series</span></a></div>
<div class="inhype-post-details">
<h1 class="post-title entry-title">Ben Rhodes wins bargain-bin Daytona endurance race with BrakeBest Select 159 victory</h1>
<div class="post-author">
<span class="vcard">
By <span class="fn"><a href="https://www.thecheckeredflag.co.uk/author/jnguyen/" title="Posts by Justin Nguyen" rel="author">Justin Nguyen</a></span>
</span>
</div>
<div class="post-info-dot"></div>
<div class="post-date"><time class="entry-date published updated" datetime="2021-02-20T03:57:28+00:00">February 20, 2021</time></div>
<div class="post-info-dot"></div>
<div class="post-read-time">7 Mins read</div>
<div class="post-details-bottom post-details-bottom-inline">
<div class="post-info-wrapper">
</div>
<div class="post-info-share">
<div class="post-social-wrapper">
<div class="post-social-title"><span class="post-social-title-text">Share</span></div>
<div class="post-social-frame">
<div class="post-social">
<a title="Share with Facebook" href="https://www.thecheckeredflag.co.uk/2021/02/ben-rhodes-wins-bargain-bin-daytona-endurance-race-with-brakebest-select-159-victory/" data-type="facebook" data-title="Ben Rhodes wins bargain-bin Daytona endurance race with BrakeBest Select 159 victory" class="facebook-share"> <i class="fa fa-facebook"></i></a><a title="Tweet this" href="https://www.thecheckeredflag.co.uk/2021/02/ben-rhodes-wins-bargain-bin-daytona-endurance-race-with-brakebest-select-159-victory/" data-type="twitter" data-title="Ben Rhodes wins bargain-bin Daytona endurance race with BrakeBest Select 159 victory" class="twitter-share"> <i class="fa fa-twitter"></i></a><a title="Share with LinkedIn" href="https://www.thecheckeredflag.co.uk/2021/02/ben-rhodes-wins-bargain-bin-daytona-endurance-race-with-brakebest-select-159-victory/" data-type="linkedin" data-title="Ben Rhodes wins bargain-bin Daytona endurance race with BrakeBest Select 159 victory" data-image="https://www.thecheckeredflag.co.uk/wp-content/uploads/2021/02/Ben-Rhodes-John-Hunter-Nemechek-2021-BrakeBest-Select-159-Daytona-RC-CWTS.jpg" class="linkedin-share"> <i class="fa fa-linkedin"></i></a><a title="Share to WhatsApp" href="whatsapp://send?text=Ben+Rhodes+wins+bargain-bin+Daytona+endurance+race+with+BrakeBest+Select+159+victory:https://www.thecheckeredflag.co.uk/2021/02/ben-rhodes-wins-bargain-bin-daytona-endurance-race-with-brakebest-select-159-victory/" data-type="link" class="whatsapp-share"> <i class="fa fa-whatsapp"></i></a><a title="Share on Reddit" href="https://www.thecheckeredflag.co.uk/2021/02/ben-rhodes-wins-bargain-bin-daytona-endurance-race-with-brakebest-select-159-victory/" data-type="reddit" class="reddit-share"> <i class="fa fa-reddit-alien"></i></a><a title="Share by Email" href="/cdn-cgi/l/email-protection#013e7274636b6462753c43646f24333153696e65647224333176686f722433316360736660686f2c63686f243331456078756e6f60243331646f657473606f626424333173606264243331766875692433314373606a644364727524333152646d646275243331303438243331776862756e737827636e65783c69757571723b2e2e7676762f756964626964626a64736465676d60662f626e2f746a2e333133302e31332e63646f2c73696e6564722c76686f722c6360736660686f2c63686f2c656078756e6f602c646f657473606f62642c736062642c766875692c6373606a64636472752c72646d6462752c3034382c776862756e73782e" data-type="link" class="email-share"> <i class="fa fa-envelope-o"></i></a> </div>
</div>
<div class="clear"></div>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
<div class="blog-post-thumb">
<img width="800" height="533" src="https://www.thecheckeredflag.co.uk/wp-content/uploads/2021/02/Ben-Rhodes-John-Hunter-Nemechek-2021-BrakeBest-Select-159-Daytona-RC-CWTS.jpg" class="attachment-inhype-blog-thumb size-inhype-blog-thumb wp-post-image" alt="" loading="lazy" srcset="https://www.thecheckeredflag.co.uk/wp-content/uploads/2021/02/Ben-Rhodes-John-Hunter-Nemechek-2021-BrakeBest-Select-159-Daytona-RC-CWTS.jpg 800w, https://www.thecheckeredflag.co.uk/wp-content/uploads/2021/02/Ben-Rhodes-John-Hunter-Nemechek-2021-BrakeBest-Select-159-Daytona-RC-CWTS-240x160.jpg 240w, https://www.thecheckeredflag.co.uk/wp-content/uploads/2021/02/Ben-Rhodes-John-Hunter-Nemechek-2021-BrakeBest-Select-159-Daytona-RC-CWTS-768x512.jpg 768w, https://www.thecheckeredflag.co.uk/wp-content/uploads/2021/02/Ben-Rhodes-John-Hunter-Nemechek-2021-BrakeBest-Select-159-Daytona-RC-CWTS-360x240.jpg 360w" sizes="(max-width: 800px) 100vw, 800px" /></div>
<div class="post-image-caption">
Credit: Brian Lawdermilk/Getty Images</div>
<article id="post-352736" class="post-352736 post type-post status-publish format-standard has-post-thumbnail category-nascar-trucks" role="main">
<div class="post-content-wrapper">
<div class="post-content clearfix">
<div class="entry-content">
<p>Friday night&#8217;s <strong>BrakeBest Select 159</strong> on the <strong>Daytona International Speedway road course</strong> provided the NASCAR Camping World Truck Series with a special combination: Truck road racing at night and in the rain. For the first time in series history, a race was conducted in wet conditions.</p>
<p>As it turned out, the rain would be the least of everyone&#8217;s concerns as numerous incidents and lengthy caution periods plagued the race, including three overtime periods. By the end of the nearly three-hour-long fiasco, ending under what was the tenth caution of the race, <strong>Ben Rhodes</strong> walked away with his second straight victory in as many races in 2021.</p>
<p>Rhodes, who won the <a href="https://www.thecheckeredflag.co.uk/2021/02/ben-rhodes-edges-out-underdogs-cory-roper-and-jordan-anderson-for-truck-opening-nextera-energy-250-win/">previous week&#8217;s opener on the Daytona oval</a>, <a href="https://www.thecheckeredflag.co.uk/2021/02/chase-elliott-brett-moffitt-ben-rhodes-to-start-nascar-daytona-rc-from-poles/">started on the pole</a> ahead of <strong>Ryan Truex</strong> while defending race winner <strong>Sheldon Creed</strong> was fifth. Due to the weather, NASCAR declared a &#8220;wet&#8221; start that required drivers to go to pit road and add treaded rain tyres. While the 159 marked the first time that the Trucks raced in the rain, the series was the first of the three NASCAR national divisions (Cup and <strong>Xfinity</strong>) to utilise rain-specific tyres for a points race weekend, doing so for a practice at Watkins Glen in 1999. Various drivers in the field boasted wet-weather racing experience such as Creed, who has won in the rain in the <strong>Stadium Super Trucks</strong> and <strong>Trans-Am Series</strong>.</p>
<h2>Stages #1 and 2</h2>
<p>Truex, Creed, and <strong>John Hunter Nemechek</strong> went wide as they entered the sharp left opening turn, but others were not as lucky when <strong>GMS Racing</strong> team-mates <strong>Raphaël Lessard</strong> and <strong>Zane Smith</strong> spun in the corner. Nemechek and Creed kept up with the leader Rhodes and Nemechek would lead the opening lap. Creed passed Rhodes for second on lap two, and he and Nemechek began to pull away.</p>
<p><strong>Tyler Ankrum</strong> and <strong>Cory Roper</strong>, who nearly won last week&#8217;s race, spun but did not suffer damage. After five laps, Truck newcomer and <strong>IMSA</strong> driver <strong><a href="https://www.thecheckeredflag.co.uk/2021/02/parker-chase-to-make-nascar-truck-debut-at-daytona-rc-also-running-cota-for-former-rolex-24-team-mate-kyle-busch/">Parker Chase</a></strong> reached the top ten after starting twenty-second. Meanwhile, <strong>Jason White</strong> received a stop-and-go penalty for missing a chicane; he eventually exited the race.</p>
<p>With four laps remaining in the stage, <strong>Riley Herbst</strong>, doing a one-off for <strong>David Gilliland Racing</strong> to prepare for Saturday&#8217;s Xfinity Series race, went into the grass in the infield. Shortly after, Roper spun in the International Horseshoe to bring out the caution. Creed was among the pitters, while Chase and <strong>Jennifer Jo Cobb</strong> suffered speeding penalties on their stops and <strong>Timothy Peters</strong> had one for equipment over the wall too soon.</p>
<p>Nemechek and Rhodes led the field to the restart with one lap to go, and the two finished in that order ahead of <strong>Chandler Smith</strong>, Brett Moffitt, Truex, <strong>Matt Crafton</strong>, <strong>Johnny Sauter</strong>, <strong>Austin Hill</strong>, Creed, and Herbst. Ankrum briefly exited the race between stages after losing power, while <strong>Chase Purdy</strong> was penalised for a safety violation.</p>
<p>After staying out, Nemechek remained the leader to begin Stage #2. Creed, on fresher tyres, caught Nemechek for the lead on lap 15; at one point, contact from <strong><a href="https://www.thecheckeredflag.co.uk/2021/02/jordan-anderson-racing-to-field-truck-for-brothers-bobby-roger-reuse/">Bobby Reuse</a></strong> as he tried to lap him sent Creed wide but he recovered. <strong>Tanner Gray</strong> spun after contact with Sauter though the race stayed green.</p>
<p>By lap 20, GMS trucks occupied the top three as Creed led Lessard and Smith. As the segment winded down, Creed pitted to add slick tyres and Lessard inherited the lead from his team-mate. With three laps to go, Nemechek&#8217;s truck lost oil pressure and stopped at the Bus Stop&#8217;s entrance, producing a caution. Unlike the conclusion to Stage #1, the second stage came to an end under yellow. Lessard led <strong>Kaz Grala</strong>, Smith, <strong>Austin Wayne Self</strong>, <strong>Todd Gilliland</strong>, Crafton, <strong>Hailie Deegan</strong>, Creed, Purdy, and Moffitt. Interestingly, the stage winners were an inversion from last week&#8217;s race as Lessard won Stage #1 and Nemechek did so for the second.</p>
<div class="wp-block-image"><figure class="aligncenter size-large"><img loading="lazy" width="800" height="533" src="https://www.thecheckeredflag.co.uk/wp-content/uploads/2021/02/Cory-Roper-spin-2021-BrakeBest-Select-159-Daytona-RC-CWTS-800x533.jpg" alt="" class="wp-image-352738" srcset="https://www.thecheckeredflag.co.uk/wp-content/uploads/2021/02/Cory-Roper-spin-2021-BrakeBest-Select-159-Daytona-RC-CWTS.jpg 800w, https://www.thecheckeredflag.co.uk/wp-content/uploads/2021/02/Cory-Roper-spin-2021-BrakeBest-Select-159-Daytona-RC-CWTS-240x160.jpg 240w, https://www.thecheckeredflag.co.uk/wp-content/uploads/2021/02/Cory-Roper-spin-2021-BrakeBest-Select-159-Daytona-RC-CWTS-768x512.jpg 768w, https://www.thecheckeredflag.co.uk/wp-content/uploads/2021/02/Cory-Roper-spin-2021-BrakeBest-Select-159-Daytona-RC-CWTS-360x240.jpg 360w" sizes="(max-width: 800px) 100vw, 800px" /><figcaption>Credit: Brian Lawdermilk/Getty Images</figcaption></figure></div>
<h2>Stage #3</h2>
<p>With the track continue to dry, drivers were permitted to turn off their red rear brake light ahead of the final stage. On pit road, one of <strong>Danny Bohn</strong>&#8216;s crewmen went over the wall too soon and he had to start at the back.</p>
<p>Rhodes was the first off pit road after only taking fuel, while Crafton stayed out to hold the lead alongside Creed for the final stage. Creed cleared Crafton for the lead approaching turn one. As Creed established a comfortable margin over the field, reaching over four seconds by lap 30, Herbst took second. Crafton, still on wet tyres, began a free-fall through the running order that dropped him out of the top ten.</p>
<p>With 13 laps to go, <strong>Niece Motorsports</strong>&#8216; <strong>Carson Hocevar</strong> and Truex were involved in a bizarre accident in which the former&#8217;s tyre went down as he exited pit road, causing him to hit the sand barrel lining the pit wall; Truex was unable to avoid him and slammed into his rear, resulting in substantial damage to both trucks. Peters was also involved as he cut a tyre.</p>
<p>During the caution, Creed failed to maintain pace car speed after being unable to re-fire his engine, relegating him to sixth for the restart as the lead was cycled to Herbst. Parallels to Creed&#8217;s predicament could be drawn to <strong>Marcos Ambrose</strong> in the 2010 Cup race at Sonoma, where his hopes of a maiden victory were dashed late after his car stalled while re-firing his engine in an attempt to save fuel.</p>
<p>The race resumed with nine laps to go, and a strong restart by <strong>Stewart Friesen</strong> sent him to the lead before going wide and losing the spot. Creed quickly rejoined the conversation behind Rhodes and Herbst as they went through the International Horseshoe. As the field settled into order, Rhodes led Creed. During the lap, Self fell off the pace after going off course in the Bus Stop chicane.</p>
<p>Nearing the frontstretch chicane, Smith was turned into the wall by Moffitt as they approached it, causing terminal damage to Smith&#8217;s truck. Chase attempted to avoid the wreck and hopped over the rumble strip, leading to a spin through the chicane.</p>
<p>The restart came six laps remaining. Rhodes cleared Creed entering turn one while Creed was passed by Herbst, sparking a battle for second. <strong>Spencer Boyd</strong> and Hill respectively spun in turn six and the Bus Stop; both trucks could not re-fire and another yellow flag was flown.</p>
<p>The next green-flag racing was short-lived after resuming with three laps left. Rhodes and Creed, who carry animosity between each other, were side-by-side through the first corner before Creed made his move along the inside in the International Horseshoe. Rhodes attempted to return the favour in the West Horseshoe but failed. In turn four, <strong>Sam Mayer</strong> hit Gray and the latter slid into the barriers, resulting in yet another caution and overtime.</p>
<div class="wp-block-image"><figure class="aligncenter size-large"><img loading="lazy" width="800" height="533" src="https://www.thecheckeredflag.co.uk/wp-content/uploads/2021/02/Zane-Smith-wreck-2021-BrakeBest-Select-159-Daytona-RC-CWTS-800x533.jpg" alt="" class="wp-image-352739" srcset="https://www.thecheckeredflag.co.uk/wp-content/uploads/2021/02/Zane-Smith-wreck-2021-BrakeBest-Select-159-Daytona-RC-CWTS.jpg 800w, https://www.thecheckeredflag.co.uk/wp-content/uploads/2021/02/Zane-Smith-wreck-2021-BrakeBest-Select-159-Daytona-RC-CWTS-240x160.jpg 240w, https://www.thecheckeredflag.co.uk/wp-content/uploads/2021/02/Zane-Smith-wreck-2021-BrakeBest-Select-159-Daytona-RC-CWTS-768x512.jpg 768w, https://www.thecheckeredflag.co.uk/wp-content/uploads/2021/02/Zane-Smith-wreck-2021-BrakeBest-Select-159-Daytona-RC-CWTS-360x240.jpg 360w" sizes="(max-width: 800px) 100vw, 800px" /><figcaption>Credit: James Gilbert/Getty Images</figcaption></figure></div>
<h2>Overtime</h2>
<p>Creed&#8217;s team expressed concern about fuel and Rhodes&#8217; presence as overtime began. He overshot the first two corners as Rhodes and Herbst passed him, though he retook second from the latter. A considerable gap developed between Rhodes and Creed as the latter faced pressure from Nemechek, but Rhodes could not take the white flag in time before Truck Series débutant <strong><a href="https://www.thecheckeredflag.co.uk/2021/02/jett-noland-to-make-truck-series-debut-on-daytona-rc-becomes-24th-nascar-sst-crossover/">Jett Noland</a></strong> spun after being clipped by Deegan and Self hit the wall.</p>
<p>Overtime #2 commenced with Nemechek pushing Rhodes to the lead and much of the field stacking up. Ankrum and Smith in the esses. <strong>Jennifer Jo Cobb</strong> would be responsible for another overtime session after stalling on track. Roper retired before the green after his truck could not fire on pit road.</p>
<p>Rhodes retained the lead on the third overtime restart as Creed and Nemechek filed in behind. Deegan spun in turn five but no caution was called. Creed narrowed the gap after Rhodes missed the Bus Stop, with the two isolating themselves from Nemechek who in turn had a gap over the field.</p>
<p>After Rhodes took the white flag to spare the world from a fourth overtime, Creed continued to give chase. Perhaps appropriately, the race would end under caution when Noland&#8217;s truck stopped in the frontstretch chicane, granting Rhodes his second consecutive win and fifth of his career. It is the first time in Rhodes&#8217; career that he won multiple Truck races in a season, and the second time he accomplished it in a NASCAR-sanctioned series after his five-win 2014 championship campaign in what is now the <strong>ARCA Menards Series East</strong>. The victory is also <strong><a href="https://www.thecheckeredflag.co.uk/2021/02/thorsport-racing-returns-to-toyota-christian-eckes-to-share-truck-with-grant-enfinger/">Toyota</a></strong>&#8216;s 200th in the Truck Series.</p>
<p><em>&#8220;I don&#8217;t have words for it. I don&#8217;t know what to say, this is so cool,&#8221;</em> Rhodes said in his post-race interview with FS1. <em>&#8220;[…] <strong>ThorSport Racing</strong> gave me a truck that handled this year and we were fast. <strong>Rich (Lushes)</strong> is a good crew chief, really good crew chief, good to be paired up with him. I&#8217;m just thrilled.</em></p>
<p><em>&#8220;I don&#8217;t know what to say. I&#8217;ve been on Cloud Nine all week, so this is above that. I&#8217;m just so happy.&#8221;</em></p>
<p>Creed settled for second, saying in his interview that it is <em>&#8220;never fun to be the first loser. Guys brought a fast truck. I felt like I was on top of the strategy there going to slicks early and I got hit by that lapper there (Reuse) leading and I don&#8217;t think that did us any favours. Got to the lead, stalled it saving fuel, and then worked for the lead, got pushed out of the way on the restart. Man, just doing everything I could there. The guys in the back were all over the place.&#8221;</em></p>
<p>The race lasted approximately two hours, 44 minutes, and 43 seconds; for comparison, the 2020 Cup race on the road course lasted just two hours, 37 minutes, and 30 seconds, while a standard-length IMSA race runs for two hours and 40 minutes. Ten cautions were flown and lasted for twenty of fifty-one total laps. Cup driver <strong>Denny Hamlin</strong> <a href="https://twitter.com/dennyhamlin/status/1362969457979752450">quipped after the race</a>, <em>&#8220;More road courses.&#8221;</em></p>
<h2>Race results</h2>
<figure class="wp-block-table"><table><tbody><tr><td><strong>Finish</strong></td><td><strong>Start</strong></td><td><strong>Number</strong></td><td><strong>Driver</strong></td><td><strong>Team</strong></td><td><strong>Manufacturer</strong></td><td><strong>Laps</strong></td><td><strong>Status</strong></td></tr><tr><td>1</td><td>1</td><td>99</td><td>Ben Rhodes</td><td>ThorSport Racing</td><td>Toyota</td><td>51</td><td>Running</td></tr><tr><td>2</td><td>5</td><td>2</td><td>Sheldon Creed</td><td>GMS Racing</td><td>Chevrolet</td><td>51</td><td>Running</td></tr><tr><td>3</td><td>4</td><td>4</td><td>John Hunter Nemechek</td><td>Kyle Busch Motorsports</td><td>Toyota</td><td>51</td><td>Running</td></tr><tr><td>4</td><td>32</td><td>38</td><td>Todd Gilliland</td><td>Front Row Motorsports</td><td>Ford</td><td>51</td><td>Running</td></tr><tr><td>5</td><td>25</td><td>17</td><td>Riley Herbst*</td><td>David Gilliland Racing</td><td>Ford</td><td>51</td><td>Running</td></tr><tr><td>6</td><td>9</td><td>88</td><td>Matt Crafton</td><td>ThorSport Racing</td><td>Toyota</td><td>51</td><td>Running</td></tr><tr><td>7</td><td>31</td><td>19</td><td>Derek Kraus</td><td>McAnally-Hilgemann Racing</td><td>Toyota</td><td>51</td><td>Running</td></tr><tr><td>8</td><td>24</td><td>02</td><td>Kaz Grala*</td><td>Young&#8217;s Motorsports</td><td>Chevrolet</td><td>51</td><td>Running</td></tr><tr><td>9</td><td>34</td><td>56</td><td>Timmy Hill*</td><td>Hill Motorsports</td><td>Chevrolet</td><td>51</td><td>Running</td></tr><tr><td>10</td><td>16</td><td>98</td><td>Christian Eckes</td><td>ThorSport Racing</td><td>Toyota</td><td>51</td><td>Running</td></tr><tr><td>11</td><td>30</td><td>52</td><td>Stewart Friesen</td><td>Halmar Friesen Racing</td><td>Toyota</td><td>51</td><td>Running</td></tr><tr><td>12</td><td>8</td><td>18</td><td><em>Chandler Smith</em></td><td>Kyle Busch Motorsports</td><td>Toyota</td><td>51</td><td>Running</td></tr><tr><td>13</td><td>37</td><td>8</td><td>Camden Murphy</td><td>NEMCO Motorsports</td><td>Chevrolet</td><td>51</td><td>Running</td></tr><tr><td>14</td><td>3</td><td>42</td><td><em>Carson Hocevar</em></td><td>Niece Motorsports</td><td>Chevrolet</td><td>51</td><td>Running</td></tr><tr><td>15</td><td>14</td><td>22</td><td>Austin Wayne Self</td><td>AM Racing</td><td>Chevrolet</td><td>51</td><td>Running</td></tr><tr><td>16</td><td>7</td><td>9</td><td>Codie Rohrbaugh</td><td>CR7 Motorsports</td><td>Chevrolet</td><td>51</td><td>Running</td></tr><tr><td>17</td><td>38</td><td>41</td><td>Dawson Cram</td><td>Cram Racing Enterprises</td><td>Chevrolet</td><td>51</td><td>Running</td></tr><tr><td>18</td><td>19</td><td>13</td><td>Johnny Sauter</td><td>ThorSport Racing</td><td>Toyota</td><td>51</td><td>Running</td></tr><tr><td>19</td><td>28</td><td>12</td><td>Tate Fogleman</td><td>Young&#8217;s Motorsports</td><td>Chevrolet</td><td>51</td><td>Running</td></tr><tr><td>20</td><td>33</td><td>15</td><td>Tanner Gray</td><td>David Gilliland Racing</td><td>Ford</td><td>51</td><td>Running</td></tr><tr><td>21</td><td>26</td><td>26</td><td>Tyler Ankrum</td><td>GMS Racing</td><td>Chevrolet</td><td>51</td><td>Running</td></tr><tr><td>22</td><td>29</td><td>23</td><td><em>Chase Purdy</em></td><td>GMS Racing</td><td>Chevrolet</td><td>51</td><td>Running</td></tr><tr><td>23</td><td>22</td><td>51</td><td>Parker Chase</td><td>Kyle Busch Motorsports</td><td>Toyota</td><td>51</td><td>Running</td></tr><tr><td>24</td><td>27</td><td>25</td><td>Timothy Peters</td><td>Rackley WAR</td><td>Chevrolet</td><td>51</td><td>Running</td></tr><tr><td>25</td><td>21</td><td>45</td><td>Brett Moffitt</td><td>Niece Motorsports</td><td>Chevrolet</td><td>51</td><td>Running</td></tr><tr><td>26</td><td>12</td><td>24</td><td>Raphaël Lessard</td><td>GMS Racing</td><td>Chevrolet</td><td>51</td><td>Running</td></tr><tr><td>27</td><td>13</td><td>3</td><td>Bobby Reuse</td><td>Jordan Anderson Racing</td><td>Chevrolet</td><td>50</td><td>Running</td></tr><tr><td>28</td><td>23</td><td>1</td><td><em>Hailie Deegan</em></td><td>David Gilliland Racing</td><td>Ford</td><td>50</td><td>Running</td></tr><tr><td>29</td><td>35</td><td>44</td><td>Jett Noland</td><td>Niece Motorsports</td><td>Chevrolet</td><td>49</td><td>Accident</td></tr><tr><td>30</td><td>15</td><td>30</td><td>Danny Bohn</td><td>On Point Motorsports</td><td>Toyota</td><td>49</td><td>Running</td></tr><tr><td>31</td><td>2</td><td>40</td><td>Ryan Truex</td><td>Niece Motorsports</td><td>Chevrolet</td><td>48</td><td>Running</td></tr><tr><td>32</td><td>39</td><td>6</td><td>Norm Benning</td><td>Norm Benning Racing</td><td>Chevrolet</td><td>48</td><td>Running</td></tr><tr><td>33</td><td>20</td><td>16</td><td>Austin Hill</td><td>Hattori Racing Enterprises</td><td>Toyota</td><td>48</td><td>Running</td></tr><tr><td>34</td><td>6</td><td>04</td><td>Cory Roper</td><td>Roper Racing</td><td>Ford</td><td>47</td><td>Fuel Pressure</td></tr><tr><td>35</td><td>17</td><td>10</td><td>Jennifer Jo Cobb</td><td>Jennifer Jo Cobb Racing</td><td>Chevrolet</td><td>47</td><td>Running</td></tr><tr><td>36</td><td>40</td><td>34</td><td>Lawless Alan</td><td>Reaume Brothers Racing</td><td>Toyota</td><td>45</td><td>Running</td></tr><tr><td>37</td><td>36</td><td>75</td><td>Sam Mayer</td><td>Henderson Motorsports</td><td>Chevrolet</td><td>41</td><td>Accident</td></tr><tr><td>38</td><td>18</td><td>33</td><td>Jason White</td><td>Reaume Brothers Racing</td><td>Chevrolet</td><td>41</td><td>Running</td></tr><tr><td>39</td><td>10</td><td>20</td><td>Spencer Boyd</td><td>Young&#8217;s Motorsports</td><td>Chevrolet</td><td>38</td><td>Transmission</td></tr><tr><td>40</td><td>11</td><td>21</td><td>Zane Smith</td><td>GMS Racing</td><td>Chevrolet</td><td>35</td><td>Accident</td></tr></tbody></table><figcaption><em>Italics</em> – Competing for Rookie of the Year<br />* – Ineligible for Truck points</figcaption></figure>
</div>
</div>
</div>
</article>
<div class="inhype-post inhype-post-bottom">
<div class="post-details-bottom post-details-bottom-single">
<div class="post-info-wrapper">

</div>
<div class="post-info-share">
<div class="post-social-wrapper">
<div class="post-social-title"><span class="post-social-title-text">Share</span></div>
<div class="post-social-frame">
<div class="post-social">
<a title="Share with Facebook" href="https://www.thecheckeredflag.co.uk/2021/02/ben-rhodes-wins-bargain-bin-daytona-endurance-race-with-brakebest-select-159-victory/" data-type="facebook" data-title="Ben Rhodes wins bargain-bin Daytona endurance race with BrakeBest Select 159 victory" class="facebook-share"> <i class="fa fa-facebook"></i></a><a title="Tweet this" href="https://www.thecheckeredflag.co.uk/2021/02/ben-rhodes-wins-bargain-bin-daytona-endurance-race-with-brakebest-select-159-victory/" data-type="twitter" data-title="Ben Rhodes wins bargain-bin Daytona endurance race with BrakeBest Select 159 victory" class="twitter-share"> <i class="fa fa-twitter"></i></a><a title="Share with LinkedIn" href="https://www.thecheckeredflag.co.uk/2021/02/ben-rhodes-wins-bargain-bin-daytona-endurance-race-with-brakebest-select-159-victory/" data-type="linkedin" data-title="Ben Rhodes wins bargain-bin Daytona endurance race with BrakeBest Select 159 victory" data-image="https://www.thecheckeredflag.co.uk/wp-content/uploads/2021/02/Ben-Rhodes-John-Hunter-Nemechek-2021-BrakeBest-Select-159-Daytona-RC-CWTS.jpg" class="linkedin-share"> <i class="fa fa-linkedin"></i></a><a title="Share to WhatsApp" href="whatsapp://send?text=Ben+Rhodes+wins+bargain-bin+Daytona+endurance+race+with+BrakeBest+Select+159+victory:https://www.thecheckeredflag.co.uk/2021/02/ben-rhodes-wins-bargain-bin-daytona-endurance-race-with-brakebest-select-159-victory/" data-type="link" class="whatsapp-share"> <i class="fa fa-whatsapp"></i></a><a title="Share on Reddit" href="https://www.thecheckeredflag.co.uk/2021/02/ben-rhodes-wins-bargain-bin-daytona-endurance-race-with-brakebest-select-159-victory/" data-type="reddit" class="reddit-share"> <i class="fa fa-reddit-alien"></i></a><a title="Share by Email" href="/cdn-cgi/l/email-protection#95aae6e0f7fff0f6e1a8d7f0fbb0a7a5c7fdfaf1f0e6b0a7a5e2fcfbe6b0a7a5f7f4e7f2f4fcfbb8f7fcfbb0a7a5d1f4ece1fafbf4b0a7a5f0fbf1e0e7f4fbf6f0b0a7a5e7f4f6f0b0a7a5e2fce1fdb0a7a5d7e7f4fef0d7f0e6e1b0a7a5c6f0f9f0f6e1b0a7a5a4a0acb0a7a5e3fcf6e1fae7ecb3f7faf1eca8fde1e1e5e6afbabae2e2e2bbe1fdf0f6fdf0f6fef0e7f0f1f3f9f4f2bbf6fabbe0febaa7a5a7a4baa5a7baf7f0fbb8e7fdfaf1f0e6b8e2fcfbe6b8f7f4e7f2f4fcfbb8f7fcfbb8f1f4ece1fafbf4b8f0fbf1e0e7f4fbf6f0b8e7f4f6f0b8e2fce1fdb8f7e7f4fef0f7f0e6e1b8e6f0f9f0f6e1b8a4a0acb8e3fcf6e1fae7ecba" data-type="link" class="email-share"> <i class="fa fa-envelope-o"></i></a> </div>
</div>
<div class="clear"></div>
</div>
</div>
</div>
</div>
</div>
</div>
<div class="col-md-4 post-sidebar sidebar sidebar-right" role="complementary">
<ul id="post-sidebar">
<li id="media_image-3" class="widget widget_media_image"><h2 class="widgettitle">Support Driven by Diversity</h2>
<a href="http://www.drivenbydiversity.com/"><img width="600" height="600" src="https://www.thecheckeredflag.co.uk/wp-content/uploads/2020/07/DbD-600px.png" class="image wp-image-343664  attachment-full size-full" alt="" loading="lazy" style="max-width: 100%; height: auto;" title="Support Driven by Diversity" srcset="https://www.thecheckeredflag.co.uk/wp-content/uploads/2020/07/DbD-600px.png 600w, https://www.thecheckeredflag.co.uk/wp-content/uploads/2020/07/DbD-600px-160x160.png 160w, https://www.thecheckeredflag.co.uk/wp-content/uploads/2020/07/DbD-600px-533x533.png 533w, https://www.thecheckeredflag.co.uk/wp-content/uploads/2020/07/DbD-600px-240x240.png 240w, https://www.thecheckeredflag.co.uk/wp-content/uploads/2020/07/DbD-600px-585x585.png 585w, https://www.thecheckeredflag.co.uk/wp-content/uploads/2020/07/DbD-600px-550x550.png 550w, https://www.thecheckeredflag.co.uk/wp-content/uploads/2020/07/DbD-600px-470x470.png 470w" sizes="(max-width: 600px) 100vw, 600px" /></a></li>
<li id="inhype-list-posts-3" class="widget widget_inhype_list_entries"> <h2 class="widgettitle">Latest News</h2>
<ul class="template-shortline-inside">
<li class="template-shortline">
<div class="inhype-shortline-post inhype-post"><div class="inhype-post-image-wrapper"><a href="https://www.thecheckeredflag.co.uk/2021/02/ben-rhodes-wins-bargain-bin-daytona-endurance-race-with-brakebest-select-159-victory/"><div class="inhype-post-image" data-style="background-image: url(https://www.thecheckeredflag.co.uk/wp-content/uploads/2021/02/Ben-Rhodes-John-Hunter-Nemechek-2021-BrakeBest-Select-159-Daytona-RC-CWTS-220x180.jpg);"></div></a></div><div class="inhype-post-details">
<h3 class="post-title entry-title"><a href="https://www.thecheckeredflag.co.uk/2021/02/ben-rhodes-wins-bargain-bin-daytona-endurance-race-with-brakebest-select-159-victory/">Ben Rhodes wins bargain-bin Daytona endurance race with BrakeBest Select 159 victory</a></h3>
<div class="post-date"><time class="entry-date published updated" datetime="2021-02-20T03:57:28+00:00">February 20, 2021</time></div></div></div> </li>
<li class="template-shortline">
<div class="inhype-shortline-post inhype-post"><div class="inhype-post-image-wrapper"><a href="https://www.thecheckeredflag.co.uk/2021/02/roush-fenway-racing-becomes-first-nascar-team-to-achieve-carbon-neutrality/"><div class="inhype-post-image" data-style="background-image: url(https://www.thecheckeredflag.co.uk/wp-content/uploads/2021/02/Ryan-Newman-Castrol-Roush-Fenway-Racing-carbon-neutral-NCS-2021-220x180.jpg);"></div></a></div><div class="inhype-post-details">
<h3 class="post-title entry-title"><a href="https://www.thecheckeredflag.co.uk/2021/02/roush-fenway-racing-becomes-first-nascar-team-to-achieve-carbon-neutrality/">Roush Fenway Racing becomes first NASCAR team to achieve carbon neutrality</a></h3>
<div class="post-date"><time class="entry-date published updated" datetime="2021-02-19T21:56:29+00:00">February 19, 2021</time></div></div></div> </li>
<li class="template-shortline">
<div class="inhype-shortline-post inhype-post"><div class="inhype-post-image-wrapper"><a href="https://www.thecheckeredflag.co.uk/2021/02/alphatauri-rookie-tsunoda-aims-to-be-first-japanese-driver-to-win-a-race-in-formula-1/"><div class="inhype-post-image" data-style="background-image: url(https://www.thecheckeredflag.co.uk/wp-content/uploads/2021/02/Webp.net-resizeimage-60-220x180.jpg);"></div></a></div><div class="inhype-post-details">
<h3 class="post-title entry-title"><a href="https://www.thecheckeredflag.co.uk/2021/02/alphatauri-rookie-tsunoda-aims-to-be-first-japanese-driver-to-win-a-race-in-formula-1/">AlphaTauri Rookie Tsunoda Aims To Be 'First Japanese Driver To Win A Race In Formula 1'</a></h3>
<div class="post-date"><time class="entry-date published updated" datetime="2021-02-19T19:31:20+00:00">February 19, 2021</time></div></div></div> </li>
<li class="template-shortline">
<div class="inhype-shortline-post inhype-post"><div class="inhype-post-image-wrapper"><a href="https://www.thecheckeredflag.co.uk/2021/02/patrik-pasma-announced-as-kic-motorsports-second-confirmed-driver-for-2021-freca-season/"><div class="inhype-post-image" data-style="background-image: url(https://www.thecheckeredflag.co.uk/wp-content/uploads/2021/02/Patrik-Pasma-01-220x180.jpg);"></div></a></div><div class="inhype-post-details">
<h3 class="post-title entry-title"><a href="https://www.thecheckeredflag.co.uk/2021/02/patrik-pasma-announced-as-kic-motorsports-second-confirmed-driver-for-2021-freca-season/">Patrik Pasma Announced as KIC Motorsport’s Second Confirmed Driver for 2021 FRECA Season</a></h3>
<div class="post-date"><time class="entry-date published updated" datetime="2021-02-19T19:00:03+00:00">February 19, 2021</time></div></div></div> </li>
<li class="template-shortline">
<div class="inhype-shortline-post inhype-post"><div class="inhype-post-image-wrapper"><a href="https://www.thecheckeredflag.co.uk/2021/02/pietro-fittipaldi-back-as-haas-test-and-reserve-driver-for-2021-season/"><div class="inhype-post-image" data-style="background-image: url(https://www.thecheckeredflag.co.uk/wp-content/uploads/2021/02/Pietro-Fittipaldi-01-220x180.jpg);"></div></a></div><div class="inhype-post-details">
<h3 class="post-title entry-title"><a href="https://www.thecheckeredflag.co.uk/2021/02/pietro-fittipaldi-back-as-haas-test-and-reserve-driver-for-2021-season/">Pietro Fittipaldi back as Haas Test and Reserve Driver for 2021 Season</a></h3>
<div class="post-date"><time class="entry-date published updated" datetime="2021-02-19T18:43:35+00:00">February 19, 2021</time></div></div></div> </li>
</ul>
</li>
<li id="custom_html-12" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><a href="https://discord.gg/7RwdjrR" target="_blank" rel="noopener"><img src="https://www.thecheckeredflag.co.uk/wp-content/uploads/2020/08/join_discord.png" /></a><br />&nbsp;<br />
<script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-9159179884377372" data-ad-slot="4409003789" data-ad-format="auto" data-full-width-responsive="true"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script></div></li>
</ul>
</div>
</div> </div>
<div class="post-container-bottom container span-col-md-8">
<div class="row">
<div class="col-md-8">
<div class="blog-post-related-wrapper clearfix"><h5>Related posts</h5><div class="inhype-list-post inhype-list-medium-post inhype-post format-standard"><div class="inhype-post-image-wrapper"><a href="https://www.thecheckeredflag.co.uk/2021/02/jordan-anderson-racing-to-field-truck-for-brothers-bobby-roger-reuse/"><div class="inhype-post-image" data-style="background-image: url(https://www.thecheckeredflag.co.uk/wp-content/uploads/2021/02/Roger-Bobby-Reuse-Jordan-Anderson-NASCAR-Trucks-Mosport-2019-555x360.jpg);"></div></a></div><div class="inhype-post-details"><div class="post-categories"><a href="https://www.thecheckeredflag.co.uk/nascar/nascar-trucks/"><span class="cat-dot"></span><span class="cat-title">NASCAR Truck Series</span></a></div><h3 class="post-title entry-title"><a href="https://www.thecheckeredflag.co.uk/2021/02/jordan-anderson-racing-to-field-truck-for-brothers-bobby-roger-reuse/">Jordan Anderson Racing to field truck for brothers Bobby, Roger Reuse</a></h3><div class="post-author">
<span class="vcard">
By <span class="fn"><a href="https://www.thecheckeredflag.co.uk/author/jnguyen/" title="Posts by Justin Nguyen" rel="author">Justin Nguyen</a></span>
</span>
</div>
<div class="post-info-dot"></div>
<div class="post-date"><time class="entry-date published updated" datetime="2021-02-18T22:20:28+00:00">February 18, 2021</time></div><div class="post-info-dot"></div>
<div class="post-read-time">3 Mins read</div>
<div class="post-excerpt">Roger Reuse and his younger brother Bobby have joined Jordan Anderson Racing for a part-time NASCAR Truck Series schedule in the #3 Chevrolet. Bobby is set to race first in Friday&#8217;s Daytona road course event.
</div>
</div>
</div>
<div class="inhype-list-post inhype-list-medium-post inhype-post format-standard"><div class="inhype-post-image-wrapper"><a href="https://www.thecheckeredflag.co.uk/2021/02/bill-mcanally-racing-form-partnership-with-nascar-for-driver-academy/"><div class="inhype-post-image" data-style="background-image: url(https://www.thecheckeredflag.co.uk/wp-content/uploads/2021/02/Bill-McAnally-Drivers-Academy-NASCAR-logo-555x360.jpg);"></div></a></div><div class="inhype-post-details"><div class="post-categories"><a href="https://www.thecheckeredflag.co.uk/nascar/nascar-trucks/"><span class="cat-dot"></span><span class="cat-title">NASCAR Truck Series</span></a></div><h3 class="post-title entry-title"><a href="https://www.thecheckeredflag.co.uk/2021/02/bill-mcanally-racing-form-partnership-with-nascar-for-driver-academy/">Bill McAnally Racing form partnership with NASCAR for driver academy</a></h3><div class="post-author">
 <span class="vcard">
By <span class="fn"><a href="https://www.thecheckeredflag.co.uk/author/jnguyen/" title="Posts by Justin Nguyen" rel="author">Justin Nguyen</a></span>
</span>
</div>
<div class="post-info-dot"></div>
<div class="post-date"><time class="entry-date published updated" datetime="2021-02-18T04:39:31+00:00">February 18, 2021</time></div><div class="post-info-dot"></div>
<div class="post-read-time">2 Mins read</div>
<div class="post-excerpt">Bill McAnally Racing have teamed up with NASCAR to operate the BMR Drivers Academy, officially turning it into a NASCAR-sanctioned driver development programme.
</div>
</div>
</div>
<div class="inhype-list-post inhype-list-medium-post inhype-post format-standard"><div class="inhype-post-image-wrapper"><a href="https://www.thecheckeredflag.co.uk/2021/02/conor-daly-returning-to-niece-nascar-truck-series-for-las-vegas/"><div class="inhype-post-image" data-style="background-image: url(https://www.thecheckeredflag.co.uk/wp-content/uploads/2021/02/Conor-Daly-2021-IndyCar-Sebring-test-555x360.jpg);"></div></a></div><div class="inhype-post-details"><div class="post-categories"><a href="https://www.thecheckeredflag.co.uk/nascar/nascar-trucks/"><span class="cat-dot"></span><span class="cat-title">NASCAR Truck Series</span></a></div><h3 class="post-title entry-title"><a href="https://www.thecheckeredflag.co.uk/2021/02/conor-daly-returning-to-niece-nascar-truck-series-for-las-vegas/">Conor Daly returning to Niece, NASCAR Truck Series for Las Vegas</a></h3><div class="post-author">
<span class="vcard">
By <span class="fn"><a href="https://www.thecheckeredflag.co.uk/author/jnguyen/" title="Posts by Justin Nguyen" rel="author">Justin Nguyen</a></span>
</span>
</div>
<div class="post-info-dot"></div>
<div class="post-date"><time class="entry-date published updated" datetime="2021-02-17T18:41:08+00:00">February 17, 2021</time></div><div class="post-info-dot"></div>
<div class="post-read-time">2 Mins read</div>
<div class="post-excerpt">IndyCar veteran Conor Daly, who made his NASCAR Camping World Truck Series début at Las Vegas last year, will return to the series and Niece Motorsports for the spring race there.
</div>
</div>
</div>
</div>
<div id="disqus_thread">
</div>
</div>
</div> </div></div>
<div class="footer-wrapper">
<footer class="footer-black">
<div class="container">
<div class="footer-menu" role="navigation">
<div class="menu-footer-container"><ul id="menu-footer" class="footer-links"><li id="menu-item-346067" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-346067"><a href="https://www.thecheckeredflag.co.uk/contact/">Contact Us</a></li>
<li id="menu-item-346068" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-346068"><a href="https://www.thecheckeredflag.co.uk/contribute/">Contribute</a></li>
<li id="menu-item-346069" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-346069"><a href="https://www.thecheckeredflag.co.uk/about-us/">About Us</a></li>
<li id="menu-item-346070" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-346070"><a href="https://www.thecheckeredflag.co.uk/tcf-partners/">TCF Friends and Partners</a></li>
<li id="menu-item-346071" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-346071"><a href="https://www.thecheckeredflag.co.uk/submitting-news/">Submitting News</a></li>
<li id="menu-item-346072" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-346072"><a href="https://www.thecheckeredflag.co.uk/terms-and-conditions/">Terms and Conditions</a></li>
<li id="menu-item-346073" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-privacy-policy menu-item-346073"><a href="https://www.thecheckeredflag.co.uk/privacy-policy/">Privacy Policy</a></li>
<li id="menu-item-346074" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-346074"><a href="https://www.thecheckeredflag.co.uk/cookies-in-use-on-this-site/">Cookies Policy</a></li>
</ul></div> </div>
<div class="footer-bottom">
<div class="footer-copyright">
<p>©Copyright MMXXI - The Checkered Flag - All Rights Reserved</p> </div>
<div class="footer-social">
<div class="social-icons-wrapper social-icons-with-bg"><a href="https://facebook.com/TheCheckeredFlag" target="_blank" class="a-facebook no-description"><i class="fa fa-facebook"></i></a><a href="https://twitter.com/TheCheckerFlag" target="_blank" class="a-twitter no-description"><i class="fa fa-twitter"></i></a><a href="https://instagram.com/thecheckeredflag/" target="_blank" class="a-instagram no-description"><i class="fa fa-instagram"></i></a><a href="https://www.linkedin.com/company/thecheckeredflag/" target="_blank" class="a-linkedin no-description"><i class="fa fa-linkedin"></i></a><a href="https://www.youtube.com/channel/UCueRVoGbSE4GF2RszehXIgw" target="_blank" class="a-youtube no-description"><i class="fa fa-youtube"></i></a></div> </div>
</div>
</div>
</footer>
</div>
<a class="scroll-to-top btn" aria-label="Scroll to top" href="#top"></a>
<div class="search-fullscreen-wrapper">
<div class="search-fullscreen-form">
<div class="search-close-btn" aria-label="Close"><i class="fa fa-angle-up" aria-hidden="true"></i>
</div>
<form method="get" role="search" class="searchform" action="https://www.thecheckeredflag.co.uk/">
<input type="search" aria-label="Search" class="field" name="s" value="" placeholder="Type keyword(s) here and hit Enter &hellip;" /><input type="submit" class="submit btn" value="Search" />
</form>
</div>
</div>

<noscript><iframe data-lazyloaded="1" src="about:blank" data-src="https://www.googletagmanager.com/ns.html?id=GTM-MG875N"
height="0" width="0" style="display:none;visibility:hidden"></iframe><noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-MG875N"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript></noscript>
<script src="https://www.thecheckeredflag.co.uk/wp-content/plugins/inhype-theme-addons/assets/js.js" id="inhype-ta-script-frontend-js"></script>
<script type='text/javascript' id='dcl_comments-js-extra'>
/* <![CDATA[ */
var countVars = {"disqusShortname":"thecheckerdflag"};
var embedVars = {"disqusConfig":{"integration":"wordpress 3.0.16"},"disqusIdentifier":"352736 https:\/\/www.thecheckeredflag.co.uk\/?p=352736","disqusShortname":"thecheckerdflag","disqusTitle":"Ben Rhodes wins bargain-bin Daytona endurance race with BrakeBest Select 159 victory","disqusUrl":"https:\/\/www.thecheckeredflag.co.uk\/2021\/02\/ben-rhodes-wins-bargain-bin-daytona-endurance-race-with-brakebest-select-159-victory\/","postId":"352736"};
var dclCustomVars = {"dcl_progress_text":"Loading..."};
/* ]]> */
</script>
<script src="https://www.thecheckeredflag.co.uk/wp-content/plugins/disqus-conditional-load/assets/js/public/embed-count-scroll.min.js" id="dcl_comments-js"></script>
<script src="https://www.thecheckeredflag.co.uk/wp-content/themes/inhype/js/aos/aos.js" id="aos-js"></script>
<script src="https://www.thecheckeredflag.co.uk/wp-content/themes/inhype/js/parallax.min.js" id="parallax-js"></script>
<script type='text/javascript' id='thickbox-js-extra'>
/* <![CDATA[ */
var thickboxL10n = {"next":"Next >","prev":"< Prev","image":"Image","of":"of","close":"Close","noiframes":"This feature requires inline frames. You have iframes disabled or your browser does not support them.","loadingAnimation":"https:\/\/www.thecheckeredflag.co.uk\/wp-includes\/js\/thickbox\/loadingAnimation.gif"};
/* ]]> */
</script>
<script src="https://www.thecheckeredflag.co.uk/wp-includes/js/thickbox/thickbox.js" id="thickbox-js"></script>
<script src="https://www.thecheckeredflag.co.uk/wp-content/themes/inhype/js/bootstrap.min.js" id="bootstrap-js"></script>
<script src="https://www.thecheckeredflag.co.uk/wp-content/themes/inhype/js/easing.js" id="easing-js"></script>
<script src="https://www.thecheckeredflag.co.uk/wp-content/themes/inhype/js/select2/select2.min.js" id="inhype-select2-js"></script>
<script src="https://www.thecheckeredflag.co.uk/wp-content/themes/inhype/js/owl-carousel/owl.carousel.min.js" id="owl-carousel-js"></script>
<script src="https://www.thecheckeredflag.co.uk/wp-content/themes/inhype/js/template.js" id="inhype-script-js"></script>
<script id="inhype-script-js-after">
(function($){
  $(document).ready(function($) {

    "use strict";

    $("body").on("click", ".inhype-post .post-like-button", function(e){

      e.preventDefault();
      e.stopPropagation();

      var postlikes = $(this).next(".post-like-counter").text();
      var postid = $(this).data("id");

      if(getCookie("inhype-likes-for-post-"+postid) == 1) {
        // Already liked
      } else {

        setCookie("inhype-likes-for-post-"+postid, "1", 365);

        $(this).children("i").attr("class", "fa fa-heart");

        $(this).next(".post-like-counter").text(parseInt(postlikes) + 1);

        var data = {
            action: "inhype_likes",
            postid: postid,
        };

        var ajaxurl = "https://www.thecheckeredflag.co.uk/wp-admin/admin-ajax.php";

        $.post( ajaxurl, data, function(response) {

            var wpdata = response;

        });
      }

    });

  });
  })(jQuery);
</script>
<script src="https://www.thecheckeredflag.co.uk/wp-content/themes/inhype/inc/modules/mega-menu/js/mega-menu.js" id="inhype-mega-menu-js"></script>
<script src="https://www.thecheckeredflag.co.uk/wp-includes/js/wp-embed.min.js" id="wp-embed-js"></script>
<script data-no-optimize="1">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</script></body>
</html>



